Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: compiz start niet meer  (gelezen 1070 keer)

jol

  • Gast
compiz start niet meer
« Gepost op: 2008/06/27, 19:37:50 »
Hardy heron 804 en compiz 0.7.6. Na booten en inloggen heb ik de gewone desktop zonder spoor van een cube . Compiz draait niet, ook al zie ik alle componenten in synaptic als geinstalleerd. Herinstalleren helpt ook al niet. In preferences staat nog de compiz settings manager maar als ik die probeer te activeren gebeurt er niets. Heeft perfect gewerkt. Had wel compiz-git geinstalleerd en gede-installeerd.

Hoe kan ik van de command line compiz proberen starten ?

Jo

jol

  • Gast
compiz start niet meer
« Reactie #1 Gepost op: 2008/06/27, 19:43:04 »
Citaat van: jol
Hardy heron 804 en compiz 0.7.6. Na booten en inloggen heb ik de gewone desktop zonder spoor van een cube . Compiz draait niet, ook al zie ik alle componenten in synaptic als geinstalleerd. Herinstalleren helpt ook al niet. In preferences staat nog de compiz settings manager maar als ik die probeer te activeren gebeurt er niets. Heeft perfect gewerkt. Had wel compiz-git geinstalleerd en gede-installeerd.

Hoe kan ik van de command line compiz proberen starten ?

Jo
En dit is wat ik krijg als ik compiz probeer manueel te starten:

$ compiz start
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0048 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz: 406: /usr/local/bin/compiz: not found

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
compiz start niet meer
« Reactie #2 Gepost op: 2008/06/27, 19:46:37 »
Citaat van: jol
$ compiz start
Checking for Xgl: not present.
dit is volgens mij het probleem. zijn de nvidia drivers geinstalleerd? systeem=>beheer=>hardware drivers

wat zegt glxinfo | grep direct in de terminal?

jol

  • Gast
compiz start niet meer
« Reactie #3 Gepost op: 2008/06/27, 20:38:28 »
Citaat van: Nunslaughter
Citaat van: jol
$ compiz start
Checking for Xgl: not present.
dit is volgens mij het probleem. zijn de nvidia drivers geinstalleerd? systeem=>beheer=>hardware drivers

wat zegt glxinfo | grep direct in de terminal?
direct rendering: yes

De nvidia drivers zijn geinstalleerd.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
compiz start niet meer
« Reactie #4 Gepost op: 2008/06/27, 21:13:43 »
jol als je compiz --replace typt in de terminal gaat het dan wel?
Als je weer Checking for Xgl: not present krijgt post dan eens je xorg.conf.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
compiz start niet meer
« Reactie #5 Gepost op: 2008/06/27, 21:28:20 »
Citaat van: Gijsbert
post dan eens je xorg.conf.
maakt dat nog iets uit in hardy. en aangezien zijn drivers zijn geinstalleerd en hij direct rendering heeft, lijkt mij dat niet echt het probleem.
maar inderdaad, misschien dat compiz --replace iets meer info geeft.


het kan goed zijn dat er gewoon wat is misgelopen met die git installatie (en het verwijderen).
/usr/bin/compiz: 406: /usr/local/bin/compiz: not found

jol

  • Gast
compiz start niet meer
« Reactie #6 Gepost op: 2008/06/29, 16:18:36 »
Ik ben vrij zeker dat de installatie en de-installatie van git er mee te maken heeft. In elk geval geeft compiz --replace het volgende:

$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0048 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz: 406: /usr/local/bin/compiz: not found

Groeten,
Jo

-------------------------------------------------- xorg.conf ---------------------------------
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "be"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
        Driver          "nvidia"
        Option          "NoLogo"        "True"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        Defaultdepth    24
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
        Load            "glx"
EndSection

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
compiz start niet meer
« Reactie #7 Gepost op: 2008/06/29, 20:56:15 »
Probeer dit eens: http://forum.ubuntu-nl.org/message/237973#p237973

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

jol

  • Gast
compiz start niet meer
« Reactie #8 Gepost op: 2008/06/30, 13:52:46 »
Bedankt voor de tips, maar na de-/herinstallatie van de vesa naar Nvidia drivers (en bijbehorende reboots) is er geen verschil. Zo geeft compiz --replace nog steeds hetzelfde (Xgl not present)

Gr,
Jo

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
compiz start niet meer
« Reactie #9 Gepost op: 2008/06/30, 15:52:06 »
Ik vind in je xorg.conf deze regels:
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "nvidia"
        Option          "NoLogo"        "True"
Bij mij staat er
Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection
Ik vind het vreemd dat er bij jou geen model weergegeven wordt, ik weet niet welke kaart je hebt van Nvidia. Kijk eens in Synaptic of nvidia-glx-new of een eerdere versie, afhankelijk van je kaart, is geïnstalleerd.
Het lijkt er nl. op dat je kaart niet herkend wordt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

jol

  • Gast
compiz start niet meer
« Reactie #10 Gepost op: 2008/06/30, 20:17:12 »
In synaptic staat het vakje links naast nvidia-glx-new grijs gekleurd. Daarnaast staat versie 169.12+2.6.24.13-19.4. Er zijn heel wat andere packages die beginnen met nvidia-*, maar alle zijn leeg, bvb. nvidia-kernel-source, nvidia-glx, nvidia-glx-envy, enz.
Ik heb een Geforce 68000XT kaart.