Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Powernowd op P Celeron M  (gelezen 740 keer)

Gast

  • Gast
Powernowd op P Celeron M
« Gepost op: 2006/08/24, 20:28:51 »
Hallo allen,

ik heb een laptop met een Pentium Celeron M processor. Ik heb powernowd geinstalleerd. Tijdens het booten kreeg ik binnen het splash screen te zien dat powernowd gestart werd, ik zag geen foutmelding, ook niet in de logs.

Toch draaide de powernowd daemon niet (ps aux | grep power).

Ik heb toen (wilde ik toch al) usplash verwijdert, zodat ik niet meer een 'fancy' splash screen kreeg bij het starten en stoppen. Toen zag ik dat mijn CPU geen cpu-frequency scaling zou ondersteunen, maar dat leek me vreemd voor een recente laptop.

Ik ontdekte dat bij het starten eerst /etc/init.d/powernowd.early wordt aangeroepen, die op zijn beurt /usr/share/powernowd/cpufreq-detect.sh aanroept om de cpu te herkenne. Zodoende kan de juiste module voor de cpu-frequency scaling geladen worden.

Echter, dit script bevat drie regels die uitgecommentarieerd zijn, terwijl ze volgens mij nodig zijn om de juiste module voor mijn CPU te laden. Ik moet namelijk de p4-clockmod laden. Als ik dat met de hand doe en ik start vervolgens /etc/init.d/powernowd, dan draait die daemon namelijk prima.

Vraag: waarom zijn die regels uitgecommentarieerd? En: waarom zorgt het splash screen ervoor dat ik een foutmelding niet te zien krijg? Tot slot: is er een betere manier om de module wel te laden dan het weghalen van de commentaar-regels in cpufreq-detect.sh?

groeten,

Martin

Gast

  • Gast
Powernowd op P Celeron M
« Reactie #1 Gepost op: 2006/08/24, 20:35:01 »
Hm :-( Aanpassen van het script werkt niet.. ik maak zelf een scriptje in /etc/init.d/ zodat de module geladen wordt voordat powernowd gestart wordt. Iemand een goede oplossing?

Gast

  • Gast
Powernowd op P Celeron M
« Reactie #2 Gepost op: 2006/08/24, 20:38:56 »
https://launchpad.net/distros/ubuntu/+source/powernowd/+bug/8200

"> This also happened to me. In my case, I needed to load p4-clockmod manually to
> get powernowd to work.
> I think the problem is that /etc/init.d/powernowd is trying to load the modules
> from /lib/modules/`uname -r`/kernel/drivers/cpufreq but they are in
> /lib/modules/`uname -r`/kernel/arch/i386/kernel/cpu/cpufreq

Nope, sorry. We load the drivers from drivers/cpufreq (ie, the governors to let
cpufreq work correctly)
then we check /etc/default/powernowd to see if the user has specified a cpufreq
type (eg, p4-clockmod), try and load that,
and then load "acpi" as a fall back.
echo "FREQDRIVER=p4-clockmod"|sudo tee -a /etc/default/powernowd
to enable the functionality you need."