Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OOo werkt niet meer :(  (gelezen 1054 keer)

Offline hadez

  • Lid
  • Steunpunt: Nee
OOo werkt niet meer :(
« Gepost op: 2008/06/24, 22:30:31 »
hi.

ik wou vandaag een documentje maken voor een bepaalde website, die ik nog niet nader zal noemen, maar daarvoor wilde (of was het nou toch "wou"? :P) Ooo gebruieken, maar die deed het niet meer. Ik weet niet vanaf wanneer hij niet meer werkt. Uit de Console ziet het er als volgt uit:

fmbroers@martin:~$ openoffice
fmbroers@martin:~$ Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x7f768136397c]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x15) [0x7f7681363a15]
#2 /usr/lib/libX11.so.6 [0x7f768502d323]
#3 /usr/lib/libX11.so.6(XCreateWindow+0x44) [0x7f7685024d54]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_window_new+0x395) [0x7f7680f0dc05]
#5 /usr/lib/libgtk-x11-2.0.so.0 [0x7f767c59c4c8]
#6 /usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10f) [0x7f76803a1bcf]
#7 /usr/lib/libgobject-2.0.so.0 [0x7f76803b5386]
#8 /usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x875) [0x7f76803b70d5]
#9 /usr/lib/libgobject-2.0.so.0(g_signal_emit+0x83) [0x7f76803b7483]
#10 /usr/lib/libgtk-x11-2.0.so.0(gtk_widget_realize+0x77) [0x7f767c58d957]
#11 /usr/lib/openoffice/program/libvclplug_gtk680lx.so [0x7f767c94576d]
#12 /usr/lib/openoffice/program/libvclplug_gtk680lx.so [0x7f767c94616a]
#13 /usr/lib/openoffice/program/libvclplug_gtk680lx.so [0x7f767c94682b]
#14 /usr/lib/openoffice/program/libvclplug_gtk680lx.so [0x7f767c91ef64]
#15 /usr/lib/openoffice/program/libvcl680lx.so [0x7f76888ca4ed]
#16 /usr/lib/openoffice/program/libvcl680lx.so [0x7f768885f322]
#17 /usr/lib/openoffice/program/libvcl680lx.so(_ZN9TabDialogC2EP6WindowRK5ResId+0x5f) [0x7f768889c1cf]
#18 /usr/lib/openoffice/program/libsvx680lx.so [0x7f7675bfb084]
#19 /usr/lib/openoffice/program/libsvx680lx.so [0x7f7675dcfdb4]
Wie kan mij helpen?

mvg,
Hadez

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #1 Gepost op: 2008/06/24, 22:51:39 »
Ik neem aan dat je dit commando in de terminal hebt ingevoerd met de bedoeling om een bruikbare backtrace te krijgen...
Kun je beschrijven wat er gebeurt als je gewoon OOo wil starten door op het menu-item te klikken.  Of gebruik je een icoontje op het bureaublad of een icoontje op het paneel ?
Hebben alle gebruikers hetzelfde probleem ?
Mogen we aannemen dat je OOo 2.4.1 onder Hardy 8.04 gebruikt ?

En als je in de terminal ingeeft "soffice" in plaats van "openoffice" ?

PS: niet dat ik direct een oplossing heb, maar we proberen het probleem te omschrijven. :)
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
OOo werkt niet meer :(
« Reactie #2 Gepost op: 2008/06/24, 22:54:26 »
Bij mij krijg ik dit in de terminal:
gijs@gijs-desktop:~$ openoffice
find: /home/gijs/.mozilla/firefox/vkuuxfit.default/minidumps: Toegang geweigerd
Ooo opent wel, alleen moet ik eerst nieuw aanklikken en dan wat voor een document. Mij ontgaat de fout van firefox. Ook kreeg ik vreemde meldingen dat kwam doordat een andere gebruiker Ooo nog open had staan.
En als je het commando sudo openoffice geeft? Gezien de eerste zin Locking assertion failure, het is maar een idee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline hadez

  • Lid
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #3 Gepost op: 2008/06/24, 23:16:15 »
Als ik hem wil openen via het menu, dan geeft hij het laadscherm zoals bedoeld is. Maar zodra het balkje vol is, sluit hij het schermpje, en doet ie niets meer.

$ sudo openoffice
werkt wel. Vreemd genoeg.

Dan geprobeerd om de map .openoffice.org2  te hernoemen (en openoffice op te starten), maar daarna geeft hij dezelfde error. Alleen als ik openoffice opstart als root, gaat het goed.

Ook als ik dat gedaan heb, en de rechten naar mij verander, $ sudo chown -R fmbroers .openoffice.org2, dan geeft hij daarna dezelfde error.

Vreemde zaken, maar hoe los ik dit op?

Hadez

edit: ja, ik gebruik de 2.4.1-1ubuntu1 versie op Hardy

Offline Jan E.

  • Lid
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #4 Gepost op: 2008/06/24, 23:18:19 »
Ik zal wel weer veel te pragmatisch zijn, maar waarom installeer je OpenOffice niet gewoon opnieuw?


Samsung NP300E7A
Ubuntu 14.04

Offline hadez

  • Lid
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #5 Gepost op: 2008/06/24, 23:20:41 »
die niet schiet, schiet niet. Toch maar geschoten, want niet geschoten is altijd ...

nja, het werkt helaas niet :(

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
OOo werkt niet meer :(
« Reactie #6 Gepost op: 2008/06/25, 00:36:44 »
Zet Open office niet een verborgen bestandje neer in je home map(net zoals firefox) waar instellingen/voorkeuren instaan? Bijv. home/hadez/.openoffice.xyz (let op de puntvoor xyz)
Dan kan je proberen dit weg te halen en kijken of het effect heeft. Kan het nu niet zelf uitproberen omdat ik op XP zit. :(

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #7 Gepost op: 2008/06/25, 01:14:20 »
Probeer dit commando eens:
sudo chown -R fmbroers:fmbroers /home/fmbroers

Misschien zijn er op andere plekken in je home map bestanden van eigenaar veranderd doordat je zomaar iets met sudo uitvoert.

Offline hadez

  • Lid
  • Steunpunt: Nee
OOo werkt niet meer :(
« Reactie #8 Gepost op: 2008/06/25, 22:13:28 »
Nou, ik doe dat niet zomaar... Maar het is ineens gebeurt :O

Wie weet hoe ik dit kan oplossen?