Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Joomla probleem.  (gelezen 10514 keer)

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Gepost op: 2008/06/24, 16:08:14 »
Ik heb net een LAMP server opgezet en ben nu joomla aan het installeren.
Ik heb tot nu toe het volgende gedaan:
1) Ubuntu (NIET de speciale server editie) Geinstalleert
2) d.m.v Synaptic de volgende software programma`s geinstalleerd:
   1. apache2
   2. php5
   3. mysql-server
   4. php5-mysql
   5. libapache2-mod-auth-mysql
3)mysql opzetten
4)Joomla gedownload ( De Joomla_1.5.3-Stable-Full_Package.tar.gz)
5)Gunzip dat bestand (Ik hou nu een .tar bestand over)
6)De map op het bureaublad uitpakken
7)De HELE map overzetten naar /var/www/ (Dus niet de bestanden afzonderlijk, maar de map incl. inhoud overgezet)
8)In de browser naar http://localhost/Joomla_1.5.3-Stable-Full_Package/ gaan.

Nu werkt alles, maar ik wil die bestanden in de map joomla hebben en niet in zo`n lange naam als Joomla_1.5.3-Stable-Full_Package
Als ik echter de naam verander kom ik niet meer op de installatie pagina, maar moet ik een phtml file openen.

Wat nu?

Groeten,

Anton Willemse

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #1 Gepost op: 2008/06/24, 17:03:12 »
Ik vind het eigenlijk wel goed zo. Nu heb ik echter weer een nieuw probleem:

Dit zie ik op een gegeven moment in de installatie.

PHP versie >= 4.3.10       Ja    
- Zlib Compressie ondersteuning    Ja  
- XML ondersteuning    Ja  
- MySQL ondersteuning    Nee  
MB taal is standaard    Ja  
MB string overload uitgeschakeld    Ja  
configuration.php Schrijfbaar    Ja  



Richtlijn      Vereist      Huidige waarde
Veilige modus:    uit    uit    
Toon errors:    uit    aan    
Bestandsupload:    aan    aan    
Magic Quotes Runtime:    uit    uit    
Register Globals:    uit    uit    
Gebufferde output:    uit    uit    
Session auto start:    uit    uit

Ik heb dus een probleem met de mysql en ik moet op de een of andere manier die toon errors uitzetten.
Mijn vraag is dus: Hoe los ik dit op?

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Joomla probleem.
« Reactie #2 Gepost op: 2008/06/24, 19:16:05 »
Volgens mij is dat laatste rijtje niet echt vereist, maar meer een richtlijn. Zou dus geen problemen op moeten leveren.

Mysql is een ander verhaal. Probeer het eens opnieuw te installeren? En herstart je pc voor de zekerheid ff.

Hoe heb je mysql trouwens opgezet?
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #3 Gepost op: 2008/06/25, 00:01:43 »
ik heb dat geprobeert, maar hielp niet.
Ik heb wel  php5-mysql opniew geinstalleert, en na een reboot werkte het.
Nu heb ik een gratis domein aangevraagt en ik zou graag willen dat iemand even checkt of dat hij bestaat.
Een vriendin van mij kreeg hem niet tezien. Dus vandaar...


http://www.yosev.nl.tt/
OF
http://192.168.1.101/Joomla_1.0.15-Stable-Full_Package/


In ieder geval al bedankt voor jullie reacties

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #4 Gepost op: 2008/06/25, 00:06:32 »
Citaat
http://192.168.1.101/Joomla_1.0.15-Stable-Full_Package/
Er zal nooit iemand op jouw LAN IP adres kunnen komen.

Kan wel via het WAN ipadres.

BTW site onbereikbaar...
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #5 Gepost op: 2008/06/25, 00:19:45 »
OK
Ik heb met succe een server opgezet en wil die dus nu gaan koppelen met een domeinnaam.
Hoe doe ik dat? Heeft u enkele linksmisschien? Het maakt niet uit hoeveel tekst ik moet lezen als ik maar mijn site gekoppelt krijg met een domeinnaam (Die het liefst gratis is)

Offline commandoline

  • LoCo-contact
    • marten-de-vries
    • Marten-de-Vries.nl
  • Steunpunt: Nee
Joomla probleem.
« Reactie #6 Gepost op: 2008/06/25, 10:52:32 »
Hoi Anton,

Ten eerste moet je server bereikbaar zijn voor de buitenwereld. Als je achter een router zit moet je dus zorgen dat die verzoeken om je server te bereiken doorgeeft. Ook moet je iptables, de firewall waarschijnlijk aanpassen. Ik weet zelf niet hoe je dat moet doen, maar iemand anders heeft dit vast al eens gedaan. Als laatste moet je een vast ip-adres hebben, of een dyndns hebben. (http://en.wikipedia.org/wiki/Dynamic_DNS )

Dan je tweede punt: Een gratis domeinnaam. De bekentste is dot.tk, maar ik wil zelf www.joynick.com aanbevelen. Die had toen ik die het laatst probeerde de mogelijkheid om reclame uit te schakelen. Toch kan er niks op tegen een normale .nl of .com o.i.d. Dan heb je nl. garantie dat je domein bereikbaar is en niet zomaar opgeheven wordt. Ook krijg je dan geen reclame, en het is niet zo duur meer. (Een tientje per jaar.) Overweeg dus goed of je de nadelen van een gratis domein wil hebben.

Marten

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #7 Gepost op: 2008/06/25, 11:02:39 »
iptables aanpassen hoeft niet.

Gewoon poort 80 openzetten op je router.

In deze post
http://forum.ubuntu-nl.org/topic/27611
is er ook een beginneling aan de gang en word al het 1 en ander duidelijk gemaakt.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #8 Gepost op: 2008/06/25, 16:05:52 »
Ok ik ga alle informatie even bekijken

En ik neem die gratis omdat ik even wil bekijken hoe alles werkt. als ik hierover tevreden ben ga ik overstappen op een .com

Bedankt voor jullie reacties!

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Joomla probleem.
« Reactie #9 Gepost op: 2008/06/25, 19:55:37 »
Let er wel op dat je je domein naar het ip-adres van je internetverbinding laat verwijzen (dat ip-adres kun je vinden in de router). Bij welke provider zit je trouwens? In je router moet je trouwens poort 80 door laten verwijzen naar poort 80 van je server.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #10 Gepost op: 2008/06/26, 09:47:22 »
Ik moet dus poort 80 door laten wijzen naar poort 80 van mijn server? En mijn domeinnaam koppelen met het ip van mijn router?
Hoe doe ik dat? ik heb een linksys router (G versie) Ik heb een tabblad gevonden waar ik deze tabel krijg:


                                   Port Range

Application    Start    End       Protocol    IP Address    Enable
?????????         0             0        BOTH        192.168.1.0
?????????         0             0        BOTH        192.168.1.0
?????????         0             0        BOTH        192.168.1.0
?????????         0             0        BOTH        192.168.1.0
?????????         0             0        BOTH        192.168.1.0



Ik zit overgens bij telenet (Belgie)

Offline Passant

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #11 Gepost op: 2008/06/26, 10:27:29 »
Citaat van: Anton_Willemse
Ik zit overgens bij telenet (Belgie)
Volgens de gedragscode van telenet is het onder puntje 6, dat hier te vinden is verboden servers te draaien op het telenet netwerk. Hierdoor zijn alle poorten tot 1023 bij de thuisaansluitingen geblokkeerd voor inkomend verkeer. Je kan dus niet te 'klassieke' poort voor een webserver namelijk 80 gebruiken.

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Joomla probleem.
« Reactie #12 Gepost op: 2008/06/26, 11:46:36 »
@ Passant:
Gekke Belgen  ;)

@ Anton:
Ergens in je router moet iets staan van port forwarding. Je hoeft daar alleen het ip-adres van je server in te voeren en de poort waar je server op zit (80 dus). Met Lynksys heb ik helaas geen ervaring, dus kan ik je daar niet verder mee helpen...

Als je een domeinnaam hebt aangevraagd, kun je in een aantal gevallen bij een aantal providers (dus lang niet allemaal) ingeven waar je website naartoe geleid moet worden. Dat kan o.a. naar een IP-adres. Dat IP-adres is het ip-adres van je internetverbinding. Kan je als het goed is ook in de router terugvinden. Ik zit bijvoorbeeld bij Hostplan.nl. Bij hen kan ik aangeven waar het domein naartoe moet verwijzen. In mijn geval is dat mijn WAN IP-adres.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #13 Gepost op: 2008/06/26, 11:49:15 »
Je moet de domein naam koppelen aan het IP adres wat je gekregen hebt van telenet.
Dus het WAN ip adres van het modem wat aan het WWW hangt.

Hmz ik dacht de mensen in Belgie een beperkt gebruik hadden ???
Is het dan zo verstandig om een server op te zetten ???
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Joomla probleem.
« Reactie #14 Gepost op: 2008/06/26, 13:42:16 »
Citaat
Hmz ik dacht de mensen in Belgie een beperkt gebruik hadden ???
Is het dan zo verstandig om een server op te zetten ???
Bij het "doorsnee abonnement (expresnet, €42/maand)" is het 512Kbit/sec upload en 12GB/maand down/up tesamen.
Zoals Passant al zegt is het niet echt mogelijk om redelijk te "hosten" met al die gesloten poorten.

Ik denk dat het heel wat kopzorgen en geprul met poorten bespaard door ergens betaalde hosting af te nemen voor enkele €'s per maand.

Grtz
Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #15 Gepost op: 2008/06/27, 10:48:43 »
Beste,

Ik heb  een tijdje geleden bekeken hoe dat hier zat in belgie. Even een beeld schetsen voor jullie:

In Belgie heb je langzamer internet MET downloadlimieten voor het dubbele van de prijs in Nederland.

Aangezien ik zelf een nederlander ben, maar ik moest van mijn ouders mee verhuizen naar belgie, is dit behoorlijk frustrerent voor mij.
En al helemaal vervelend aangezien ik net begonnen ben met het leren over servers en dergelijke en ik daar helemaal gek van ben ;)



Ik heb ook even lopen redeneren over het geen dat ik nu geleert heb en ik denk dat er ergens een fout zit in mijn redenering:

Stel:
Ik ben eigenaar van 2 servers met op de eerste server de website www.a.com en op de tweede de website www.b.com

*Een persoon tikt in zijn webbrowser www.a.com --> door dns wordt hij doorverwezen naar de ip van mijn router --> Mijn router zegt : Inkoment verkeer = poort 80, en dat is dit ip adres ( Mijn eerste lan ip dus).

*Een tweede persoon tikt in zijn webbrowser www.b.com --> door dns wordt hij doorverwezen naar de ip van mijn router --> Mijn router zegt : Inkoment verkeer = poort 80, en dat is dit ip adres ( Mijn tweede lan ip dus).

en hier komt mijn probleem: Poort 80 verwijst al door naar mijn eerste lan ip. Dus zou het onmogelijk kunnen zijn dat mensen 2 webservers draaien achter 1 router.

Wat is mijn fout?


Ik kijk uit naar jullie antwoorden.

Groeten,

Anton Willemse

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #16 Gepost op: 2008/06/27, 11:56:58 »
De DNS server staat online op het WWW bij diegene waar je een domein naam gehost hebt.

Jij hebt 10 namen geclaimt , 1 t/m 10
Op zijn DNS server stel je in dat alle verzoeken voor de website's 1 t/m 10 moeten gaan naar jouw WAN internet adres van je modem.
Van het modem komt dit op je router waar je poort 80 open hebt staan.

In je router zeg je dat alle verzoeken op poort 80 moeten gaan naar het LAN ip adres van jouw server.

Op jouw server komen dus alle verzoeken binnen voor de website's 1 t/m 10 via poort 80.
Op jouw server werkt bijv. Apache.

Hierin heb je een hoofd server werken met 10 subservers die allemaal een naam hebben.
uiteraard de namen 1 t/m 10

dus zodra er een verzoek komt voor website 1 zal Apache dit naar subserver 1 gooien.

Verzoek voor 9 naar subserver 9

enz enz enz
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #17 Gepost op: 2008/06/27, 16:19:34 »
Ik heb op mijn router poort 80 geforward en bij mij domeinnaam een verwijzing gegeve naar mijn wan ip. Toch kunnen enkel mensen binnen mijn lan mijn webpage zien. Iedcereen daar buiten  niet. Wat nu? Licht dit inderdaad aan telenet?

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Joomla probleem.
« Reactie #18 Gepost op: 2008/06/27, 16:22:09 »
Zou kunnen. Maar het duurt ook ff voordat die aanpassingen aan je domeinnaam door alle grote internetverkeersknooppunten ook opgepikt worden. Meestal moet binnen een dag of twee iedereen je WAN-IP bereiken.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #19 Gepost op: 2008/06/27, 16:24:28 »
Maar hoe komt het dan dat mensen lokaal wel mijn website zien? Omdat die nogsteeds door verwezen worden naar mijn lan ip ofzo?

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #20 Gepost op: 2008/06/27, 16:27:47 »
Modification successful!

The settings for the domain

        http://www.yosev.nl.tt

were successfully changed!

The modifications are in effect immediately.





Dit zie ik als ik mijn instellingen bij mijn domein verander. Er moet dus een andere fout zijn.

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #21 Gepost op: 2008/06/27, 16:38:51 »
Kan er weer even iemand checken of hij online is:

http://www.yosev.nl.tt
Dan staat er: It Works!

http://www.yosev.nl.tt/Joomla_1.0.15-Stable-Full_Package
Dat is dan mijn webpagina

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #22 Gepost op: 2008/06/27, 16:46:35 »
Het werkt, maar de pagina laadt niet door.

Offline Anton_Willemse

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #23 Gepost op: 2008/06/27, 16:47:33 »
Hoe komt dat?
Hoe los ik dat op?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Joomla probleem.
« Reactie #24 Gepost op: 2008/06/27, 17:54:27 »
op je laatste vragen:
geen idee, weet niet wat jij brouwt op je server ??

Citaat
Ik heb op mijn router poort 80 geforward en bij mij domeinnaam een verwijzing gegeve naar mijn wan ip.
die verwijzing heb je gedaan op de DNS server ??

Normaal gesproken ziet iedereen lokaal alles van de server, op enkele uitzonderingen na,

Ik denk dus dat je Apache niet goed geconfigureerd hebt.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D