Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: loginscherm in qwerty? Hoe veranderen?  (gelezen 5101 keer)

verhaba

  • Gast
loginscherm in qwerty? Hoe veranderen?
« Gepost op: 2008/06/24, 11:20:59 »
Hallo
Heb een hardy heron, maar mijn loginscherm staat in querty. Eens ik ingelogd ben staat alles in azerty? heel waarschijnlijk een domme instelling ergens veranderen, maar waar? Iemand een idee?
Alvast bedankt.

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #1 Gepost op: 2008/06/24, 11:52:39 »
alt f2 > gksudo gedit /etc/X11/xorg.conf
Zoek naar het lijntje met
Option          "XkbLayout"     "us"
en maak ervan
Option          "XkbLayout"     "be"

verhaba

  • Gast
loginscherm in qwerty? Hoe veranderen?
« Reactie #2 Gepost op: 2008/06/24, 14:41:53 »
Thx. Vanavond eens testen sè. Laat je zeker iets weten.

verhaba

  • Gast
loginscherm in qwerty? Hoe veranderen?
« Reactie #3 Gepost op: 2008/06/24, 17:14:20 »
Hey
idd Thx het werkt. Enig idee hoe ik mijn numlock automatisch aanzet en het ledje laten branden op het toestenbord?

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #4 Gepost op: 2008/06/24, 19:11:06 »
numlockx installeren met synaptic.
En vervolgens Systeem > voorkeuren > sessies > numlockx uitvoeren bij elke sessie.

verhaba

  • Gast
loginscherm in qwerty? Hoe veranderen?
« Reactie #5 Gepost op: 2008/06/25, 10:25:12 »
Hm... Gisteren naar gezocht, zonder enig resultaat... Gaat het via de terminal?

Offline joop905

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #6 Gepost op: 2008/06/25, 10:31:30 »
open een terminal venster en tik in (knippen/plakken)

sudo apt-get install numlockx

gksudo gedit /etc/gdm/Init/Default

voeg dan aan het einde juist voor “exit 0" : de code toe

if [ -x /usr/bin/numlockx ]; then
  /usr/bin/numlockx on
fi

sluit af en start opnieuw op.


GrJ.

verhaba

  • Gast
loginscherm in qwerty? Hoe veranderen?
« Reactie #7 Gepost op: 2008/06/25, 10:38:03 »
hey joop905
hartelijk dank voor je snel antwoord. Misschien domme vraag, maar brandt de led dan ook? Heb gelezen dat dit soms niet het geval is, terwijl de numlock wel aanstaat. Hoe dit kan weet ik niet goed, soit.

Offline joop905

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #8 Gepost op: 2008/06/25, 10:46:40 »
Als het goed is brandt die.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #9 Gepost op: 2008/06/25, 10:48:19 »
Dan is het keyboard kapot.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #10 Gepost op: 2008/10/11, 15:26:48 »
Ik heb net hetzelfde probleem als "verhaba" in zijn openings-post van dit draadje beschrijft.

Dit staat in mijn /etc/X11/xorg.conf
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
Misschien is er nog een andere plaats waar ik iets moet veranderen?
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #11 Gepost op: 2008/10/11, 15:32:15 »
Laat de volledige xorg.conf eens zien.
Want er moet bv ook een lijntje zoals
InputDevice    "Generic Keyboard"in je server sectie staan.

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #12 Gepost op: 2008/10/11, 17:43:40 »
De volledige /etc/X11/xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #13 Gepost op: 2008/10/11, 17:48:49 »
Citaat van: ShadowDragon
De volledige /etc/X11/xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
        Identifier        "Generic Keyboard"
EndSection
Ik heb even Identifier   "Generic Keyboard" toegevoegd aan server layout in je post. Doe dit ook even zo.
De sections die daar niet instaan zullen bij het uitvoeren van xorg overgeslagen worden.

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #14 Gepost op: 2008/10/11, 17:57:05 »
Ehm, ik heb die aanpassing aangebracht.

Dit is nu dat bestand:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
Identifier "Generic Keyboard"
EndSection
En daarna heb ik gereboot. Enkel bij het rebooten kreeg ik de melding dat ubuntu in low-graphics mode is opgestart en mijn scherm is nu precies iets van een 800-600 resolutie...
En bij het inloggen was het nog steeds qwerty... en na het inloggen azerty.
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #15 Gepost op: 2008/10/11, 18:02:55 »
Ik heb blijkbaar inplaats van  InputDevice    "Generic Keyboard" in mijn server sectie. Het volgende staan.
 InputDevice    "Generic Keyboard" "CoreKeyboard"

Ik zou denken dat je een ander foutje hebt gemaakt als je save graphics mode krijgt.
Misschien dat de inhoud van volgende file kan helpen.
/var/log/Xorg.0.log

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #16 Gepost op: 2008/10/11, 18:08:15 »
Ik moet zeggen dat ikzelf niet durf aan het bestand komen om het manueel te veranderen, dus ik ben wel nieuwsgierig hoe het komt dat ie zo hoekig draait...

Het bestand /var/log/Xorg.0.log:

- Verwijderd door ShadowDragon -

Kan je verduidelijken wat ik moet aanpassen? Moet ik nu Identifier aanpassen in InputDevice?
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #17 Gepost op: 2008/10/11, 18:14:21 »
Ah ik zie mijn fout al, het moet InputDevice zijn. :)
Daarmee dat X ook niet opstarte.

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #18 Gepost op: 2008/10/11, 18:24:03 »
Dat is inderdaad beter. X-org start terug op zoals het moet. Maar eh, ik blijft qwerty hebben bij het inloggen...
Nog ideeën?
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline vanadium

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #19 Gepost op: 2008/10/11, 18:27:49 »
Voor de console moet je /etc/defaults/console-setup
aanpassen.

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #20 Gepost op: 2008/10/11, 18:34:37 »
Heeft het zin om dat bestand in te loggen als ik enkel grafisch inlog?

Hoe dan ook hier is dat bestand (staat wel in de map default i.p.v. defaults)
# A configuration file for setupcon

# Change to "yes" and setupcon will explain what is being doing
VERBOSE_OUTPUT=no

# Setup these consoles.  Most people do not need to change this.
ACTIVE_CONSOLES="/dev/tty[1-6]"

# Put here your encoding.  Valid charmaps are: UTF-8 ARMSCII-8 CP1251
# CP1255 CP1256 GEORGIAN-ACADEMY GEORGIAN-PS IBM1133 ISIRI-3342
# ISO-8859-1 ISO-8859-2 ISO-8859-3 ISO-8859-4 ISO-8859-5 ISO-8859-6
# ISO-8859-7 ISO-8859-8 ISO-8859-9 ISO-8859-10 ISO-8859-11 ISO-8859-13
# ISO-8859-14 ISO-8859-15 ISO-8859-16 KOI8-R KOI8-U TIS-620 VISCII
CHARMAP="UTF-8"

# The codeset determines which symbols are supported by the font.
# Valid codesets are: Arabic Armenian CyrAsia CyrKoi CyrSlav Ethiopian
# Georgian Greek Hebrew Lao Lat15 Lat2 Lat38 Lat7 Thai Uni1 Uni2 Uni3
# Vietnamese.  Read README.fonts for explanation.
CODESET="Uni1"

# Valid font faces are: VGA (sizes 8, 14 and 16), Terminus (sizes
# 12x6, 14, 16, 20x10, 24x12, 28x14 and 32x16), TerminusBold (sizes
# 14, 16, 20x10, 24x12, 28x14 and 32x16), TerminusBoldVGA (sizes 14
# and 16), Fixed (sizes 13, 14, 15, 16 and 18), Goha (sizes 12, 14 and
# 16), GohaClassic (sizes 12, 14 and 16).
FONTFACE="Fixed"
FONTSIZE="16"

# You can also directly specify nonstandard font and ACM to load:
# FONT=/usr/local/share/funnyfonts/sarge16.psf
# ACM=/usr/local/share/consoletrans/my_special_encoding.acm

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="pc105"
XKBLAYOUT="be"
XKBVARIANT=""
XKBOPTIONS=""


# Do not update the following md5 sum if you change
# /etc/console-setup/boottime.kmap.gz and Debconf will not overwrite
# your custom keymap.  Do not update it even if you want to make
# Debconf overwrite it.  Instead simply specify the empty string as
# a md5 sum.

BOOTTIME_KMAP_MD5="aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
En ook hier vinden we "be" terug? Ik begin er bijna aan te twijfelen of be ook een qwerty variant heeft... :P
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #21 Gepost op: 2008/10/13, 18:58:24 »
Na lang grasduinen is dit de oplossing geworden:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection
Er moet blijkbaar de optie "CoreKeyboard" bij. Kan iemand mij eigenlijk uitleggen wat die optie eigenlijk doet, zodat ik meer inzicht in het geheel krijg?

Edit:
Oké na een reboot stond het inlogscherm terug op qwerty grr... Ik snap er helemaal niets meer van...
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline siegi

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #22 Gepost op: 2008/10/13, 19:34:10 »
Uit de man pagina.
[code]Option "CoreKeyboard"
              When  this  is  set,  the input device is to be installed as the
              core (primary) keyboard device.  There must be exactly one  core
              keyboard.   If  this option is not set here, in the ServerLayout
              section, or from the -keyboard command  line  option,  then  the
              first  input device that is capable of being used as a core key

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
loginscherm in qwerty? Hoe veranderen?
« Reactie #23 Gepost op: 2008/10/13, 21:46:22 »
Dank je voor de uitleg, maar die ben ik ook tegengekomen ;)

Bedoelde eigenlijk hoe het toevoegen van die optie kon bijdragen tot oplossen van mijn probleem. Maar blijkbaar lost die optie helemaal niets op, zucht...
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB