Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Shermresolutie opnieuw niet goed  (gelezen 2213 keer)

speek

  • Gast
Shermresolutie opnieuw niet goed
« Gepost op: 2008/06/20, 18:38:01 »
Een paar dagen geleden was mijn schermresoltutie naar de filistijnen.
Dankzij hulp hier is dat hersteld (dank!).
In onderstaand prograama op 'model' klikken en dan had ik wat om te kiezen:


Dat werkte prima, echter die instelling bleef niet bewaard zodat ik die wijziging bij elke start opnieuwe moest doen.
Ik heb daarom in bovenstaand scherm een andere keuze gemaakt met dit resultaat:


Dat heet volgens mij 'van de wal in de sloot', want nu kan ik dus niks meer.

Is er een of andere save-mode waarin ik dit kan herstellen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Shermresolutie opnieuw niet goed
« Reactie #1 Gepost op: 2008/06/20, 18:43:48 »
Als je in de recovery mode opstart krijg je een keuze schermpje met als laatste try to fix X server. Bedankt voor de tip, jan11000

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

speek

  • Gast
Shermresolutie opnieuw niet goed
« Reactie #2 Gepost op: 2008/06/20, 18:45:52 »
Hoe start ik op in recovery mode?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #3 Gepost op: 2008/06/20, 18:48:07 »
http://computertip.googlepages.com/herstelgrafischeomgeving

Overigens: als je een instelling blijvend wil laten zijn, dan moet je sudo of gksudo voor het commando zetten.

speek

  • Gast
Shermresolutie opnieuw niet goed
« Reactie #4 Gepost op: 2008/06/20, 18:55:08 »
Ik ga aan de slag!
Dank sofar.

speek

  • Gast
Shermresolutie opnieuw niet goed
« Reactie #5 Gepost op: 2008/06/20, 19:24:07 »
Recovery mode gevonden en op die manier weer een leesbaar scherm gekregen.
Maar nu krijg ik weer een 600x800 scherm zonder de 'Toepassingen' 'Locaties' 'Systeem' in de bovenste werkbalk !!!!
Via een 'nieuw paneel' kan ik dan het Terminalvenster wel weer bereiken.
Als ik daarin opnieuw gksudo displayconfig-gtk doe dan kan ik wel weer een scherm van 1024x768 krijgen alleen dat is weer verdwenen na een herstart grrr....

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Shermresolutie opnieuw niet goed
« Reactie #6 Gepost op: 2008/06/20, 21:24:09 »
Is je restricted driver voor de grafische kaart geinstalleerd?
Post anders je xorg.conf eens en welke grafische kaart heb je.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #7 Gepost op: 2008/06/20, 22:07:02 »
sudo dpkg-reconfigure -phigh xserver-xorg

Als je iets niet weet, gewoon op enter drukken.

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

speek

  • Gast
Shermresolutie opnieuw niet goed
« Reactie #8 Gepost op: 2008/06/20, 23:12:16 »
Citaat van: SeySayux
sudo dpkg-reconfigure -phigh xserver-xorg
- SeySayux
Geen veranderingen te zien.

Ik heb een nVidia Gforce 7 serie grafische kaart.

Irritant is dat ik ook de opdrachtmogelijkheden 'Toepassingen' 'Locaties' 'Systeem' in de bovenste werkbalk mis.

Ik wordt er wel een beetje moe van.....

Offline siegi

  • Lid
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #9 Gepost op: 2008/06/20, 23:14:52 »
Probeer dan de resolutie gewoon eens in te stellen met nvidia-settings
Dit programma kan je gewoon vinden in synaptic.

Als je nvidia-settings op volgende manier opstart kan je ook blijvende veranderingen doen.
alt f2 > gksudo nvidia-settings

speek

  • Gast
Shermresolutie opnieuw niet goed
« Reactie #10 Gepost op: 2008/06/20, 23:43:02 »
Citaat van: siegi
Probeer dan de resolutie gewoon eens in te stellen met nvidia-settings
Dit programma kan je gewoon vinden in synaptic.
Als je nvidia-settings op volgende manier opstart kan je ook blijvende veranderingen doen.
alt f2 > gksudo nvidia-settings
Hij zegt dat hij een backup heeft gemaakt van xorg.conf, maar verder ?????
Nog steeds heel trouw 600x800.

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #11 Gepost op: 2008/06/22, 15:02:29 »
Citaat van: speek
Citaat van: siegi
Probeer dan de resolutie gewoon eens in te stellen met nvidia-settings
Dit programma kan je gewoon vinden in synaptic.
Als je nvidia-settings op volgende manier opstart kan je ook blijvende veranderingen doen.
alt f2 > gksudo nvidia-settings
Hij zegt dat hij een backup heeft gemaakt van xorg.conf, maar verder ?????
Nog steeds heel trouw 600x800.
Beste mensen

Ik ben al 2 of 3 dagen bijna full time bezig met xorg.conf ik word gek.

ik heb zelf een ATI X1950 PRO AGP.

Ik heb Envyng geprobeerd (verwijderen en installeren van drivers), Ik heb handmatig geprobeerd. Van downloaden van 8.5 en 8.6 drivers van ATI allebei geprobeerd 8.6 krijg ik een witte beeld maar als het goed is had ik compiz nog niet eens werkend.

Envyng krijg ik een zwarte scherm na ubuntu laad scherm. dan xserver gefixt gaat ie weer  vesa drivers gebruiken.

Opgegeven moment handmatig 8.5 geinstalleerd en aangevinkt bij hardwaredrivers. Had ik problemen met scherm. Ik heb een

Laser 17 inch scherm crt
Model: LC7028/17SC
serial no: GC1Y4K0029

zag nog extra info iets met 719B hij pakte soms wel Daewoo als scherm.

Maar ik heb echt werkelijk ALLES tot wat ik weet en opgezocht heb geprobeerd.

mijn xorg.conf

 
Citaat
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "alt-intl"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
EndSection

Section "Device"
   Identifier   "ATI X1950 PRO"
   Boardname   "ati"
   BusID      "PCI:1:0:0"
   Driver      "fglrx"
EndSection

Section "Extensions"
   Option      "Composite"   "0"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Generic LCD Display"
   Modelname   "LCD Panel 1024x768"
   Horizsync   31.5-48.0
   Vertrefresh   56.0   -   65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Configured Video Device"
   Monitor      "Configured Monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1024   768
      Modes      "800x600@60"   "1024x768@60"   "800x600@56"   "640x480@60"
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
   Group           "groep1"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
     screen       "Default Screen"
EndSection
Section "Module"
   Load      "glx"
EndSection

Section "device" #        
   Identifier   "ATI X1950 PRO 1"
   Boardname   "ati"
   Busid      "PCI:1:0:1"
   Driver      "ati"
   Screen   0
EndSection
Section "screen" #        
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #        
   Identifier   "monitor1"
   Gamma   1.0
EndSection

Offline jan11000

  • Lid
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #12 Gepost op: 2008/06/22, 15:40:08 »
1 do this then compiz does not start with ubuntu, and you don't get the white screen.

Stop Compiz-Fusion From Loading Automatically

This guide will show you how to stop Compiz-Fusion from loading automatically on startup in Hardy Heron and how to setup a shortcut for launching Compiz when you want.

Step 1: Run gconf-edit
Start Run Application by pressing Alt+F2

Screenshot-Run Application

Enter gconf-editor into the box, hit enter


Step 2: Set Metacity as your default start up window manager
Once in gconf-editor navigate to desktop>gnome>applications>window_manager

Screenshot-Configuration Editor - window_manager

under current and default replace each instance of:
/usr/bin/compiz with /usr/bin/metacity
it should like this when you're done:

Screenshot-Configuration Editor - window_manager-1



Step 3: Create a shortcut for starting Compiz-Fusion
right click the Applications Places System Menu
select the Edit Menu option

Screenshot-Main Menu

pick a location for your shortcut and select New Item box

Screenshot-Launcher Properties
Type: Application
Name: Compiz
Command: compiz --replace
COmment compiz window manager


2 try this:
dpkg-reconfigure xserver-xorg is not the same anymore, now you can install your keybord and more with this.
But your videocard and monitor goes like this,
start in safe mode,
choose the last options with the x,
Here ubuntu will search and identify your monitor and videocard, so you have all your posssible settings.
Then reboot and install your videcard driver.(i use envy for this).

3

/etc/modprobe.d/blacklist

hier in kopieren

blacklist i82875p_edac
blacklist edac_mc

4

Setup Compiz Fusion with open source ati radeon drivers

Older ATI cards have been blacklisted for Compiz Fusion because of a bug in the driver, but there is an easy workaround for many cards that use the open source ati drivers. Radeon 9500 are the oldest cards to support the restricted "fglrx" drivers, so everything older requires the open source drivers to function properly.



First edit the launcher for Compiz Fusion:

gksudo gedit /usr/bin/compiz

Near the top, add the line

SKIP_CHECKS="yes"

I added it under VERBOSE="yes"

You may also need to install the Compiz settings manager program that you can access from System->Preferences->Advanced Desktop Effect Settings | 1-click install or:

sudo apt-get install compizconfig-settings-manager

You can now load Compiz Fusion with

compiz --replace

and revert to Metacity (the basic window manager) with

metacity --replace

I suggest making launchers in a panel for this.

Remember that this is a workaround and may not work for everybody. If you have further problems, you should consider running a forum search and then posting on one of the main support forums if you still need help.
For the record, my card is an ATI Mobility Radeon 9000.

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #13 Gepost op: 2008/06/23, 02:43:25 »
Geprobeerd maar met geen succes..rare hiervan is week geleden deed hij het helemaal goed. Toen heb ik maar opnieuw geinstalleerd omdat ik behoorlijk wat troep erop had getest. Hij ging toen ook zwaar crashen kreeg hem niet aanparaat.  Ik had hem geinstalleerd toen deden drivers al dat gebeure niet. Later 2 keer opnieuw geinstalleerd maar nog steeds niet.

Toen ben ik maar eens diep in de xorg.conf gaan duiken. Maar wilt constant maar niet een fatsoenlijke scherm gaan pakken met fatsoenlijke resolutie (ik heb altijd 1024x768@85 hz)

Ik vink een Generic LCD Panel 1024x768 (al heb ik geen lcd panel) maar in verleden pakte hij het met geen gezeur. Maar nu meeste geprobeerd ..maar nog steeds niks..

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #14 Gepost op: 2008/06/23, 02:55:35 »
Gewoon weghalen in de config wat je niet wilt dan blijft automagisch over wat je wel wilt.
Hij zal dan hiermee werken.

OF?
Hij pakt een andere, er kunnen er 6 staan met het nummer erachter.

ook de failsafe staat er beijk die ook eens..
Het kan gebeuren dat hij die aldoor pakt omdat de originele niet in orde is.

Jij zit dan vrolijk de originele te veranderen maar je start op metde failsafe en ziet dus geen wijzigingen.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Shermresolutie opnieuw niet goed
« Reactie #15 Gepost op: 2008/06/23, 03:17:43 »
Citaat van: Gandyman
Gewoon weghalen in de config wat je niet wilt dan blijft automagisch over wat je wel wilt.
Hij zal dan hiermee werken.

OF?
Hij pakt een andere, er kunnen er 6 staan met het nummer erachter.

ook de failsafe staat er beijk die ook eens..
Het kan gebeuren dat hij die aldoor pakt omdat de originele niet in orde is.

Jij zit dan vrolijk de originele te veranderen maar je start op metde failsafe en ziet dus geen wijzigingen.
Zou ik opzich alles kunnen verwijderen wat xorg.conf.* achter staat?


en dan kijken wat hij dan bij maaktt/gebruikt.

Wat zijn de xorg.conf.failstafe files??