Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 8.04 loopt vast op Dell C400  (gelezen 1339 keer)

gman

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Gepost op: 2008/06/20, 12:02:59 »
Hallo,

Ik heb gisteren versie 8.04 lts geinstalleerd en geupdate maar het loopt continu vast zodat ik enkel nog maar een heropstart kan doen (2.22.2 kernel 2.6.24-19 generic).
Soms is dit direct na een paar minuten en een andere keer kan je iets langer werken, maar in een uur tijd heb je toch minstens 2 vastlopers. Met of zonder internetverbinding geprobeerd, geen verschil. Draai geen verschillende programma's tesamen.
Pc is een dell laptop C400 intel P3 mobile 1.20Ghz/800mhz -512kb - 40Gb hd - cicco aironet wireless card - intel 830M Grafics. Wie kan me helpen, ben een leek in linux ? Mvg, Eddy.

pjvolders

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #1 Gepost op: 2008/06/20, 12:11:51 »
Een startpunt kan mss zijn om eens in de systeemlogboeken (Systeem>beheer>systeemlogboek) te kijken of er een bepaalde foutmelding(en) vooraf gaat aan de vastloper.
Je kan ook de systeemmonitor openen en kijken of er bepaalde processen veel CPU in beslag nemen.

groetjes
PJ

gman

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #2 Gepost op: 2008/06/20, 20:27:52 »
Bij de monitor valt het me op dat de cpu tussen de 25 en 70% schommelt (grafiek) Bij de processen staat er enkel system monitor actief 12%. Uit het systeemlog kan ik niet veel uitmaken, denk dat de ethernetkaart er iets mee te maken heeft, maar weet het niet zeker. Mss halen jullie iets meer uit onderstaande bericht.

Jun 20 19:45:50 ubuntu-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/ath0 for sub-path ath0.dbus.get.interface_mtu

Jun 20 19:45:50 ubuntu-laptop NetworkManager:  Activation (ath0) Stage 5 of 5 (IP Configure Commit) scheduled...

Jun 20 19:45:50 ubuntu-laptop NetworkManager:  Activation (ath0) Stage 4 of 5 (IP Configure Get) complete.

Jun 20 19:45:50 ubuntu-laptop NetworkManager:  Activation (ath0) Stage 5 of 5 (IP Configure Commit) started...

Jun 20 19:45:50 ubuntu-laptop dhclient: bound to 192.168.1.4 -- renewal in 76846 seconds.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Withdrawing address record for 192.168.1.4 on ath0.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Leaving mDNS multicast group on interface ath0.IPv4 with address 192.168.1.4.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Interface ath0.IPv4 no longer relevant for mDNS.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Withdrawing address record for fe80::240:96ff:fea7:b4c3 on ath0.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Joining mDNS multicast group on interface ath0.IPv4 with address 192.168.1.4.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: New relevant interface ath0.IPv4 for mDNS.

Jun 20 19:45:50 ubuntu-laptop avahi-daemon[4783]: Registering new address record for 192.168.1.4 on ath0.IPv4.

Jun 20 19:45:51 ubuntu-laptop NetworkManager:  Clearing nscd hosts cache.

Jun 20 19:45:51 ubuntu-laptop NetworkManager:  nm_spawn_process(): nm_spawn_process('/usr/sbin/nscd -i hosts'): could not spawn process. (Failed to execute child process "/usr/sbin/nscd" (No such file or directory))  

Jun 20 19:45:51 ubuntu-laptop NetworkManager:  Activation (ath0) successful, device activated.

Jun 20 19:45:51 ubuntu-laptop NetworkManager:  Activation (ath0) Finish handler scheduled.

Jun 20 19:45:51 ubuntu-laptop NetworkManager:  Activation (ath0) Stage 5 of 5 (IP Configure Commit) complete.

Jun 20 19:45:52 ubuntu-laptop ntpdate[5859]: step time server 91.189.94.4 offset 1.003672 sec

Jun 20 19:45:54 ubuntu-laptop avahi-daemon[4783]: Registering new address record for fe80::240:96ff:fea7:b4c3 on ath0.*.

Jun 20 19:46:03 ubuntu-laptop kernel: [   92.057598] ath0: no IPv6 routers present

groetjes, Eddy.

pjvolders

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #3 Gepost op: 2008/06/21, 18:43:58 »
Is dat da output die hij vlak voor een crash geeft?

groetjes
PJ

gman

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #4 Gepost op: 2008/06/21, 21:30:56 »
ja, heb ook een dmesg maar die telt 10paginas en is wat te groot om hier neer te zetten.
Ben tijdens het zoeken ook op het volgende uitgekomen dat erg op mijn probleem lijkt:

Het probleem is dat je X-server je toetsenbord/muis/beeldscherm overneemt van Linux. Als de X-server dus bevriest, bevriest je beeldscherm, en reageert Linux niet meer op invoer van je toetsenbord/muis. Gevolg is dat je het idee hebt dat heel Linux is vastgelopen.

Voor een desktopgebruiker maakt het op zich weinig uit of het linux-systeem is vastgelopen of dat alleen de X-server is bevroren: er rest je enkel een druk op de reset-knop om uit de situatie te kunnen komen.

Wie wat meer kennis van linux heeft kan vanaf een andere pc via bijv. ssh inloggen op de bevroren computer, en dan de X-server killen.
En je hebt bepaalde toetsencombinaties waarmee je je uit deze benarde positie kunt bevrijden (vereist wel bepaalde kernelpatch) .

Ze hebben het over volgende combinatie: ALT+SYSRQ en tik dan de volgende letters langzaam (1 voor 1) na elkaar in: R, E, I, S, U, B maar dit helpt ook niet bij mij. Zegt het jullie iets ?

pjvolders

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #5 Gepost op: 2008/06/21, 22:32:51 »
Hoi

In de logboeken vind je ook een Xorg (xorg.0.log) logboek dat specifiek zaken van X server bijhoudt. Als de X server moeilijk doet vind je mss hier meer boeiends..
Tip: als enkel de x-server hangt kan je deze herstarten via Crtl+Alt+Backspace.
Je komt dan terug bij het inlogscherm.

groetjes
PJ

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #6 Gepost op: 2008/06/21, 22:57:00 »
Citaat van: gman
Ze hebben het over volgende combinatie: ALT+SYSRQ en tik dan de volgende letters langzaam (1 voor 1) na elkaar in: R, E, I, S, U, B maar dit helpt ook niet bij mij. Zegt het jullie iets ?
Ja, je gebruikt alleen de verkeerde volgorde. De goede volgorde is:

r (zet keyboard in raw mode)
s (probeer alle niet bewaarde data naar schijf te schrijven)
e (zend een stop signaal naar alle processen behalve init)
i (stuur een kill signaal naar alle processen behalve init)
u (remount alle bestandssystemen als read only en voorkomt een diskcheck bij startup)
b (reboot het systeem)

(overgenomen uit de Mandrake 8.2 Reference Manual)

Het verbaast met niet dat het niet werkt. Je stuurt namelijk eerst een stopsignaal (e) naar alle processen en probeert later alle data naar schijf te schrijven (s)

Probeer altijd eerst in de console te komen met CTRL+ALT+F2 dan kun je het proces dat vervelend is ook killen (eerst weer inloggen). Als dat niet lukt kun je die magic toetsencombinatie gebruiken en die werkt (bij mij althans) altijd.
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

gman

  • Gast
Ubuntu 8.04 loopt vast op Dell C400
« Reactie #7 Gepost op: 2008/06/22, 12:37:56 »
Bedankt voor de tips maar als hij "hangt" dan is er geen leven meer in te krijgen.
De console kan ik niet oproepen, backspace doet het ook niet, en de andere lettervolgorde ook  niet.
Zou dat eerst in de kernel moeten geactiveerd worden?
Ben aan een hamer en beitel aan het denken, word er zot van.