Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: mount, ik doe iets niet goed  (gelezen 8151 keer)

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Gepost op: 2008/06/17, 18:22:42 »
Ik heb een Synology DS207+. Ik heb gedaan;

mkdir /mnt/synology

in /etc/fstab heb ik staan;

//10.0.0.11/download /mnt/synology username=*****,password=***** ,rw 0 0

Na het opnieuw opstarten van Ubuntu ziet hij de NAS niet meer.
Dus wat vergeet ik nou?  Of wat doe ik nou niet goed?  Graag advies...

Offline siegi

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #1 Gepost op: 2008/06/17, 19:04:52 »
syntax van fstab (wat ik bv niet uit jouw lijntje kan halen is het file-system?)
[device] [mount point] [file_system] [Options] [dump] [fsck order]
zoiets dus waarbij dan smbfs je filesystem is
//win_box/shared_folder /mnt/samba smbfs rw,credentials=/home/user_name/winbox-credentials.txt 0 0

http://www.ubuntu-nl.org/documentatie/overig/fstab

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #2 Gepost op: 2008/06/17, 19:09:01 »
Bedankt, ik zie dat je mensen steeds naar die pagina stuurt (met uitleg). Maar daar staat zoveel dat ik de weg kwijt raak. Welk deel van die pagina moet IK nu lezen voor mijn situatie?

Ik probeer overigens een NFS ding te mounten.

Ik snap dit niet;
smbfs rw,credentials=/home/user_name/winbox-credentials.txt 0 0

Moet ik dat deel ook zo letterlijk overnemen?

Offline Duckie

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #3 Gepost op: 2008/06/17, 19:13:32 »
Als je een nfs ding wilt mounten, zoals je zegt, dan moet je dat m.i. niet doen met smbfs maar met nfs.
ietst als:
10.0.0.11:/download /mnt/synology nfs username=*****,password=***** ,rw 0 0
Of dat gaat werken met die usernama en password dat durf ik niet te zeggen. Normaal zet je dat bij de server in /etc/exports, maar met zo'n Synology heb ik geen ervaring.
____________________________________________

Offline siegi

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #4 Gepost op: 2008/06/17, 19:17:59 »
Deze pagina is ook meestal duidelijk voor de mensen die even de moeite nemen het proberen te begrijpen. Opzich is de configuratie van het bestand niet zo'n gemakkelijke materie
Aan je voorbeeld te zien //10.0.0.11/download dacht ik dat je smb gebruikte.
Voor nfs neem je volgens mij de verkeerde manier om de server aan te spreken.
daar moet het volgens mij zo
server:/shared_directory

Het lijntje dat ik je gaf was een voorbeeld uit diezelfde handleiding.
Dit is de syntax die word gebruikt in fstab
[device] [mount point] [file_system] [Options] [dump] [fsck order]

device =  10.0.0.11:/download
mount point =  /mnt/synology
file_system = nfs
options = username=*****,password=***** ,rw  (alhoewel ik niet weet of je met nfs wel de optie gebruikersnaam en wachtwoord moet gebruiken)
dump = 0
fsck oder = 0

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #5 Gepost op: 2008/06/17, 19:20:50 »
Username en password zijn bij NFS niet nodig.

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #6 Gepost op: 2008/06/17, 19:20:57 »
dit is de inhoud van mijn fstab;

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/host/ubuntu/disks/root.disk /               ext3    loop,errors=remount-ro 0       1
/host/ubuntu/disks/boot /boot           none    bind            0       0
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
//10.0.0.11:/download/ /mnt/synology nfs username=****,password=****,rw 0 0

Als ik dan doe sudo mount -a dan zie ik dit;
mount.nfs: can't get address for //10.0.0.11

Hmmm...

sorry dat ik niet weet wat de juiste benaming is voor dat nfs-ding.  :-)

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #7 Gepost op: 2008/06/17, 19:22:32 »
Ik probeer ECHT over te stappen van Windows naar Linux, maar dingen zoals dit maken dat ik draaierig word. Ik wil alleen maar toegang tot mijn NAS.  Dat je daar dan zo'n hele studie voor moet volgen. Maar ik hou vol hoor!  hahaha

Offline siegi

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #8 Gepost op: 2008/06/17, 19:23:04 »
//10.0.0.11
Geen // gebruiken das voor smb.

@johanvd het kwam me ook raar over gebruikersnaam en wachtwoord :)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #9 Gepost op: 2008/06/17, 19:26:18 »
10.0.0.11:/download/ /mnt/synology nfs rw,auto 0 0
Dit zou moeten werken. Evt. kan je de auto optie weglaten of er noauto van maken als je niet wil dat hij standaard gemount wordt.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #10 Gepost op: 2008/06/17, 19:31:09 »
Voorbeeld van wat ik zelf gebruik:
### NFS mounts
192.168.1.2:/home/johan /media/desktophome nfs rw,rsize=16384,wsize=16384,hard,intr,auto,user 0 0

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #11 Gepost op: 2008/06/17, 19:31:30 »
Bedankt voor jullie geduld mannen,

Nu heb ik;
10.0.0.11:/download/ /mnt/synology nfs rw,auto 0 0

als ik dan doe sudo mount -a, dan krijg ik...
mount.nfs: access denied by server while mounting 10.0.0.11:/download/

Dus heb ik het gevoel dat ik dichtbij zit, maar nog niet helemaal.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #12 Gepost op: 2008/06/17, 19:37:41 »
Dan heb je het op de server (de Synology dus) niet goed ingesteld.

Weet je zeker dat je NFS shares hebt aangemaakt?

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #13 Gepost op: 2008/06/17, 19:42:37 »
Yup, maar ik denk dat ik zie wat er dan niet goed is;

10.0.0.11:/volume1/download/ /mnt/synology nfs rw,auto 0 0

Ik moest /volume1 er ook nog bijzetten.

Als ik dan mount -a doe, dan krijg ik geen output meer, dus neem ik aan dat hij goed gaat.
Echter, wanneer ik Ubuntu opnieuw opstart, heb ik wederom geen icon of een link naar mijn download map?  Dus gaat het toch nog niet goed.

Misschien moet ik maar terug naar het opzetten van een SMB regel, want het kan mij eigenlijk niet zoveel schelen hoe hij verbinding maakt.

Offline siegi

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #14 Gepost op: 2008/06/17, 19:43:51 »
Op volgende pagina lees ik verschillende dingen.
http://synology.com/wiki/index.php/How_to_enable_NFS_on_the_Synology_Server
Staat nfs wel aan want volgens de pagina staat het standaard uit.

The NFS Service is disabled after every firmware upgrade.
The NFS mount is not shown in the web interface

Edit: mount -a na opnieuw opstarten, zorgt er wel voor dat er iets onder /mnt/synology komt te staan?

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #15 Gepost op: 2008/06/17, 19:45:40 »
Ik heb het aangezet, dat weet ik zeker.  Daar moest ik een aantal handelingen voor doen.

Offline vanadium

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #16 Gepost op: 2008/06/18, 10:17:45 »
Citaat
Echter, wanneer ik Ubuntu opnieuw opstart, heb ik wederom geen icon of een link naar mijn download map?  Dus gaat het toch nog niet goed.
Als het maar dat is, dan gaat het waarschijnlijk wel goed. Het lijkt me normaal dat er voor volumes die onder /mnt gekoppeld zijn, geen desktop icoon komt. Je kan eenvoudig een link vanuit je home leggen naar de nas met het commando

ln -s /mnt/synology $HOME/synology

Dit creƫert een "directory" in je home die je direct op de nas brengt. (hetzelfde kan je doen met rechts-klik, "Maak link" in nautilus).

Wil je het op je desktop, dan:

ln -s /mnt/synology $HOME/Desktop/synology

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #17 Gepost op: 2008/06/18, 19:48:10 »
Als ik de eerste regel uitvoer krijg ik de synology map wel te zien, maar ik mag er niet in kijken. Dus dacht ik, ik doe het met sudo ervoor. Maar ook dat wil niet helpen.

Offline siegi

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #18 Gepost op: 2008/06/18, 20:23:24 »
Navigeer eens gewoon met nautilus naar /mnt/synology

locaties > computer > bestandensysteem > mnt > synology
Werkt dit?

Offline dennus

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #19 Gepost op: 2008/06/18, 21:20:04 »
Ik ben er uit, na een hoop ge-google....

ik heb eerst een mount gemaakt;
mkdir /media/synology

in de /etc/fstab heb ik nu staan;
10.0.0.11:/volume1/download /media/synology nfs rw,hard,intr 0 0

Allemaal bedankt voor de hulp en het meedenken!

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
mount, ik doe iets niet goed
« Reactie #20 Gepost op: 2008/06/21, 13:06:59 »
Leuk ik heb de zelfde NAS en ben er nog niet uit.

Dennus, kun je nog eens precies aangeven wat je hebt gedaan om het geheel te laten werken?

Ik heb iets vergelijkbaars gedaan:

De gedeelde map in de 207. music, heb bij het NFS gedeelte ip-synology/255.255.255.0 /24 gezet.

In mijn /etc/fstab staat: 192.168.178.27:/volume1/music /media/synology nfs rw,hard,intr 0 0

Als ik nu fstab opnieuw uitvoer krijg ik de volgende melding: mount.nfs: access denied by server while mounting 192.168.178.27:/volume1/music.

De pap die ik aanroep in de 207 is een standaard gedeelde map. Wat gaat hier nu mis, iemand enig idee?

Bedankt vast!
« Laatst bewerkt op: 2009/03/31, 21:10:33 door ejfrolich »

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Re: mount, ik doe iets niet goed
« Reactie #21 Gepost op: 2009/03/31, 21:44:37 »
Iemand...? Enig idee?!

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: mount, ik doe iets niet goed
« Reactie #22 Gepost op: 2009/03/31, 21:55:12 »
Citaat
author=ejfrolich link=topic=28538.msg391841#msg391841 date=1238528677]
Iemand...? Enig idee?!

Als je op die NAS een
ps -ef
uitvoert, krijg je dan deze processen tussen de lijst?

portmap
rpc.mountd
[nfsd]
[nfsd]
[lockd]
« Laatst bewerkt op: 2009/03/31, 21:57:03 door ivo »
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Re: mount, ik doe iets niet goed
« Reactie #23 Gepost op: 2009/04/01, 08:15:34 »
ehhhh???

Ik heb behoorlijk rondgekeken in mijn NAS, ik zou niet weten waar ik comando's zou kunnen geven...

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: mount, ik doe iets niet goed
« Reactie #24 Gepost op: 2009/04/01, 14:51:12 »
ehhhh???

Ik heb behoorlijk rondgekeken in mijn NAS, ik zou niet weten waar ik comando's zou kunnen geven...

Ik ging er vanuit dat er een Linux OS op draait, dan zal je toch wel naar de CLI kunnen neem ik aan.
There are only 10 types of people in the world; those who understand binary and those who don't.