Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba via Swat instellen  (gelezen 1247 keer)

Offline Pivni Pes

  • Lid
  • Steunpunt: Nee
Samba via Swat instellen
« Gepost op: 2006/08/22, 18:51:52 »
Ik ben begonnen met het instellen van mijn Samba server.
Ik heb op mijn PC met WinXP een nieuwe gebruikers account aangemaakt omdat mijn bestaande gebruikersnaam verkeerde tekens bevatten.

Mijn nieuwe gebruikersnaam is pivni-pes + wachtwoord.
Dan heb ik via "Systeem" --> "beheer" --> "gebruikers en groepen" een nieuwe gebruiker aangemaakt.
Deze heeft de zelfde gebruikersnaam en wachtwoord als in WinXP.

Daarna heb ik in Swat --> "password" --> "Server Password Management" een nieuwe gebruiker aangemaakt, pivni-pes + wachtwoord als in WinXP

Als volg in Swat --> "Shares" --> "Share Parameters" --> "Security Options" --> "valid users" heb ik "pivni-pes" ingegeven.

De output van "View" is als volg:
[global]
workgroup = WERKGROEP
netbios aliases = MOSCOW
server string = %h server
security = SHARE
obey pam restrictions = Yes
passdb backend = tdbsam
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
wins support = Yes
ldap ssl = no
panic action = /usr/share/samba/panic-action %d
invalid users = root

[printers]
comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[Werkmap]
path = /home/server/Werkmap
valid users = pivni-pes
read only = No
In WinXP via CMD geef ik in \\mijn IP
Dan krijg ik een venster met mijn werkmap en printer van mijn Linux PC te zien.
Dubbel klik ik nu op mijn werkmap krijg ik een foutmelding.

\\192.168.1.10\Werkmap is niet toegankelijk. U hebt mogelijk niet de juiste machtingen voor deze netwerkbron.