Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen met compiz  (gelezen 640 keer)

Offline Grieteke

  • Lid
  • Steunpunt: Nee
Problemen met compiz
« Gepost op: 2008/06/12, 19:25:33 »
Na het opstarten van mijn computer kwam ik erachter dat AWN niet startte. Opnieuw inloggen en opnieuw opstarten maakte geen verschil. Daarom geprobeerd om AWN te starten vanuit de terminal, maar hierbij kreeg ik de volgende foutmelding.
Citaat
Error: Screen isn't composited. Please run compiz (-fusion) or another compositing manager.
Via mijn 'compiz-icon' heb ik daarna geprobeerd op compiz te gebruiken als windowmanager (via reload en door te switchen tussen metacity en compiz). Maar als ik compiz gebruik krijg ik geen window borders te zien. Er gaat dus iets mis, maar ik heb geen idee wat. Zou iemand me hiermee kunnen helpen?

Offline Passant

  • Lid
  • Steunpunt: Nee
Problemen met compiz
« Reactie #1 Gepost op: 2008/06/12, 19:35:22 »
Citaat van: Grieteke
Via mijn 'compiz-icon' heb ik daarna geprobeerd op compiz te gebruiken als windowmanager (via reload en door te switchen tussen metacity en compiz). Maar als ik compiz gebruik krijg ik geen window borders te zien. Er gaat dus iets mis, maar ik heb geen idee wat. Zou iemand me hiermee kunnen helpen?
Je zal dit waarschijnlijk wel al gedaan hebben maar,.... Als je na het klikken op Compiz Fusion Icon een icoon krijgt in de balk bovenaan kan je dan als je rechts klikt naar de Settings Manager. Zo ja, kijk eens of je zeker Window Decoration aangevinkt hebt.

Offline Grieteke

  • Lid
  • Steunpunt: Nee
Problemen met compiz
« Reactie #2 Gepost op: 2008/06/12, 19:40:55 »
Ik heb het gecontroleerd, maar window decoration staat netjes aan. Dit zou ook een vreemde oorzaak zijn omdat AWN niet werkt en meldt dat er composite manager (of hoe je dit moet noemen) draait, terwijl ik compiz heb aanstaan.

Offline Grieteke

  • Lid
  • Steunpunt: Nee
Problemen met compiz
« Reactie #3 Gepost op: 2008/06/12, 21:33:43 »
Het probleem is verholpen, maar vraag me niet hoe :s. Ik snap helaas totaal niet waarom het nu wel werkt.
Ik heb geprobeerd om compiz te runnen in de terminal om zo een eventuele foutmelding te achterhalen.
Citaat van: Foutmelding
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity
Hiermee naar google gegaan en forum post met een gelijksoortig probleem gevonden. Hierop werd oa de suggestie gegeven om xserver-xgl te installeren, dus dat maar geprobeerd. Na het herstarten van de xserver werkte compiz, maar mijn resolutie was enorm (ik heb 't echt nog nooit zo hoog gezien, niet normaal!) en deze kon ik niet veranderen. Dus xserver-xgl maar weer uitgezet en weer de xserver herstart. En opeens werkte compiz weer :s.
Als iemand enig idee heeft waarom het nu wel weer werkt zou ik het graag horen. Ik heb er namelijk een hekel aan om niet te weten hoe een probleem opgelost is.