Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wireless werkt niet (Ubuntu 8.04 / Ath. AR5007EG / ndisw. / DHCP/WPA2)  (gelezen 5322 keer)

TeqT

  • Gast
Goedemiddag,

Ik ben nu al 2 dagen bezig met het draadloze netwerk maar ik ben nu toch echt door de ideeën heen. Nadat het met madwifi niet werkte, heb ik de drivers voor de Atheros AR5007EG via ndiswrapper geïnstalleerd (net5211). Nu kreeg ik eindelijk een overzicht van de beschikbare netwerken. Het maken van een verbinding hiermee lukt echter niet.

lspci:
 05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

dmesg | grep ndis
 [   38.619784] ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
 [   38.735329] ndiswrapper (link_pe_images:576): fixing KI_USER_SHARED_DATA address in the driver
 [   38.737273] ndiswrapper: driver net5211 (,06/21/2007,5.3.0.56) loaded
 [   38.738243] ndiswrapper (ZwClose:2227): closing handle 0x0 not implemented
 [   39.158741] ndiswrapper: using IRQ 19
 [   39.365389] usbcore: registered new interface driver ndiswrapper

iwlist wlan0 scan
--- Knip ---
           Cell 10 - Address: 00:80:5A:5A:62:E3
                     ESSID:"TeqT"
                     Protocol:IEEE 802.11g
                     Mode:Managed
                     Frequency:2.442 GHz (Channel 7)
                     Quality:100/100  Signal level:-24 dBm  Noise level:-96 dBm
                     Encryption key:on
                     Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                               6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                               36 Mb/s; 48 Mb/s; 54 Mb/s
                     Extra:bcn_int=200
                     Extra:atim=0
                     IE: IEEE 802.11i/WPA2 Version 1
                         Group Cipher : CCMP
                         Pairwise Ciphers (1) : CCMP
                         Authentication Suites (1) : PSK
--- Knip ---

Wanneer ik vervolgens connect zie ik het volgende terug in syslog

tail -f /var/log/syslog
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) New wireless user key for network 'TeqT' received.
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
 Jun  8 13:02:20 teqt NetworkManager:  Activation (wlan0/wireless): access point 'TeqT' is encrypted, and a key exists.  No new key needed.
 Jun  8 13:02:22 teqt NetworkManager:  retry to connect to global supplicant socket (try=1)
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'INTERFACE_ADD wlan0^I^Iwext^I/var/run/wpa_supplicant0^I'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'AP_SCAN 1'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'ADD_NETWORK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was '0'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'SET_NETWORK 0 ssid 54657154'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'SET_NETWORK 0 proto WPA2'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'SET_NETWORK 0 key_mgmt WPA-PSK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'SET_NETWORK 0 psk '
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: sending command 'ENABLE_NETWORK 0'
 Jun  8 13:02:22 teqt NetworkManager:  SUP: response was 'OK'
 Jun  8 13:02:22 teqt NetworkManager:  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
 Jun  8 13:02:25 teqt kernel: [ 5409.744910] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
 Jun  8 13:02:26 teqt avahi-daemon[5257]: Registering new address record for fe80::219:7eff:feb1:ecfe on wlan0.*.
 Jun  8 13:02:35 teqt kernel: [ 5414.016027] wlan0: no IPv6 routers present
 Jun  8 13:03:22 teqt NetworkManager:  Activation (wlan0/wireless): association took too long (>60s), failing activation.
 Jun  8 13:03:22 teqt NetworkManager:  Activation (wlan0) failure scheduled...
 Jun  8 13:03:22 teqt NetworkManager:  Activation (wlan0) failed for access point (TeqT)
 Jun  8 13:03:22 teqt NetworkManager:  Activation (wlan0) failed.
 Jun  8 13:03:22 teqt NetworkManager:  Deactivating device wlan0.
 Jun  8 13:03:24 teqt avahi-daemon[5257]: Withdrawing address record for fe80::219:7eff:feb1:ecfe on wlan0.
 Jun  8 13:03:24 teqt NetworkManager:  nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device wlan0: Invalid argument
 Jun  8 13:03:24 teqt NetworkManager:  SWITCH: no current connection, found better connection 'eth0'.

Wanneer ik het rechtstreeks via wpa_supplicant probeer werkt het ook niet:
/etc/wpa_supplicant/config:
 network={
     ssid="TeqT"
     psk="Knip"
 }

wpa_supplicant -iwlan0 -Dwext -c/etc/wpa_supplicant/config -w:
 Trying to associate with 00:80:5a:5a:62:e3 (SSID='TeqT' freq=2442 MHz)
 Associated with 00:80:5a:5a:62:e3
 Bovenstaande regel herhaalt zich vervolgens oneindig (ik heb het iig gestopt met CTRL-C)

Wanneer ik WPA2 vervolgens uitzet (dus het netwerk onbeveiligd maak) kan ik nog steeds niet connecten. Dan krijg ik geen DHCPOFFER terug. DHCP werkt wel via de bedrade verbinding. Ik kom er echt niet meer uit, ook niet na eindeloos googlen. Ik hoop dat iemand me hiermee kan helpen.

Bij voorbaat dank!

- Tristan.


EDIT:
WICD ook geprobeerd, werkte ook niet.
Statisch + WPA geprobeerd, werkte ook niet.


TeqT

  • Gast
Wireless werkt niet (Ubuntu 8.04 / Ath. AR5007EG / ndisw. / DHCP/WPA2)
« Reactie #2 Gepost op: 2008/06/08, 14:23:56 »
Citaat van: pjotr123
Heb je deze versie van madwifi al geprobeerd:
http://computertip.googlepages.com/atherosdraadlozekaart
Citaat van: website
Let op: dit werkt slechts bij sommige Atheros chipsets en bovendien alleen voor 32-bits Ubuntu, niet voor 64-bits!
Sorry, vergeten te melden, ik heb een 64-bits Ubuntu installatie.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Wireless werkt niet (Ubuntu 8.04 / Ath. AR5007EG / ndisw. / DHCP/WPA2)
« Reactie #3 Gepost op: 2008/06/08, 14:28:14 »
Citaat van: TeqT
Sorry, vergeten te melden, ik heb een 64-bits Ubuntu installatie.
Overweeg eens een overstap naar 32-bits?
http://computertip.googlepages.com/ubuntuversiekiezen
(nummer 2)

pjcvdpol

  • Gast
Wireless werkt niet (Ubuntu 8.04 / Ath. AR5007EG / ndisw. / DHCP/WPA2)
« Reactie #4 Gepost op: 2008/07/06, 11:53:12 »
Ik draai de 32-bit versie, en lijk hetzelfde probleem te hebben.  Laptop is compaq presario A900. WIE oh WIE??????

heb zojuist de net5211 driver opnieuw geïnstalleerd in ndiswrapper: als ik wilde verbinden bevroor mijn systeem en hielp alleen de uitknop nog, niet lekker voor de harde schijf... Heb wicd geprobeerd, mad wifi drivers etc. etc. etc. begin wanhopig te worden.  in networkmanager is nu echter geen draadloos netwerk meer te bespeuren, maar:

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated  
          Bit Rate:54 Mb/s  
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

 en:
ndiswrapper -l
net5211 : driver installed
   device (168C:001C) present (alternate driver: ath_pci)  

m.a.w. driver geladen en klaar om te draaien! ath_pci is van systeem verwijderd.

sudo wpa_supplicant -iwlan0 -Dwext -c/etc/wpa_supplicant/config -w

ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
etc.

lspci:
01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

/var/log/syslog bij boot:

Jul  6 11:08:06 valiant kernel: [   41.971714] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul  6 11:08:06 valiant NetworkManager:  wlan0: Device is fully-supported using driver 'ndiswrapper'.
Jul  6 11:08:06 valiant NetworkManager:  wlan0: driver does not support SSID scans (scan_capa 0x00).
Jul  6 11:08:06 valiant NetworkManager:  nm_device_init(): waiting for device's worker thread to start
Jul  6 11:08:06 valiant NetworkManager:  nm_device_init(): device's worker thread started, continuing.
Jul  6 11:08:06 valiant NetworkManager:  Now managing wireless (802.11) device 'wlan0'.
Jul  6 11:08:06 valiant NetworkManager:  Deactivating device wlan0.
Jul  6 11:08:06 valiant NetworkManager:  nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device wlan0: Invalid argument

en uit /var/log messages:

Jul  6 11:08:03 valiant kernel: [   31.615412] ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
Jul  6 11:08:03 valiant kernel: [   31.771587] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Jul  6 11:08:03 valiant kernel: [   32.319948] ndiswrapper: driver net5211 (,11/15/2006,5.1.1.9) loaded
Jul  6 11:08:03 valiant kernel: [   32.320246] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 21
Jul  6 11:08:03 valiant kernel: [   32.320318] ndiswrapper (ZwClose:2227): closing handle 0xdf84e028 not implemented
Jul  6 11:08:03 valiant kernel: [   32.733291] ndiswrapper: using IRQ 21
Jul  6 11:08:03 valiant kernel: [   32.937239] wlan0: ethernet device 00:1f:3a:9c:67:db using serialized NDIS driver: net5211, version: 0x50001, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 168C:001C.5.conf
Jul  6 11:08:03 valiant kernel: [   32.944174] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
Jul  6 11:08:03 valiant kernel: [   32.976938] usbcore: registered new interface driver ndiswrapper

van_zwier

  • Gast
Wireless werkt niet (Ubuntu 8.04 / Ath. AR5007EG / ndisw. / DHCP/WPA2)
« Reactie #5 Gepost op: 2008/09/05, 10:23:17 »
Ik heb dit wel niet zelf bedacht, maar omdat ik er zo tevreden mee ben, en ik weet dat meer mensen hiermee zitten wil ik het graag posten, wellicht iets voor je handleidingen PJOTR123.

Voor details over het probleem kun je kijken op:
 http://madwifi.org/ticket/1679 en http://madwifi.org/ticket/1192
Let op is alleen bedoeld voor 64 bit versies

Je hebt internet verbinding nodig, dus om zeker te gaan heb ik de boel bekabeld geïnstalleerd.

1: Zorg eerst dat je build-essential hebt geinstalleerd

Code:
sudo apt-get install build-essential

2: Ook heb je de linux-restricted-modules pakketten nodig om de driver te kunnen compilen

Code:
sudo apt-get install linux-restricted-modules-$(uname -r)

3: En ook heb je nodig subversion

Code:
sudo apt-get install subversion

NOTITIE: als je ndiswrapper gebruikt verwijder die dan

Heb je geen bekabelde verbinding, en je gebruikt ndiswrapper voor je wireless, dan eerst stap 4 uitvoeren!!

Code:
sudo ndiswrapper -e net5211
sudo modprobe -r ndiswrapper
sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils ndisgtk
Vervolgens
Code:
gksudo gedit /etc/modprobe.d/blacklist
Verwijder de regels met ath_pci en ath_hal erin.

Ga nu naar Systeem ->Beheer ->Hardware Drivers en controleer of beide Atheros drivers zijn disabled, waren ze actief dan eerst herstarten.

4: Download de files en installeer de driver

Code:
svn co https://svn.madwifi.org/madwifi/branches/madwifi-hal-0.10.5.6
cd ~/madwifi-hal-0.10.5.6
make
sudo make install
sudo depmod -ae
sudo modprobe ath_pci
echo ath_hal | sudo tee -a /etc/modules
echo ath_pci | sudo tee -a /etc/modules

5: Als laatste ga naar Systeem ->Beheer ->Hardware Drivers en Enable de Atheros drivers en herstart.

Let op: na elke kernel update moet dit herhaalt worden, de simpele methode is dan, bewaar de gedownloade bestanden, en na herstarten met de nieuwe kernel doe het volgende:

Code:
cd ~/madwifi-hal-0.10.5.6
make clean
sudo make install
Herstart en alles zou weer moeten werken.

Notitie:
Als alles goed is gedownload en goed geinstalleerd, maar je kunt nog steeds niet met een netwerk contact maken, is onderstaande link een prima hulp voor assistentie http://madwifi.org/wiki/UserDocs/FirstTimeHowTo