Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ALSA of OSS  (gelezen 1021 keer)

Brusk

  • Gast
ALSA of OSS
« Gepost op: 2008/06/06, 13:26:50 »
Sinds enige tijd heb ik de nieuwste Ubuntu op mijn pc staan. Werkt heerlijk, alleen heb ik mijn Creative X-fi geluidskaart nog steeds niet aan de praat, ondanks de lancering van nieuwe drivers afgelopen april. Ik ben helaas absoluut niet de enige :(

In dit verband twee vragen:

+ Hoe kan ik nu zien of ik Alsa of OSS gebruik? En wat is het verschil tussen die twee?
+ Als ik die dramatische XF-i uiteindelijk niet aan de praat krijg, welk alternatief merk/type werkt dan wel goed samen met Ubuntu?

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
ALSA of OSS
« Reactie #1 Gepost op: 2008/06/08, 09:17:30 »
Ubuntu gebruikt standaard Alsa en volgens deze link (http://cad.cx/blog/2008/03/25/howto-creative-x-fi-sound-card-on-ubuntu-gutsy/) werkt OSS niet zo goed op ubuntu. Volgens deze link (http://www.alsa-project.org/main/index.php/Matrix:Vendor-Creative_Labs) heeft Alsa een kaart ontvangen en begint men met de ontwikkeling van de driver in Alsa.
In mijn eerste link staat ook een referentie naar het internationale ubuntu forum met daar een howto om de kaart op ubuntu vooralsnog aan de praat te krijgen, met OSS.
Al deze kaarten (http://www.alsa-project.org/main/index.php/Matrix:Main) zijn gesupporteerd.

Nizzle

  • Gast
ALSA of OSS
« Reactie #2 Gepost op: 2008/06/08, 19:35:49 »
standaard heeft ubuntu ALSA

ik heb zelf ook een Creative X-Fi en het was mij niet gelukt op die drivers te installeren dus ik heb deze howto gevolgd
http://ubuntuforums.org/showpost.php?p=4874981&postcount=2

alles werkt voor mij nu prima :)

Brusk

  • Gast
ALSA of OSS
« Reactie #3 Gepost op: 2008/06/09, 08:25:03 »
Als dat gaat lukken, dan ben ik je erg denkbaar. :)

Brusk

  • Gast
ALSA of OSS
« Reactie #4 Gepost op: 2008/06/09, 14:07:16 »
Helaas, bij stap 6 gaat het alsnog mis. Wie weet wat er fout zit?

root@ben-desktop:~/Downloads# sudo dpkg -i oss-linux_v4.0-1015_i386.deb
(Database inlezen ... 265239 bestanden en mappen geïnstalleerd.)
Voorbereiden om oss-linux v4.0-1015 te vervangen (door oss-linux_v4.0-1015_i386.deb) ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg: waarschuwing - verouderd pre-removal script gaf een foutcode 2
dpkg - script uit het nieuwe pakket wordt geprobeerd ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg: fout bij afhandelen van oss-linux_v4.0-1015_i386.deb (--install):
 subproces nieuw pre-removal script gaf een foutwaarde 2 terug
Building OSS Modules for Linux-unknown 2.6.24-18-generic
cd: 3: can't cd to /usr/lib/oss/build
sh: Can't open install.sh
Starting Open Sound System
cat: /usr/lib/oss/version.dat: Bestand of map bestaat niet
/usr/lib/oss/etc/devices.list: No such file or directory
No /usr/lib/oss/etc/installed_drivers - cannot continue
Fouten gevonden tijdens behandelen van:
 oss-linux_v4.0-1015_i386.deb
root@ben-desktop:~/Downloads#

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ALSA of OSS
« Reactie #5 Gepost op: 2008/06/09, 15:37:57 »
En als je het pakket installeerd via de pakketmanager? Klikken op het gedownloade pakketje opent de pakketmanager. Ik heb het net op deze manier geinstalleerd.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Brusk

  • Gast
ALSA of OSS
« Reactie #6 Gepost op: 2008/06/09, 16:02:58 »
Hallo.

Met pakketmanager nu ook geprobeerd. Komt vergelijkbare melding:

root@ben-desktop:~/Downloads# sudo dpkg -i oss-linux_v4.0-1015_i386.deb
(Database inlezen ... 265239 bestanden en mappen geïnstalleerd.)
Voorbereiden om oss-linux v4.0-1015 te vervangen (door oss-linux_v4.0-1015_i386.deb) ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg: waarschuwing - verouderd pre-removal script gaf een foutcode 2
dpkg - script uit het nieuwe pakket wordt geprobeerd ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg: fout bij afhandelen van oss-linux_v4.0-1015_i386.deb (--install):
 subproces nieuw pre-removal script gaf een foutwaarde 2 terug
Building OSS Modules for Linux-unknown 2.6.24-18-generic
cd: 3: can't cd to /usr/lib/oss/build
sh: Can't open install.sh
Starting Open Sound System
cat: /usr/lib/oss/version.dat: Bestand of map bestaat niet
/usr/lib/oss/etc/devices.list: No such file or directory
No /usr/lib/oss/etc/installed_drivers - cannot continue
Fouten gevonden tijdens behandelen van:
 oss-linux_v4.0-1015_i386.deb
root@ben-desktop:~/Downloads#

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ALSA of OSS
« Reactie #7 Gepost op: 2008/06/11, 16:09:57 »
Wat ik bedoel is als je op een deb pakket klikt opent zich een grafische pakket manager als het pakket niet te installeren is door bijv. ontbrekende afhankelijke pakketen, libs etc. geeft deze het ook aan.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.