Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mounten HD en root-rechten  (gelezen 1150 keer)

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Gepost op: 2008/06/03, 08:06:11 »
Ik heb onlangs een clean install voor Hardy gedaan en heb daarnaast WinXP nog geïnstalleerd (voor de spellen :P). Mijn harde schijf is opgedeeld in 4 partities: 2 NTFS voor in Windows, een EXT3 voor Ubuntu en een SWAP partitie. Daarnaast heb ik nog een externe (USB) harde schijf, ook NTFS. De externe harde schijf wordt keer op keer foutloos gemount. In Gutsy werden mijn 2 NTFS partities ook altijd foutloos gemount, maar daar schijnt ubuntu nu wat meer moeite mee te hebben. Na wat draadjes op dit forum gelezen te hebben heb ik zelf mijn Fstab aangepast. Dat is allemaal voor 100% gelukt, want de eerste paar keer opstarten daarna draaide alles als een zonnetje en werden de NTFS partities normaal gemount. Ik heb dus in Fstab de juiste volume ID's ingevoerd zou je zeggen. Een check bevestigde dit.
Nu dat feestje echter over. Om magische redenen worden de partities niet meer gemount (ondanks dat Fstab ongewijzigd is). De partities staan wel onder "Locaties", maar niet gemount. Door er op te klikken zouden ze handmatig gemount moeten worden, maar dan komt er een pop-up die meldt dat alleen root de partitie /dev/sda1 kan mounten op /media/Data. "Vroeger" deed 'ie dit niet en werkte dit ook gewoon.

Hieronder mijn fdisk resultaten + info over de NTFS partities:
janwillembol@bulderdoos:~$ sudo fdisk -l

Schijf /dev/sda: 81.9 GB, 81964302336 bytes
255 koppen, 63 sectoren/spoor, 9964 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0xf5edf5ed

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1        3824    30716248+   7  HPFS/NTFS
/dev/sda2            3825        6864    24418800    7  HPFS/NTFS
/dev/sda3            6865        8080     9767520   83  Linux
/dev/sda4            9722        9964     1951897+  82  Linux wisselgeheugen

Schijf /dev/sdb: 500.1 GB, 500107862016 bytes
255 koppen, 63 sectoren/spoor, 60801 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0x8d399bc0

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1               1       60800   488375968+   7  HPFS/NTFS
janwillembol@bulderdoos:~$ sudo vol_id /dev/sda1
ID_FS_USAGE=filesystem
ID_FS_TYPE=ntfs
ID_FS_VERSION=3.1
ID_FS_UUID=D09CA11D9CA0FEDA
ID_FS_UUID_ENC=D09CA11D9CA0FEDA
ID_FS_LABEL=Data
ID_FS_LABEL_ENC=Data
ID_FS_LABEL_SAFE=Data
janwillembol@bulderdoos:~$ sudo vol_id /dev/sda2
ID_FS_USAGE=filesystem
ID_FS_TYPE=ntfs
ID_FS_VERSION=3.1
ID_FS_UUID=5E281A65281A3D09
ID_FS_UUID_ENC=5E281A65281A3D09
ID_FS_LABEL=Vermaak
ID_FS_LABEL_ENC=Vermaak
ID_FS_LABEL_SAFE=Vermaak
en mijn Fstab:
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=D09CA11D9CA0FEDA /media/Data   ntfs defaults  
# /dev/sda2
UUID=5E281A65281A3D09 /media/Vermaak  ntfs   defaults
# /dev/sda3
UUID=013f744e-bce9-43e3-a16a-27404e7bb0b7 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda4
UUID=e07c3001-cf5b-44a7-a404-ababd8986d92 none             swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
Jullie begrijpen: Hoe zorg ik ervoor dat mijn machine weer draait als een zonnetje en mijn NTFS partities weer normaal doen? Bij voorbaat dank!

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #1 Gepost op: 2008/06/03, 08:22:49 »
Wat zegt het commando: sudo mount -a ?
En zijn die partities daarna wel gemount?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #2 Gepost op: 2008/06/03, 08:51:51 »
Het eerste wat je moet doen als een ntfs partitie niet gemount wordt, is een schijfcontrole onder Windows, en er telkens voor zorgen dat Windows correct en volledig afgesloten wordt.

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #3 Gepost op: 2008/06/03, 09:40:01 »
Citaat van: vanadium
Het eerste wat je moet doen als een ntfs partitie niet gemount wordt, is een schijfcontrole onder Windows, en er telkens voor zorgen dat Windows correct en volledig afgesloten wordt.
Zit nu op mijn werk, zal vanavond nog even kijken ivm jouw post, Johan.
@Vanadium; dank voor je tips. Ik heb gelet op correct afsluiten van Windows, ik ken de problemen die optreden als dat niet gebeurt, dank daarvoor. Schijfcontrole zal ik nog even doen!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #4 Gepost op: 2008/06/03, 18:47:31 »
Als het dát niet is, dan inderdaad: zie Johanvd. Soms kan het nodig zijn om na de schijfcontrole Windows nog een tweede keer op te starten en af te sluiten!

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #5 Gepost op: 2008/06/04, 07:57:45 »
Citaat van: Johanvd
Wat zegt het commando: sudo mount -a ?
En zijn die partities daarna wel gemount?
Dit geeft bij mij:
janwillembol@bulderdoos:~$ sudo mount -a
[sudo] password for janwillembol:
fuse: failed to access mountpoint /media/Data: Bestand of map bestaat niet
fuse: failed to access mountpoint /media/Vermaak: Bestand of map bestaat niet
Partities zijn dus nog niet gemount. Ik dat de oplossing niet zo simpel is als in Nautilus gewoon weer een map "Data" en "Vermaak" aanmaken? Iemand suggesties?

Ik zal nog eens proberen een schijfcontrole uit te voeren in Windows. Had daar gisteren de tijd helaas niet voor ('s avonds ook weer afspraken...) Uitkomsten zal ik wederom posten.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #6 Gepost op: 2008/06/04, 13:58:17 »
Ik vermoed dat de oplossing wel zo simpel is. Je kunt moeilijk verwachten dat je partitie kan mounten op een koppelpunt dat nog niet bestaat.

Verander "ntfs" in je /etc/fstab misschien meteen door ntfs-3g voor schrijftoegang

Voeg " 0 0" toe aan de lijnen van je ntfs partities: die velden ontbreken nu (hoewel dat misschien geen probleem is)

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #7 Gepost op: 2008/06/04, 16:18:35 »
Citaat van: vanadium
Ik vermoed dat de oplossing wel zo simpel is. Je kunt moeilijk verwachten dat je partitie kan mounten op een koppelpunt dat nog niet bestaat.

Verander "ntfs" in je /etc/fstab misschien meteen door ntfs-3g voor schrijftoegang

Voeg " 0 0" toe aan de lijnen van je ntfs partities: die velden ontbreken nu (hoewel dat misschien geen probleem is)
Ik heb  gister even geprobeerd een nieuwe map toe te voegen aan de map /media, maar die optie is grijs... :S Vanadium, weet je misschien hoe ik toch mappen toe kan voegen? Ik vind het allemaal trouwens een beetje vreemd, vooral doordat van het ene op het andere moment de mappen Data en Vermaak uit /media verdwenen zijn :S

Vanavond de schijfcontrole uitvoeren, wellicht ligt het daar aan!

NLsandman

  • Gast
Mounten HD en root-rechten
« Reactie #8 Gepost op: 2008/06/05, 03:05:02 »
open terminal:

sudo nautilusNu kun je wel een map aanmaken in media.

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Mounten HD en root-rechten
« Reactie #9 Gepost op: 2008/06/05, 07:51:46 »
Ja!! Eindelijk! Jullie reacties tezamen hebben de oplossing gegeven:

- sudo nautilus
- mappen aanmaken in /media (zodat er gemount kan worden)
- sudo mount -a
- herstart

En alles draait weer als een zonnetje. Hopen dat dit zo blijft!
Bedankt heren (en dames?) !!