Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OpenFTD  (gelezen 4066 keer)

Nizzle

  • Gast
OpenFTD
« Gepost op: 2008/06/02, 22:44:45 »
nouja iig.. ik ging dus naar die site..
http://www.ftd4linux.nl/wiki/index.php/UbuntuHardy_installatie
zijn er geen debs dus ik denk nou dan doe k t tog zelf..

alles gaat al fout bij stap #1
Citaat
sudo apt-get install build-essential pkg-config \
                    libsqlite3-dev libsexy-dev \
                    libgtkspell-dev libgtkhtml3.8-dev \
                    libglib2.0-dev libdbus-glib-1-dev \
                    libcurl3-dev libpcre3-dev \
                    libxslt1-dev libnotify-dev libtool \
                    automake1.9 autoconf firefox-dev \
                    xulrunner-1.9-dev libwebkitgtk-dev \
                    checkinstall dh-make devscripts \
                    fakeroot patch diff patchutils \
                    lintian
dan krijg ik dus dit:
he following packages have unmet dependencies:
  firefox-dev: Depends: firefox-3.0-dev but it is not going to be installed
  libcurl4-openssl-dev: Depends: libldap2-dev but it is not going to be installed
  libgtkhtml3.8-dev: Depends: libgnomeui-dev but it is not going to be installed
  xulrunner-1.9-dev: Depends: libnspr4-dev but it is not going to be installed
                     Depends: libnss3-dev but it is not going to be installed
E: Broken packages
nizzle@nizzle-desktop:~$
dus ik denk slim te zijn k doe die dan tog gewoon installeren wat die nodig heb..
dan krijg je deze:
The following packages have unmet dependencies:
  firefox-3.0-dev: Depends: firefox-3.0 (= 3.0~b5+nobinonly-0ubuntu3) but 3.0~rc1+nobinonly-0ubuntu0.8.04.1 is to be installed
  libgnomeui-dev: Depends: libgnomeui-0 (= 2.22.1.0-0ubuntu1) but 2.22.1.0-0ubuntu2 is to be installed
  libnspr4-dev: Depends: libnspr4-0d (<= 4.7.1~beta2-0ubuntu1.1~) but 4.7.1+1.9-0ubuntu0.8.04.1 is to be installed
  libnss3-dev: Depends: libnss3-1d (< 3.12.0~beta3-0ubuntu1.1~) but 3.12.0.2+1.9-0ubuntu0.8.04.1 is to be installed
E: Broken packages
en hij installeerd dus me dependencies niet eens.. laat staan het programma
dus ik dacht slim te zijn.. ik zoek gewoon een repo of een deb en dan fixt synaptic het maar lekker allemaal zelf
http://www.google.nl/search?hl=nl&q=openftd+repository+ubuntu&btnG=Google+zoeken&meta=
http://forum.ubuntu-nl.org/message/260911
http://www.somp.nl/nl/projects/ubuntu_packages

nou daar staat dus een repo bij.. ik toegevoegd want ik vertrouw onze nederlandse ubuntu mensjes wel


dus dat werkte ook al niet
als laatste hoop heb ik dan maar heel windows style die .deb package daar gedownload want ja je moe toch iets
en dan staat er dus dat die package voor i386 is en ik heb 64 bits dus dat werkte ook al niet

iemand nog een idee voor hoe het WEL kan? :|

Offline eendje

  • Lid
  • Steunpunt: Nee
OpenFTD
« Reactie #1 Gepost op: 2008/06/02, 22:54:03 »
Volgens mij zijn er hier op het forum mensen die packages voor OpenFTD hebben gemaakt. 'k Weet alleen niet meer wie...
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Nizzle

  • Gast
OpenFTD
« Reactie #2 Gepost op: 2008/06/02, 22:55:55 »
daar had ik er 1 van gevonden.. maar deze was i386 en ik heb een amd64 package nodig :(

Offline eendje

  • Lid
  • Steunpunt: Nee
OpenFTD
« Reactie #3 Gepost op: 2008/06/02, 23:01:23 »
Aha. Misschien kan die persoon ook helpen met het compileren toevallig?
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline kihid

  • Lid
  • Steunpunt: Nee
OpenFTD
« Reactie #4 Gepost op: 2008/06/02, 23:11:38 »
Nizzle,

ik heb toevallig vanmiddag OpenFTD geinstalleerd en had precies hetzelfde als jij, ook deze melding:
he following packages have unmet dependencies:
  firefox-dev: Depends: firefox-3.0-dev but it is not going to be installed
  libcurl4-openssl-dev: Depends: libldap2-dev but it is not going to be installed
  libgtkhtml3.8-dev: Depends: libgnomeui-dev but it is not going to be installed
  xulrunner-1.9-dev: Depends: libnspr4-dev but it is not going to be installed
                     Depends: libnss3-dev but it is not going to be installed
E: Broken packages

Heb toen in System> Beheer> Softwarebronnen en dan bij het tabblad Updates, Vooraf vrijgegeven Updates (hardy-proposed) aangevinkt en de repo van Medibuntu ook en de gehele installatie cyclus nog een keer gedaan, toen werd wel alles meegeinstalleerd, daarna weer uitgevinkt.


Dus probeer het zo ook eens.

Suc6
OS: Ubuntu 12.04 64 bits and Lubuntu  12.04  32 bits Registered Linux User #450631
Never trust an operating system you don't have sources for.

Nizzle

  • Gast
OpenFTD
« Reactie #5 Gepost op: 2008/06/03, 12:36:18 »
jeej kihid dat heeft op een manier gewerkt
al die packages zijn nu wel geinstalleerd maar openFTD lukt me nog steeds niet

ik kom nu tot:
nizzle@nizzle-desktop:/tmp/openftd-1.1.0$ dh_make -e emailadres@domein.nl -s -n
Maintainer name : Niels Gouman
Email-Address   : emailadres@domein.nl
Date            : Tue, 03 Jun 2008 12:33:23 +0200
Package Name    : openftd
Version         : 1.1.0
License         : gpl
Type of Package : Single
Hit to confirm: debuild -us -uc
Done. Please edit the files in the debian/ subdirectory now. openftd
uses a configure script, so you probably don't have to edit the Makefiles.
nizzle@nizzle-desktop:/tmp/openftd-1.1.0$ cd ..
nizzle@nizzle-desktop:/tmp$ ls
gconfd-nizzle   openftd-1.1.0.tar.bz2  seahorse-FjwoNE  Tracker-nizzle.6793
keyring-vj3oPI  orbit-nizzle           ssh-RqWtJX6617   virtual-nizzle.9nACVP
openftd-1.1.0   screenlets             tmp.EEpFPE6570

Offline kihid

  • Lid
  • Steunpunt: Nee
OpenFTD
« Reactie #6 Gepost op: 2008/06/03, 13:09:30 »
Nizzle,

dat was alles, als het goed is staan er nu 2 icoontjes in > Toepssingen> Internet> Openftd en Openftd (Light)

Als je het programma opstart maak je een account aan en klaar is kees.

Suc6
OS: Ubuntu 12.04 64 bits and Lubuntu  12.04  32 bits Registered Linux User #450631
Never trust an operating system you don't have sources for.

Nizzle

  • Gast
OpenFTD
« Reactie #7 Gepost op: 2008/06/03, 13:12:02 »
nee ik moet de laatste stap nog doen.. maar dat bestand bestaat niet?

http://www.ftd4linux.nl/wiki/index.php/UbuntuHardy_installatie
oor de AMD64 versie is de laatste regel als volgt:

sudo dpkg -i openftd_1.1.0_amd64.deb

Offline kihid

  • Lid
  • Steunpunt: Nee
OpenFTD
« Reactie #8 Gepost op: 2008/06/03, 13:19:15 »
Heb je middels dit commando gekeken of het bestand er tussen staat: ls -a
(het relevante bestand (in dit geval 'openftd_1.1.0_amd64.deb') staat dan tussen de andere bestanden van deze directory).


En sorry maar ik gebruik gewoon een 32 bits systeem

EDIT: ik zie dat je een half commando hebt gegeven nl: nizzle@nizzle-desktop:/tmp$ ls


Maar het moet zijn: ls -a
OS: Ubuntu 12.04 64 bits and Lubuntu  12.04  32 bits Registered Linux User #450631
Never trust an operating system you don't have sources for.

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
OpenFTD
« Reactie #9 Gepost op: 2008/06/03, 14:14:25 »
Gewoon goed kijken mensen :P
Er zijn verschillende pakketten te verkrijgen: 64-bit openftd & 32-bit
Ubuntu user#: 24352

Nizzle

  • Gast
OpenFTD
« Reactie #10 Gepost op: 2008/06/03, 20:20:45 »
Citaat van: BMF
Gewoon goed kijken mensen :P
Er zijn verschillende pakketten te verkrijgen: 64-bit openftd & 32-bit
danku danku :)

deze geinstalleerd kreeg wat foutmeldingen maar het lijkt verder gewoon prima te werken

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.la': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so.0.0.0': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so.0': libxul.so: cannot open shared object file: No such file or directory

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
OpenFTD
« Reactie #11 Gepost op: 2008/06/03, 21:28:59 »
Citaat van: Nizzle
danku danku :)

deze geinstalleerd kreeg wat foutmeldingen maar het lijkt verder gewoon prima te werken

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.la': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so.0.0.0': libxul.so: cannot open shared object file: No such file or directory

Error while trying to load '/usr/lib/openftd/libopenftd_gui_mozilla.so.0': libxul.so: cannot open shared object file: No such file or directory
Graag gedaan !!!

Geen idee wat die fout betreft.
Ben je lid van FTD? Zo ja, stel even de vraag in het desbetreffende forum, dat kunnen zij je wellicht uitleggen wat de oorzaak hiervan is.

grtz
Ubuntu user#: 24352