Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: xp start niet op via grub  (gelezen 1329 keer)

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Gepost op: 2008/05/25, 10:42:28 »
Hallo,
Gisteren Hardy geïnstalleerd op asus commando : http://nl.asus.com/products.aspx?l1=3&l2=117&l3=0&l4=0&model=1480&modelmenu=2
Had hier een aparte hdd voor aangesloten en de rest afgekoppeld. Installatie verliep snel en vlot maar na de entry in grub om xp te starten ingebracht te hebben en alle hdd terug aangesloten - xp start niet. Als ik in het bios de bootvolgorde terug verander start xp wel op. Wel beetje omslachtig. Volgens mij heb ik de hdd niet correct aangesloten, of speelt dat geen rol.
De 2 DVD toestellen staan op sata 5 en 6
De windows schijven op 1 en 3 (eigenaardig genoeg hebben die 2 schijven alletwee een bootvlag op de eerste partitie)
De nieuwe schijf met ubuntu op 4
Heb ik een conflict i.v.m. master en slave. Dacht dat zulks met sata poorten niet zoveel uitmaakte.



dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #1 Gepost op: 2008/05/25, 11:38:18 »
In de bootloader van windows, net als in Grub voor linux, staat keihard het pad van de partitie waarvan ie moet booten. Als je dus alle schijven loskoppelt en linux installeert, staat linux op /dev/sda1. Als je alle schijven loskoppelt en je installeert windows, dan staat windows ook op /dev/sda1. Als je de windows en de linux schijf nu aansluit, zit windows bijvoorbeeld op /dev/sda1 en linux op /dev/sdb1. Linux zal je dus niet meer kunnen opstarten.
Je kan dit uiteraard allemaal aanpassen door te gaan klooien in menu.lst bestanden van Linux of in de bootloader van windows, maar het is eigenlijk gewoon beter om Linux te installeren met de schijf van windows er ook aan. Bespaart heel wat rompslomp.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #2 Gepost op: 2008/05/25, 11:51:44 »
Dus jij raadt een herinstall van hardy aan met alle schijven aangesloten. Speelt het dan geen rol waar de schijven op het mobo zijn aangesloten (master of slave) Kan ik dit echt op geen andere manier oplossen. voor de veiligheid installeer ik altijd eerst linux op een aparte hdd (cfr; dual boot with 2 harddisks - engels forum) Het is de eerste maal dat zulks niet direct lukt.:)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #3 Gepost op: 2008/05/25, 11:56:15 »
Wel, de reden waarom het niet lukt heb ik reeds aangegeven in mijn post. Zowel windows als Linux maken gebruik van een bootloader. Deze wordt steeds gezocht op de eerste schijf. Vandaar dat het veranderen van boot volgorde in het bios wel werkt. Master slave spelen inderdaad geen rol. Bootvolgorde wel.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #4 Gepost op: 2008/05/25, 11:59:21 »
Citaat van: kennywest
Wel, de reden waarom het niet lukt heb ik reeds aangegeven in mijn post. Zowel windows als Linux maken gebruik van een bootloader. Deze wordt steeds gezocht op de eerste schijf. Vandaar dat het veranderen van boot volgorde in het bios wel werkt. Master slave spelen inderdaad geen rol. Bootvolgorde wel.
+1

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #5 Gepost op: 2008/05/25, 12:39:17 »
pjotr123, verklaar je nader ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

NLsandman

  • Gast
xp start niet op via grub
« Reactie #6 Gepost op: 2008/05/25, 13:11:42 »
Wat nu als ik boot vanaf hd0 en windows staat op hd1, de bootloader staat dus op hd0, moet grub dan op hd0 zijn geinstalleerd en waar moet de regel in grub om windows te starten naar verwijzen?

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #7 Gepost op: 2008/05/25, 13:26:20 »
Deze entry moet in /boot/grub/menu.lst staan, achter vermelding " END DEBIAN AUTOMAGIC KERNELS LIST"

title              Windows XP
root               (hd1,0)
savedefault
makeactive
map                (hd0) (hd1)
map                (hd1) (hd0)
chainloader        +1

maar in dit specifiek geval in deze draad werkt het niet
grub staat op hd0 en je verwijst zo naar hd1,0 waar de bootloader van windows staat
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

NLsandman

  • Gast
xp start niet op via grub
« Reactie #8 Gepost op: 2008/05/25, 14:08:25 »
Wat je mischien in jouw geval kunt doen is de bootvolgorde zo laten zodat xp opstart en dan de grub loader op die hd plaatsen die je in de bios als boot hebt staan, ik ga er van uit dat de bootloader van xp daar staat.
De ubuntu entry's in grub menu list naar de schijf laten verwijzen waar de root staat van ubuntu.

Waar staat de windows root? op die 1e of 3e ntfs schijf?

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #9 Gepost op: 2008/05/25, 17:36:43 »
Das juist het vreemde, hebben alletwee een bootvlag. Ga proberen vanuit hardy uitdraai te posten van fdisk :)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #10 Gepost op: 2008/05/25, 17:42:17 »
Hierzie :

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0007e08d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3916    31455238+  83  Linux
/dev/sda2            3917       30401   212740762+   5  Extended
/dev/sda5            3917        4438     4192933+  82  Linux swap / Solaris
/dev/sda6            4439        8354    31455238+  83  Linux
/dev/sda7            8355       30401   177092496    7  HPFS/NTFS

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc584c584

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       10454    83971723+   7  HPFS/NTFS
/dev/sdb2           10455       20015    76798732+   7  HPFS/NTFS
/dev/sdb3           20016       29321    74750445    7  HPFS/NTFS
/dev/sdb4           29322       38913    77047740    f  W95 Ext'd (LBA)
/dev/sdb5           29322       38913    77047708+   7  HPFS/NTFS

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc5bdc5bd

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1        7904    63488848+   7  HPFS/NTFS
/dev/sdc2            7905       15808    63488880    7  HPFS/NTFS
/dev/sdc3           15809       23712    63488880    7  HPFS/NTFS
/dev/sdc4           23713       38913   122102032+   f  W95 Ext'd (LBA)
/dev/sdc5           23713       31361    61440561    7  HPFS/NTFS
/dev/sdc6           31362       38913    60661408+   7  HPFS/NTFS
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

NLsandman

  • Gast
xp start niet op via grub
« Reactie #11 Gepost op: 2008/05/25, 18:02:30 »
Zou het volgende niet werken?

title              Windows XP
root               (hd2,0)
savedefault
makeactive
map                (hd0) (hd2)
map                (hd2) (hd0)
chainloader        +1

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #12 Gepost op: 2008/05/25, 18:51:42 »
idd gelukt, had ik juist ingegeven. In windows zag ik op de eerste part. v/d 2e schijf de bestanden boot.ini en ntldr staan.Maar dat was nog niet genoeg. In het bios stond eerst : 1e drive : 4M-ST3320620AS - 2e drive SS -ST3320620AS (de twee hdd waarop Win was geïnstalleerd) Als derde drive (waar ubuntu op geïnstalleerd is) WDC en nog enkele serienummers.
Had dus die WDC als eerste gezet, en de volgorde v/d andere 2 aangehouden. Dat werkte niet. Nu staat WDC als eerste, dan SS en 4M als laatste. Misschien beetje ingewikkeld uitgelegd, maar alle problemen werden wss veroorzaakt omdat Win de boot bestanden blijkbaar op die 2de hdd heeft gezet. Enfin, volgens mij is het opgelost :lol: :lol:
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
xp start niet op via grub
« Reactie #13 Gepost op: 2008/05/25, 19:02:13 »
En NLsandman, nog bedankt voor de tip maar ik geloof dat we tegelijkertijd op hetzelfde idee kwamen :lol:
Achteraf is het logisch maar wie vermoed nu dat die opstartbestanden op de 2de hdd staan.
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

NLsandman

  • Gast
xp start niet op via grub
« Reactie #14 Gepost op: 2008/05/25, 19:36:04 »
Niets te danken, hier leer ik ook weer van :)