Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met pakkettenbeheer  (gelezen 1525 keer)

Offline koen_92

  • Lid
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Gepost op: 2008/05/22, 17:16:22 »
Ook ik heb nu Ubuntu Hardy Heron draaien.
Twee weken voor de release ben ik zo ver gekomen dat Gusty niet meer werkte. Toen ben ik gaan kijken naar Fedora, en dat beviel me wel. Maar toch niet zo goed als Ubuntu, dus zit ik nu met Hardy.

1 ding is gelukt, wat nog nooit gelukt is: De ati-driver, dankzij deze tutorial:
http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide

Maar ik heb ook een probleem, de pakkettenbeheer werkt niet meer, als ik iets probeer te installeren krijg ik dit:
koen@ubuntu:~$ sudo apt-get install thunderbird
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Voorgestelde pakketten:
  latex-xft-fonts thunderbird-gnome-support
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  thunderbird
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Er moeten 11,0MB aan archieven opgehaald worden.
After this operation, 32,8MB of additional disk space will be used.
Ophalen:1 http://nl.archive.ubuntu.com hardy-updates/main thunderbird 2.0.0.14+nobinonly-0ubuntu0.8.04.1 [11,0MB]
11,0MB opgehaald in 1min29s (122kB/s)                                          
dpkg: parse error, in file `/var/lib/dpkg/available' near line 1:
 nieuwe regel in veldnaam `aries.'
E: Sub-process /usr/bin/dpkg returned an error code (2)
koen@ubuntu:~$
En dat heb ik bij ieder programma dat ik probeer te installeren.

Kan iemand mij helpen?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #1 Gepost op: 2008/05/22, 17:20:39 »
sudo dpkg --clear-avail && sudo apt-get update

Offline koen_92

  • Lid
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #2 Gepost op: 2008/05/22, 17:27:06 »
Hartstikke bedankt!

Het werkt weer perfect!

Edit: O nee, toch niet (iets te snel gepost)

Kijk:
koen@ubuntu:~$ sudo apt-get install thunderbird
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Voorgestelde pakketten:
  latex-xft-fonts thunderbird-gnome-support
De volgende pakketten zullen VERWIJDERD worden:
  amsn
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  thunderbird
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 1 te verwijderen en 1 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B/11,0MB aan archieven opgehaald worden.
After this operation, 21,2MB of additional disk space will be used.
Wilt u doorgaan [J/n]? j
(Database inlezen ... 100770 bestanden en mappen geïnstalleerd.)
amsn wordt verwijderd ...
dpkg (subproces): kan post-removal script niet uitvoeren: Exec format error
dpkg: fout bij afhandelen van amsn (--remove):
 subproces post-removal script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 amsn
E: Sub-process /usr/bin/dpkg returned an error code (1)
koen@ubuntu:~$
Amsn doet het dus blijkbaar niet

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #3 Gepost op: 2008/05/22, 17:50:53 »
Wel raar dat ie amsn wil verwijderen om thunderbird te installeren ??

Nu zijn er volgens mij twee mogelijkheden:
ofwel kies je om amsn effectief te verwijderen en kan je dat proberen met
sudo apt-get remove amsn

ofwel wil je dat niet en kun je misschien proberen om eerst amsn te herinstalleren
sudo apt-get re-install amsn

alvorens thunderbird opnieuw te proberen installeren;
Verwijdert ie alsnog amsn en wil je dat toch hebben, zul je opnieuw
sudo apt-get install amsn moeten doen.

Raar...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline koen_92

  • Lid
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #4 Gepost op: 2008/05/22, 19:36:42 »
amsn verwijderen lukt ook niet:
koen@ubuntu:~$ sudo apt-get remove amsn
[sudo] password for koen:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
De volgende pakketten zullen VERWIJDERD worden:
  amsn
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 1 te verwijderen en 1 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
After this operation, 11,6MB disk space will be freed.
Wilt u doorgaan [J/n]? j
(Database inlezen ... 100770 bestanden en mappen geïnstalleerd.)
amsn wordt verwijderd ...
dpkg (subproces): kan post-removal script niet uitvoeren: Exec format error
dpkg: fout bij afhandelen van amsn (--remove):
 subproces post-removal script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 amsn
E: Sub-process /usr/bin/dpkg returned an error code (1)
koen@ubuntu:~$
Ik heb verder nog niks geinstalleerd (op de atidriver na), misschien moet ik anders maar een herinstallatie doen?

Offline Typhoner

  • Lid
    • http://typhoner.blogspot.com/
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #5 Gepost op: 2008/05/22, 19:45:43 »
Hij zegt dat aMSN niet volledig is geïnstalleerd, probeer eens eerst amsn te herinstalleren:

sudo apt-get install amsn

Offline koen_92

  • Lid
  • Steunpunt: Nee
Probleem met pakkettenbeheer
« Reactie #6 Gepost op: 2008/05/22, 19:51:29 »
Ja! Nou lukt het als het goed is, bedankt!

De installatie van amsn ging goed, maar thunderbird gaf nog wel een error:
koen@ubuntu:~$ sudo apt-get install thunderbird
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Voorgestelde pakketten:
  latex-xft-fonts thunderbird-gnome-support
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  thunderbird
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 1 niet opgewaardeerd.
Er moeten 0B/11,0MB aan archieven opgehaald worden.
After this operation, 32,8MB of additional disk space will be used.
Selecteren van voorheen niet geselecteerd pakket thunderbird.
(Database inlezen ... 101740 bestanden en mappen geïnstalleerd.)
Uitpakken van thunderbird (uit .../thunderbird_2.0.0.14+nobinonly-0ubuntu0.8.04.1_i386.deb) ...
Instellen van thunderbird (2.0.0.14+nobinonly-0ubuntu0.8.04.1) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
/sbin/ldconfig.real: /usr/lib/libtcl8.5.so.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libtk8.5.so.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libtls.so.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libtls1.50.so is not an ELF file - it has the wrong magic bytes at the start.
Thunderbird start gewoon op, kan ik die error dan negeren?