Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met dualscreen  (gelezen 1726 keer)

bart_ellebaut

  • Gast
problemen met dualscreen
« Gepost op: 2008/05/20, 15:13:57 »
Ik probeer vandaag een 2e scherm te installeren op kubuntu KDE4, maar niets werkt, hij herkent tijdens het opstarten het scherm, maar vanaf mijn inlogscherm niets meer.
Via settings, display kan ik ook niet veranderen. vroeger kon ik ng inloggen als systeembeheerder. nu is dit nergens terug te vinden.
Hoe los ik dit op? kan het desnoods via terminal?

thx
Bart

Offline Petervdw

  • Lid
  • Steunpunt: Nee
problemen met dualscreen
« Reactie #1 Gepost op: 2008/05/20, 15:26:43 »
Aan bart_ellebaut
Geen idee, maar onder schermresolutie heb ik wel eens zo'n vinkje gezien voor Clone Screen. Verder weet ik het echt niet. Slaat misschien nergens op, maar ja.
Vr.groet, peter

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #2 Gepost op: 2008/05/20, 15:40:15 »
ja, maar dat vinkje is nergens aanwezig

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #3 Gepost op: 2008/05/20, 15:46:20 »
ok; nu slaat alles tilt; bij opstarten is het in gewoon terminal, kan mijn Xserver niet meer vinden

Offline Petervdw

  • Lid
  • Steunpunt: Nee
problemen met dualscreen
« Reactie #4 Gepost op: 2008/05/20, 15:58:16 »
Oei, oei, met de terminal ben ik niet zo'n ster. Via de recovery mode kun je aan het eind, even uit laten razen, de derde regel aanvinken: reconfigure xserver of zoiets.
Links bovenin in schermpje Clone Screen: Systeem>Voorkeuren>Schermresolutie. Lijkt me dat je daar toch geen crash mee kan veroorzaken.
peter

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #5 Gepost op: 2008/05/20, 16:02:13 »
ik had hem eindelij gevonden die dualscreen en bij herstarten x server is alles tiult geslaan en vind hij de x server niet meer.
waar vind ik die recovery mode? ik heb hem laten opstarten met boot cd, maar daar staat die recovery mode niet meer bij

Offline Petervdw

  • Lid
  • Steunpunt: Nee
problemen met dualscreen
« Reactie #6 Gepost op: 2008/05/20, 16:10:58 »
Aan bart_ellebaut
Bij opstarten op de grub melding letten, 3 sec tijd om op ESC te drukken. Opstarten vanaf schijf.
peter

Even geduld als ie de disks gaat controleren. Laten gaan. Ik zie het hier op een laptop, het is de vierde regel.

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #7 Gepost op: 2008/05/20, 16:18:26 »
ok thx, ik probeer dit eens
ik post dan hoe het is gelukt / niet gelukt

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #8 Gepost op: 2008/05/20, 16:20:11 »
ok, bedankt, ik krijg opnieuw een loogin scherm.
thx

maar dat is nu al de zoveelste keer dat ik problemen heb met die dualscreen.
begint me toch mijn keel uit te hangen

Offline Petervdw

  • Lid
  • Steunpunt: Nee
problemen met dualscreen
« Reactie #9 Gepost op: 2008/05/20, 16:22:25 »
Aan bart_ellebaut
Ik schreef het al, geen idee. Misschien anderen die kunnen helpen?
Vr.groet, peter

bart_ellebaut

  • Gast
problemen met dualscreen
« Reactie #10 Gepost op: 2008/05/20, 16:28:25 »
aan Petervdw: allesinds bedankt voor de hulp nu!!, anders zat ik dik in de miserie.

Offline koorknaap

  • Lid
    • http://www.mannenkoorkoningsbosch.nl
  • Steunpunt: Nee
problemen met dualscreen
« Reactie #11 Gepost op: 2008/05/23, 22:50:21 »
Mogelijk heb je hier wat aan. Ik werk zelf al enige maanden met een dual screen onder Ubuntu 7.10.
Mijn configuratie is:
onboard  GeForce 7050 PV / NVIDIA nForce 630a (GPU 0)
met AOC LM725 (CRT-0) en
Arnos Instruments H-W22 DVI (DFP-0)
Ik heb ze geconfigureerd als separate x screen
na lang zoeken heb ik eea geconfigureerd met een programma nvidia settings.
Dit heb ik van de nvidia site gedownload
NVIDIA-Linux-x86_64-171.06-pkg2.run

Dit werkt voldoende goed op 7.10, maar op 8.04 heb ik het niet goed aan de gang.

Ook op 7.10 heb ik nog wat  problemen.
De AOC is een 17" 3*4 scherm en de Arnos (er staat neovo op) is een 22" 9*16 scherm
Ik zou graag de Arnos als hoofdscherm gebruiken maar Gnome kiest de AOC als hoofdscherm.

Dit heeft als nadeel dat je moet inloggen op het kleine scherm en dat de screensaver aanspreekt als je alleen op het grote scherm werkt.
Ik ben nog aan het zoeken hoe ik dit (en natuurlijk op hardy) aan de gang krijg.
Maar mogelijk kun je er toch iets mee ;)
grtz
Gert

nb
mijn xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder26)  Wed Sep 12 14:29:53 PDT 2007

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Wed Feb 20 09:25:02 PST 2008
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
    Identifier     "Default Layout"
    Screen      0  "Screen0" RightOf "Screen1"
    Screen      1  "Screen1" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Generieke beeldscherm"
    HorizSync       28.0 - 64.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AOC LM725"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Arnos Instruments H-W22 DVI"
    HorizSync       24.0 - 83.0
    VertRefresh     55.0 - 75.0
EndSection

Section "Device"
    Identifier     "nVidia Corporation NVIDIA Default Card"
    Driver         "nvidia"
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "NoLogo" "True"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7050 PV / NVIDIA nForce 630a"
    BusID          "PCI:0:18:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7050 PV / NVIDIA nForce 630a"
    BusID          "PCI:0:18:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NVIDIA Default Card"
    Monitor        "Generieke beeldscherm"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1280x1024_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: 1280x1024 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: 1600x1024 +0+0"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
EndSection
Er is al veel uitgezocht. Je moet het alleen weten te vinden.
Ubuntu 9.10/ASUS M2N-VM DVI AMD 64X2 Dual Core 6400+/22" NEOVO (Arnos Instruments H-W22 DVI)+17" AOC LM725