Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geluidskaart in laptop niet herkent  (gelezen 1112 keer)

piven

  • Gast
geluidskaart in laptop niet herkent
« Gepost op: 2006/08/15, 22:24:05 »
In mijn laptop met SIS onderdelen en een geluidskaart ook van SIS wordt de geluidskaart niet automatisch herkent door de kernel. De geluidskaart is dus een SIS PCI audio accelerator (rev 02). Kunnen jullie mij aangeven welke module ik hiervoor moet laden. Ik zoek al een tijdje op diverse sites maar kan de oplossing nog niet vinden.

budster

  • Gast
geluidskaart in laptop niet herkent
« Reactie #1 Gepost op: 2006/08/15, 23:03:38 »
Ik zou eens lspci doen en kijken hoe jouw geluidskaart precies genoemd wordt en daar eens op google-en

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
geluidskaart in laptop niet herkent
« Reactie #2 Gepost op: 2006/08/15, 23:13:05 »
PCI geluidskaarten worden normaal gezien automatisch gedetecteerd. Als je een ISA geluidskaart hebt ga je deze niet zien in lspci, en ga je zelf de module moeten zoeken tenzij je alsaconf hebt, maar dat levert men tegenwoordig niet meer standaard bij ubuntu.. :/

geeft lspci output over je geluidskaart?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

piven

  • Gast
geluidskaart in laptop niet herkent
« Reactie #3 Gepost op: 2006/08/16, 19:04:11 »
Citaat van: profoX
PCI geluidskaarten worden normaal gezien automatisch gedetecteerd. Als je een ISA geluidskaart hebt ga je deze niet zien in lspci, en ga je zelf de module moeten zoeken tenzij je alsaconf hebt, maar dat levert men tegenwoordig niet meer standaard bij ubuntu.. :/

geeft lspci output over je geluidskaart?
Ja die geeft aan voor multimediacontroller: SIS (Silicon integrated systems) pci audio accelerator (rev02).
Ik zag op een andere site www.calel.org/pci-devices/alsa-device-list.html dat de info van de pci kaart te achterhalen is met 'pciscan"' dat levert een vendor id en een device id op, aan de hand daarvan kun je in een tabel op de site de naam van de alsadriver voor de kaart vinden. Die van mij zou een trident moeten zijn.
Met 'modprobe trident' heb ik geprobeerd de kaart in de kernel te plaatsen, ik krijg geen foutmelding maar als ik daarna op de volumeregeling klik geeft die aan dat er geen apparaten geinstalleerd.In de var/log/messages staan wel een aantal meldingen.
Aug 16 19:51:24 localhost kernel: [ 4930.572628] Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio, version 0.14.10j-2.6, 02:57:06 Aug  3 2006
Aug 16 19:51:24 localhost kernel: [ 4930.575379] PCI: IRQ 0 for device 0000:00:01.4 doesn't match PIRQ mask - try pci=usepirqmask
Aug 16 19:51:24 localhost kernel: [ 4930.576380] PCI: No IRQ known for interrupt pin B of device 0000:00:01.4. Please try using pci=biosirq.
Aug 16 19:51:24 localhost kernel: [ 4930.577272] trident: SiS 7018 PCI Audio found at IO 0x3100, IRQ 0
Ik heb ook nog een update van pciids gedaan maar dat leverde geen andere ids op.Ik heb ook in de opstartlijst /etc/modules de trident er aan toegevoegd en de  pc opnieuw opgestart, maar geeft geen veranderingen.
Kun je mij vertellen wat ik nu verder moet doen?