Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 2e HD mounten  (gelezen 5295 keer)

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Gepost op: 2008/05/17, 18:36:34 »
Ik heb net een 20G schijfje extra gemonteerd, moest een PS kabeltje bij aan solderen ook weer gelukt. In bios automatic detect gekozen. 7.10 starten, die herkende netjes de slave schijf. Via partitioner de schijf in reiser gepartitioneer na ontkoppelen. Nu wil weer aankoppelen maar waar doe ik dat ook al weer?

Vast bedankt: Jan Willem

Offline Floyo

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #1 Gepost op: 2008/05/17, 19:45:05 »
Gewoon in de terminal,
sudo mount hdaXEn dan is je X je partitie nummer.

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #2 Gepost op: 2008/05/17, 20:03:36 »
Bedankt floyo

Ben ondertussen ook aan het zoeken en bezig geweest maar is me nog niet gelukt

Dit krijg ik:

------------
jw@pentium840:~$ sudo mount sdb
[sudo] password for jw:
mount: kan sdb niet vinden in /etc/fstab noch in /etc/mtab
jw@pentium840:~$

----------------

Heb sda1 en sda2 benoemd op 1e disk. 2e is sdb

Offline Floyo

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #3 Gepost op: 2008/05/17, 20:11:50 »
Wat is sdb over het algemeen bestaat een schijf uit de letters hda of sda met vervolgens een nummer erachter. Iets als sdb ken ik niet.

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #4 Gepost op: 2008/05/17, 20:20:04 »
Ik heb de hele schijf geformatteerd naar reiserfs, en mag helemaal gebruikt worden.

sda klopt: sda is 1e hard disk de 1 erachter de partitie
Dus sdb is 2e schijf, alleen ik heb de partitie (de hele schijf) nog niet benoemd. Zal eens kijken hoe.
En misschien moet ik gewoon de pc nieuw starten.

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #5 Gepost op: 2008/05/17, 20:33:19 »
net nieuw geboot en ik kan de 20G schijf weer zien in locaties->computer
Dus nu kan ik als het goed is er wat op kwijt. Omdat ik de hele schijf heb gebruikt staat er geen getal achter, dus blijft het bij sdb. Best logisch eigenlijk! Beter als dat afschuifsysteem van win, a->->g wat is nu f als je er een 2e dvdrom inzet?

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #6 Gepost op: 2008/05/17, 22:36:57 »
Als ik wat met die schijf wil doen moet ik wel steeds inloggen. Is daar een oplossing voor?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #7 Gepost op: 2008/05/18, 02:58:04 »
Waarom geformatteerd naar reiserfs ??

En niet naar EXT3 ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Floyo

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #8 Gepost op: 2008/05/18, 08:00:10 »
Gijsbert gaf mij deze link in een ander topic maar mischien kun jij hier ook wat mee?

http://ubuntuforums.org/showthread.php?t=432659

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #9 Gepost op: 2008/05/18, 09:44:21 »
@Gandyman: Heb een keer ext2 gehad waarmee ik problemen kreeg. Ext3 en reiserfs zijn loggend, en wou nu reiser 's een keer proberen. Maar kan het zo omzetten naar ext3 als dat nodig is.

@Floyo zal het bekijken en uitzoeken ;)

Offline vanadium

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #10 Gepost op: 2008/05/18, 11:11:13 »
Het linkje van Floyo toont inderdaad hoe het moet. Een nieuwe permanente schijf moet je toevoegen aan /etc/fstab.

Op een schijf (vb sdb) staan partities (vb sdb1, sdb2). Je kan de namen én de UUID van je partities zien met:

sudo blkid

Je kan rechtstreeks het UUID="...." van je nieuwe partitie kopiëren en plakken in /etc/fstab.

Hierna komt het koppelpunt: dat kies je zelf, maar het is goede praktijk een koppelpunt onder /media (je zal een icoon op de desktop krijgen) of onder /mnt (je krijgt geen icoon op de desktop) te kiezen. Dergelijk koppelpunt is niets anders dan een lege directory, die je zelf moet maken, vb.

sudo /mnt/data

Derde item in /etc/fstab wordt het bestandssysteem. In jou geval zal je daar "reiserfs" moeten invullen.

Vierde item zijn de opties: wellicht kan je dat op "defaults" zetten.

Vijfde en zesde zijn cijfertjes, "0" (volume moet niet gedumpt worden) en "2" (volume moet in tweede prioriteit gechecked worden tijdens opstart (enkel je root partitie krijgt nummertje 1).

Je zal dus iets krijgen als:

UUID="..."   /mnt/data  reiserfs defaults 0 1

Offline jw

  • Lid
  • Steunpunt: Nee
2e HD mounten
« Reactie #11 Gepost op: 2008/05/18, 11:20:49 »
Bedankt vanadium, zal dit gaan doen. Zelf al bezig geweest sudo (vol_id -u /dev/sdb) maar de schijf werd niet herkend. Moet er even rustig voor gaan zitten, mijn oudste dochter vraagt nu net om te computeren :lol: :cool:

Offline jw

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #12 Gepost op: 2009/07/08, 10:53:57 »
De HD mount ook niet op de xubuntu laptop, geeft aan wrong filesystem. Ik format m eerst maar eens naar ntfs en dan eens weer proberen. De apple g4 kon er helemaal niks mee.

Babertje

  • Gast
Re: 2e HD mounten
« Reactie #13 Gepost op: 2009/07/16, 23:35:10 »
defaults moet je vervangen door: rw,users,
dan kun je als gewone gebruiker er op schrijven en lezen zonder te sudo-en

Offline jw

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #14 Gepost op: 2009/08/09, 11:07:13 »
Goed, inmiddels veel raw plaatjes geschoten, en de draad na de vakantie maar weer opgepakt.

Ik kom met terminal nog niet in fstab, wel via de browser, en daar is inderdaad sdb niet in vermeld.
« Laatst bewerkt op: 2009/08/09, 11:19:24 door jw »

Offline jw

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #15 Gepost op: 2009/08/09, 12:04:03 »
sudo gedit /etc/fstab    is het enigste juiste commando

Nu gaat het lukken, al een eind op weg.

Fstab is nu bijgewerkt in:
-----------
jwo@jwo-desktop:~$ more /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=407c2559-9dbb-4ea1-99e4-2b68b338769c /               ext3    relatime,error
s=remount-ro 0       1
# /dev/sda5
UUID=58297ca1-b356-4f1e-917a-63c4831aa5be none            swap    sw           
  0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# /dev/sdb1
UUID=c960349a-3844-48a5-972a-6e06c2fe7bde /mnt/data ext3 defaults 0 1
-----------------------------------------

Welk correcte mountopdracht moet ik nu geven? (kreeg foutmelding na   "sudo mount -a ') 
Maar kan ook zijn dat de spatie's achter schijfcode en ext niet goed verdeeld zijn, de regel van sda is anders

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #16 Gepost op: 2009/08/09, 12:04:57 »
bestaat /mnt/data wel?
« Laatst bewerkt op: 2009/08/09, 12:15:25 door Cumulus007 »

Offline jw

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #17 Gepost op: 2009/08/09, 12:06:40 »
Nee dus

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #18 Gepost op: 2009/08/09, 12:10:30 »
Bij een nieuwe, toegevoegde schijf, kun je met gparted kijken welke schijf het is en formateren.

Dan start je gksudo pysdm, dan kun je grafisch je schijf verbinden met een map. Dan is hij bij opstarten ook weer aanwezig.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #19 Gepost op: 2009/08/09, 12:14:47 »
Maak /mnt/data aan, dan zou het moeten werken.

Offline jw

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #20 Gepost op: 2009/08/09, 17:11:30 »
Net pc weer gestart, een extra schijf in fstab bracht de boel wel in de war. Maar ik ben er weer.

Grafisch de schijf koppelen lukt niet, na gksudo/pysdm lijkt systeemtoepassing te starten, maar na paar seconden stopt dit.

Hoe maak je mnt/data aan?

Gparted werkt bij deze 64bit versie niet, blijft schijven scannen zonder verder te komen (ook toen de usb HD er niet in zat)
« Laatst bewerkt op: 2009/08/09, 17:27:53 door jw »

Offline Linux-user

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #21 Gepost op: 2009/08/11, 00:14:10 »
sudo gedit /etc/fstab    is het enigste juiste commando

Nee, dat is het niet. Aangezien gedit een grafisch programma is, is het goede commando "gksu gedit /etc/fstab".

# /dev/sdb1
UUID=c960349a-3844-48a5-972a-6e06c2fe7bde /mnt/data ext3 defaults 0 1

Die 1 helemaal op het eind moet een 2 zijn. Je / is namelijk 1 en alle volgende schijven krijgen hogere nummers, in jouw geval dus 2 voor de schijf die je hebt toegevoegd.

Hoe maak je mnt/data aan?

sudo mkdir /mnt/data

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #22 Gepost op: 2009/08/11, 00:37:57 »
sudo gedit /etc/fstab    is het enigste juiste commando

Nee, dat is het niet. Aangezien gedit een grafisch programma is, is het goede commando "gksu gedit /etc/fstab".

Met sudo gaat dit wel, en gksu heb ik nog nooit gebruikt, altijd sudo of gksudo.

Ten andere, Welkom op het forum Linux-user.

Offline Linux-user

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #23 Gepost op: 2009/08/11, 00:58:23 »
sudo gedit /etc/fstab    is het enigste juiste commando

Nee, dat is het niet. Aangezien gedit een grafisch programma is, is het goede commando "gksu gedit /etc/fstab".

Met sudo gaat dit wel, en gksu heb ik nog nooit gebruikt, altijd sudo of gksudo.

Ten andere, Welkom op het forum Linux-user.

Het gaat wel, ja. Tenminste, vaak gaat het wel. Het is echter niet de goede manier en als je steeds sudo gebruikt voor grafische applicaties, gaat het ooit een keer mis.
http://www.psychocats.net/ubuntu/graphicalsudo

Dank je wel.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: 2e HD mounten
« Reactie #24 Gepost op: 2009/08/11, 01:54:36 »
Ok, thx voor de link en de info.
Begrijp nu beter waarom je hier een correctie geeft.
Ben (nog steeds) een beginner en alle bijkomende/achterliggende info blijft interessant.