Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Na inloggen geen geluid meer  (gelezen 659 keer)

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Na inloggen geen geluid meer
« Gepost op: 2008/05/16, 21:23:15 »
Bij het opstarten van ubuntu heb ik wel geluid (het geluidje voordat je inlogd). Echter na het inloggen blijft het stil.....

Heb reeds van alles geprobeerd maar geen geluid. Ik heb de onboard geluidkaart gedisabled in de bios.  

Uitkomst van: cat /proc/asound/modules
 0 snd_emu10k1
 1 snd_via82xx

De emu10k1 is een SB audigy (die ik graag wil horen).

In voorgaande ubuntu versie was het zo dat ik in  /etc/modprobe.d/alsa-base moest aangeven wat de voorkeur geluidskaart is. Dat heb ik nu in 8.04 ook weer gedaan. Zie de laatste 2 regels van  /etc/modprobe.d/alsa-base:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd-emu10k1 index=0
options snd-via82xx index=1


Maar helaas geen geluid.  Wie weet een oplossing.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Na inloggen geen geluid meer
« Reactie #1 Gepost op: 2008/05/16, 23:16:13 »
Aan hang-oor
Onder Ubuntu SB audigy komt er heel wat info op het internet. Misschien heb je er wat aan.
Verder vraag ik me af of je die on board geluidskaart wel in de Bios moet afzetten, als je hem later toch op plaats 2 zet. Sluit daar gewoon niks op aan, en probeer het eens met enable. Niet geschoten, altijd mis. Bij mijn laptap ging door het uitschakelen met de knop de ingebouwde wireless af, maar ook de ingestoken wireless cardbus. Vandaar mijn idee.
Vr.groet, peter

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Na inloggen geen geluid meer
« Reactie #2 Gepost op: 2008/05/16, 23:37:02 »
Het vreemde is dat de sinds versie 6.06 de audigy het altijd zonder probleen heeft gedaan. Ook in 8.04 heb ik de kaart al werkend gehad, echter na wederom een clean install werkt het dus niet meer. Had enkel in vorige versies het probleem dat de voorkeurskaart wisselde per programma. Hetgeen dus op te lossen is door het aanpassen van /etc/modprobe.d/alsa-base.

Bij de installatie van 8.04 had ik reeds de onboard kaart gedisabled. Echter deze wordt desondanks toch gevonden (zie uitvoer /etc/modprobe.d/alsa-base in de startpost). Daarom zet ik deze op plaats 2 ondanks dat de onboard kaart niet zou kunnen werken. Dit voorkomt (volgens mij) in ieder geval dat deze onbaord kaart niet als default wordt gezien.

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Na inloggen geen geluid meer
« Reactie #3 Gepost op: 2008/05/17, 10:03:10 »
Nog eeven aanvullende info:

Met system --> administration --> harware testing wordt de audigy gevonden en is ook geluid hoorbaar.

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Na inloggen geen geluid meer
« Reactie #4 Gepost op: 2008/05/17, 13:59:07 »
Ik heb weer geluid!

NA het wijzigingen "autodetect" in "ALSA advanced linux sound architecture" onder system --> preferences --> sound heb ik weer geluid. Eerder kon ik dit altijd op autodetect laten staan, maar waarom dit nu gewijzigd moet worden is mij een raadsel. Het werkt tenmiste weer.