Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Zwart scherm bij spelen van film (dvd)  (gelezen 1444 keer)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Gepost op: 2008/05/11, 09:09:13 »
Hallo,


ik heb daarnet alle nodige pulgins en codecs en alles geïnstalleerd volgens de uitleg zoals dat in Hardy Heron zou moeten gaan.
Ik heb een probleem met een dvd af te spelen. Als ik een dvd erin stop, komt er na enkele seconden een venster om de film af te spelen. Ik kan niet zien welke speler er open gaat. Het wordt direct een groot zwart scherm en ik kan niks meer doen met de laptop. Geen esc of niks, alleen op de knop duwen om hem af te zetten.

Weet iemand hoe dat komt? Ik heb alles volgens de uitleg geïnstalleerd en ik begrijp het niet. Ik heb dat ook al voor gehad in Feisty fawn en nu is het weer hetzelfde.

Alvast heel vriendelijk bedankt voor de hulp.

Groetjes,

Els

Offline Maarten123

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #1 Gepost op: 2008/05/11, 10:14:19 »
Zie nog wel het muispijltje over het scherm?

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #2 Gepost op: 2008/05/11, 10:25:33 »
Dag Maarten,


nee, ik zie dan alleen een zwart scherm en kan niks anders doen dan de laptop afzetten.

Groetjes,

Els

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #3 Gepost op: 2008/05/11, 10:36:35 »
Heb je "Visuele effecten" of Beryl of zulk een grafisch programma draaien? Zoja, schakel deze dan eens uit.

Groetjes,
Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #4 Gepost op: 2008/05/11, 13:23:24 »
Nee, ik denk niet dat ik zoiets heb. Ik ken geen Beryl.

Offline Bobbie

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #5 Gepost op: 2008/05/11, 15:08:16 »
Meestal wordt DVD met Totem geopent, die heeft exstra plugins nodig.
Met VLC kan je het beste DVD afspelen, je hoeft geen exstra plugins te installeren en de onder titel is ook OK

Nb even geprobeerd met DVD en kan kiezen openen met GXINE, daar ik het ook goed mee afspelen.

Offline Hanssun

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #6 Gepost op: 2008/05/11, 18:25:47 »
Ik heb de Kaffeine player geinstalleerd en gebruik hem al zo lang ik Ubuntu op me computer heb en hij heb me nog nooit in de steek gelaten :) , je moet wel even de codecs en plugin installeren , maar dat had je al geinstalleerd[dit was een tip]

Gr Hans,

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #7 Gepost op: 2008/05/15, 07:53:26 »
Hallo,


ik heb Kaffeine geïnstalleerd. Het beeld gaat maar ik heb geen geluid. Ik heb bij de opties gekeken en het geluid staat ingeschakeld. Hoe komt het dan dat ik geen geluid heb?

Weet iemand hier raad mee?

Groetjes,

Els

Offline ohjajoh

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #8 Gepost op: 2008/05/15, 12:10:20 »
is libdvdcss geinstalleerd? bij mijn weten kan dat niet zomaar en moet je daar echt voor gaan zoeken (bij videolan).
Zal het probleem niet zijn daar Kaffeine wel beeld geeft, maar je weet maar nooit....

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #9 Gepost op: 2008/05/17, 11:51:11 »
Hallo,


ja, libdvdcss is geïnstalleerd.  Wat is videolan, waar kan ik dat vinden?

Groetjes,

Els

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #10 Gepost op: 2008/05/20, 08:25:31 »
Halo,


nog altijd heb ik veel problemen met het afspelen met een DVD. Ik heb onderstaande lijst nog eens helemaal doorgelopen, alles nagekeken. Bij 1 ding zat een fout, die heb ik aangepast (dat met die pakketbronnen, als je daar een zinnetje moest toevoegen stond daar een # voor en dat mocht niet).

Eerst ging 1 speler niet verder dan de beginstukjes (dat je ziet voor welke leeftijd de dvd geschikt is en het stukje van Universal, daarna begon hij niet met de dvd zelf af te spelen). Ondertussen is dat verholpen maar heb ik nog altijd geen enkel geluid erbij. Film kijken zonder geluid is natuurlijk ook niks.

Ik zal eventjes hier vermelden wat ik allemaal gedaan en geïnstalleerd heb. Wat ik nog wou vragen is: moet ik misschien alles van totem mediaspeler de-installeren?

Dit heb ik gedaan omdat er kleine boxjes aan de laptop hangen van Trust, om te zorgen dat het geluid daar uit komt en niet uit de speakers van de laptop.

sudo nano  /etc/modprobe.d/alsa-base

- en voeg aan het einde van het bestand de volgende regels toe:

# Toegevoegd door user, aug 2007.
options snd-usb-audio index=0
options snd-intel8x0 index=1

- en verwijder de "options snd-usb-audio index=-2" regel door er een # teken voor te zetten. Het laatste gedeelte van de file ziet er dan als volgt uit:


# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

# Toegevoegd door user, aug 2007.
options snd-usb-audio index=0
options snd-intel8x0 index=1


- Vervolgens: save (ctrl-o) en de editor afsluiten
(ctrl-x). Reboot.

Muziek komt er wel uit als ik muziek afspeel die ik erop gezet heb.. Wat hij niet afspeelt is het inlog- en uitlogmuziekje van Ubuntu (raar) maar wel het tromgeroffel van Ubuntu als je inlogt.

Verder heb ik ook heel de volgende uitleg gevolgd om alles te installeren van plugins die nodig zijn voor dvd 's te spelen.

"Zo installeer je snel je multimedia-codecs:
http://computertip.googlepages.com/mult … buntulinux"

Dat heb ik ook allemaal geïnstalleerd. Ergens moest je daar wat doen met sudo gedit en een regel aan 't einde toevoegen. Die stond met een # ervoor, dat heb ik weggedaan, laptop terug opgestart en toen wilden de dvd-programma 's wel de dvd zelf afspelen. Dan gingen ze door na de beginstukjes die ik daarnet zei van universal en voor wie de film bestemd is.

Nog altijd geen enkel geluidje uit de boxen als er een dvd wordt afgespeeld. Wel geluid als ik een mp3 bestand afspeel. Wel het tromgeroffel bij het inloggen op de laptop en weer niet de geluiden van Ubuntu (inlog- en afsluitmuziekje).
Ik hoor nu wel, anders staat het volume van die laptop zijn eigen speakers dicht, dat het geluid van de dvd uit die speakers komt. Dat is verkeerd, het geluid moet uit de boxen van Trust komen die aan de laptop hangen. Weet iemand hoe ik dat moet veranderen?

Ik kon bij media player connectivity, om de plugins te installeren voor firefox, die media player connectivity niet doen. Die is voor oudere versies van firefox. Op de laptop staat Ubuntu 8.04 Hardy Heron geïnstalleerd. Daardoor kreeg ik ook niet die wizard van firefox om voorkeurspelers aan te duiden.

Weet iemand misschien wat ik moet aanduiden bij systeem- voorkeuren- geluid bij de apparaten? Nu staat er overal USB audio (die boxen van Trust zijn met een USB-aansluiting op de laptop aangesloten) maar ik weet niet of dat juist is om aan te duiden.
Als ik bij Geluiden daar kies voor het opstart- en afsluitgeluid en dat wil afspelen, komt er ook geen enkel geluid.

Kan iemand mij helpen? Het geluid moet uit de Trust boxen komen, niet uit de speakers van de laptop. Weet iemand hoe ik dat moet doen?

Groetjes en alvast heel vriendelijk bedankt voor de hulp,

Els

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Zwart scherm bij spelen van film (dvd)
« Reactie #11 Gepost op: 2008/05/20, 10:55:13 »
Download eens VLC via Intalleren/verwijderen. Probeer daarmee de dvd eens af te spelen. Als hij het niet doet, ga dan naar instellingen -> preferences. Klik op uitvoer modules en vink vervolgens rechtsonderaan 'Geavanceerde opties' aan. Vervolgens verschijnt er een scherm met Audio Output Module. Zet die op Alsa audio uitvoer, of Jack Audio Output, of Linux OSS audio output. Herstart het programma elke keer als je zo'n uitvoer hebt geselecteerd en kijk dan of het geluid het dan wel doet.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."