Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Verkeerde apparaat krijgt voorkeur bij geluids opties  (gelezen 3581 keer)

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Gepost op: 2008/05/09, 20:29:44 »
Wanneer ik naar het speaker icoontje rechts bovenin ga en er met de rechter muisknop op klik en naar Volumeregeling openen ga en bij bestand Verander van apparaat kijk zie ik dat mijn geluidskaart op (1) staat.
Nu heb ik geen geluid maar gister toen deze op (0) stond wel.
Nu is mijn vraag, hoe kan ik dit omzetten?

Ik denk dat dit de oplossing is maar ik krijg het niet voor elkaar op de een of andere mannier.
http://forums.whirlpool.net.au/forum-re … 62321.html

Dit is zijn de gegevens:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #1 Gepost op: 2008/05/09, 20:44:09 »
Ubby de link werkt niet.
In der Beschränkung zeigt sich der Meister.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #2 Gepost op: 2008/05/09, 20:45:17 »
Het zou dit probleem kunnen zijn:
http://forum.ubuntu-nl.org/message/249453#p249453

Ik zal het er eens bijzetten in mijn docu. Dit komt best vaak voor.

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #3 Gepost op: 2008/05/09, 21:01:03 »
Oh, sorry:-)
http://forums.whirlpool.net.au/forum-replies-archive.cfm/962321.html

pjotr123, als ik het zo zie komen onze problemen wel aardig overeen.
Ik heb een TerraTec DMX6Fire geluidskaart en het vreemde is dat alles wel onder de vorige Ubuntu werkte.
Ik heb het idee dat de HDMI van de videokaart wordt aangezien als iets voor het geluid omdat er ATI bij staat en dat is mijn videokaart.

steefjeqv

  • Gast
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #4 Gepost op: 2008/05/11, 09:31:43 »
Hoi,

Zou het kunnen dat er telkens een andere geluidskaart als "default' wordt genomen ?
Dit kan je oplossen door een rangorde te geven aan je geluidskaarten.

In terminal ingeven :

sudo cat /proc/asound/modules

Deze output toont de verschillende geluidsapparaten en hun naam.
De namen heb je nodig om de volgorde van je geluidskaarten te bepalen.

In terminal ingeven :

sudo gedit /etc/modprobe.d/alsa-base

Onderaan dit bestand geef je de gewenste volgorde als volgt in, waarbij je C, A en B vervangt door de correcte namen :

options snd-C index=0
options snd-A index=1
options snd-B index=2

De kaart met naam C is nu "default".

Ik heb dit trouwens overgenomen van volgende link :

https://help.ubuntu.com/community/SoundTroubleshooting#head-72023a784829d5d128546a6092d67062ab50dfea

Groetjes,
Steven

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #5 Gepost op: 2008/05/11, 11:37:59 »
Bedankt, nu heb ik de geluidskaart op de goede plaats staan.
Ik heb echter nog 1 probleempje.
Wanneer ik naar het speaker icoontje rechts bovenin ga en er met de rechter muisknop op klik en naar Volumeregeling openen ga en bij bestand Verander van apparaat kijk zie ik dat de Terratec geluidskaart keurig op 0 staat nu.
Maar op 2 staat nu ice1712 - multitrack (oss mixer).
Maar ice1712 is de driver van de videokaart en ik denk dat dit de reden is waardoor ik nu nog niets kan horen.

Ik heb hieronder de output:
-desktop:~$ sudo cat /proc/asound/modules
 0 snd_ice1712
 1 snd_hda_intel


-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: DMX6Fire [TerraTec DMX6Fire], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


En zo heb ik het nu in het alsa base stand staan:
options snd-ice1712 index=0
options snd-hda_intel index=1
options snd-hda_intel index=2 (ik heb ook dit geprobeerd options snd-B index=2)

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #6 Gepost op: 2008/05/11, 21:26:34 »
Ik van alles en nog wat geprobeerd maar ik kom er niet uit.
Is er iemand die een oplossing heeft want ik ben radeloos.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #7 Gepost op: 2008/05/11, 21:37:16 »
Dit misschien:

maasnet@ubuntu:~$ sudo asoundconf list
Names of available sound cards:
CMI8738MC6
Live

maasnet@ubuntu:~$ sudo asoundconf set-default-card Live
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

steefjeqv

  • Gast
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #8 Gepost op: 2008/05/12, 08:30:54 »
Dag Ubby,

Je kan via Synaptic pakketbeheer het volgende programma installeren :

alsamixergui

Hiermee kan je kijken of er evt. nog geluidskanalen uitgeschakeld zijn (of op mute staan).

Groetjes,
Steven

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #9 Gepost op: 2008/05/12, 09:34:16 »
Hieronder de output:

sudo asoundconf list
Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.

Names of available sound cards:
DMX6Fire
HDMI

Ik heb alsamixergui geinstalleerd maar kan deze niet openen.
Ik krijg ook elke keer deze melding:


Het lijkt alsof hij de kaart niet kan vinden.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #10 Gepost op: 2008/05/12, 10:40:38 »
Als je twee geluidskaarten hebt: eentje uitschakelen. Kijk hier eens:
http://computertip.googlepages.com/geluidskaartinubuntu

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #11 Gepost op: 2008/05/12, 10:47:45 »
Citaat van: ubby
Hieronder de output:

sudo asoundconf list
Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.

Names of available sound cards:
DMX6Fire
HDMI

Ik heb alsamixergui geinstalleerd maar kan deze niet openen.
Ik krijg ook elke keer deze melding:
[url]http://img59.imageshack.us/img59/4645/schermafdrukuc2.th.png[/url]

Het lijkt alsof hij de kaart niet kan vinden.
Heb dit je ook gedaan sudo asoundconf set-default-card DMX6Fire en opnieuw opstarten.
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #12 Gepost op: 2008/05/12, 12:44:51 »
Citaat van: pjotr123
Als je twee geluidskaarten hebt: eentje uitschakelen. Kijk hier eens:
http://computertip.googlepages.com/geluidskaartinubuntu
De geluidskaart op het moederbord heb ik via de bios uitgeschakeld.
De HDMI kaart die gevonden wordt is de ATI videokaart.


Citaat van: maasnet
Heb dit je ook gedaan sudo asoundconf set-default-card DMX6Fire en opnieuw opstarten.
Heb ik ook gedaan.
Als ik van bepaalde instellingen een screenshot moet maken om te laten zien hoe alle instellingen zijn wil ik dat ook wel doen als dat makkelijker is.

Ik krijg nu wel geluid als ik op de Apple website een trailer afspeel met de mplayer plugin.
Als ik dan met de rechter muisknop op het filmpje klik en bij audio kijk is het open gelaten.

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #13 Gepost op: 2008/05/12, 19:23:15 »
Zou het ook kunnen dat pulse audio iets niet goed doorgeeft.
Want ik ben net het onderstaande tegen gekomen maar als ik "pulseaudio -nC" in de terminal doe krijg ik niet dit te zien "Welcome to PulseAudio! Use "help" for usage information.
>>> "
http://www.pulseaudio.org/wiki/FirstSteps

Dit is de driver voor mijn geluidskaart:
http://www.alsa-project.org/main/index.php/Matrix:Module-ice1712

Ik kwam het onderstaande tegen maar weet niet zeker of het ook een optie is.
http://kubasik.net/blog/2008/03/31/sound-problems-in-ubuntu-hardy/

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #14 Gepost op: 2008/05/14, 14:09:19 »
Ik diverse dingen geprobeerd maar tot op heden heeft niets geholpen.
Heeft iemand nog een idee?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #15 Gepost op: 2008/05/14, 14:16:50 »
Je kan ook de hele hda_intel kaart blacklisten, zodat die helemaal niet meer gebruikt wordt in Ubuntu.
Open /etc/modprobe.d/blacklist
Zet onderaan het volgende:
blacklist snd_hda_intel

Hierna opnieuw opstarten.

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #16 Gepost op: 2008/05/14, 16:45:43 »
Ik heb hem geblacklist zoals je hebt gezegd alleen heb ik nog geen geluid.
Ik krijg deze melding:



Aan de melding te zien heb ik het idee dat hij de geluidskaart niet kan vinden.
Maar ik heb wel geluid als ik op de Apple site een trailer afspeel met de mplayer plugin.

Ik kom er net achter dat als ik Pulse audio in de Systeemmonitor sluit het geluid wel werkt in VLC player.
Ik heb het idee dat het aan de combinatie alsa en pulse audio ligt.
Kan het zijn dat ik iets ben vergeten te installeren?


Offline shappie

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #17 Gepost op: 2008/05/15, 14:49:21 »
Misschien wat overbodig maar om even alles zeker te weten kan je de uitkomsten van deze commando's even hier neerzetten. Ik heb namelijk zelf hetzelfde gehad maar moet wel even weten hoe het allemaal zit ;)

cat /proc/asound/cards

cat /proc/asound/modules

cat /etc/modprobe.d/alsa-base
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #18 Gepost op: 2008/05/16, 08:40:40 »
Ik hieronder de uitkomsten:

ubby@ubby-desktop:~$ cat /proc/asound/cards
 0 [DMX6Fire       ]: ICE1712 - TerraTec DMX6Fire
                      TerraTec DMX6Fire at 0xd000, irq 21
ubby@ubby-desktop:~$ cat /proc/asound/modules
 0 snd_ice1712
ubby@ubby-desktop:~$ cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

Offline shappie

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #19 Gepost op: 2008/05/16, 08:56:39 »
Je moet de intel_hda niet blacklisten, haal hem uit de blacklist. Dit is je gewone geluidskaart. Je moet de ice1720 blacklisten. Haal intel_hda dus uit je etc/modprobe.d/blacklist (dacht ik). En voeg dit eraan toe: snd_ice1712
Dus in de terminal: sudo gedit etc/modprobe.d/blacklist

Laat even horen of het zo wel lukt!
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #20 Gepost op: 2008/05/16, 10:27:09 »
Ik heb het gedaan alleen het werkt niet.
Hij zet nu de HDA ATI HDMI als eerste geluidskaart en de TerraTec komt niet meer voor.
Ik denk dat de ICE1712 (DMX6Fire [TerraTec DMX6Fire], device 0: ICE1712 multi [ICE1712 multi]) de driver van de TerraTec kaart is.

Offline shappie

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #21 Gepost op: 2008/05/16, 17:19:12 »
Citaat van: ubby
Ik heb het gedaan alleen het werkt niet.
Hij zet nu de HDA ATI HDMI als eerste geluidskaart en de TerraTec komt niet meer voor.
Ik denk dat de ICE1712 (DMX6Fire [TerraTec DMX6Fire], device 0: ICE1712 multi [ICE1712 multi]) de driver van de TerraTec kaart is.
Als je wilt dat het geluid uit de terratec komt moet je de snd_hda_intel blacklisten. Zoals hierboven is aangegeven.

Voeg dit onderaan toe:
# hda intel ati hdmi
blacklist snd_hda_intel
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #22 Gepost op: 2008/05/16, 18:54:53 »
Gedaan, maar heb alleen geluid als ik Pulse audio sluit via de systeem monitor.
Het zit ergens nog niet goed maar ik weet niet waar.

Offline shappie

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #23 Gepost op: 2008/05/16, 19:40:19 »
Citaat van: ubby
Gedaan, maar heb alleen geluid als ik Pulse audio sluit via de systeem monitor.
Het zit ergens nog niet goed maar ik weet niet waar.
Probeer anders pulseaudio eens zo goed te installeren: http://ubuntuforums.org/showthread.php?t=776739

Probeer wel te backuppen want er kan natuurlijk altijd iets mis gaan. Voor mij werkte het perfect!
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline ubby

  • Lid
  • Steunpunt: Nee
Verkeerde apparaat krijgt voorkeur bij geluids opties
« Reactie #24 Gepost op: 2008/05/17, 10:57:33 »
Ik zal er deze dagen even mee aan de gang omdat eerst even een backup moet maken.

Ik heb wel even gekeken of ik dingen kon vinden die anders staan.
Dit was is dus het geval in /etc/libao.conf:
default_driver=alsa moet zijn default_driver=pulse

Omdat dit onder andere al anders staat heb ik hoop dat het gaat werken.
Het is wel jammer dat het voor veel mensen niet gelijk goed werkt, beetje jammer dat ze dat dan zo in de LTS versie hebben gedaan.

Ik laat het nog weten of het is gelukt.