Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba [ubuntu,Windows]  (gelezen 2119 keer)

Webshit

  • Gast
Samba [ubuntu,Windows]
« Gepost op: 2006/08/14, 10:28:44 »
Low,

Ik heb op een engelstalig forum een zeer goede Tutorial gevonden. En op eerste zicht werkt alles naare behoren, tot als ik probeer te connecteren met men windows pc naar men samba server (laptop). Nadat deze hem gevonden heeft (ik vermoed dit toch) krijg ik een username en paswoord venster te zien. Na het invullen en op OK te drukken krijg ik gewoon weg weer het inlog venster te zien...

Ik heb echt alles al geprobeert en wil gewoon een connectie tussen men pc en men laptop om sommige files te kunnen delen en makkelijk over te zetten. Het irritante eraan is dat ik blijkbaar ook onmogenlijk kan connecteren met men shared folders op men windows machiene (dus ubunutu -> windows).

Ter informatie Ik gebuik de laatste Ubuntu met een samba server, een router/modem (SpeedTouch 716), Windows Xp Home Sp2, Firewall Zone Alarm.

wr19026

  • Gast
Samba [ubuntu,Windows]
« Reactie #1 Gepost op: 2006/08/14, 10:43:02 »
Moet gewoon werken, ik neem aan dat je je windows user oon als Samba user op hebt gezet (met hetzelfde password)?

Hier een copy/paste van hoe het bij mij werkt. In het voorbeeld log je in als gebruiker samba met password samba

Samba
-----

apt-get install samba samba-common samba-doc smbfs inetd libcupsys2-gnutls10 libkrb53 winbind smbclient

vi /etc/inetd.conf
netbios-ssn     stream  tcp     nowait  root    /usr/sbin/tcpd  /usr/sbin/smbd

mv /etc/samba/smb.conf /etc/samba/smb.old
vi /etc/samba/smb.conf
[global]
   workgroup = [JOUW WORKGROUP]
   netbios name = [servernaam]
   server string = %h server (Samba, Ubuntu)

   passdb backend = tdbsam
   security = user
   username map = /etc/samba/smbusers
   name resolve order = wins bcast hosts
   domain logons = yes
   preferred master = yes
   wins support = yes
;   # Set CUPS for printing
;   printcap name = CUPS
;   printing = CUPS

   # Default logon
   logon drive = F:
;   logon script = scripts/logon.bat
;   logon path = \\[servernaam]\profile\%U
   # Useradd scripts
   add user script = /usr/sbin/useradd -m %u
   delete user script = /usr/sbin/userdel -r %u
   add group script = /usr/sbin/groupadd %g
   delete group script = /usr/sbin/groupdel %g
   add user to group script = /usr/sbin/usermod -G %g %u
   add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
   idmap uid = 15000-20000
   idmap gid = 15000-20000


   # sync smb passwords with linux passwords
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
   passwd chat debug = yes
   unix password sync = yes

   # set the loglevel
   log level = 3

;[homes]
;   comment = Home
;   valid users = %S
;   read only = no
;   browsable = no

;[printers]
;   comment = All Printers
;   path = /var/spool/samba
;   printable = yes
;   guest ok = yes
;   browsable = no

[netlogon]
   comment = Network Logon Service
   path = /home/samba/netlogon
   admin users = Administrator
   valid users = %U
   read only = no

[profile]
   comment = User profiles
   path = /home/samba/profiles
   valid users = %U
   create mode = 0600
   directory mode = 0700
   writable = yes
   browsable = no

[Share]
   path = /share
   valid users = %U
   create mode = 0600
   directory mode = 0700
   writable = yes
   browsable = yes

mkdir /home/samba
mkdir /home/samba/netlogon
mkdir /home/samba/profiles
mkdir /var/spool/samba
chmod 777 /var/spool/samba/
chown -R root:users /home/samba/
chmod -R 771 /home/samba/
/etc/init.d/samba restart

vi /etc/nsswitch.conf
hosts: files wins dns

smbpasswd -a root

echo "root = Administrator" > /etc/samba/smbusers
smbclient -L localhost -U%
net groupmap modify ntgroup="Domain Admins" unixgroup=root
net groupmap modify ntgroup="Domain Users" unixgroup=users
net groupmap modify ntgroup="Domain Guests" unixgroup=nogroup
useradd samba -m -G users
smbpasswd -a samba

mkdir /share
chown -R root:users /share
chmod -R ug+rwx,o+rx-w /share

Webshit

  • Gast
Samba [ubuntu,Windows]
« Reactie #2 Gepost op: 2006/08/14, 10:54:02 »
hmm. had deze van men ubuntu genomen. Nu heb ik deze snel aangepast, maar een nieuwe poging wilt windows nu niks meer vinden? Als ik via cmd ga pingen krijg ik een positief signaal terug, via uitvoer krijg ik niks te vinden en via explorer crashed deze gewoon. AAAAAAAAAAAAAAAARG ik haat netwerken, hoe te neuk doen die network administrators dat?????

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Samba [ubuntu,Windows]
« Reactie #3 Gepost op: 2006/08/14, 11:10:50 »
Ik heb er ook mee zitten klieren tot ik in de forum de tip las dat ik dit moest tokkelen in een terminalvenster:
sudo smbpasswd -a gebruiksnaamMisschien dat dit helpt. Bij mij was het iig de oplossing.

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba [ubuntu,Windows]
« Reactie #4 Gepost op: 2006/08/14, 11:28:49 »
Klopt!

Bij Samba -MOET- je ook een smbpasswd invoeren identiek aan dat van het bestaande account.

Gebruiker X, passwd xyz

dan ook smbpasswd xyz

Die parameter -a zorgt ervoor dat een nieuw smbpasswd wordt aangemaakt.

Dit alles heeft te maken met het feit dat Windows en Linux op een verschillende manier met een netwerk om gaan, en Samba een laag is om tussen Linux en Windows systemen te kunnen communiceren. Daarvoor is vanuit Linux gezien een kleine aanpassing nodig, en dat is het smbpasswd.

Voor domeinen heb je zelfs machineaccounts nodig, maar dat is specialistische kost.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Furdon

  • Gast
Samba [ubuntu,Windows]
« Reactie #5 Gepost op: 2007/01/07, 20:56:06 »
Hallo,
ik ben ook pas begonnen met kubuntu.
Het bevalt me perfekt.
Alleen een probleem waar ik nog steeds niet uit kom is het gedeelte samba.
Net als bovenstaande mn windows laptop ziet mijn pc die met kubuntu draait alleen het probleem is ik kom gewoon niet met mn windows binnen in de kubuntu bak??????????
Moet mn laptop(windows) sowieso een username en passwd hebben.
Ik heb nl op mn laptop geen passw geinstalleerd.
Of maak dat nou niet uit,je moet toch gewoon een username en een inlog passwd maken in de linux pc en die moet de windows laptop dan gewoon gebruiken om in te loggen??????????of zie ik het nu helemaal verkeerd.
Ik vergelijk het nl met windows server 2003 ,daar creeer je gewoon op de server een account met password en als de client deze goed invoert komt hij gewoon binnen in de server.
Ik hoop dat jullie me hiermee zouden kunnen helpen

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Samba [ubuntu,Windows]
« Reactie #6 Gepost op: 2007/01/08, 06:47:00 »
Op http://members.chello.nl/w.hellinga staat mijn Samba installatie manier, die werkt uitstekend.
Wellicht heb je er wat aan..

Succes