Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: suspend hybernate  (gelezen 3054 keer)

Offline postbus24

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Gepost op: 2008/05/09, 10:47:12 »
Hoi allen,

Ik heb al een paar weken een alfa versie van Hardy Heron en dat werkte voor mij probleemloos.
Braafjes heb ik altijd de updates gedaan zodat ik uiteindelijk hetzelfde als de 'release' versie heb, toch ? maar sinds kort werkt hybernate en suspend niet meer :(

Is het eventueel mogelijk om dit eenvoudig weg te herstellen door door enkele paketten te herinstalleren ? of zit ik tegen een compleet nieuwe installatie aan te kijken ? (waar ik niet echt zin in heb aangezien alles wat ik verder gebruik heel vlot werkt :( )

groetjes,
pb24

Offline nor

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #1 Gepost op: 2008/05/09, 17:58:56 »
Hibernate werkt bij mij niet altijd goed. 8 van 10 lukt het wel.

Ik kan mijn pc alleen op hibernate zetten, als ik compiz uitschakel. Draai je compiz op je PC? Zo, ja, dan werkt het misschien ook bij jou.

compiz uitschakelen:
alt + F2 =>  metacity --replace &

Dan kan je misschien nu wel je PC op hibernate zetten.

compiz inschakelen:
alt + F2 =>   compiz --replace &

Extra, maar dan wel in engels:
Here's what I did:

Create two shortcuts on your panel
shortcut #1: Start Compiz code: compiz --replace &
shortcut #2: Stop Compiz code: metacity --replace &

When you want compiz running, click shortcut 1, shortcut 2 when you don't.

Offline postbus24

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #2 Gepost op: 2008/05/12, 12:48:59 »
suspend op zich werkt wel, alleen bij het wakker worden blijft men scherm op zwart :(

Offline Dorst

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #3 Gepost op: 2008/05/12, 13:18:47 »
Misschien helpt het om via gconf-editor hibernate uit te schakelen (dus alleen van suspend gebruik maken). Ook kun je proberen de pauzestand in te schakelen via sudo pm-suspend. Dit werkte bij mij onder 7.10 meestal wel.


Offline postbus24

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #5 Gepost op: 2008/05/12, 13:51:36 »
Citaat van: pjotr123
http://computertip.googlepages.com/enkelebekendefouteninubuntu
(nummer 4)
Geen suspend of hybernate doen is natuurlijk ook een 'oplossing' :D:D

Ik heb ondertussen op een vrije partitie een nieuwe installatie gedaan en krijg hetzelfde probleem.

Het ligt volgens mijn bescheiden mening aan kernel versie 2.6.24-15 want ik had nog een oude versie 2.6.24-12 op men pc staan en daar werkt het vlotjes mee. Ik weet niet wat er verkeerd is aan deze versie tov de -15 maar zolang alles hier netjes werkt ga ik deze voorlopig als 'default' gebruiken.

Offline nor

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #6 Gepost op: 2008/05/12, 16:30:46 »
Citaat van: postbus24
suspend op zich werkt wel, alleen bij het wakker worden blijft men scherm op zwart :(
Ik krijg ook soms een zwarte scherm. Maar als je CTRL + ALT + DEL drukt, dan krijg je de venster te zien. Dan kan je inloggen. LUkt het?

Hendrikdegraaf

  • Gast
suspend hybernate
« Reactie #7 Gepost op: 2008/05/13, 11:22:24 »
Bij mij werk hybernate ook nog niet vlekkeloos (soms een wit scherm, volgende keer gaat het weer goed), maar toch al wel een stuk beter dan in Gutsy.

Als je wel een cursor maar geen beeld ziet bij het ontwaken, kan je deze naar het midden van het scherm verplaatsen, waar hij in een tekstcursor veranderd. Als je dan klik en je wachtwoord ingeeft start het scherm weer gewoon op.

Dat is bij mij tenminste de 'oplossing'.

PS: het is overigens ook mogelijk om een andere (oudere) kernel te gebruiken. Ik kon alleen niet vinden hoe dat ook al weer precies moest.

Offline Samsam

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #8 Gepost op: 2008/06/20, 13:33:19 »
Het blijft tobben met suspend en hibernate. Ik heb de suspend stand via diverse noodgrepen (weet al niet meer precies welke) uiteindelijk redelijk functionerend gekregen op mijn BTO laptop (15w26+ intel T8300 nvidia). Vaak krijg ik een blanco  scherm na het opstarten, maar daar gaat het inlogscherm achter verborgen, dus als ik mijn ww intyp en enter dan kom ik gewoon terug in de laptop. Alleen werkt dan de sounddriver niet meer. Dat heb ik uiteindelijk op weten te lossen middels een noodgreep met het  force reload commando voor de alsa driver: sudo /sbin/alsa force-reload. Die staat nu als snelkoppeling op mijn bureaublad. Het is behelpen, maar het werkt.

Offline postbus24

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #9 Gepost op: 2008/06/20, 13:54:33 »
met versie 2.6.24-19 werkt het voor de verandering weer vlotjes ;)

Offline ThomasC.

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #10 Gepost op: 2008/06/20, 15:47:36 »
Had ik ook. (suspend gebruikte ik nooit dus weet niet of die werkte)
Hybernate werkte na een update een tijdlang niet meer (ontwaken werkte niet meer) maar sinds de laatste kernelupdate van 2 dagen terug geloof ik werkt het weer.
Xubuntu, Pentium 111 CPUat 450 MHz Mermorytest: 262144K Award Plug and Play BIOS Extensions v1.0A 1998 Base memory 640 K extended memory 261120K Cache Memory: 512K PriMaster Disk: LBA , UDMA 2,10255 MB Display Type: EGA/VGA

Offline nor

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #11 Gepost op: 2008/06/20, 19:59:13 »
Dat gebeurde bij mij ook.

versie 2.6.24-16 werkt hibernate wel.
versie 2.6.24-17 werkt hibernate niet.
versie 2.6.24-18 werkt hibernate niet.
versie 2.6.24-19 werkt hibernate wel.

:)

Offline Samsam

  • Lid
  • Steunpunt: Nee
suspend hybernate
« Reactie #12 Gepost op: 2008/06/21, 23:59:32 »
Ik heb versie 2.6.24-19, maar Hibernate werkt niet. Suspend wel, maar ook niet perfect. na hibernate start mijn laptop gewoon opnieuw op en loopt vervolgens halverwege vast. pas na een reboot werkt alles weer.