Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: World of Warcraft in Ubuntu 8.04  (gelezen 5543 keer)

PaulRS2300

  • Gast
World of Warcraft in Ubuntu 8.04
« Gepost op: 2008/05/09, 09:06:38 »
Ik ben sinds kort aan t dual booten met Vista en Ubuntu. Ik wil mss Vista eraf gooien maar zolang ik niet weet hoe ik World of Warcraft onder Ubuntu aan t draaien krijg blijft Vista erop....

Hier ff wat ik heb:
WoW (vanaf Vista partitie naar Ubuntu gekopieerd)
Ubuntu 8.04
Wine 0.9.61 laatste nieuwe dus

Zijn er hier mensen die WoW spelen onder Ubuntu en mij willen helpen om WoW draaiend te krijgen???

Is to ook zo dat WoW grafisch onder Ubuntu beter uitziet???
Heb een HP pc dual core 2x 2.4ghz 3.0g werkgeheugen Nvidia 8500gt 512mb videokaart...

Offline shappie

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #1 Gepost op: 2008/05/09, 09:31:19 »
Heb je het al geprobeerd met wine?
Je moet dan via de terminal naar de map van WoW gaan en daar intypen: wine bestandje.exe (bestandje is de naam van de .exe van WoW dan). Als dat niet werkt moet je nog wat meer aanpassen maar dat weet ik ook niet allemaal. Als dit werkt en je vind het wat onhandig elke keer naar die map te gaan met de terminal kan je er een scriptje voor maken. Hoe dit moet ben ik even vergeten maar dat weten anderen hier wel.

ps. je gaat naar een map met de terminal door: "cd mapnaam".
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline SWAT

  • Administrator
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #2 Gepost op: 2008/05/11, 12:39:14 »
Kijk op de world of warcraft appdb pagina van Wine, daar staan voldoende tips/hints etc :)

sketcher

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #3 Gepost op: 2008/05/11, 13:51:35 »
Hier vind je een goede guide http://www.wowwiki.com/Linux/Wine
alles staat er, zelfs het aanmaken van een icoontje. :)

Offline kamelot

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #4 Gepost op: 2008/05/11, 17:03:33 »
wow werkt perfect onder ubuntu als hij het vreemd doet zet dan compiz uit dit kan storing geven .
Zelf op mijn laptop met een nvidia 7300 kaart haal ik hoge fps .
Vergeet niet om wow in opengl te zetten .
kijk hier maar is.

Installeer wow niet opnieuw copieer hem inderdaad gewoon van je windows partition af en dan het Config.wtf aanpassen

https://help.ubuntu.com/community/WorldofWarcraft
Humankind cannot gain anything without first giving something in return.
To obtain, something of equal value must be lost

Offline Arvid Van Essche

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #5 Gepost op: 2008/05/11, 17:23:15 »
^^ Deze tutorial heb ik ook gevolgd en die werkt perfect en is speciaal voor Ubuntu geschreven.
Nu nog wachten tot Archlord op linux werkt en dan is het volledig feest!
Wel OpenGL aanpassen (zie die tutorial) want anderskreeg ik +- 0,5 frame/sec

mvg,
Arvid

Offline Rishca

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #6 Gepost op: 2008/05/13, 00:09:39 »
Ik run wow vanaf de wow folder op mn windows partitie.

had gfx probleem waardoor ik een laag frame rate had en ongedetaileerde landschappen. Maar dat is nu helemaal gefixed door die guide door regels toe te voegen in de config.wtf :)

Er kunnen ook bepaalde functies niet werken met de ctrl-click of shift click in de game (stacks of items splitten of gear bekijken in de dressroom)  dit kan je weer oplossen door bepaalde key bindings in compiz uit te zetten.

Nu nog dual layer dvd's kunnen branden in ubuntu en dan kan vista er helemaal vanaf!

Groetjes

Rishca

Dwarrel

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #7 Gepost op: 2008/05/17, 20:55:25 »
Gister na een paar jaar niet spele van een vriend 1 maand gratis gekregen. Dus ik maar proberen in wine, makkelijker kon het niet.

Download wine 1-rc1 (nieuwste)
Stop cd der in, installeerd gewoon normaal.
Stop burning crusade der in (als je die hebt) installeerd zich ook gewoon normaal.
Download patch 2.0.0 -> 2.4.0
Installeerd patch net als in windows.
Patch kan je ook gewoon downloaden met hun updater maar duurt erg lang.
Ga naar je wine folder met terminal en navigeer naar je wow folder.
type: wine Wow.exe -opengl
En het werkt. Ik heb geen enkele tweek hoeven te doen niks veranderen alles werkte 100% alleen even -opengl doen.

Windows fps van ongeveer 37 gemiddeld. Ubuntu ongeveer 40 fps, dus dat scheeld wel een klein beetje. :)

Hostpik1992

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #8 Gepost op: 2008/05/18, 20:03:02 »
Citaat van: Arvid Van Essche
Nu nog wachten tot Archlord op linux werkt en dan is het volledig feest!
Daar ben ik het helemaal met je mee eens! Archlord werkt niet eens op Vista (wat ik nu draai) en ik wil verder gamen!

Offline Arvid Van Essche

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #9 Gepost op: 2008/05/18, 21:19:44 »
Archlord werkt wel onder vista.
Heb het paar maand geleden nog eens gedaan.
Je moet Archlord opstarten met rechtermuis > start als administrator en dan werkt het.

Niet dat we daar veel mee zijn, want vista is gewoonweg zo slecht dat ik er nu voor archlord terug XP op heb.
Enkel nu nog linux support en dan weg met XP.

Arvid

buntuxu

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #10 Gepost op: 2008/05/19, 17:33:50 »
hopelijk kan iemand mij aan een antwoord helpen. Ik kan draaien in Directx maar daar ben ik niet echt van onder de indruk, het gaat mij op openGL, OpenGL werkt correct! alleen me karakter word niet ingeladen en huisjes etc ook niet..
Menu en chat etc wordt wel weergegeven.  Dit verschijnt overigens in mijn terminal als ik wine wow.exe invoer. Vooral al die fixme: doen bij mij een vermoeden kweken dat er iets niet snor is,.

/edit : ik draai 8.04 en wine 1.0.

/media/disk-1/World of Warcraft$ wine wow.exe
fixme:advapi:SetSecurityInfo stub
archive Data\patch.MPQ opened
archive Data\enGB\patch-enGB.MPQ opened
archive Data\enGB\patch-enGB-2.MPQ opened
archive Data\patch-2.MPQ opened
archive Data\expansion.MPQ opened
archive Data\common.MPQ opened
archive Data\enGB\locale-enGB.MPQ opened
archive Data\enGB\speech-enGB.MPQ opened
archive Data\enGB\expansion-locale-enGB.MPQ opened
archive Data\enGB\expansion-speech-enGB.MPQ opened
fixme:powrprof:DllMain (0x7bf80000, 1, (nil)) not fully implemented
fixme:ntdll:NtPowerInformation Unimplemented NtPowerInformation action: 11
fixme:powrprof:DllMain (0x7bf80000, 0, (nil)) not fully implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x32eda4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32ec94,0x00000000), stub!
fixme:d3d:test_pbo_functionality >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from Loading the PBO test texture
 @ directx.c / 3520
fixme:win:EnumDisplayDevicesW ((null),0,0x32f42c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f57c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f144,0x00000000), stub!
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT
fixme:reg:GetNativeSystemInfo (0x37402b24) using GetSystemInfo()
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
fixme:imm:ImmReleaseContext (0x20024, 0x12b398): stub
fixme:imm:ImmAssociateContextEx (0x20024, (nil), 16): stub

Hostpik1992

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #11 Gepost op: 2008/05/20, 06:59:58 »
Citaat van: Arvid Van Essche
Archlord werkt wel onder vista.
Heb het paar maand geleden nog eens gedaan.
Je moet Archlord opstarten met rechtermuis > start als administrator en dan werkt het.

Niet dat we daar veel mee zijn, want vista is gewoonweg zo slecht dat ik er nu voor archlord terug XP op heb.
Enkel nu nog linux support en dan weg met XP.

Arvid
Echt waar? Want als ik probeer te patchen bij Vista verdwijnt de launcher na drie patches geïnstalleerd te hebben. En als ik een goede Archlord die volledig gepatched is te kopiëren naar mn PC en dan op te starten beweerd ie dat hij 200 patches moet installeren. Maarja, een beetje offtopic dit

Offline Arvid Van Essche

  • Lid
  • Steunpunt: Nee
World of Warcraft in Ubuntu 8.04
« Reactie #12 Gepost op: 2008/05/20, 10:07:41 »
idd we zijn serieus off topic aant gaan, maar dat zal je probleem verhelpen.

kurosaki_ichigo

  • Gast
World of Warcraft in Ubuntu 8.04
« Reactie #13 Gepost op: 2008/06/08, 13:30:39 »
Ik heb world of warcraft werkend is bijna zo goed werkend als in windows op glithes in iconen en landschap dat beetje blokkig uit ziet.