Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ik krijg geen geluid uit mijn systeem.  (gelezen 3033 keer)

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Gepost op: 2008/05/09, 08:02:40 »
Na zo'n beetje alle wiki's over geluid te hebben gevolgd wil mijn pc niets meer installeren (zie ander topic) en heb ik nog steeds geen geluid (ook niet op de koptelefoon).
Het is een ASUS laptop en de uitkomst van de commando's staat hieronder.  Alsa is geinstalleerd evenals alsa-mixer. Er komt zelfs geen geluid uit bij opstarten. Onder vista heb ik wel geluid dus de kaart/speakers zijn OK.

De kaart zou een HDA intel met realtec ALC660-VD zijn maar blijkbaar ook een HDA-ATI-HDMI

Aplay-l:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci -v:

01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
        Subsystem: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at fdeec000 (32-bit, non-prefetchable) [size=16K]
        Capabilities:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. Unknown device 1339
        Flags: bus master, fast devsel, latency 0, IRQ 23
        Memory at febf8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities:

modinfo soundcore:

filename:       /lib/modules/2.6.24-16-generic/kernel/sound/soundcore.ko
alias:          char-major-14-*
license:        GPL
author:         Alan Cox
description:    Core sound module
srcversion:     548AA54AF08207316C104F8
depends:
vermagic:       2.6.24-16-generic SMP mod_unload 586


Fred

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #1 Gepost op: 2008/05/09, 11:34:18 »
Zoek in Synaptic op naam naar "alsa".
Je moet zeker alsa-base hebben, misschien nog enkele plugins. De meeste pakketten met het ubuntu-favicon ervoor zijn nuttig, maar het hangt een beetje van je voorkeuren af.

Waarschijnlijk moet je achteraf ook nog iets doen als
sudo dpkg-reconfigure alsa-base
maar er zijn betere specialisten dan ik op dit forum... ;)
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #2 Gepost op: 2008/05/09, 12:36:06 »
Heb ik al gedaan, maar dat deed niets.

Fred

Offline siegi

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #3 Gepost op: 2008/05/09, 12:39:50 »
Piet een oplossing voor dit probleem geschreven. Kijk eens bij punt 6.
http://computertip.googlepages.com/geluidskaartinubuntu

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #4 Gepost op: 2008/05/09, 14:49:19 »
Dat gaat over een ander acer en medion, ik heb een asus. Die dingen heb ik echter al geprobeerd, stonden ook in andere wiki's. Dat laatste nietr geprobeerd, de kaart is eerder te nieuw dan te oud. Ik denk zelf dat er gewoon nog geen driver voor is. Bij alsa wordt de ICH7 genoemd en niet de 8. Ben bang dat ik dus gewoon geduld moet hebben en in de tussentijd vista voor muziek gebruiken (alleen het idee al is niet lekker :-) )

Fred

Offline siegi

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #5 Gepost op: 2008/05/09, 15:38:02 »
Dat lijntje is trouwens voor elke geluidskaart van dat type. (bv ook bij dell kan ik u verzekeren)
In de vorige versie van ubuntu had ik er ook last van, voor mij is het nu opgelost maar voor verschillende nieuwere laptops nog niet.
Dus je hebt aan /etc/modprobe.d/alsa-base volgend lijntje toevoegt
options snd-hda-intel model=auto

Nadien moet je het systeem nog rebooten.

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #6 Gepost op: 2008/05/09, 16:34:08 »
Dat heb ik inderdaad er instaan maar helaas.

Fred

Offline nicolas

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #7 Gepost op: 2008/05/09, 16:51:42 »
Ik blijf het vreemd vinden. Ik heb met mijn HP 350 onder Gutsy geen enkel probleem gehad. Na de upgrade naar Hardy wel. Of ik krijg geen geluid, of erg verstoord. Na alle tips te hebben uitgevoerd is het resultaat nog steeds nada.

Eens kijken of op de release party in Amsterdam iemand een suggestie heeft.

Ik herinnerde me net dat ik Hardy nog in een virtualbox had draaien. Naar nu blijkt heeft deze helemaal geen geluidsproblemen. Dat wordt dus zoeken naar de verschillen. Dit was overigens een fresh install. Het ziet er naar uit dat ik toch maar een fresh install ga doen van mijn laptop. :-(
Nico Veenkamp
Open Source Solutions for Internet

xubuntufan01

  • Gast
ik krijg geen geluid uit mijn systeem.
« Reactie #8 Gepost op: 2008/05/09, 18:26:21 »
Beste Fred101,

Waarschijnlijk heb je twee geluidschips in je computer zitten en weet Ubuntu niet welke geluidchip hij moet aansturen. In de Bios kun je de onboard geluidskaart geloof ik uitzetten en dan krijg je alleen geluid via de andere geluidskaart. Je kunt proberen of dit werkt.
Anders zou ik pulse-audio deactiveren.  Die staat sandaard geactiveerd in Hardy dit in tegenstelling tot Gutsy

En misschien nog handiger is om op de pictorgram van e volume-regeling te klikken met de rechtermuisknop en de goede geluidskaart te selecteren.

Vriendelijke groet,
Xubuntufan01

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #9 Gepost op: 2008/05/09, 18:44:57 »
In Kmix kan ik twee geluidskaarte selecteren maar beide doen niets. Ik zal eens in het bios kijken. Daar had ik nog niet aan gedacht. Iets installeren kan ik helaas niet want er zit nog een enorme fout in mijn systeem waar al een topic over loopt. Zou echter best gerelateerd aan elkaar kunnen zijn.

Mijn andere systeem heeft een upgrade van gutsy naar hardy en die heeft wel geluid. Dit was een verse install van een iso-disk

Fred

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #10 Gepost op: 2008/05/09, 19:25:08 »
Heb je ook een ouderwets telefoonmodem erin zitten? Ubuntu ziet die als geluidskaart (wegens de inbelgeluiden zit er een geluidschip op). Zo ja, schakel hem uit in het BIOS.

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #11 Gepost op: 2008/05/09, 19:55:08 »
Ga ik proberen want dat zit er inderdaad in.

Fred

Offline Petervdw

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #12 Gepost op: 2008/05/09, 23:30:14 »
Aan fred101
hetzelfde probleem heb je aangekaart onder:
http://forum.ubuntu-nl.org/message/249596#p249596
Daar heb ik het beantwoord, als je belangstelling hebt, ga dan daar verder.
Vr.groet, peter

Offline ubby

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #13 Gepost op: 2008/05/10, 08:12:22 »
Werkte het allemaal wel onder Ubuntu 7.10?
Want ik heb een soortgelijk probleem alleen alles werkte wel on 7.10 dus dan is er in 8.04 iets veranderd waardoor het niet goed gaat.

Offline fred101

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #14 Gepost op: 2008/05/10, 08:59:42 »
Is een nieuwe pc zo uit de doos. Maar op mijn compaq laptop heeft alles van edgy tot hardy gestaan en daar werkt alles gewoon.

Fred

Offline ubby

  • Lid
  • Steunpunt: Nee
ik krijg geen geluid uit mijn systeem.
« Reactie #15 Gepost op: 2008/05/10, 09:41:31 »
Die van mij is ook nog geen 6 maanden oud en het geluid werkte wel gewoon on Ubuntu 7.10 dat is het vreemde.
Ik heb het idee dat ze iets nieuws hebben gedaan met het geluid in Ubuntu 8.10 maar dat werkt dus niet voor iedereen.