Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (just run `nvidia-xconfig` as root)  (gelezen 8140 keer)

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Gepost op: 2008/05/05, 13:44:36 »
ik krijg een foutmelding als ik nvidia-settings wil opstarten

You do not appear to be using the NVIDIA X driver.
Please edit your X configuration file (just run `nvidia-xconfig` as root),
and restart the X server.



Ik kom er zelf niet uit mischien kan iemand kan iemand mij opweg helpen?!


Alvast bedankt

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #1 Gepost op: 2008/05/05, 14:05:36 »
open een terminal en copy-past
sudo nvidia-xconfigen druk op enter. Vul je wachtwoord in (er komen geen sterretjes of iets te staan, maar werkt wel ** extra beveiliging **) en druk weer op enter.
Druk op CTRL + ALT + Backspace om de X server te restarten
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #2 Gepost op: 2008/05/05, 14:06:59 »
Heb je de Nvidia drivers wel aangezet? Dit kan het makkelijkst via Systeem>Beheer>Hardware drivers

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #3 Gepost op: 2008/05/05, 14:38:46 »
Citaat van: Ronnie
open een terminal en copy-past
sudo nvidia-xconfigen druk op enter. Vul je wachtwoord in (er komen geen sterretjes of iets te staan, maar werkt wel ** extra beveiliging **) en druk weer op enter.
Druk op CTRL + ALT + Backspace om de X server te restarten
als ik dat doe dan start hij opnieuw op...
maar bedankt:P

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #4 Gepost op: 2008/05/05, 14:39:51 »
Citaat van: Johanvd
Heb je de Nvidia drivers wel aangezet? Dit kan het makkelijkst via Systeem>Beheer>Hardware drivers
als ik bij hardware drivers ben dan staat er niks.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #5 Gepost op: 2008/05/05, 14:49:37 »
Wat voor videokaart heb je precies?
Als je dat niet weet, dan staat het ook op je scherm als je het commando sudo lspci uitvoert in een terminal

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #6 Gepost op: 2008/05/05, 14:55:41 »
Citaat van: Johanvd
Wat voor videokaart heb je precies?
Als je dat niet weet, dan staat het ook op je scherm als je het commando sudo lspci uitvoert in een terminal
ik heb een geforce 6150 (onboard)!

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #7 Gepost op: 2008/05/05, 15:00:32 »
Dan zou je het pakket "nvidia-glx-new" moeten installeren als het goed is.

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #8 Gepost op: 2008/05/05, 15:02:11 »
Citaat van: Johanvd
Dan zou je het pakket "nvidia-glx-new" moeten installeren als het goed is.
kan je mij misschien vertellen hoe dat moet ?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #9 Gepost op: 2008/05/05, 15:24:01 »
Ga naar systeem>beheer>synaptic pakketbeheer.
Dan even zoeken op nvidia-glx-new en het pakket installeren.

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #10 Gepost op: 2008/05/05, 15:27:50 »
Citaat van: Johanvd
Ga naar systeem>beheer>synaptic pakketbeheer.
Dan even zoeken op nvidia-glx-new en het pakket installeren.
bij mij staan er alleen nvidia-glx-legacy-dev
en nvidia-glx-legacy

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #11 Gepost op: 2008/05/05, 15:33:21 »
Welke versie van Ubuntu gebruik je?

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #12 Gepost op: 2008/05/05, 15:36:20 »
Citaat van: Johanvd
Welke versie van Ubuntu gebruik je?
ubuntu 8.04

ps. top dat je me helpt:)!

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #13 Gepost op: 2008/05/05, 16:15:48 »
Als je naar systeem>beheer>software bronnen gaat, staan in het eerste tabblad de bovenste 4 regels aangevinkt?
In het 3e tabblad (updates) moeten de bovenste 2 aangevinkt zijn.

p.s. graag gedaan hoor :)

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #14 Gepost op: 2008/05/05, 17:02:00 »
Citaat van: Johanvd
Als je naar systeem>beheer>software bronnen gaat, staan in het eerste tabblad de bovenste 4 regels aangevinkt?
In het 3e tabblad (updates) moeten de bovenste 2 aangevinkt zijn.

p.s. graag gedaan hoor :)
ik heb het geflikt vraag me niet hoe maar hij doet het!
maar ik heb weer het probleem dat hij niet op 1360x768 kan:S

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #15 Gepost op: 2008/05/05, 17:32:21 »
Kan je die resolutie niet instellen via het programma nvidia-settings?
Ook niet bij systeem>voorkeuren>schermresolutie?

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #16 Gepost op: 2008/05/06, 09:18:22 »
Citaat van: Johanvd
Kan je die resolutie niet instellen via het programma nvidia-settings?
Ook niet bij systeem>voorkeuren>schermresolutie?
nee dat heb ik al geprobeerd..
maar nu was er een goeie maat van me en die had via terminal het er in gezet de resolutie 1360x768 maar na een klein probleempje is hij er weer eruitgegaan ik weet neit of jij weet hoe dat moet?:P

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #17 Gepost op: 2008/05/06, 13:08:27 »
Kan je het volgende commando uitvoeren in een terminal en de inhoud van het bestand hier plaatsen?
Schrijf hier op het forum dan voor de tekst [code ] en erachter [/code ], maar dan zonder spaties tussen de vierkante haken.
Het commando:
gedit /etc/X11/xorg.conf

Let op de hoofdletter, die is belangrijk :)

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #18 Gepost op: 2008/05/06, 15:37:30 »
Citaat van: Johanvd
Kan je het volgende commando uitvoeren in een terminal en de inhoud van het bestand hier plaatsen?
Schrijf hier op het forum dan voor de tekst [code ] en erachter [/code ], maar dan zonder spaties tussen de vierkante haken.
Het commando:
gedit /etc/X11/xorg.conf

Let op de hoofdletter, die is belangrijk :)
Natuurlijk kan ik dat!

hier komt ie

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Tue Mar  4 20:28:57 UTC 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@crested)  Tue Jan 22 12:14:09 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
  screen 0 "Screen0" 0 0
Inputdevice "Keyboard0" "CoreKeyboard"
Inputdevice "Mouse0" "CorePointer"
EndSection

Section "Files"
Rgbpath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1360x768"
Horizsync 31.5-48.0
Vertrefresh 56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
Boardname "nvidia"
Busid "PCI:0:5:0"
Screen 0
EndSection

Section "Device"
Identifier "Videocard0"
Boardname "nvidia"
Busid "PCI:0:5:0"
Driver "nvidia"
Screen 0
EndSection

Section "Screen"

# Removed Option "metamodes" "1280x768@60 +0+0; 1280x720@60 +0+0; 800x600@60 +0+0; 800x600@56 +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
Defaultdepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1360x768 +0+0"
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #19 Gepost op: 2008/05/06, 17:08:43 »
Kan je een backup maken?
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Hierna kan je het bestand openen:
gksudo gedit /etc/X11/xorg.conf

Verwijder alle tekst die er in staat, en zet dit ervoor in de plaats:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
Hierna de computer opnieuw opstarten.

Dit is zo ongeveer het minimum wat standaard ingesteld moet zijn. Ubuntu moet hierna zelf de goede instellingen kunnen vinden. Werkt dit niet, dan kan je het oude bestand weer terug zetten:
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #20 Gepost op: 2008/05/06, 17:31:36 »
Citaat van: Johanvd
Kan je een backup maken?
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Hierna kan je het bestand openen:
gksudo gedit /etc/X11/xorg.conf

Verwijder alle tekst die er in staat, en zet dit ervoor in de plaats:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
Hierna de computer opnieuw opstarten.

Dit is zo ongeveer het minimum wat standaard ingesteld moet zijn. Ubuntu moet hierna zelf de goede instellingen kunnen vinden. Werkt dit niet, dan kan je het oude bestand weer terug zetten:
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
het is voor elkaar heb me juiste resolutie hartstikke bedankt!:D

alleen nu me geluid nog uitvogelen...:S

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #21 Gepost op: 2008/05/06, 20:03:48 »
Graag gedaan :)

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #22 Gepost op: 2008/05/06, 20:19:52 »
Citaat van: ANKIS
het is voor elkaar heb me juiste resolutie hartstikke bedankt!:D

alleen nu me geluid nog uitvogelen...:S
Hey Ankis, welke geluids"kaart" heb je dan? Uiteraard waarschijnlijk onboard, maar weet je toevallig welke chip dat is? Daarmee bedoel ik dan welke modelnaam en welk merk. Als het bijvoorbeeld een Realtek AC 97 is, heb je de ALSA drivers nodig. Die vindt je geloof ik in de softwarebronnen, anders onder "installeren/verwijderen". Al moet je bij het laatstgenoemde wel opletten dat je te maken hebt met een driver, en niet bij een ALSA-volumeregeling. Het beste lijkt mij dat je eerst "ALSA driver" intikt in de softwarebronnen.

Succes!

ANKIS

  • Gast
(just run `nvidia-xconfig` as root)
« Reactie #23 Gepost op: 2008/05/06, 22:19:11 »
Citaat van: Richard_Rahl
Citaat van: ANKIS
het is voor elkaar heb me juiste resolutie hartstikke bedankt!:D

alleen nu me geluid nog uitvogelen...:S
Hey Ankis, welke geluids"kaart" heb je dan? Uiteraard waarschijnlijk onboard, maar weet je toevallig welke chip dat is? Daarmee bedoel ik dan welke modelnaam en welk merk. Als het bijvoorbeeld een Realtek AC 97 is, heb je de ALSA drivers nodig. Die vindt je geloof ik in de softwarebronnen, anders onder "installeren/verwijderen". Al moet je bij het laatstgenoemde wel opletten dat je te maken hebt met een driver, en niet bij een ALSA-volumeregeling. Het beste lijkt mij dat je eerst "ALSA driver" intikt in de softwarebronnen.

Succes!
bij mijn device manager staat MCP51 High Definition Audio...

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
(just run `nvidia-xconfig` as root)
« Reactie #24 Gepost op: 2008/05/08, 20:31:25 »
Citaat van: ANKIS
Citaat van: Richard_Rahl
Citaat van: ANKIS
het is voor elkaar heb me juiste resolutie hartstikke bedankt!:D

alleen nu me geluid nog uitvogelen...:S
Hey Ankis, welke geluids"kaart" heb je dan? Uiteraard waarschijnlijk onboard, maar weet je toevallig welke chip dat is? Daarmee bedoel ik dan welke modelnaam en welk merk. Als het bijvoorbeeld een Realtek AC 97 is, heb je de ALSA drivers nodig. Die vindt je geloof ik in de softwarebronnen, anders onder "installeren/verwijderen". Al moet je bij het laatstgenoemde wel opletten dat je te maken hebt met een driver, en niet bij een ALSA-volumeregeling. Het beste lijkt mij dat je eerst "ALSA driver" intikt in de softwarebronnen.

Succes!
bij mijn device manager staat MCP51 High Definition Audio...
Dan de ALSA driver :)