Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen met video playback  (gelezen 1290 keer)

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Gepost op: 2008/05/04, 12:53:02 »
Hoi allemaal,

Ik heb een vervelend probleem. Als ik film wil gaan kijken, gaat deze erg traag en schokkerig in fullscreen. Geluid gaat dan ook een stuk schokkeriger aan de gang.

Wat info:
lscpi | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]

glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

HOe kan ik dit probleem tackelen? (Lees: ontdekken waar het aan ligt?)
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Problemen met video playback
« Reactie #1 Gepost op: 2008/05/04, 14:12:02 »
Je hebt de verkeerde driver: de Mesa. Je wil de fglrx. Als het niet lukt om die te installeren via Systeem - Beheer - Hardware drivers, probeer dan envyng-gtk eens. Te installeren via Synaptic.

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #2 Gepost op: 2008/05/05, 11:18:18 »
Hmm.. je laatste tip lijkt de oplossing te zijn geweest... Video draait nu goed en lekker snel. Heb alleen af en toe dat de pc wat langzamer gaat lopen. Moet nog ff uitzoeken hoe het zit :)
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #3 Gepost op: 2008/05/05, 23:34:17 »
Hmm.. het is ten dele de oplossing geweest... Fullscreen video kijken op Youtube gaat nog steeds schokkerig en films in Fullscreen werken weliswaar voor het grootste deel vloeiend, maar af en toe toch ook schokkerig... In Gutsy 32 bit had ik hier nooit problemen mee. Blijkbaar heeft Hardy 64 bit wel problemen met het afspelen van films e.d. op mijn laptop (zie onderschrift).
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Problemen met video playback
« Reactie #4 Gepost op: 2008/05/05, 23:35:56 »
Heb je 32-bits 8.04 al geprobeerd?

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #5 Gepost op: 2008/05/05, 23:47:36 »
Nee, nog niet. Gebrek aan cd-r's is daar de oorzaak van :) Ik wilde eigenlijk met de 64  bits alle kracht uit mijn pc halen die erin zit. Het lijkt er overigens wel op dat ie iets sneller is, behalve dan met de video playback.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #6 Gepost op: 2008/05/05, 23:55:58 »
Overigens heb ik nu een aparte home-partitie. Maakt het wat uit of ik op de / partitie een 64-bits versie overschrijf met een 32-bits versie?
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #7 Gepost op: 2008/05/15, 16:23:21 »
Vandale eh... crashit wacht op antwoord...
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Problemen met video playback
« Reactie #8 Gepost op: 2008/05/16, 11:54:44 »
En Crashit heeft weer een antwoord gevonden:

the file is pixelated in full-screen mode
For reasons unknown to anyone except ATI, the proprietary ATI video driver has its XVideo extension disabled by default. XVideo is required for smooth, non-pixelated scaling of video. It will also decrease CPU load during playback since the scaling and overlay is handled by the video card.

You can enable XVideo by entering the following command into a terminal:

sudo aticonfig --ovt Xv

You have to restart the system once for the new setting to take effect.

-------

Werkt nu goed onder Hardy 32 bit.

-------

Bron: http://ubuntuforums.org/archive/index.php/t-571875.html
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."