Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Virtual machine in Hardy Heron  (gelezen 2425 keer)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Gepost op: 2008/05/04, 07:52:18 »
Hallo,


ik ben Els. Ik heb pas Hardy Heron geïnstalleerd. Graag had ik een virtual machine gehad. Mijn broer heeft mij geholpen met op de vorige versie (Ubuntu 7.10 Gutsy gibbon) een virtual machine te installeren, namelijk Virtualbox. Omdat het standaard niet ging om usb te activeren zodat het virtual machine het herkent als je een USB toestel aan de computer hangt, heeft hij uitgezocht hoe het wel ging. Ik heb toen Virtualbox moeten downloaden van virtualbox.org/wiki/downloads
Hij had dan opgezocht hoe de USB aan de praat moest, daarvoor moest er iets veranderd worden aan 2 bestanden via de terminal.

Nu vraag ik mij af of er misschien met de nieuwe Hardy Heron verbetering gekomen is in dat USB probleem. Ik weet nu niet goed of ik bij installeren/verwijderen of bij synaptic een virtual machine moet installeren. Of moet ik het doen zoals mijn broer mij uitgelegd had?

Weet iemand hier raad mee? Is dat van die USB al opgelost in Hardy Heron zodat het moet werken als je het juiste virtual machine installeert, of moet ik het doen zoals mijn broer zei?

Alvast vriendelijk bedankt voor de hulp.

Els

Offline Ramana

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #1 Gepost op: 2008/05/04, 09:37:30 »
Na de installatie van Virtualbox moet je (nog steeds) de usb aan de praat krijgen. Dat kan op twee manieren

Manier 1
open als root /etc/fstab en voeg deze regel toe:
usbfs                /proc/bus/usb        usbfs      devgid=XXX,devmode=664             0 0

Pas XXX aan. XXX is te vinden met: cat /etc/group | grep vboxusers
bij mij geeft dat de melding: vboxusers:x:119:ubuntu. XXX is bij mij (ubuntu) dus 119


manier 2 (makkelijker)

doe in console: sudo gedit /etc/init.d/mountdevsubfs.sh
 Vervolgens moet je even dit onderdeel opzoeken:
#
 # Magic to make /proc/bus/usb work
 #
 Daaronder staan vier regels, die zijn voorzien van een comment (#). Die moet je weghalen:

#
   # Magic to make /proc/bus/usb work
   #
   mkdir -p /dev/bus/usb/.usbfs
   domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
   ln -s .usbfs/devices /dev/bus/usb/devices
   mount --rbind /dev/bus/usb /proc/bus/usb

na herstarten werkt de USB

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #2 Gepost op: 2008/05/04, 10:21:42 »
Citaat
Nu vraag ik mij af of er misschien met de nieuwe Hardy Heron verbetering gekomen is in dat USB probleem.
Op die vraag krijg je antwoord indien je het betreffende USB apparaat in je pc stopt.

Gebeurd er niets, word het ook in HH niet herkend.
Gebeurd er wel iets, dus word het gemount, dan ondersteund HH het wel.

Dus voor je jezelf een boel werk op je nek haalt, lijkt het me verstandig om eerst ff die USB in je pc te steken. ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #3 Gepost op: 2008/05/04, 11:22:36 »
Bedankt voor jullie hulp.

Weet iemand van waar ik virtualbox dan moet halen? Is dat via installeren/verwijderen of moet ik het via die link doen die mijn broer gaf?

Groetjes,

Els

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #4 Gepost op: 2008/05/04, 11:25:41 »
in synaptic te vinden onder het pakket virtualbox-ose. Volg daarna de volgende aanwijzingen:

Je moet synaptic starten en het bovengenoemde pakket virtualbox-ose-modules-generic installeren. Vervolgens maak je je gebruiker lid van de groep vboxusers (systeem>beheer>gebruikers en groepen>klik op groepen beheren>zoek groep vboxusers in de lijst en dubbelklik erop>maak je gebruiker lid van die groep>klik ok>log opnieuw in)

Jezelf lid maken van de bovengenoemde groep moet je doen, anders krijg je daar ook een foutmelding van.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #5 Gepost op: 2008/05/04, 11:41:17 »
Bedankt cumulus.

Ik had virtualbox al geïnstalleerd toen ik Gutsy gibbon heb, nu is het hardy heron. Als ik een machine wil aanmaken, krijg ik te lezen dat er al eentje bestaat. Weet jij misschien wat ik nu moet doen? Moet ik alles op mijn computer wissen van de vorige installatie om het nu in hardy heron helemaal nieuw te installeren?

Groetjes en alvast bedankt,

Els

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #6 Gepost op: 2008/05/04, 11:48:49 »
Je kunt in virtualbox gewoon meerdere virtuele machines maken. Als je er nog geen hebt aangemaakt is er wel wat mis. Kun je een screenshot plaatsen of de foutmelding hier plaatsen?

PieterD

  • Gast
Virtual machine in Hardy Heron
« Reactie #7 Gepost op: 2008/05/04, 11:56:53 »
Er moeten TWEE groepen bestaan:

vboxusers (wordt door VB zelf aangemaakt, heb je verder geen omkijken naar)
usbusers (die moet je zelf aanmaken om USB werkend te krijgen. Noteer het nummer dat deze groep krijgt toegewezen, b.v. 1001. Dat is je latere devgid).

Van beide groepen moet de gebruiker 'lid' zijn en de groep usbusers moet aan fstab worden toegevoegd:

 # is de USB group
none    /proc/bus/usb  usbfs devgid=1001,devmode=664    0


Daarna opnieuw opstarten. In VB moet onder settings van het betreffende besturingssysteem nu ook USB verschijnen. Door daar op te klikken kun je de USB-apparaten toevoegen die je wil gebruiken.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #8 Gepost op: 2008/05/04, 19:53:59 »
Hallo PieterD,


ik denk dat ik begrijp wat je bedoelt, alleen weet ik dat juiste commando niet om die groep usbusers aan fstab toe te voegen. Kan je mij daar aub mee helpen? Ik begrijp nooit veel van de commando 's.

Alvast vriendelijk bedankt!

Els

PieterD

  • Gast
Virtual machine in Hardy Heron
« Reactie #9 Gepost op: 2008/05/05, 11:46:33 »
Je hoeft geen commando te gebruiken.

Gewoon fstab in root openen, die regels onderaan toevoegen en het bestandje weer opslaan. Let wel op de devgid. Bij mij is dat 1001 maar bij jou kan dat anders zijn.

Het bestandje fstab vind je overigens in de map /etc

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #10 Gepost op: 2008/05/05, 16:10:54 »
Dag PieterD,

ik denk dat ik wel een commando in moet voeren want als ik het zo plak in fstab, de juiste cijfers invul en wil opslaan, zegt hij dat ik niet de juiste rechten heb om dat op te slaan. Ik ken alleen het commando niet om dat te doen.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #11 Gepost op: 2008/05/05, 16:25:42 »
Hallo,

er klopt ergens iets niet met dat commando, ik weet alleen niet wat, ik krijg altijd foutmeldingen dat die map niet bestaat.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #12 Gepost op: 2008/05/05, 16:27:27 »
Hij zegt ook dat ik de nodige rechten niet heb en dat ik moet kijken of de locatie correct is ingetypt.

xubuntufan01

  • Gast
Virtual machine in Hardy Heron
« Reactie #13 Gepost op: 2008/05/05, 16:36:52 »
Citaat van: Els1980
Hallo,

er klopt ergens iets niet met dat commando, ik weet alleen niet wat, ik krijg altijd foutmeldingen dat die map niet bestaat.
Er klopt inder daad niets met dat commando:
probeer het volgende eens:
gksu gedit  /etc/fstab in de terminal
of
ALT FN2
gedit /etc/fstab
er wordt dan om je wachtwoord gevraagd

FN2 is functietoets 2

Er stonden namelijk enkele spaties teveel in het commando.
Linux kent ook zoiets als auto-aanvulling (oftewel auto-completion). Je
kunt bovenstaand commando ook als volgt bereiken:
typ in:
gksu gedit /etc/fs
en druk op de [tabtoets], je krijgt dan alle mogelijkheden, die beginnen met fs...

Die tab-toets is erg handig bij het intoetsen van commando's, hoef je niet alles te onthouden!!!

Vriendelijke groet,

Xubuntufan01

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #14 Gepost op: 2008/05/05, 17:46:44 »
Het is nu gelukt om die fstab aan te passen, alleen nog uitvissen hoe ik die andere foutmeldingen van virtualbox weg krijg.


VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Please install the virtualbox-ose-modules package for your kernel, e.g. virtualbox-ose-modules-generic..
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

Weet iemand hier raad mee? Normaal gezien heb ik Virtualbox gisteren gedownload van Synaptic en zou ik denken dat dat gelukt is.

Offline Ramana

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #15 Gepost op: 2008/05/05, 18:08:57 »
Je bent er bijna, maar op dit moment klopt de kernel-versie (2.6-24-17) niet met module versie van Virtual box. Gebruik daarom liever de deb-versie van virtualbox zelf.  Maar het wordt makkelijker: de nieuwe versie 1.6 is uit! Met heel veel verbeteringen! :) :).....

Offline shappie

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #16 Gepost op: 2008/05/05, 18:13:52 »
Als ik u was zou ik de closed source versie gebruiken. Deze is veel nieuwer en zoals Ramana al zei met veel verbeteringen! Gewoon die versie verwijderen en de .deb van de virtualbox downloaden en installeren, werkt hier ook perfect. (hier is de site trouwens: https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_SMI-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=innotek-1.6-G-F@CDS-CDS_SMI)
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #17 Gepost op: 2008/05/05, 18:55:17 »
Bedankt voor jullie uitleg, ik ga dat uitproberen.

ik wou nog graag iets weten. Als je een programma of zo 'n .virtualbox op je computer hebt staan en je klikt daarop en duid aan "Naar prullenbak verplaatsen", is het dan helemaal van je computer?
Ik heb die virtualbox die aangeduid stond in synaptic aangeduid om volledig te verwijderen en dat gedaan. Nu ga ik dat andere uitproberen wat jullie zeiden.

Groetjes en bedankt voor de hulp,

Els

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #18 Gepost op: 2008/05/05, 19:05:42 »
Hallo,


ik heb nog wat hulp nodig denk ik. Ik heb dat gedownload van de website die shappie gaf maar krijg foutmeldingen als ik op het bestand klik om het te openen. Ik weet niet precies wat ik moet doen als ik het gedownload heb. Kan iemand daar mee helpen? Liefst geen heel moeilijke uitleg want ik ben nog niet zo goed thuis in de commando 's en computertaal.

Deze foutmelding krijg ik:

Het bestand /home/els/.fr-5jnUpu/vmw…distrib/vmware-install.pl is gewijzigd op schijf.
En dan deze:
Kan het bestand ‘/home/els/.fr-5jnUpu/vmw…distrib/vmware-install.pl’ niet terugzetten. De tekst-editor kan het niet vinden, mogelijk is het onlangs verwijderd.

Ik hoop dat iemand mij kan helpen want zo geraak ik er niet uit.

Groetjes,

Els

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #19 Gepost op: 2008/05/05, 19:09:24 »
Sorry, ik had iets aangeduid bij dat downloaden, een vinkje gezet bij download met sun manager en dat moest blijkbaar niet. Ik denk dat ik er nu wel mee verder kan. Eerst eventjes computer terug opstarten en dan kijken of het bij Toepassingen komt te staan.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #20 Gepost op: 2008/05/06, 08:37:37 »
Hallo,

ondertussen is dat virtual machine geïnstalleerd en werkt het goed.
Het enige probleem heb ik nog dat ik mijn Nokia 6070 eraan wil hangen, ik heb die vakjes van USB aangevinkt zodat hij dat zou moeten zien en er gebeurt niks als ik mijn gsm aansluit via de gegevensoverdrachtkabel van Nokia.

Weet iemand hoe dat komt? Doe ik nog iets verkeerd?

Groetjes en bedankt voor de hulp,

Els

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Virtual machine in Hardy Heron
« Reactie #21 Gepost op: 2008/05/12, 10:48:02 »
Hallo,


als ik mijn gsm aankoppel zie ik ook niet in Ubuntu dat die is aangekoppeld. Bij de USB devices in de virtual machine is ook niks te zien.

Je hebt een document op de computer, iets met permission rules 40 waar je volgens een website iets aan moest veranderen om die USB werkend te krijgen. Mijn broer heeft dat eens opgezocht toen ik bij hem was. Ik zal het hier eventjes zetten wat je daarvoor moest doen:

"I was able to get USB working in VirtualBox bij editing this fils:

sudo gedit /etc/udev/rules.d/40-permissions.rules

and changing the line for usb devices from 0664 into 0666

I got this information from this (http://ubuntuforums.org/showthread.php?t=341740&page=3) post, which might be of further assistance to you." Er ging iets mis met die link,na dat ? moet er staan t=341740&page=3

Dat heeft mijn broer toen voor mij gekopieerd van een website en ik denk dat ik misschien daar teveel cijfertjes veranderd heb om die USB te laten werken. Nu ben ik niet zeker wat het moet zijn.

Ik hoop dat iemand mij kan helpen. Alvast heel vriendelijk bedankt!

Groetjes,

Els