Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xgl maakt computer sloom -> geen Compiz  (gelezen 1201 keer)

monnick

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Gepost op: 2008/05/03, 00:20:40 »
Sinds gisteren werk ik op een nieuwe install van Ubuntu. Ik draai nu Gutsy (nee geen Hardy, daar heb ik allerlei probs mee), net als mijn vorige install.

Bij mijn vorige install gebruikte ik de drivers van ATi die ik aangezet had bij "restriced drivers", verder had ik een aantal pakketen bij synaptic pakketmanger gedownload en ook XGL. Ook had ik 'composite' oid. ge-enabled in xorg.conf. Toen werkte Compiz goed.

Nu op mijn huidige install als ik alles precies hetzelfde doe als bij de vorige install wordt mijn PC na 5 min eeeeenorm traag. Met behulp van iemand op het IRC kanaal ontdekte ik dat dit komt door XGL, dat proces vreet CPU. Erg raar, want alles staat verder precies hetzelfde als bij de vorige installatie, en toen had ik nergens last van.

Momenteel heb ik XGL gedeinstalleerd (als het wel geinstalleerd is, is op de PC niet te werken zo traag als hij is). Maar nu kan ik helaas geen gebruik maken van Compiz, dit zou ik toch graag willen.

Heeft er iemand enig idee wat dit voor raar probleem is en hoe ik het kan oplossen. (met of zonder XGL?), ik zou graag Compiz weer gebruiken! :)

pc. Mijn videokaart is een ATi RADEON x800 xx

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Xgl maakt computer sloom -> geen Compiz
« Reactie #1 Gepost op: 2008/05/03, 00:23:09 »
Kan je niet gewoon de open source drivers van Ati gebruiken? Dan heb je helemaal geen XGL nodig.

monnick

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Reactie #2 Gepost op: 2008/05/03, 00:36:01 »
Bedoel je met de Open Source drivers (van ATi) de drivers die standaard gebruikt worden wanneer je Ubuntu net installeerd? Die werkten namelijk niet helemaal goed (rand van beeldscherm mist), daarom heb ik de drivers van ATi ingeschakeld bij 'restricted drivers', nu werkt het beeld helemaal goed behalve Compiz (en Open Arena....).

tuxido_devito

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Reactie #3 Gepost op: 2008/05/03, 12:29:00 »
probeer beryl eens, een afstammeling van compiz, iets minder mooi dan compiz fusion maar het zou mischien wel kunnen werken...

monnick

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Reactie #4 Gepost op: 2008/05/03, 13:34:08 »
Dat vind ik eerder het omzeilen van het probleem. Zou liever gewoon Compiz gebruiken. Hoe zit het met aiglx, is dat een (goed) alternatief voor XGL ?

ikkefc3

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Reactie #5 Gepost op: 2008/05/03, 13:46:25 »
Mischien zou je met Envy (http://www.albertomilone.com/nvidia_scripts1.html)  de nieuwste drivers voor je ATi kaart kunnen halen. Dan kun je AIGLX gebruiken (de oude drivers die in gutsy zitten ondersteunen nog geen aiglx).
AIGLX is een goed alternatief voor XGL, omdat het vrijwel niets veranderd aan je fontconfig of een aparte xserver start zoals XGL.
AIGLX draait ook niet als een apart proces (het zit dus veel meer "geintegreerd").

monnick

  • Gast
Xgl maakt computer sloom -> geen Compiz
« Reactie #6 Gepost op: 2008/05/03, 22:23:10 »
Ben uiteindelijk toch (weer) overgestapt naar Hardy Heron. En godzijdank werkt nu alles prima, al mijn (voor)oordelen tegen 8.04 zijn uit de wereld!

In ieder geval bedankt voor jullie hulp!