Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Plone CMS installeren op Unbuntu 8.04 Desktop en Server  (gelezen 996 keer)

Offline force317

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Gepost op: 2008/05/02, 07:58:45 »
Kan iemand mij - stap voor stap - uitleggen hoe je een programma als Ploen ( + Zope ) installeert :

1°/ op een Ubuntu 8.04 of Kubuntu 8.04 Desktop versie : deze pc gebruik ik vnl voor testen alvorens te installeren op Server versie.

2°/ op een Ubuntu 8.04 Server : momenteel draait Plone CMS op een oude Windows 2000 SBS Server. De bedoeling is deze machine om te bouwen tot een Ubuntu 8.04
Server met daarop als belangrijkste programma Plone CMS (als intranet).

Onder Windows is de installatie volledig automatisch. Voor add-ons hoef je de zip files alleen maar uit te pakken naar de map /plone/data/products, en vervolgens te installeren via het Plone installatie menu. Installeren/deinstalleren onder Ubuntu : even vlot.

Plone (+Zope) behoort niet tot de pakketten die door Ubuntu op een geautomatiseerde wijze kunnen geinstalleerd. Is er dan geen mogelijkheid om dit zelf te doen via een of andere softwareapplicatie die je kan installeren in plaats van dit te doen via het invoeren van kommandoregels ? Deze vraag geldt trouwens ook voor andere pakketten.

Hoe doe je de installatie in Ubuntu Desktop of Server, stap voor stap ? Als er een nieuwe versie uitkomt, hoe installeer je de upgrades ?

Nog iemand ervaring met Plone CMS ? Tevreden ? Of toch liever een PHP product zoals Joomla of Drupal ?
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #1 Gepost op: 2008/05/02, 08:03:59 »
Heb er nooit mee gewerkt, zal er wel eens naar kijken, toen ik ging zoeken naar de officiële site, viel me oog op deze link: http://howtoforge.com/debian_plone

Misschien dat je er iets aan hebt.
Live to win, dare to lose
http://www.robmaas.eu

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #2 Gepost op: 2008/05/02, 09:36:32 »
Er staan in synaptics ook iets: plone-site

This package setups an own zope instance with a ready-to-be-used
plone site.

zie ook:

http://plone.org/documentation/how-to/plone-on-debian-etch

edit:

Ik krijg een niet functioneel pakket als ik dit installeer. Er wordt geen instance aangemaakt. Dit heb ik vervolgens handmatig gedaan, zie "man dzhandle" in een terminal voor meer info:

sudo dzhandle --zope-version=2.9 make-instance myplone --addon-mode=all --service-user=:zopevervolgens opstarten:

/etc/init.d$ sudo /etc/init.d/zope2.9 starten dan:

Citaat
Create a Plone site:

Go to your browser and type http://localhost:9673/manage' and log in. You are now in the so called ZMI (Zope Management Interface).

To create a Plone site, you need to add it to your zope instance within the ZMI: Use the drop-down at the right, choose Plone Site and klick add. Give your Plone Site at least an ID (do not use fancy characters) for example myplone.

Congratulations: your Plone instance is available at http://localhost:9673/myplone
Dan kan je beginnen met plone. Ziet er leuk uit, en de sites die ermee gemaakt zijn, niet verkeerd.

Offline force317

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #3 Gepost op: 2008/05/02, 16:11:47 »
Heb Plone en essentieel toebehoren geinstalleerd via Synaptec-pakketbeheer (Synaptec bepaald zelf wat er allemaal nodig is om Plone te draaien) , administratornaam ingegeven, paswoord gekozen, poortnummer opgegeven die zal gebruikt worden. Ik neem aan dat ik nu nog de Zope server waarop Plone CMS draait moet opstarten en vervolgens via http:/localhost:poortnummer/ kan ik dan de startpagina bereiken ? Hoe doe ik dat ?
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #4 Gepost op: 2008/05/02, 17:38:38 »
Nou, volgens mij heb ik dat ongeveer beschreven in het bovenstaande berichtje?

edit:
(waarbij 9673 in jouw geval wellicht een andere poort is)

Offline force317

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #5 Gepost op: 2008/05/02, 19:54:15 »
Oké, installatie is gelukt, ben echt die commandoregels niet gewoon, maar ik leer het nog wel. Hartelijk bedankt voor de info.

Plone Site is nu geinstalleerd onder Zope 2.9. Ik stel wel vast dat er ook een Zope 2.10 op mijn pc staat ...

Mijn pc veegt wel zijn voeten aan het poortnummer dat ik opgaf bij de installatie via adept (Kubuntu 8.04) van Plone+Toebehoren, nl 8081. Heb om Plone te bereiken poort 9673 moeten gebruiken ( de Zope poort). Kan dat poortnummer nu nog veranderd worden ?

Nogmaals hartelijk bedankt !
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Plone CMS installeren op Unbuntu 8.04 Desktop en Server
« Reactie #6 Gepost op: 2008/05/03, 00:50:51 »
Citaat van: force317
Oké, installatie is gelukt, ben echt die commandoregels niet gewoon, maar ik leer het nog wel. Hartelijk bedankt voor de info.

Plone Site is nu geinstalleerd onder Zope 2.9. Ik stel wel vast dat er ook een Zope 2.10 op mijn pc staat ...

Mijn pc veegt wel zijn voeten aan het poortnummer dat ik opgaf bij de installatie via adept (Kubuntu 8.04) van Plone+Toebehoren, nl 8081. Heb om Plone te bereiken poort 9673 moeten gebruiken ( de Zope poort). Kan dat poortnummer nu nog veranderd worden ?

Nogmaals hartelijk bedankt !
Dat nr. kan je nog veranderen.

Je moet dan in de file zope.conf wat veranderen. Je vindt deze file in /etc/zope/zope2.9/myplone/zope.conf

open deze in een terminal met sudo:

sudo gedit /etc/zope2.9/myplone/zope.confZoek naar de volgende regel, in het begin van het bestand.

%define INSTANCE /var/lib/zope2.9/instance/myplone
%define HTTPPORT 9673
Als je hier 9673 veranderd in 8081 zou het volgens mij moeten lukken (ik heb het niet geprobeerd, maar las vanmiddag ergens dat je dit bestand kon wijzigen voor deze instelling).

wel zope eerst herstarten:

/etc/init.d/zope2.9 restartsucces ermee.