Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Asus P5GC-MX/1333 LAN-problemen  (gelezen 2753 keer)

Offline geertbruijnes

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Gepost op: 2008/05/01, 23:29:19 »
Ik ben beginner en krijg mijn LAN niet aan de praat.
Bij Ubuntu 7.10 na veel vijven en zessen, ik weet niet wat ik allemaal gedaan heb maar na een herstart werkte het ineens.
Nu 8.04 loop ik weer tegen de problemen aan.
Moederbord: Asus P5GC-MX/1333 met:
Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet Adaper (rev a0)

Al veel topics her en der over gelezen, maar geen een eindigt met 'ja het werkt'

Ik moet kennelijk zelf een driver bouwen, gezien de bestanden die ik meegekregen heb op CD.
De readme zegt het volgende:


 ...
This file describes the Linux* Base Driver for the Atheros(R) L2 Fast
Ethernet Adapter, version 1.0.x. This driver supports the 2.4.x and 2.6.x kernels.

This driver is only supported as a loadable module at this time. Atheros is not
supplying patches against the kernel source to allow for static linking of
the driver. For questions related to hardware requirements, refer to the
documentation supplied with your Atheros(R) adapter. All hardware
requirements listed apply to use with Linux.

Building and Installation
=========================

To build a binary RPM* package of this driver, run 'rpmbuild -tb
'. Replace with the specific filename of
the driver.


NOTE: For the build to work properly, the currently running kernel MUST match
      the version and configuration of the installed kernel sources. If you
      have just recompiled the kernel reboot the system now.

      RPM functionality has only been tested in Red Hat distributions.


1. Move the base driver tar file to the directory of your choice. For example,
   use /home/username/atl2 or /usr/local/src/atl2.

2. Untar/unzip archive:

     tar zxf atl2-x.x.x.tar.gz

3. Change to the driver src directory:

     cd atl2-x.x.x/src/

4. Compile the driver module:

     make install

   The binary will be installed as:

     /lib/modules//kernel/drivers/net/atl2.[k]o

   The install locations listed above are the default locations. They might
   not be correct for certain Linux distributions. For more information,
   see the ldistrib.txt file included in the driver tar.

5. Install the module:

     insmod atl2 =

6. Assign an IP address to the interface by entering the following, where
   x is the interface number:

     ifconfig ethx

7. Verify that the interface works. Enter the following, where
   is the IP address for another machine on the same subnet as the interface
   that is being tested:

     ping  
...


Het begint er al mee (punt 2) de de file geen atl2-x.x.x.tar.gz heet maar l2-linux-v1.0.40.4.tar.gz.
De src map (punt 3) wordt wel gemaakt, maar make install (punt 4) geeft de volgende meldingen:

make: Warning: File `Makefile' has modification time 5,8e+07 s in the future
make -C /lib/modules/2.6.24-16-generic/build SUBDIRS=/home/geert/Bureaublad/LAN/l2-linux-v1.0.40.4/src modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/geert/Bureaublad/LAN/l2-linux-v1.0.40.4/src/Makefile". Fix it to use EXTRA_CFLAGS.  Stop.
make[1]: *** [_module_/home/geert/Bureaublad/LAN/l2-linux-v1.0.40.4/src] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
make: *** [default] Error 2

Veel warnings en errors dus.

Er ontstaat geen atl2.[k]o in kernel/drivers/net; ook nergens anders te vinden.
Er staat wel een alt1 in deze map, maar deze is van oudere datum, dus stond er w.s. al.
Vanaf hier gaat het (uiteraard fout). Ik zou ook niet weten wat ik bij punt 5 voor = in moet vullen.

Wie helpt mij verder?
Graag kleine stappen; ik ben zoals gezegd een beginner.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #1 Gepost op: 2008/05/01, 23:46:22 »
Aan geertbruijnes
Voor je verder gaat, ik ben ook maar een beginner, een paar vragen. Is dat een min of meer "gewone" PC met een Lan kaartje (al of niet on board) waar je over praat. En komt die dan met een ethernet kabel aan een router/modem/switch? Of draadloos.
Vr.groet, peter

Offline geertbruijnes

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #2 Gepost op: 2008/05/07, 17:56:39 »
De LAN-kaart is geïtegreerd op het moederboard en is via een kabel verbonden met m'n router/modem.
Mvg, Geert

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #3 Gepost op: 2008/05/08, 14:39:40 »
Aan geertbruijnes
Door de bank genomen werken die ethernet aansluitingen na een keertje opstarten vanzelf. Heb je alleen Ubuntu op je schijf of is het een dual boot met Windows?
En doet ie het onder Windows dan wel?
Sorry voor de late beantwoording maar ik had dit topic een beetje uit het oog verloren.
Vr.groet, peter

Offline geertbruijnes

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #4 Gepost op: 2008/05/08, 17:15:19 »
Peter,
Ik was ook even een paar dagen op vakantie. Ik heb dual boot met WindowsXP. Onder Windows werkt het wel. Met Ubuntu 7.10 heeft het kaartje eenmaal vanzelf gewerkt, overigens ook niet de eerste keer, maar zomaar 'ineens'. Zoals gezegd met veel 5-en en 6-en toen aan de praat gekregen. Na de installatie (geheel nieuw, geen update) van 8.04 niet meer gelukt.
Mvg, Geert

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #5 Gepost op: 2008/05/08, 17:43:53 »
Aan geertbruijnes
Denk je er wel aan om na gebruik van Windows het IP nummer vrij te geven. Want bij DHCP krijgt Ubuntu dan geen nieuw IP nummer. Dus bij overgang van W. naar U. eerst: Uitvoeren, cmd, ipconfig /release en dan pas keuze maken naar Ubuntu. (spatie tussen ipconfig en  /release.)
Vr.groet, peter

Offline petervs

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #6 Gepost op: 2008/05/08, 18:08:20 »
Citaat van: Petervdw
Aan geertbruijnes
Denk je er wel aan om na gebruik van Windows het IP nummer vrij te geven. Want bij DHCP krijgt Ubuntu dan geen nieuw IP nummer. Dus bij overgang van W. naar U. eerst: Uitvoeren, cmd, ipconfig /release en dan pas keuze maken naar Ubuntu. (spatie tussen ipconfig en  /release.)
Vr.groet, peter
Hier zijn wat links:
http://computertip.googlepages.com/geennetwerkverbinding
http://www.ubuntu-nl.org/documentatie/handig/
Ubuntu MATE 16.04

Offline Maarten123

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #7 Gepost op: 2008/05/08, 20:19:11 »
Tijdens de installatie van 7.10 wordt de netwerkkaart van de ASUS P5GC-MX/1333 niet goed herkent. Opgelost door tijdens de installatie een losse netwerkkaart te gebruiken. Na de gebruikelijke herstart werd de kaart opeens wel herkent. De losse kaart kon er weer uit! Werkte verder prima!
Had gedacht dat het met 8.04 wel opgelost zou zijn.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Asus P5GC-MX/1333 LAN-problemen
« Reactie #8 Gepost op: 2008/05/08, 21:43:46 »
Aan geertbruijnes
Een los netwerkkaartje tijdelijk gebruiken kan inderdaad een berg problemen oplossen. Bij Windows doe ik dat vaak om bij nieuwe installaties de benodigde drivers voor de on board spullen op te halen, daarna kan ie eruit. Zo zou je je het bij Ubuntu ook voor kunnen stellen.
Vr.groet, peter

iomicifikko

  • Gast
Asus P5GC-MX/1333 LAN-problemen
« Reactie #9 Gepost op: 2008/05/16, 10:35:38 »
hi there, sorry i'm italian and i can't speak your language, anyway i have your hardware and same problems. here is the solution if u have not find it yet.

(Assuming u can't access internet)
0.u have to download in some way this package http://people.redhat.com/csnook/atl2/atl2-2.0.4.tar.bz2 and unpack somewhere in your pc.
1.start ubuntu.
2.insert the livecd
3.system->adiministrations->software sources(to manage repositories) : select the Ubuntu 8.04 cdrom and exit
4.start synaptic
5.reload repositories 1 or 2 times (u'll get an error, couse u can't connect to internet)
5.now install build-essential
6.open terminal, and go to the directory of the downloaded package (there's no src/ subdirectory)
7."make" end enter. that creates our beautiful module we searched for so long . it's named "atl2.ko"
8.now if u type "sudo make install" that simply doesn't work, I dunno why (i'm not expert at all of compiling and modules etc...)
9.type "sudo insmod atl2.ko" and enter. (now your module is loaded and fully functional)
10.system->admin->net : unlock to go to your ethernet properties, deselect roaming mode and, for example use "automatic dhcp" (if u usually connect that way, if not change as desired).
11.close and you should be up and running

Problem: when u exit your machine, next time you restart u have to do the last passages (n.9 in particular), so we have to find a way to install permanently the driver. It's something simple and stupid (maybe modprobe or something like that) but i actually don't know it;) .i'm googling right now for the solution...

bye