Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hardy: toestenbord "Layouts" probleem  (gelezen 2517 keer)

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Gepost op: 2008/05/01, 16:25:30 »
Hallo, Hardy draait na installatie lekker (en start snel op! :)), slechts twee probleemjes waarvan ik er een al elder postte.

Ik heb een prob met de toestenbordinstelling...
Voorheen, in Gutsy, had ik gewoon "USA international with dead keys" als voorkeursinstelling. Geen probleem: alle tekens zaten op hun plek in volledige overeenstemming met mijn standaard toestenborden.
Sinds ik hardy heb geïnstalleerd niet meer.
Enkele tekens, zoals @ en " zijn verwisseld, in plaats van # heb ik een £ en de backslash heb ik nog helemaal niet kunnen vinden...
Gewoon "USA international with dead keys". Heb verschillende andere instellingen geprobeerd. oa de USA international met AltGr en UK, maar daarbij kreeg ik volstrek onleesbare symbolen te zien...

Geen idee hoe en wat nu verder, om weer normaal te kunnen typen...

Wie weet...?

Alvast bedankt!

oh ja, toevoeging; juiste toetsenbord geselecteerd.
Opmerkelijk: zojuist heb ik voor de zoveelste keer de voorkeursinstelling  "USA international with dead keys" geselecteerd. Alles bleek plots op z'n plek te zitten. Tot na de herstart: de instellingen zijn ongewijzigd, maar de '@' is weer een ' " ' enzovoorts... Vreemd................

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Hardy: toestenbord "Layouts" probleem
« Reactie #1 Gepost op: 2008/05/01, 16:38:34 »
Nogmaals de instelling aanpassen en daarna verwijderen wat je niet gebruikt.
Helpt het verwijderen ?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Maarten123

  • Lid
  • Steunpunt: Nee
Hardy: toestenbord "Layouts" probleem
« Reactie #2 Gepost op: 2008/05/01, 16:38:35 »
Weet je het zeker dat je een "US int. with death keys" hebt?
Welk teken krijg je met SHIFT + 2? Als dat @ is,  dan heb waarschijnlijk je een US keyboard.
Krijg je met SHIFT + 2 echter een " , dan is het een Nederlands toetsenbord.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Hardy: toestenbord "Layouts" probleem
« Reactie #3 Gepost op: 2008/05/01, 16:49:52 »
Ik heb Algemeen 105-toetsen(internationaal)PC  VS ingesteld, ik had dat eerst ook met "USA international with dead keys" dat een aantal toetsen niet werkte. Het eenigste wat ik nog niet voor elkaar heb is het euroteken.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #4 Gepost op: 2008/05/01, 17:32:58 »
Citaat van: r0n.
Nogmaals de instelling aanpassen en daarna verwijderen wat je niet gebruikt.
Helpt het verwijderen ?
Had ik gedaan... Dan doet-ie het even, tot ik opnieuw opstart... Ik zal het nog eens proberen.

Het lukt me niet om de gekozen instelling default te maken, het vakje aanvinken werkt niet. Overigens blijft de laatst gekozen instelling in het instellingsvenster na herstart wel staan. Ik wil anders wel eens proberen de default settings via ede terminal te wijzingen, maar ben niet gewend met de terminal te werken, weet iemand waar ik dat kan doen?


Citaat van: Maarten123
Weet je het zeker dat je een "US int. with death keys" hebt?
Welk teken krijg je met SHIFT + 2? Als dat @ is,  dan heb waarschijnlijk je een US keyboard.
Krijg je met SHIFT + 2 echter een " , dan is het een Nederlands toetsenbord.
En wel een waar netjes een @ op de toests van de 2 staat! ;)

Citaat van: Gijsbert
Ik heb Algemeen 105-toetsen(internationaal)PC  VS ingesteld, ik had dat eerst ook met "USA international with dead keys" dat een aantal toetsen niet werkte. Het eenigste wat ik nog niet voor elkaar heb is het euroteken.
Zal ik eens proberen, maar waar vindt ik die? 105 staat niet in mijn lijst met voorkeurslanden...

Bedankt voor het meedenken allemaal!

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #5 Gepost op: 2008/05/01, 19:22:50 »
Ok, bij de keyboard preferences ->layout options -> layout switching het standaard aangevinkte vakje uitgeklikt ("both alt keys together change layout") lijkt te helpen. Ik zal maar niet te vroeg juichen, soms brengt herstarten iets vreemds teweeg, maar ik ben hoopvol gestemd.
Soms moet je 't zoeken in een vreemde hoek... Kan me niet heugen wanneer ik voor het laatst bijde alt toetsen gelijktijdig heb ingetoetst, maat 't was zeker niet vandaag of gisteren!

LeoCardinaals

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #6 Gepost op: 2008/05/01, 23:22:24 »
@hertogjan, het lijkt erop dat je settings niet bewaard blijven. Voer eens in een terminal het commando gnome-keyboard-properties uit. Dit om te kijken of je eventueel een foutmelding krijgt.
Zo niet, doe dan het volgende:
- ga naar systeem --> voorkeuren --> toetsenbord
- in het Toetsenbordeigenschappen venster klik op de 'Terug naar standaardinstellingen' button
- kies je toetsenbordmodel. Als je toestenbord niet in de lijst staat kies als fabrikant Generic  en als model Algemeen 105-toetsen(internationaal)PC.
- klik op de toevoegen button en selecteer als indeling VS en als variant 'With eurosign on 5'
- eventueel kun je achter 'Tik iets in om de instellingen te testen' iets in tikken om je keuzes te controleren
- klik op de Sluiten button.
Als het goed is moet je toetsenbord het nu gewoon doen. Als je instelling tenminste vastgehouden wordt.

PS. Ik weet niet of het niet bewaard blijven van settings aan de policy kit (autorisaties) kan liggen. Misschien dat iemand hier op het forum dat weet.

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #7 Gepost op: 2008/05/02, 11:35:28 »
@Leo: Geen foutmeldingen in de terminal.
Het lijkt mij ook dat de juiste settings niet bewaard worden.

Gisteren na opnieuw instellen van de settings was alles normaal. Vanochtend na het opstarten was het probleem weer terug.
Ik heb de settings wederom opnieuw ingesteld, volgens bovenstaand recept, en nu werkt het naar behoren. Tot herstart, wellicht.

LeoCardinaals

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #8 Gepost op: 2008/05/02, 12:49:36 »
Citaat van: hertogjan
@Leo: Geen foutmeldingen in de terminal.
Het lijkt mij ook dat de juiste settings niet bewaard worden.

Gisteren na opnieuw instellen van de settings was alles normaal. Vanochtend na het opstarten was het probleem weer terug.
Ik heb de settings wederom opnieuw ingesteld, volgens bovenstaand recept, en nu werkt het naar behoren. Tot herstart, wellicht.
Hmm, kijk eens onder Systeem --> Beheer --> Authorizations of je wel instellingen mag wijzigen. Autorisaties zijn nieuw en ik weet ook nog niet exact welke instelling wat doet, maar ik vermoed dat je in het Authorizations venster bij freedesktop --> self --> Manage system configuration of Change user configuration moet zijn. Voeg jezelf toe door op de Grant button te klikken.
Ik weet dus niet of dit werkt. Zo niet, dan kun je de grant weer verwijderen.
Ik heb deze aan staan en bij mij werkt het.

Succes

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #9 Gepost op: 2008/05/03, 13:54:54 »
Gedaan.
Helaas: na herstart blijkt het probleem niet opgelost...

Grr. Ik begin een nieuwe installatie te overwegen.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Hardy: toestenbord "Layouts" probleem
« Reactie #10 Gepost op: 2008/05/03, 15:01:48 »
Het lijkt er sterk op dat gnome-keyboard-properties de instellingen niet goed wegschrijft.
Een herinstallatie is denk ik niet nodig, je kunt de instellingen in /etc/X11/xorg.conf goed zetten
Die van mij- usa (met dode toetsen)-
Citaat
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "intl"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #11 Gepost op: 2008/05/03, 18:28:58 »
Citaat
Het lijkt er sterk op dat gnome-keyboard-properties de instellingen niet goed wegschrijft.
Klinkt aanneemlijk inderdaad...
Ok, eerst het volgende probleempje oplossen:
Citaat
bash: /etc/X11/xorg.conf: Permission denied

Tsiburaska

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #12 Gepost op: 2008/05/03, 18:34:51 »
Mensen die in Rusland waar we USA + RU gebruiken hadden dit probleem na installeren van de CD, mensen die Updaten naar 8.04 hadden dit niet, dus ik denk dat een Update beter is als schone instaalatie, hoewel hier meestal anders word verteld, maar....

Problemen uit verleden zijn geen garantie voor de toekomst....
Nu is dus daar de Upgrade naar 8.04 beter dan de volle installatie gebleken!

Offline lizardman

  • Lid
  • Steunpunt: Nee
Hardy: toestenbord "Layouts" probleem
« Reactie #13 Gepost op: 2008/05/03, 18:38:22 »
om je xorg.conf te editten heb je rootrechten nodig:
Citaat
gksudo gedit
opent gedit met rootrechten. :-)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

LeoCardinaals

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #14 Gepost op: 2008/05/03, 21:30:52 »
Wat lizardman over /etc/X11/xorg.conf zegt klopt. Toch een tip: Als je echter een toetsenbord hebt met een € op de 5 toets zou ik de regel  Option        "XkbVariant"    "intl" vervangen door  Option        "XkbVariant"    "euro". Werkt perfect.

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #15 Gepost op: 2008/05/04, 00:53:35 »
Ok, gedaan... Maar... ("us" of "euro", om het even)...  helaas: het probleem is er nog steeds...
Citaat
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "intl"
EndSection

hertogjan

  • Gast
Hardy: toestenbord "Layouts" probleem
« Reactie #16 Gepost op: 2008/05/04, 01:12:09 »
Hoogst interessante ontwikkeling: na het krijgen van een foutmelding, na resetten van de default keyboard instelling:
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation


... werkt alles naar behoren. Ook na een herstart.
Hopende dat hiermee het probleem is opgelost... Dank ik jullie voor de hulp! :)