Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met bridged netwerk  (gelezen 634 keer)

andy

  • Gast
Probleem met bridged netwerk
« Gepost op: 2008/05/01, 11:54:27 »
Ik heb gisteren Kubuntu 8.04 geïnstalleerd. Voor Virtualbox heb ik ook een network bridge gemaakt door de volgende regels aan /etc/network/interfaces toe te voegen:

auto br0
iface br0 inet dhcp
    bridge_ports eth0

Wanneer ik de machine opnieuw start werkt de netwerkverbinding niet meer. Dit  komt omdat de routing tabel fout lijkt. Deze ziet er dan namelijk zo uit:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 br0
default         outpost         0.0.0.0         UG    0      0        0 eth0
default         outpost         0.0.0.0         UG    100    0        0 br0

Volgens mij zijn de regels met als iface eth0 niet goed. Dit wordt bevestig wanneer ik bijvoorbeeld de laatste regel verwijder. Dan werkt het netwerk weer zonder problemen. Met dezelfde configuratie had Kunbuntu 7 geen problemen. Heeft iemand dit ook al ondervonden en er een oplossing voor gevonden?

andy

  • Gast
Probleem met bridged netwerk
« Reactie #1 Gepost op: 2008/05/03, 17:04:06 »
Het probleem is opgelost! Ik moest de volgende regels aan het bestand /etc/network/interfaces toevoegen:

auto eth0
iface eth0 inet manual
    up ifconfig eth0 up

Nu wordt eth0 wel opgebracht maar zonder een ip-adres. Het ip-adres wordt een de bridge br0 toegewezen.  Met dank aan nixscripter op het engelstalig formum.