Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid  (gelezen 3345 keer)

Strafke

  • Gast
Geen geluid
« Gepost op: 2006/08/10, 17:43:27 »
Ja, weer een topic over het geluid.

Ben net klaar met de Ubuntu installatie en kom er achter dat het geluid niet werkt :(.
Ik heb net al wat gedownload via dat pakkettenprogramma, maar zonder resultaat.

Als ik 2x op het speakertje klik rechtsboven krijg ik de volgende foutmelding:

Geen volumeregelingselementen en/of apparaten voor GStreamer gevonden.

Bij het laden van XMMS wordt ik geholpen met deze fout:

"Gelieve te controleren dat:
- je geluidskaart correct ingesteld is
- je de juiste uitvoerplugin hebt geselecteerd
- geen ander programma de geluidskaart blokkeert"

Ik gebruik de geluidskaart die standaard op het moederboard zit van mijn Dell Optiplex GX1.

Wat nu te doen?

Ook systeemgeluiden werken niet.

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
Geen geluid
« Reactie #1 Gepost op: 2006/08/11, 19:16:11 »
doe eens lspci | grep audio

Strafke

  • Gast
Geen geluid
« Reactie #2 Gepost op: 2006/08/11, 19:46:27 »
Lspci:

0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:0d.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 (rev 01)
0000:00:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
0000:00:11.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 24)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)


bij grep audio krijg ik niks te zien.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
Geen geluid
« Reactie #3 Gepost op: 2006/08/11, 19:50:53 »
Is slechts 1 commando ( en niet twee) dat je in zijn geheel kan kopieeren en plakken.

Strafke

  • Gast
Geen geluid
« Reactie #4 Gepost op: 2006/08/11, 19:54:39 »
Gedaan. Maar vervolgens krijg ik niets te zien?

Offline Kelderkeuken

  • Lid
  • Steunpunt: Nee
Geen geluid
« Reactie #5 Gepost op: 2006/08/11, 20:06:43 »
" | grep audio" wil alleen maar zeggen: laat alleen de regels zien waar "audio" in voor komt. Dus uit je lspci lijstje is al te zien dat er geen audio tussen staat. Blijkbaar is er geen geluidskaart gevonden op je pci...

Strafke

  • Gast
Geen geluid
« Reactie #6 Gepost op: 2006/08/12, 08:43:03 »
Ok. Wat zou ik daaraan kunnen doen? De geluidskaart zit op het moederbord en in Windows werkte het wel altijd?.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #7 Gepost op: 2006/08/12, 15:15:17 »
is het een oudere pc? heb je een ISA geluidskaart misschien?
Stap 1 is achterhalen welke geluidskaart je precies hebt.
Ik weet niet of "lshw|grep Multimedia -A 10" je iets nuttigs geeft, anders moet je het zelf uitzoeken.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Strafke

  • Gast
Geen geluid
« Reactie #8 Gepost op: 2006/08/12, 17:18:03 »
Na wat zoeken heb ik de volgende gegevens kunnen bemachtigen:

Bedrijf die kaart gemaakt heeft: Crystal Semiconductor
Chipset: CS4236

Naam onder Windows: Crystal WDM Audio Codec

Het is volgens een post uit een topic (weet zogauw niet meer welk forum) een ISA kaart.

lshw|grep Multimedia -A 10 levert niets op.

Strafke

  • Gast
Geen geluid
« Reactie #9 Gepost op: 2006/08/12, 17:25:40 »
Vond net dit antwoord op een discussiegroep:

What I've always done with CS42nn cards is this:

modprobe sound dmabuf=1
modprobe opl3 io=0x388
modprobe cs4232 io=0x534 irq=5 dma=1 dma2=0 mpuio=0x330 mpuirq=9

...try 0x530 if 0x534 doesn't work.  


Maar als ik modprobe in wil geven krijg ik een error:

WARNING: Error inserting soundcore (/lib/modules/2.6.15-26-386/kernel/sound/soundcore.ko): Operation not permitted
FATAL: Error inserting sound (/lib/modules/2.6.15-26-386/kernel/sound/oss/sound.ko): Operation not permitted

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #10 Gepost op: 2006/08/12, 17:54:44 »
die opties kunnen wel verschillen van kaart tot kaart, maar je moet in ieder geval modprobe als root uitvoeren:

sudo modprobe ...
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Strafke

  • Gast
Geen geluid
« Reactie #11 Gepost op: 2006/08/12, 18:29:33 »
Hmm, dat blijkt bij mij ook niet te werken.

Iemand nog een idee om mij te helpen?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #12 Gepost op: 2006/08/12, 20:21:25 »
Probeer eens:

sudo modprobe -v snd-cs4236

als het niet werkt, post de output
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Strafke

  • Gast
Geen geluid
« Reactie #13 Gepost op: 2006/08/12, 20:30:59 »
Heel hartelijk bedankt!
Het werkt nu, alleen wat zachtjes. (iig ik kan de systeemgeluiden horen).

Wat rest is dat ik nog steeds een foutmelding krijg in XMMS en bij het speakertje rechtsboven.

*edit*
De output:

insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd-page-alloc.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/soundcore.ko
install modprobe --ignore-install snd  && { modprobe -Qb snd-ioctl32 ; : ; }
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd-timer.ko
install modprobe --ignore-install snd-pcm  && { modprobe -Qb snd-pcm-oss ; : ; }insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd-pcm.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/oss/snd-mixer-oss.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/oss/snd-pcm-oss.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/isa/cs423x/snd-cs4231-lib.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/seq/snd-seq-device.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd-rawmidi.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/isa/cs423x/snd-cs4236-lib.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/core/snd-hwdep.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/drivers/opl3/snd-opl3-lib.ko
insmod /lib/modules/2.6.15-26-386/kernel/sound/isa/cs423x/snd-cs4236.ko

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #14 Gepost op: 2006/08/12, 20:35:36 »
Geluid harder zetten:
- dubbelklik op dat speakertje en zet PCM en Master op een hoog volume. (PCM 100% of als het geluid raar klinkt (kraakt, alsof het geluid te hoog staat) tussen de 80 en 100%) Master is het uiteindelijke volume dat je wilt, als je luidsprekers gebruikt kan je dat best gewoon op 100% zetten.
- je kan ook "alsamixer" gebruiken in de terminal

Geluidsmodule laden bij opstarten:
gksudo gedit /etc/modules

voeg onderaan het tekstbestand dat op je scherm verschijnt toe:
# Sound
snd-cs4236
bestand opslaan en sluiten

vraagjes:
1. welke foutmelding krijg je bij XMMS
2. welke foutmelding krijg je bij dat speakertje
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Strafke

  • Gast
Geen geluid
« Reactie #15 Gepost op: 2006/08/12, 20:48:55 »
De foutmeldingen die ik kreeg staan in de 1e post.
Maar ze zijn nu verbannen :D.
Ben nu m'n eerste mp3'tje aan het luisteren onder Ubuntu!

Heel erg bedankt voor de goede behulpzaamheid op dit forum.

Zal zeker nog eens terugkomen :).

Strafke

  • Gast
Geen geluid
« Reactie #16 Gepost op: 2006/08/12, 20:51:38 »
Oeps, iets te overhaast gereageerd.
Bij XMMS krijg ik nog steeds de foutmelding maar ik klik 'm vervolgens weg en kan gewoon muziek luisteren.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #17 Gepost op: 2006/08/12, 20:52:00 »
Ah :) sorry, mijn fout, ik was vergeten terug naar de eerste post te kijken...

Maarja, zonder muziek kan je niet leven vind ik :) dus mensen met geluidsproblemen moeten altijd geholpen worden :D
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid
« Reactie #18 Gepost op: 2006/08/12, 20:53:16 »
Citaat van: Strafke
Oeps, iets te overhaast gereageerd.
Bij XMMS krijg ik nog steeds de foutmelding maar ik klik 'm vervolgens weg en kan gewoon muziek luisteren.
vreemd... kijk even na of je in opties van XMMS de "alsa uitvoer" gebruikt en niet oss of dergelijke...

anders zou ik het niet weten :) succes
(misschien dat het vanzelf verdwijnt na de volgende reboot?)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Strafke

  • Gast
Geen geluid
« Reactie #19 Gepost op: 2006/08/12, 20:54:37 »
Ja, muziek is een essentieel deel van 't leven ;). Nogmaals bedankt voor je hulp. Zelf zou ik er niet uitgekomen zijn.