Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apostrof in Ubuntu  (gelezen 7026 keer)

Thisegzz

  • Gast
Apostrof in Ubuntu
« Gepost op: 2008/04/27, 18:38:42 »
Net een dualboot Ubuntu/Vista gemaakt, maar er is één ding in Ubuntu waar ik me erg aan irriteer; de apostrof. In windows was het altijd dat als ik twee keer op apostrof op het toetsenbord drukte, ik '' kreeg. Nu in Ubuntu krijg ik geen '' maar ´. Dit is erg lastig tijdens het scripten dus daarom zou ik de Windows-manier weer terug willen.

Wie heeft er een oplossing voor dit vervelende probleem?

//Thisegzz.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #1 Gepost op: 2008/04/27, 18:55:44 »
Waar ik me aan erger... ;-)

probeer het eens met de alt-gr
Of anders Systeem->Voorkeuren->Toetsenbord   hier kun je een andere indeling kiezen.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline joseph

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #2 Gepost op: 2008/04/27, 19:11:51 »
Twee keer ' drukken = een " in windows, vreemd?
Hoe kreeg je dan een ' ??

Bij mij werkt het als volgt:
 2x ' of de ' gevolgd door de spatie = '
2x de shift tezamen met '  = ¨
shift met ' gevolgd door de spatie = "

In combinatie met een letter gewoon benodigde teken gevolgd door de letter.
Bijvoorgbeeld " (shift met ') gevolgd door e = ë of ' gevolgd door a = á of ^ (shift met de 6) gevolgd door e = ê et cetera.
Heb je hier misschien iets aan?

Thisegzz

  • Gast
Apostrof in Ubuntu
« Reactie #3 Gepost op: 2008/04/27, 19:48:32 »
@joseph; zo heb ik het idd in Windows, maar in Ubuntu krijg ik als ik 2x op ' druk een `.

@lizardman; zal zo even kijken of dit werkt, bedankt.

Offline JvH

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #4 Gepost op: 2008/04/27, 20:11:58 »
De indeling 'Amerikaans - Internationaal met dode toetsen' wijkt in Ubuntu op enkele punten af van de Windows-variant.
Het punt dat jij noemt is er één van. Ik heb er zelf voor gekozen de Amerikaanse layout zonder dode toetsen in te stellen, icm de Compose key. Misschien is dat ook iets voor jou?

Offline Mij

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #5 Gepost op: 2008/04/27, 20:18:52 »
Als je twee keer op de ' in windows drukt krijg je '' twee losse apostrofs i.p.v. als je op shift + " + spatie drukt dan krijg je ook een echte ". Dat is ook zo in Ubuntu. Leer het je aan op deze manier, dit is de manier hoe het hoort, en hoe het het snelste is! Dode toetsen heet dat :)

Thisegzz

  • Gast
Apostrof in Ubuntu
« Reactie #6 Gepost op: 2008/04/27, 20:29:17 »
@JvH; Waar vind ik die layout zonder dode toetsen? Is dat die ene met AltGr? Die veranderd namelijk niets, ik krijg nog steeds die ´.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #7 Gepost op: 2008/04/27, 20:41:46 »
Probeer die met Alt-Gr en dan het vinkje weghalen bij: Aparte groep voor elk venster (weet ook niet waarom) Dan ff restart.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Thisegzz

  • Gast
Apostrof in Ubuntu
« Reactie #8 Gepost op: 2008/04/27, 20:59:54 »
Yeah, door het weghalen van dat vinkje deed 'ie het goed. Erg bedankt!
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
Ja, het apostrof-probleem is opgelost, maar hoe krijg ik nu een E met een ' erop? Normaal is dit eerst ' en dan gelijk een E, maar dat werkt nu dus niet meer xD

Offline JvH

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #9 Gepost op: 2008/04/28, 09:17:14 »
Ik geloof dat daar ook een AltGr-combinatie voor is.
Je kunt aan je menubalk bovenin de applet Toetsenbordwisselaar toevoegen. Via deze applet kun je de huidige indeling weergeven op je scherm. Daar kun je zien welke AltGr-combinaties mogelijk zijn.

Je kunt in Indelingsopties ook een toets aanwijzen die dient als Compose key. Een é typ je dan als volgt:
' e

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #10 Gepost op: 2008/07/07, 17:49:45 »
Ook ik blijf de grootste problemen houden met de dode toetsen. Ze doen het gewoon helemaal niet. ´e ¨e ´a ¨a ´E ¨E ´c ^a Ook in OpenOffice werkt het niet.
Zodra ik een accent aantik, staat het op het scherm.
Toetsenbord instelling ´vs internationaal met dode toetsen´
Het beroerde is, dat wel heeft gewerkt, maar sinds een een paar weken niet meer.
Alle berichten van ´dode toetsen´ heb ik doorgelezen, maar geen enkel ´recept´ heeft geholpen.
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline ohjajoh

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #11 Gepost op: 2008/07/07, 18:24:43 »
Als je de standaardwijze niet zint of er zijn gewoonweg te weinig opties kun je dit ook door X laten regelen ipv gnome.

in ~/.gnomerc of ~/.Xsession voeg je toe: export GTK_IM_MODULE = "xim"
Dan zoek je in /usr/share/X11/locale/compose.dir het locale compose bestand op, die copieer je dan naar je ~/ dir en noem je m .XCompose.

waarschijnlijk is het:
/usr/share/X11/locale/en_US.UTF-8/Compose

Dan ga je dat bestand editen, je kunt dan alle dead-keys instellen en ook de compose-key opties, precies zoals je het zelf zou willen.

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #12 Gepost op: 2008/07/07, 19:13:10 »
ohjajoh, bedankt, ik zal dat eens proberen aan de praat te krijgen!
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #13 Gepost op: 2008/07/07, 19:35:10 »
ohjajoh, de exercitie strandde als snel op het ontbreken van
.gnomerc  en .Xsession
Het Compose bestand heb ik gevonden, daar staan de dead keys inderdaad goed ingesteld zoals ik het wil...
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #14 Gepost op: 2008/07/07, 20:14:10 »
ohjajoh, het verhaal gaat verder:
Ik heb een bestand gevonden .xsession-errors, dat vertelt dat enige malen de keycodes voor 92 t/m 255 niet zijn ontvangen. Naast allerlei andere fouten.
Er gaat met het laden van het keyboard van alles fout dus. Vandaar dat de dode toetsen het niet doen.
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #15 Gepost op: 2008/07/07, 22:23:06 »
Nu we toch bezig zijn,
in MS-Windows kon ik via Alt en Num-keypad alle speciale ASCII-karakters kiezen; bijv. Alt ingedrukt en dan 0128 en Alt weer los, voor €.

Is dit ook in UBUNTU voor elkaar te krijgen?
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #16 Gepost op: 2008/07/07, 22:34:17 »
Willem_D, ik meen van wel, in het hele verhaal van "dode toetsen" wordt daar een paar maal op gewezen. Maar, zoals duidelijk is, ik heb het ook niet voor elkaar. Maar er zullen wéinig schrijvers zijn, die accenten gebrúiken. Ik schrijf dit ff voor het gemak onder Windows XP op m´n laptop, daar werken de "dode toetsen" vlekkeloos. Ik heb de indruk, dat de inplementatie van toetsenborden binnen Ubuntu nog niet helemaal uitgekristalliseerd is. Aangezien dit een raakvlak tussen soft- en hardware aangaat, voel ik mij als software-man uit de accountancy-hoek niet geheel aangesproken... Maar als 70-jarige hacker zit ik wel lekker te spitten :-) spannend hoor!!
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #17 Gepost op: 2008/07/08, 00:40:03 »
Verander anders je xorg.conf even:

Toepassingen - Hulpmiddelen - Terminalvenster

tik in: gksudo gedit /etc/X11/xorg.conf

druk op Enter

De sectie in xorg.conf in xubuntu moet dan als volgt worden:

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
    Option        "XkbVariant"    "intl"
EndSection

Het gaat natuurlijk om de laatste Option!

Daarna een complete herstart van je computer doen.

Groet, Pjotr.

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #18 Gepost op: 2008/07/08, 08:51:11 »
Sorry Pjotr, xorg.conf staat er bij zoals jij opgeeft. Dat is het dus ook niet.
Wat ik nu ga proberen, is de harde methode: keyboard uit de hardware verwijderen en Ubuntu met een herstart het opnieuw laten installeren. Onder WinXP werkt dat perfekt. Ik hoop, dat Ubuntu ook alle links naar het keyboard verwijdert, als ik het keyboard uit de hardware verwijder.
Dick
PS
´e´a¨a dode toetsen werken nog steeds niet
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #19 Gepost op: 2008/07/08, 09:38:24 »
Het verwijderen van het toetsenbord uit de lijst en Ubuntu herstarten, geeft gewoon VS international 105 met dode toetsen, die het niet doen.
Ik vind dit belachelijk! Onder Ubuntu 7.10 werkten de dode toetsen wel en onder 8.04 niet meer...
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #20 Gepost op: 2008/07/08, 10:21:08 »
Citaat van: DickStomp
Het verwijderen van het toetsenbord uit de lijst en Ubuntu herstarten, geeft gewoon VS international 105 met dode toetsen, die het niet doen.
Ik vind dit belachelijk! Onder Ubuntu 7.10 werkten de dode toetsen wel en onder 8.04 niet meer...
@DickStomp:
dank zij de conversatie "apostrof in Ubuntu" heb ik -onder 8.04- de dode toetsen werkend gekregen.
(Zelfs zonder de xorg.conf te editen.)
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #21 Gepost op: 2008/07/08, 15:06:19 »
Willem_D, dat vind ik knap? Hoe heb je dat gedaan?
Wat ik wel ontdekt heb is, dat in het Ubuntu inlog scherm de dode toetsen wel werken maar zodra X of Gnome of wie dan ook er zich mee bemoeid heeft, is het over...
De oorzaak ligt in het switchen van utf-7 naar utf-8, of omgekeerd, dat moet ik nog verder uitzoeken. Ubuntu werkt met de verkeerd utf-map. Ik krijg ook steeds mailtjes retour, die zeggen, dat mijn code-mapping niet klopt.
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #22 Gepost op: 2008/07/08, 16:27:14 »
@DickStomp:
Je schreef:
Citaat
Hoe heb je dat gedaan?
Ik denk dat ik je niet veel verder kan helpen. Mijn post was bedoeld om te onderstrepen dat het in 8.04 (soms of) in het algemeen wèl goed gaat.
In mijn geval had ik gewoon een verkeerde toetsenbord-layout staan: "vs", in plaats van "vs-internationaal met dode toetsen". Dat kon ik op de standaardwijze corrigeren via Systeem>voorkeuren>toetsenbord.

(Of ik als layout: "internationaal (met dode toetsen)", "voormalig us_intl", of "AltGr dead keys" selecteer, maakt bij mijn installatie niet uit: de dode toetsen werken correct.)
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #23 Gepost op: 2008/07/08, 16:49:07 »
Citaat van: arie
Citaat van: DickStomp
Het verwijderen van het toetsenbord uit de lijst en Ubuntu herstarten, geeft gewoon VS international 105 met dode toetsen, die het niet doen.
Ik vind dit belachelijk! Onder Ubuntu 7.10 werkten de dode toetsen wel en onder 8.04 niet meer...
ik werk hier gewoon in 8.04 met dode toetsen
Arie, welke character-set is bij ingesteld door Gnome of X? utf-7 of utf-8?
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home

Offline DickStomp

  • Lid
    • Projecten Dick Stomp
  • Steunpunt: Nee
Apostrof in Ubuntu
« Reactie #24 Gepost op: 2008/07/08, 17:16:00 »
Ha Arie, daar komen de verschillen! Thunderbird draait bij mij  voor verzenden en ontvangen met ISO-8859-1. Van het beeldscherm moet ik het nog opzoeken.
Bedankt!
Dick
7 okt 2016:  Ubuntu 14.04 LTS > ThinkPad T410+Win7 > BioStar desktop+WinXP Home > Asus Eee 900A > ThinkPad T61; allen hebben geen data maar draaien op dezelfde DropBox; verder FireFox & LibreOffice & Wine
https://sites.google.com/site/dickstomp/home