Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wacom probleempje  (gelezen 841 keer)

Beftus

  • Gast
Wacom probleempje
« Gepost op: 2008/04/27, 17:03:53 »
Op 7.10 m'n Wacom tablet werkend gekregen. Ik wil button 2 als modifier de Shift functie geven. De aanpassing van button 2 via wacomcpl overleeft een reboot niet, na reboot staat het weer op default waarde. Hoe krijg ik deze aanpassing permanent? Via xorg.conf? Zo ja, hoe?

Ik heb Wacom driver versie 0.7.8-3 geinstalleerd.

Offline eendje

  • Lid
  • Steunpunt: Nee
Wacom probleempje
« Reactie #1 Gepost op: 2008/04/27, 22:10:24 »
Geen idee. Ik moet het ook nog uitzoeken. Misschien als richting... Zoek eens op internet op xsetwacom. Dit is een programma om van alles in te stellen voor je tablet. Ook een applicatie voor je tablet is http://www.alexmac.cc/tablet-apps/
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Beftus

  • Gast
Wacom probleempje
« Reactie #2 Gepost op: 2008/04/27, 22:20:04 »
xsetwacom werkt net als wacomcpl ook, echter na een reboot staat alles weer op default waarde.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Wacom probleempje
« Reactie #3 Gepost op: 2008/04/27, 22:25:10 »
Je moet het ook als root doen. Dus progje starten in de terminal en sudo ervoor zetten.

Toepassingen - Hulpmiddelen - Terminalvenster
tik in: sudo xsetwacom
druk op Enter
tik je wachtwoord in (blijft 100 % onzichtbaar, zelfs geen sterretjes, dat hoort zo)
druk op Enter

Beftus

  • Gast
Wacom probleempje
« Reactie #4 Gepost op: 2008/04/27, 23:01:26 »
Helaas, sudo xsetwacom werkt niet. Inmiddels ook geprobeerd om de xsetwacom parameters in /etc/X11/xinit/xinitrc te plaatsen maar ook dat werkt niet. Een reboot gooit alles terug naar af.

Voor de goede orde, ik probeer met xsetwacom set stylus button2 "core key SHIFT" voor elkaar te krijgen dat de zij-schakelaar als SHIFT toets gaat functioneren. In combinatie met een left-click van de penpunt moet dat in SHIFT+left-click resulteren.

Offline FreakyDude

  • Lid
  • Steunpunt: Nee
Wacom probleempje
« Reactie #5 Gepost op: 2008/04/30, 20:22:57 »
je kan het in xorg proberen met de volgende regel misschien?


Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "stylus"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    Option        "Button2"    "3"
    Option        "Button3"    "2"
EndSection

weet het niet hoor, maar van 7.04 en xinput cheats gebruiken naar 7.10, was de oplossing voor mijn probleem dat ik de knoppen niet om kon draaien door gewoon 2 regeltjes in xorg erbij te zetten.
als je nou bijvoorbeeld option "button2"  "3" verandert in option "button2"  "shift"?
Ik weet het niet het is maar een gok, maar wie weet werkt het nog ook.

OPMERKING!
het werktte niet direct ookzo in 8.04 en dat kwam omdat de volgene regeltjes er niet meer bij stonden:
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"

heeeeeelemaal onderaan, ik zit nu op een laptop en het eerste deel (met option button blabla) moet VOOR de synaptic's touchpad, en ik heb het laatste deel (inputdevice blabla) maar na het synaptic regeltjein het laatste blok gezet.
In de gimp werkt het nu bij mij.

alleen mijn logitech muis weer aan de praat krijgen.... en mijn webcam, en vingerafdrukregistratie en... en.... scrollen met mmb in firefox, en flash....

EDIT:
ik had trouwens wat info uit deze thread gehaald: http://ubuntuforums.org/showthread.php?t=765915 is misschien wel handig. Ik hoefde alleen dat inputdevice nog extra toe te voegen, meer niet.