Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: programmeren in java  (gelezen 3740 keer)

Offline frankje

  • Lid
  • Steunpunt: Nee
programmeren in java
« Gepost op: 2008/04/21, 08:33:44 »
Hallo,

Ik heb een beetje python geleerd en nu vroeg ik mij af hoe het is om te programmeren in java. Wat heb ik voor programmatuur nodig, want ik heb de java-console geinstalleerd, maar het is me niet duidelijk of ik hier ook programmaregels in kwijt kan. Wat ik dus zoek is voor java een soortgelijk progje als IDLE er voor python is. Bvd.


grtn, Frank
Mac OS X  El Capitan  dualboot met Ubuntu 15.10

Offline Rulus

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #1 Gepost op: 2008/04/21, 09:15:45 »
Je hebt een Java JDK nodig, hetzij die van Sun, sun-java6-jdk, hetzij het open-source IcedTea, icedtea-java7-jdk. Daarenboven is een ontwikkelomgeving als Netbeans of Eclipse wel handig. (Alles zit in Synaptic)

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
programmeren in java
« Reactie #2 Gepost op: 2008/04/21, 09:34:10 »
Zeker.

Je zal trouwens ondervinden dat Java misschien iets meer werk is (haakjes enzo), maar het is een fantastische taal die heel consistent en heel gebruiksvriendelijk is.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

Offline frankje

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #3 Gepost op: 2008/04/21, 15:52:49 »
Bedankt, ik heb ze geinstalleerd, nu aan de slag!!


grtn, Frank
Mac OS X  El Capitan  dualboot met Ubuntu 15.10

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
programmeren in java
« Reactie #4 Gepost op: 2008/04/21, 16:24:01 »
Voor kleine testjes raad ik Netbeans trouwens niet aan, ik raad dan aan dat je je broncodes in één map zet en gewoon javac *.java typt, omdat je in netbeans al direct een project moet starten.
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #5 Gepost op: 2008/06/12, 21:25:11 »
Netbeans gebruikte ik vroeger wel veel onder windows. Dit vind ik een goed programma om nieuwe javacode te schrijven vermits mijn code automatisch wordt aangevuld.
Nu zou ik het graag onder linux, Ubuntu 7.10 gebruiken maar ik heb nog een probleem onder Netbeans.

Ik heb hiervoor het volgende geïnstalleerd:
via Synaptic pakketbeheer:
icedtea-java7-bin
icedtea-java7-jdk
icedtea-java7-jre
java-common     versie 0.26ubuntu1

NetBeans IDE 6.1. Dit via de website gedownload en geïnstalleerd. Bestand: netbeans-6.1beta-javase-linux.sh

Bij het uitvoeren (Run File) van een willekeurig java-bestand in Netbeans krijg ik steeds dezelfde uitvoer zoals hieronder.


Mijn java-code:
public class test {
public static void main(String[] args){
System.out.println("Dit is een test");
}

}

Uitvoer:
init:
deps-jar:
compile-single:
run-single:
Exception in thread "main" java.lang.UnsupportedClassVersionError: test : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:638)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:143)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:281)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:74)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:216)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:209)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:324)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:337)
Error: Could not find the main class.
Error: A JNI error has occurred, please check your installation and try again
Java Result: 1
BUILD SUCCESSFUL (total time: 0 seconds)


Hoe kan ik dit oplossen zodat ik een java-bestand normaal kan uitvoeren?

Offline Rulus

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #6 Gepost op: 2008/06/12, 21:43:55 »
Je kan Netbeans ook gewoon vanuit Synaptic installeren, probeer die eens.

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
programmeren in java
« Reactie #7 Gepost op: 2008/06/13, 08:34:32 »
Gebruik Sun Java ipv. icedtea/gcj/openjdk/...

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #8 Gepost op: 2008/06/13, 09:38:05 »
Ga eens naar Tools - Java Platforms en vertel eens wat daar staat?

Ik gebruik openjdk en het werkt goed hier.
Mark heeft trouwens onlangs nog gevraagd om deze zoveel mogelijk te gebruiken/testen. :)

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #9 Gepost op: 2008/06/16, 20:42:02 »
Citaat van: blackdrive
Ga eens naar Tools - Java Platforms en vertel eens wat daar staat?

Ik gebruik openjdk en het werkt goed hier.
Mark heeft trouwens onlangs nog gevraagd om deze zoveel mogelijk te gebruiken/testen. :)
Platform Name: JDK 1.7 (Default)
Platform Folder: /usr/lib/jvm/java-7-icedtea
Tabblad classes -> Platform classpath:
/usr/lib/jvm/java-7-icedtea/jre/lib/resources.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/rt.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/sunrsasign.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/jsse.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/jce.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/charsets.jar
/usr/lib/jvm/java-7-icedtea/jre/classes
/usr/lib/jvm/java-7-icedtea/jre/lib/ext/dnsns.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/ext/localedata.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/ext/sunjce_provider.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/ext/gnome-java-bridge.jar
/usr/lib/jvm/java-7-icedtea/jre/lib/ext/sunpkcs11.jar

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #10 Gepost op: 2008/06/16, 20:43:31 »
Citaat van: Rulus
Je kan Netbeans ook gewoon vanuit Synaptic installeren, probeer die eens.
Dit had ik al gedaan. Ik heb netbeans5.5 geïnstalleerd, maar met hetzelfde resultaat!

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #11 Gepost op: 2008/06/16, 21:00:29 »
En heb je de sun jdk al geïnstalleerd?
sun-java6-jdk
Uninstall andere jdk's die je staan hebt (icedtea).

Eens zien of die het wel goed doet dan.

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #12 Gepost op: 2008/08/11, 22:09:44 »
Ik had dit al eerder geprobeerd met hetzelfde resultaat!

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
programmeren in java
« Reactie #13 Gepost op: 2008/08/11, 22:50:52 »
gooi alles er eens uit, installeer sun-java6-jdk en netbeans 6.1

Ik vind openJDK/IcedTea en zo wel mooi, maar als het niet werkt... Het testen laat ik liever aan mensen over die zich daar specifiek mee bezig houden ;).
Trouwens, bij mijn eigen java programma's vermeld ik altijd dat Sun Java vereist is... en dat is niet alleen gericht op Linux-gebruikers (MS Java werkt ook van geen kanten met mijn progs).

En als je een JNI-fout krijgt bij Hello world... zoals ik al eerder zei, alles eruit, sun java 6 en netbeans 6.1 er terug op.

Werkt het dan nog niet, dan kan ik helaas niets meer voor je doen...
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Jorisvh

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #14 Gepost op: 2008/08/12, 12:44:58 »
Ik heb via Synaptic Package Manager volgende paketten verwijderd:
icedtea-java7-jdk, icedtea-java7-bin, icedtea-java7-jre
en volgende paketten geïnstalleerd: sun-java6-jdk, sun-java6-bin, sun-java6-jre.
Hierna kon ik netbeans niet meer opstarten.
Ik heb dit dan verwijderd via /usr/local/netbeans-6.1beta/uninstall.sh
Netbeans 6.1 kon ik niet vinden via  Synaptic Package Manager. Dus heb ik netbeans5.5 geïnstalleerd.
Met dit programma kon ik echter geen bestaand java-project openen en kon ik geen nieuw java-bestand compileren en uitvoeren!
Ik heb dit dan maar terug verwijderd en netbeans6.1 opnieuw geïnstalleerd.
joris@joris-desktop:~$ sudo ./netbeans-6.1beta-javase-linux.sh

Dit had ik gedownload op: http://download.netbeans.org/netbeans/6.1/beta/
Configuring the installer...

Searching for JVM on the system...

Extracting installation data...

Running the installer wizard...



(:17335): Gtk-WARNING **: Attempting to add a widget with type GtkButton to a GtkComboBoxEntry (need an instance of GtkEntry or of a subclass)



(:17335): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed



(:17335): Gtk-CRITICAL **: gtk_paint_box: assertion `style->depth == gdk_drawable_get_depth (window)' failed



(:17335): Gtk-CRITICAL **: gtk_paint_box: assertion `style->depth == gdk_drawable_get_depth (window)' failed

joris@joris-desktop:~$

Na opnieuw een java-bestand uit te voeren kreeg ik nog steeds dezelfde melding.

Hierna heb ik in een terminal het volgende gedaan:
joris@joris-desktop:~$ which java

joris@joris-desktop:~$ which javac

joris@joris-desktop:~$ sudo apt-get install sun-java6-bin sun-java6-jdk

Pakketlijsten worden ingelezen... Klaar

Boom van vereisten wordt opgebouwd      

Reading state information... Klaar

sun-java6-bin is reeds de nieuwste versie.

sun-java6-bin set to manual installed.

sun-java6-jdk is reeds de nieuwste versie.

0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 5 niet opgewaardeerd.

joris@joris-desktop:~$ which java

joris@joris-desktop:~$ sudo update-alternatives --config java



Er is slechts 1 programma dat java voorziet

(/usr/lib/jvm/java-6-sun/jre/bin/java). Er is niets in te stellen.

joris@joris-desktop:~$ sudo update-alternatives --config javac



Er is slechts 1 programma dat javac voorziet

(/usr/lib/jvm/java-6-sun/bin/javac). Er is niets in te stellen.

joris@joris-desktop:~$


Ik heb in netbeans6-1 een nieuw java testbestand gemaakt en dat kon ik wel uitvoeren. Hierna heb ik ook een oud java testbestand kunnen uitvoeren!

Jij had dus idd gelijk dat ik java en netbeans volledig moest verwijderen en  sun-java6-jdk en netbeans 6.1 installeren!

Offline HP

  • Lid
  • Steunpunt: Nee
programmeren in java
« Reactie #15 Gepost op: 2008/08/12, 15:44:42 »
Gewoon eclipse gaan gebruiken joh. Mocht je programmeerwerk een succes worden dan koppel je het aan subversion en kunnen anderen er ook aan mee sleutelen............ héél erg open source 8-)
--
Taking on nearly religious proportions, the established monetary institution exists as one of the most unquestioned forms of faith there is. How money is created, the policies by which it is governed, and how it truly affects society, are unregistered interests of the great majority of the population. [Zeitgeist addendum]

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
programmeren in java
« Reactie #16 Gepost op: 2008/08/12, 16:06:20 »
Niet teveel op Synaptic vertrouwen ;) Ik begin hoe langer hoe meer een afkeer van synaptic te krijgen...

Oh ja, NetBeans staat onder de CDDL en GPL met Classpath-exception, en heeft een ingebouwde functie voor CVS, SVN, Git is onderweg.

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net