Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Localhost werkt niet  (gelezen 2848 keer)

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
Localhost werkt niet
« Gepost op: 2008/04/18, 22:55:35 »
Hallo.

Net ubuntu opnieuw geinstalleerd omdat mijn interne internet kaart niet meer werkte doordat ik wat stoute dingen was aan het doen via de command-line en een howto. Op school deed mijn localhost het gewoon prima, nog even phpmyadmin gebruikt om de SQL terug te zetten. Ik zit in de trein en geen localhost. Nog even sudo dpkg-reconfigure -a gedaan en na enige tijd toen ik daarmee klaar was de laptop herstart, geen resultaat. Nog geen localhost. Apache draait gewoon.

De apache2 logfile:
Citaat
[Fri Apr 18 18:44:48 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch configured -- resuming normal operations
[Fri Apr 18 18:48:10 2008] [warn] (101)Network is unreachable: connect to listener on [::]:2222
[Fri Apr 18 18:48:10 2008] [notice] caught SIGWINCH, shutting down gracefully
[Fri Apr 18 18:48:12 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch configured -- resuming normal operations
[Fri Apr 18 19:11:54 2008] [notice] Graceful restart requested, doing restart
[Fri Apr 18 19:11:54 2008] [warn] (101)Network is unreachable: connect to listener on [::]:2222
[Fri Apr 18 19:11:55 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch configured -- resuming normal operations
[Fri Apr 18 19:21:03 2008] [warn] (101)Network is unreachable: connect to listener on [::]:2222
[Fri Apr 18 19:21:03 2008] [notice] caught SIGWINCH, shutting down gracefully
[Fri Apr 18 19:22:14 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch configured -- resuming normal operations
[Fri Apr 18 22:22:10 2008] [notice] Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch configured -- resuming normal operations
Hij is uiteraard groter, alleen gaat het eigenlijk om hetzelfde. Je ziet in de log vooral poort 2222, dat is voor mijn KCP. Echter doen poort 80 en 2222 het beide niet.

"Network is unreachable", is het probleem neem ik aan. Ik kom voor de verdere informatie gewoon op internet. sudo /etc/init.d/apache2 restart geeft verder geen errors.

Ik heb verder op internet nog wat gezocht, maar ik kan zo snel niets vinden.
Heeft iemand een oplossing?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Localhost werkt niet
« Reactie #1 Gepost op: 2008/04/19, 09:46:16 »
Probeer het eens met het ip-adres 127.0.0.1
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
Localhost werkt niet
« Reactie #2 Gepost op: 2008/04/19, 11:49:28 »
Had ik ook al geprobeerd, maar dat werkt ook niet.

Heeft netwerkinstellingen >> hostinstellingen er wat mee te maken misschien?

Edit
Grrrrrrr  als ik nu localhost intyp ga ik naar de wikipedia pagina.....

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Localhost werkt niet
« Reactie #3 Gepost op: 2008/04/19, 12:11:33 »
Vlerknozem kijk eens onder Systeem>Beheer>Netwerk>tabje Hosts. Daar staan genoemd. Misschien moet het wel bijv.  127.0.1.1 zijn. Dat kan je vlug genoeg zien.
En anders je Apache script nalopen.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
Localhost werkt niet
« Reactie #4 Gepost op: 2008/04/19, 18:35:09 »
Nee werkt niet...
koen@127:/etc/apache2/sites-enabled$ sudo /etc/init.d/apache2 force-reload
sudo: cannot get working directory
No apache MPM package installed
koen@127:/etc/apache2/sites-enabled$


En weer een herinstallatie nodig

Rune

  • Gast
Localhost werkt niet
« Reactie #5 Gepost op: 2008/04/25, 11:36:06 »
gezien je bash prompt:

'koen@127:'

denk ik dat er iets niet helemaal lekker zit in je hosts setup.
ik denk dat je /etc/hosts kapot is, (dwz dat er iets in staat wat niet helemaal volgens de syntax is).