Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: windows werkt niet meer  (gelezen 828 keer)

Offline patrick

  • Lid
  • Steunpunt: Nee
windows werkt niet meer
« Gepost op: 2008/04/15, 21:44:30 »
Na de update van ubuntu, heb ik de pc laten herstarten en wilde even in windows werken dat een tijdje daarvoor nog werkte.
Nu krijg ik de fout dat hal.ddl niet gevonden is, nochtans staat deze file wel op de goede plaats.
Het is of linux iets heeft gedaan met mijn windows HD. Als ik opstart met de windows cd en recovery kies geeft hij standaard de d; schijf waar een dir windows opstaat ook op de c: schijf staat deze dir.
kan geen bootcfg /rebuild doen om te herstellen.
wat is er mis gegaan.
Acer desktop met intel E5200 - 4Gb Ram - ATI RADEON HD3450 256Mb - 640Gb HD en 1 van 320 Gb.
Dual boot systeem met Ubuntu 11.04 32Bit en Windows 7 Ultimate 32Bit

Offline Ubert

  • Lid
  • Steunpunt: Nee
windows werkt niet meer
« Reactie #1 Gepost op: 2008/04/15, 22:12:06 »
hier staat de supportpagina met oa. hall.dll missing: http://support.microsoft.com/kb/330184/nl


gr ubert

Offline patrick

  • Lid
  • Steunpunt: Nee
windows werkt niet meer
« Reactie #2 Gepost op: 2008/04/16, 08:52:03 »
Ik krijg allerlei rare dingen.
Nu vond hij plotseling ntldr niet meer.
Opgestart met de cd van windows, repair gestart en mij aangemeld. Het rare is dat hij een windows versie vind, maar dat deze op de D schijf staat.
Het is precies of hij ergens in de knoei zit met de drive letters.
Acer desktop met intel E5200 - 4Gb Ram - ATI RADEON HD3450 256Mb - 640Gb HD en 1 van 320 Gb.
Dual boot systeem met Ubuntu 11.04 32Bit en Windows 7 Ultimate 32Bit

Offline patrick

  • Lid
  • Steunpunt: Nee
windows werkt niet meer
« Reactie #3 Gepost op: 2008/04/16, 08:59:34 »
Heb de fout gevonden. Heb opgestart met hirent boot cd en disk partition opgestart.
de tweede partitie was active gezet en de eerste de C drive op inactive.
Heb de tweede partitie op inactive gezet en de eerste terug op active en nu start de pc terug op in windows.
Wel mioet ik nu nog de grub herstellen want windows had de mbr terug geplaatst.
Waarom of hoe dit is gebeurd is mij een raadsel, want ik heb niks gedaan met de partities. Enkel de update van ubuntu.

Ik had met grub de grub teruggeplaatst en wat was het resultaat de 2 partitie was terug de boot partitie geworden van windows.
heb met partitiebewerker de eerste partitie boot gemaakt en alles werkt nu terug.
Kan het zijn dat  ubuntu de boot partitie van windows veranderd.
heb HD 1 voor windows en 1 voor ubuntu met de volgende indeling
windows HD  1 partitie boot - 2 partitie data - 3 partitie backups
ubuntu HD 1 partitie / - 2 partitie /home
Acer desktop met intel E5200 - 4Gb Ram - ATI RADEON HD3450 256Mb - 640Gb HD en 1 van 320 Gb.
Dual boot systeem met Ubuntu 11.04 32Bit en Windows 7 Ultimate 32Bit

Offline Dave

  • Lid
  • Steunpunt: Nee
windows werkt niet meer
« Reactie #4 Gepost op: 2008/04/16, 14:27:47 »
denk dat je indeling en/of bootflag niet is zoals het moet. ubuntu komt niet aan windows partities verder.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
windows werkt niet meer
« Reactie #5 Gepost op: 2008/04/16, 14:34:19 »
Dit is het probleem + oplossing (had een vriend van me ook):

Citaat
Pas rond 03:30 uur was ik klaar. Nadat de backup was terug gezet werkte boot.ini niet meer.
error   hal.dll is missing or corrupt please replace with the original van de cd.

Dit gedaan werkte nog van geen kant. Via forums kwam ik erachter dat deze melding niet moet worden opgevolgd!!!
(dus niet vervangen van de hal.dll) maar dat de boot.ini hersteld moet worden via de Windows CD in recovery mode.

Het commando fixboot wilde een aparte bootpartitie gaan aanmaken, doch dit vond ik te riskant na al jouw werk.
Ik heb daarna de boot.ini file weggegooid en via de recovery mode een boofcfg gedraaid.
Deze maakte toen een nieuwe boot.ini aan van de windows (eerste keer zag bootcfg alleen maar de windows op C terwijl de cd beide liet zien???)
Dit dus twee keer overgedaan.

Als ik nu die oude boot.ini met die nieuwe vergelijk, dan zie je verschillen.

Nieuwe gewijzigde regel is:
multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Microsoft Windows XP Professional D-Drive" /fastdetect /NoExecute=OptIn

De oude was:
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /noexecute=optin

Dus verschil in partitie nummer. Logisch natuurlijk, ik vermoedde dit al want ik had dat nummer partition(5) al zitten uit te proberen.
Mijn tijdverlies zat vooral in het opzoeken via forum waar ik het zoeken moest van die foutmelding.

Moe maar voldaan uiteindelijk naar bed. Alles werkt nu als een trein, ook mijn windows d drive gaat super. Haal nu tot 3000kbs bij copiƫren etc.