Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: toegangsrechten lampp/xampp  (gelezen 3701 keer)

Offline Christophe Hollebeke

  • Lid
    • Persoonlijke blog
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Gepost op: 2008/04/15, 09:05:55 »
Beste linuxers,

Heb xampp geinstalleerd, zoals aangegeven op de site van xampp.
Alles ging perfect!

Ik start xampp door het volgende te typen in console:

/opt/lampp/ ./lampp start

Daarna typ ik in de browser:

http://localhost

Dan zie ik de splash-pagina waar ik de taal moet kiezen.
Dan krijg ik volgende melding in de browser:

-----------------------------
Warning: fopen(lang.tmp) [function.fopen]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/lang.php on line 2

Warning: fwrite(): supplied argument is not a valid stream resource in /opt/lampp/htdocs/xampp/lang.php on line 3

Warning: fclose(): supplied argument is not a valid stream resource in /opt/lampp/htdocs/xampp/lang.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/lang.php:2) in /opt/lampp/htdocs/xampp/lang.php on line 5
-----------------------------

Dit heeft volgens mij iets met toegangsrechten te maken.

op de toegangsrechten gewijzigd van volgende mappen bestanden:

chmod -R 755 /opt/lampp/htdocs/
chmod -R 755 /opt/lampp/htdocs/xampp/
chmod -R 755 /opt/lampp/htdocs/xampp/index.php
chmod -R 755 /opt/lampp/htdocs/xampp/lang.php

Maar niks helpt, wie kan mij verder helpen?

Ik heb ook al gekeken op de website van xampp, alsook gegoogled voor dit probleem, maar vind niks specifieks.

Offline Rulus

  • Lid
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #1 Gepost op: 2008/04/15, 09:12:13 »
Zucht, xampp. Waarom een niet ondersteunde, onveilige en moeilijke versie installeren als het zo eenvoudig beschikbaar is op Ubuntu? Gooi die xampp maar weg en installeer Apache, MySQL en PHP via:
sudo taskselVervolgens kiezen voor LAMP server.

Offline Christophe Hollebeke

  • Lid
    • Persoonlijke blog
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #2 Gepost op: 2008/04/15, 09:38:58 »
Waarom gebruik ik xampp?? Om eerlijk te zijn werk ik met dsl linux op mijn oude laptop.
(mijn favoriete distro is uiteraard (k)ubuntu maar op de oude laptop werkt deze distro ongelooflijk traag
PII300 - 96MB ram, zelfs met de howto 'klein en snel' werkt deze traag. De reden dat ik DSL koos was, dat deze gebaseerd is op debian net zoals ubuntu!)

het commando :

sudo tasksel

werkt niet via dsl.

Heb ook al in de forums van dsl gezocht, en daar staat ook geen oplossing voor het probleem.

Liefst zou ik het apache, Mysql, PHP en phpmyadmin 'neutraal' willen inststalleren, maar als er één iets niet werkt sta ik weer even ver, en probeer het dan maar eens aan de praat  te krijgen.

Marcel1557

  • Gast
toegangsrechten lampp/xampp
« Reactie #3 Gepost op: 2008/04/15, 19:59:43 »
Je werkt met lampp ipv xampp commando's. Da's een wereld van verschil...
Binnen Linux kan één letter verschil héél veel betekenen... Hou 't op Xampp...

RTFM en succes: Marcel1557

Offline Christophe Hollebeke

  • Lid
    • Persoonlijke blog
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #4 Gepost op: 2008/04/15, 20:58:22 »
Typ bewust xampp/lampp, daar deze fout zo in het pakket zit.

Ze spreken over xampp maar toch moet je een 'lampp'-commando geven.
... raar maar waar ;-)

Offline Christophe Hollebeke

  • Lid
    • Persoonlijke blog
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #5 Gepost op: 2008/04/15, 22:19:04 »
PROBLEEM OPGELOST!

Had xampp geinstalleerd als gewone gebruiker, en dit most als su !

Offline JanClaeys

  • Lid
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #6 Gepost op: 2008/05/30, 20:17:10 »
Citaat van: ctuxboy
Waarom gebruik ik xampp?? Om eerlijk te zijn werk ik met dsl linux op mijn oude laptop.
(mijn favoriete distro is uiteraard (k)ubuntu maar op de oude laptop werkt deze distro ongelooflijk traag
PII300 - 96MB ram, zelfs met de howto 'klein en snel' werkt deze traag. De reden dat ik DSL koos was, dat deze gebaseerd is op debian net zoals ubuntu!)
DSL is gebaseerd op een Debian-versie die al jaren geen security-updates meer krijgt, m.a.w. ten alle prijze te vermijden voor alles wat je aan het internet wil hangen.

Trouwens, Ubuntu Server + LAMP kan je perfect draaien op jouw systeem.  Zo'n 8 jaar geleden draaiden wij probleemloos Debian + LAMP + mailserver op een Pentium 100 MHz met 64 MiB RAM.  Jouw systeem moet dat dus probleemloos aankunnen...
Jan Claeys
Ubuntu-nl IRC team - Ubuntu-be LoCoTeam Contact

Offline Christophe Hollebeke

  • Lid
    • Persoonlijke blog
  • Steunpunt: Nee
toegangsrechten lampp/xampp
« Reactie #7 Gepost op: 2008/06/02, 14:42:14 »
Denk inderdaad om opnieuw ubuntu server + lampp te installeren, zal de beste oplossing zijn