Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Netwerk adapter uitschakelen (blacklist?)  (gelezen 4554 keer)

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Gepost op: 2008/04/02, 09:24:36 »
In een ander topic heb ik dit al een saangehaald, maar ik wil het toch graag oplossen.
Ik heb een ingebouwde wlan adapter (CONNECT2AIR WLAN E-5400 USB D1700 (ingebouwd in fuijitsu-siemens pc)

maar omdat deze niet echt compatible was met ubuntu (wel/geen internet) heb ik een sitecom usn adapter gekocht. Deze werkt prima.

Nu heb ik het volgende probleem:
Beide adapters zijn actief, dus mijn pc wisselt weleens tussen die twee. gevolg, wegvallende verbindingen. Heel irritant. In de networkmanager kan ik niet goed zien welke adpater watis, ik krijg mijn thuisnetwerk twee keer in beeld. De naam van de adapter is in beide gevallen: unknown vendor. Dus ik weet niet waar ik mee verbnonden ben.

Dus de concrete vragen:
1. Hoe kan ik erachterkomen welke adapter actief is en hoe deze adapter heet (driver??/)
2. Als ik dat weet, hoe kan ik de ingebouwde adapter uitzetten, blacklisten of iets dergelijks.

bedankt voor de info, hopelijk is mijn probleem een beetje duidelijk. :)
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline woteb

  • Lid
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #1 Gepost op: 2008/04/02, 10:01:19 »
Met het commando (in een terminal): ifconfigkun je zien welke adapters aanwezig zijn en wat voor een IP-adres ze hebben.

Hier mijn output (als voorbeeld):
Citaat
vader@enigma:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:D0:59:2B:A0:75
          inet addr:192.168.1.28  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2d0:59ff:fe2b:a075/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14484 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16853 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5583596 (5.3 MiB)  TX bytes:14029920 (13.3 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:560 (560.0 b)  TX bytes:560 (560.0 b)
Je ziet, mijn vaste netwerkkaart heeft als devicenaam: eth0. (ik werk op deze school met een vaste verbinding, draadloos zou het wlan0 of ra0 (afhankelijk of ik een Ovislink of een Asus kaartje gebruik) hebben.)

Om een adapter uit te zetten gebruik je het commando ifdown. Een voorbeeld:

sudo ifdown eth0Dit zorgt ervoor dat eth0 wordt uitgezet.

Wil je dit permanent doen, dan moet je een aanpassing maken in het bestandje /etc/network/interfaces.

Daar staat bij mij:
Citaat
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
Zet voor de regels waar het betrekking heeft voor eth0 een #, dus:
Citaat
auto lo
iface lo inet loopback
#auto eth0
#iface eth0 inet dhcp
En mijn eth0 is bij het opstarten uitgeschakeld.
Uiteraard kun je dit alleen muteren met rootrechten, dus bijv. met het commando:
sudo kwrite /etc/network/interfaces (voor KDE gebruikers)
sudo gedit /etc/network/interfaces (voor Gnome gebruikers)
sudo mousepad /etc/network/interfaces (voor XFCE gebruikers)
sudo nano /etc/network/interfaces (werkt bij alle desktops, opslaan met + O en + x voor het afsluiten).

Maar plaats je dump van ifconfig hier maar eens.....
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline tabasco

  • Lid
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #2 Gepost op: 2008/04/02, 10:01:32 »
Is het mogelijk om het in je bios uit te schakelen?

Offline woteb

  • Lid
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #3 Gepost op: 2008/04/02, 10:11:41 »
Citaat van: tabasco
Is het mogelijk om het in je bios uit te schakelen?
Dat heeft alleen zin als je bios dat ondersteunt, maar met mijn vorige antwoord doe je dat eleganter en heb je controle over wat je allemaal hebt gedaan. Even die # weghalen en je netwerkkaart werkt weer bij het opstarten. Met BIOS wijzigen loop je een risico (als je meer dan 1 vaste netwerkkaart hebt, eentje op je moederbord en een PCI kaart) dat je met eth0 en eth1 instellingen problemen gaat krijgen. Door simpel binnen het bestandje /etc/network/interfaces te wijzigen kun je met een # dan óf eth0 óf eth1 uitschakelen.
Verder moet je niet teveel in je bios gaan rommelen. Een config bestandje aanpassen heeft meer controle, zeker als je ergens een fout hebt gemaakt. Dan kun je makkelijker een config bestandje als /etc/network/interfaces aanpassen dan een bios wijziging doorvoeren.
Als je een wijziging hebt gemaakt in bovengenoemde bestandje, dan kun je dat ook meteen doorvoeren met het commando (ik gebruik mijn eigen voorbeeld maar even): sudo ifdown eth0. Inschakelen is dan: sudo ifup eth0
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #4 Gepost op: 2008/04/02, 15:37:32 »
Dit is de uitkomst bij mijn ifconfig:

bas@bas-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:13:D4:95:D2:86  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:22 Base address:0xdead

eth0:avah Link encap:Ethernet  HWaddr 00:13:D4:95:D2:86  
          inet addr:169.254.9.97  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:22 Base address:0xdead

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:176 (176.0 b)  TX bytes:176 (176.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:0C:F6:39:26:99  
          inet addr:192.168.1.7  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:f6ff:fe39:2699/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8035 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8738 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6275668 (5.9 MB)  TX bytes:5265548 (5.0 MB)

wlan1     Link encap:Ethernet  HWaddr 00:30:05:A3:3D:1A  
          inet6 addr: fe80::230:5ff:fea3:3d1a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:5497 (5.3 KB)

wlan1:ava Link encap:Ethernet  HWaddr 00:30:05:A3:3D:1A  
          inet addr:169.254.3.154  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

wmaster0  Link encap:UNSPEC  HWaddr 00-0C-F6-39-26-99-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster1  Link encap:UNSPEC  HWaddr 00-30-05-A3-3D-1A-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

bas@bas-desktop:~$
Als ik het goed begrijp is dus op dit moment wlan0 de actieve adapter (daar staat een ipadres bij). die andere kan ik dus uitschakelen? Dus ik moet doen:

sudo ifdown wlan1begrijp ik dat goed??
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline woteb

  • Lid
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #5 Gepost op: 2008/04/02, 16:56:09 »
Dat heb je goed....! En 'permanent' (dus bij het opstarten) de regels die betrekking hebben op wlan1 voorzien van een # ervoor.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #6 Gepost op: 2008/04/02, 20:21:06 »
heb nu een # gezet voor de regel met wlan1:

sudo gedit /etc/network/interfaces

uitkomst is dus nu:
auto lo
iface lo inet loopback






iface eth0 inet dhcp





auto eth0


#iface wlan1 inet dhcp
wireless-key s:ABCDEFG181076
wireless-essid DV201AM

#auto wlan1

edit: toch zie ik bij de networkmanager nog twee wlan adapters actief, bij beide zie ik mijn netwerk staan..
als ik nu sudo ifdown wlan doe krijg ik deze melding:

bas@bas-desktop:~$ sudo ifdown wlan1
[sudo] password for bas:
/etc/network/interfaces:19: misplaced option
ifdown: couldn't read interfaces file "/etc/network/interfaces"
bas@bas-desktop:~$
dus de #jes hebben wel gewerkt, waarom zie ik dan toch 2 adapters en 2 dv201am netwerken???
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #7 Gepost op: 2008/04/02, 23:34:10 »
nu heb ik als tets alle # weggehaald  dmv:

sudo gedit /etc/network/interfaces en
sudo ifup wlan1 gedaan.

Naar mijn idee moet dat dus betekenen dat wlan1 is ingeschakeld. Dat klopt ook:
Tot mijn verbazing hebben ze nu allebei een ipadres (.7 en .8)
MAAR in mijn networkmanager-icoontje re-onder zie ik nu  maar 1 keer alle netwerken staan, ipv dubbel bij mijn vorige post (#7). Het lijkt er dus op of de pc maar 1 wlan adapter ziet terwijl ze beide een ipadres hebben.

vreemd toch??
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #8 Gepost op: 2008/04/03, 17:57:29 »
WEER EEN RAAR PROBLEEM:

als ik ifconfig intik krijg ik deze melding over de wlan0 en wlan1:

wlan0     Link encap:Ethernet  HWaddr 00:0C:F6:39:26:99  
          inet addr:192.168.1.7  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:f6ff:fe39:2699/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16493 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18283 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12708647 (12.1 MB)  TX bytes:15762872 (15.0 MB)

wlan1     Link encap:Ethernet  HWaddr 00:30:05:A3:3D:1A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:898 errors:0 dropped:0 overruns:0 frame:0
          TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:592380 (578.4 KB)  TX bytes:204543 (199.7 KB)
als ik nu sudo gedit /etc/network/interfaces intik krijg ik dit te zien:
auto lo
iface lo inet loopback






iface eth0 inet dhcp









iface wlan1 inet dhcp
wireless-key ABCDEFG181076
wireless-essid DV201AM

auto wlan1

auto eth0
Vraag:
Hoe kan in het eerste scherm staan dat wlan0 actief is, terwijl in het laatse venster, wlan0 niet genoemd staat???
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #9 Gepost op: 2008/04/03, 21:33:56 »
ik denk dat ik het heb opgelost:

ik heb de driver van de interne wlanadapter (wlan1) geblacklist:
sudo modprobe -r p54usbtoen ik dat deed viel de netwerkverbinding direct weg (externe wlanadapter was niet aangesloten).
in de networkmanager waren geen wlan verbindingen meer te zien.

Daarna externe usb adapter ingeplugd en het werkt nu. Nu even afwachten of het ook blijft werken.
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #10 Gepost op: 2008/04/04, 07:47:59 »
wederom te vroeg gejuicht!! :(
ik heb nu wel maar 1 adapter die werkt, dus het blacklisten werkt. Maar regelmatig worden de blauwe balkjes van de wifi verbinding wit (terwijl hij wel het draadloze netwerk ziet met een sterkte van 72%). Ik moet dan de wlan adpater in en uitpluggen om het weer werkedn te krijgen. Als ik mijn netwerk manager instel op handmatig, maakt ie helemaal geen verbining, ik moet zwervende modus aanzetten. Schiet mij maar lek, maar blijkbaar is een draadloos netwerk met ubuntu erg moeilijk....ik weet niet meer wat ik nu nog kan doen om het goed (lees stabiel) werkend te krijgen. :( :(

ik kan ook niet de handmatige instellingen werkend krijgen; ik vul naam van het netwerk in, wep en wachtwoord en dan? Ik kan nergens op connect klikken of iets dergelijks.

iemand een idee / ervaring met dit probleem (tele2 modem wireless)
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline Idzme

  • Lid
    • http://idzme.wordpress.com/
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #11 Gepost op: 2008/04/04, 21:16:28 »
Het is me gelutk om via dit commando:
sudo modprobe -r p54usbde driver voor wlan0 op de blacklist te zetten.
Maar na een herstart werkt ie weer. iemand enig idee hoe ik dit permanent kan maken?
Intel Pentium 4 630, 3000 MHz (15 x 200), 1024 MB (SDRAM), 2x ST3160021A (160 GB, 7200 RPM, Ultra-ATA/100)
Ubuntu 8.10-Xubuntu 8.10
Linux user #464441 / Ubuntu user # 23391
Mini-distro's en het laatste Linux nieuws: http://idzme.wordpress.com
www.twitter.com/basidz

Offline siegi

  • Lid
  • Steunpunt: Nee
Netwerk adapter uitschakelen (blacklist?)
« Reactie #12 Gepost op: 2008/04/04, 22:03:27 »
gksudo gedit /etc/modprobe.d/blacklist > en een lijntje erbij zetten blacklist p54usb