Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ADSL van XS4ALL in Ubuntu (6.06 LTS)  (gelezen 3367 keer)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Gepost op: 2006/08/01, 03:07:02 »
Hallo allemaal,

ik ben enorm nieuw tot elk ander OS dan Windows. Nu heb ik de overstap toch geprobeerd op gewoon wat dingen spelende wijs te leren. Echter blijft dat wel uit wanneer ik geen Internet verbinding kan krijgen.

De Desktop in kwestie is in dit geval aangesloten op een speedtouch alcatel (multi pc) modem.
Om een verbinding te krijgen via windows hoef ik alleen de ethernet kabel in te pluggen waarna hij een LAN verbinding legt en ik direct internet heb. Onder Ubuntu heb ik hier echter meer problemen mee.

Via system/administration/networking kom ik bij de netwerk instellingen. Hier klik ik op Ethernet connection en ga naar de eigenschappen hiervan. Wanneer ik de configuratie op DHCP (welke wel draait op de modem) laat staan, dan krijg ik geen internet. Dan maar volgens een 'Static IP adres' denk ik dan. Als Ip adres heb ik zowel ip adressen binnen de range gebruikt die de modem DHCP aangeeft als een ip adres dat hier direct buiten valt. DHCP loopt van 10.0.0.150 tot / met 10.0.0.200.
De subnet mask staat ingesteld op: 255.255.255.0
De gateway staat op 10.0.0.138
Bij de 't tabblad DNS heb ik de standaard DNS servers van Xs4all. (194.109.9.99 194.109.6.66 194.109.104.104 )

Welke van deze setting ik ook uitprobeer niks werkt. Toen kreeg ik van een vriend te horen dat ik eens in de terminal moest kijken naar:
vi /etc/network/interfaces.Daar vertelde hij me dat ik het volgende moest toevoegen:
network 10.0.0.0
broadcast 10.0.0.255
Dit probeerde ik op te slaan met: :w en daarna ook met :w/ Geen van twee lukte overigens. Bij :w kwijg ik de melding dat ik een 'readonly' bestand te pakken heb.
en bij :w! krijg ik de melding:
*/etc/network/interfaces* E212: Can't open file for writing
 Hit ENTER or type command to continue
Overzicht van wat ik exact heb staan wanneer ik nu vi /etc/network/interfaces invoer bij de terminal:
auto eth0
iface eth0 inet static
address 10.0.0.201
netmask 255.255.255.0
gateway 10.0.0.138
Zoals je dus merkt zit ikzelf als nieuwkomer bij Ubuntu vast en hoop dus graag dat iemand me kan helpen met wat ik zou moeten doen om mijn internet werkend te krijgen.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #1 Gepost op: 2006/08/01, 04:21:29 »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #2 Gepost op: 2006/08/01, 11:40:12 »
je moet het bestand bewerken met:

"sudo vi /etc/network/interfaces"

en daarna kan je in vi "i" drukken om tekst te bewerken en dan ESC :wq! typen om de tekst op te slaan en om vi af te sluiten

Nota 1: nano is gemakkelijker dan vi, da's gewoon typen en dan CTRL+Q om te stoppen dacht ik
Nota 2: vim is een "improved" versie van vi
Nota 3: je kan ook gewoon "sudo gedit /etc/network/interfaces" doen en dan krijg je een grafische teksteditor om het bestand te bewerken

Succes
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #3 Gepost op: 2006/08/01, 13:43:12 »
Als ik in de terming ifconfig tik krijg ik de volgende uitkomst:
eth0   Link encap:Ethernet HWaddr 00:10:DC:4c:88:70
         inet addr:10.0.0.201 Bcasr:20.0.0.225 Mask:255.255.255.0
         inet6 addr:fe80::210:dcff:f34c:8b70/64 Scope:link
        UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
        RX packets:59 errors:233 dropped:0 overruns:0 carrier:0
        collisions:o txqueuelen:1000
        RX bytes:5549 (5.4 KiB)  TX bytes: 18205  (17.7 KiB)

lo    Link encap:Local Loopback
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING MRU:16436 Metric:1
      RX packets: 16 errors:0 dropped:0 Overruns:0 frame:0
      TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
     collissions :o txqueuelen:0
     RX bytes:2541 (2.4 KiB)  TX bytes:2531 (2.4 KiB)
Bij iwconfig geeft hij aan:
Lo         no wireless extentions.

eth0     No wireless extensions.

ath0    IEEE 802.11 ESSID:"  "
          Mode: Managed Frequency 2.412 Ghz Access Point: Not - associated
         Bit Rate: okb/s  Tx-power: 20 dBm  Sensitivity=0/3
         Retry: off TRS thr:off    Fragment thr:off
         Power Management:off
         Link Quality=0/94 Signal level= - 95 dBm Noise level = - 95 dBm
         RX invalid nwid:o Rx invalid crypt:o Rx invalid frag:o
         TX excenssive retries:o    Invalid misc:o   Missend beacon:o

sit0   No wireless extensions.
Helaas heeft het toevoegen van de twee regels in eerste instantie geen verschil uitgemaakt. Ik bleef geen internet krijgen, daarna heb ik je Deactiveren en Activeren testje geprobeerd. Helaas mocht dat ook niet baten, hopelijk hebben jullie wat meer aan de ifconfig en iwconfig info.

Wederom alvast bedankt,
Joost

Ps. Het maakt mij in eerste instantie niet uit hoe ik verbinding heb, via de ethernet of wireless. Het is toch een desktop, die versleep je niet zo heel veel, en met 1 werkende verbinding kan je al een heleboel meer oplossen.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #4 Gepost op: 2006/08/01, 14:03:37 »
Bij DHCP zou je normaal gezien met het commando "sudo dhclient eth0" wel verbinding moeten krijgen

wat voor een netwerkkaart is dat? "lspci|grep Ethernet"
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #5 Gepost op: 2006/08/01, 15:10:31 »
Wanneer ik in de terminal het commando "sudo dhclient eth0" intik krijg ik hetvolgende:
Internet System Consortium DHCP Client v3.0.3
Copyright 2004-2005 internet Systems Consortium.
All right reserved.
For info, please visit http://www.isc.org/products/DHCP

SIOCSIFADDR: No such device
eht0: ERROR while getting interface flags: No such device
eht0: ERROR while getting interface flags: No such device
bind socket to interface: no such device
Na dit gedaan te hebben (en ondanks de errors te zien) heb ik nogmaals FF geprobeerd, zowel met DHCP als static IP. Geen van beiden werkt nog.

De netwerkkaart code:
0000:03:03.0 Ethernet controller: Atheros Commu nications, Inc. : Unknown device 00la (rev 01)
0000:03:08.0 Ethernet controller: intel Corporations 82801DB PRO/100 VE (CNR) ethernet Coltroller (Rev 81)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #6 Gepost op: 2006/08/01, 16:44:00 »
eth0 en niet eht0 he :) ?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #7 Gepost op: 2006/08/01, 16:53:03 »
Okay, sla me even wakker...
Vernieuwde code:
Internet System Consortium DHCP Client v3.0.3
Copyright 2004-2005 internet Systems Consortium.
All right reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:10:dc:4c:8b:70
Sending on  LPF/eth0/00:10:dc:4c:8b:70
Sending on  Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS recieved.
No working leases in persistent database - sleeping.
Het is me duidelijk dat er een proces uitstaat. (Had via system/administration/?? al gezien dat mijn processen sliepen...) Echter, welk proces moet aangezet worden en hoe doe ik dit? (Vermits ik logisch genoeg nagedacht heb).

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #8 Gepost op: 2006/08/01, 17:04:04 »
Je krijgt om een of andere reden geen DHCP toegewezen vanaf je router/modem
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #9 Gepost op: 2006/08/01, 17:52:05 »
Dat was zo ongeveer al bekend, nu is alleen de vraag nog hoe we dit kunnen forceren. Zelfs met een static IP lukt het niet.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #10 Gepost op: 2006/08/01, 19:24:39 »
Hmmmmz ff terug naar de bron ?

*Kijk eens in je modem/Router of daar de DHCP wel aanstaat ?
*Zet het broadcasten eens aan in je Modem/router ?
 
misschien een domme opmerking maar in netwerk fouten ligt de oplossing vaak in iets simpels.

Dat wireles gedeelte is vaak een verhaal apart als dit niet werkt, dus lijkt het me het beste dat je dit kaartje ff uit je PC haalt.
Ik kan me zo voorstellen dat Ubuntu nu over 2 netwerkaarten requesten aan het doen is bij je modem/router en dat je modem/router ff niet weet wat te doen.

Als zometeen het wired gedeelte werkt kan je altijd nog gaan beginnen met het wireles gedeelte.

Stap-voor stap werken.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

MacGyver

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #11 Gepost op: 2006/08/01, 21:57:28 »
Ik ben ook geen linux-veteraan, en helemaal niet als het op netwerken aankomt, maar ik heb wel wat theoretische netwerkkennis...

En het valt me op dat hij de melding geeft

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5Hoort dat niet overeen te komen met het netmask, en dus in ieder geval niet 255.255.255.255 te zijn, maar waarschijnlijk 255.255.255.0?

Just a thought...

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #12 Gepost op: 2006/08/01, 22:00:22 »
Nee hoor, bij mij is dat ook gewoon 255.255.255.255
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #13 Gepost op: 2006/08/01, 22:04:13 »
De instellingen van de modem werken wel voor Windows, waarom zouden ze dan niet onder Ubuntu werken?

Maar okay, de DHCP server staat aan, en er zijn geen DHCP client 'defined' wat dus Logisch is. Daarbij moet de broadcast al aanstaan gezien bij windowsclients wel een internet verbinding verkregen wordt.

Edit:
*Wireless kaart is er nu uitgehaald* en dus heb ik alleen 't lan Ethernet nog.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #14 Gepost op: 2006/08/01, 22:09:42 »
Heb je er 2 netwerkkaarten inzitten? Die atheros klinkt eng...

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #15 Gepost op: 2006/08/01, 22:13:50 »
atheros zou normaal gezien gewoon moeten werken op ubuntu, maar misschien helpt het als je die ff uitschakelt met "sudo ifconfig ath0 down" aangezien je met 2 kaarten tegelijk zit (wired en wireless)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #16 Gepost op: 2006/08/01, 22:25:13 »
Heb die wireless kaart eruit gehaald (hardware matig) en nog komt er geen internet verbinding tot stand.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #17 Gepost op: 2006/08/01, 22:27:46 »
Ok, wat zget dit commando:

sudo mii-diag eth0

Het zou 'You have link beat, everything is working ok' moeten zeggen.

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #18 Gepost op: 2006/08/01, 23:09:21 »
Het commando geeft devolgende reactie:
Basic registers of MII PHY #l:  3100 782d 02a8 0330 05e1 41e1 0003 0000.
The autonegotiated capability is 01e0
The autonegotiated media type is 100baseTx-FD.
Basic mode control register 0x3100: auto-negotiation enabled.
You have link beat, and everything is working OK.
Your link partnet advertised 41e1: 100baseTX-FD     100baseTx     10baseT - FD   10 baseT.
End of basic transceiver infromation.
He he, lekker dubbel: Everything is working fine, maar nog geen inet verbinding:P

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #19 Gepost op: 2006/08/02, 10:21:58 »
Wat je ook nog zou kunnen controleren is of je wel contact hebt met de modem:
- staan aan beide zijden (netwerkkaart PC en poort op router) de ledjes aan? Dit geeft aan of op fysiek niveau de spullen elkaar kunnen "zien"
- met een statisch IP adres moet je PC dacht ik 10.0.0.150 zijn en is de modem 10.0.0.138 (sorry, weet ik niet meer uit m'n hoofd en kan het momenteel niet controleren)
- probeer de modem en de machine zelf te "pingen" met het commando:
ping 10.0.0.150
ping 10.0.0.138
- is het mogelijk dat op de router je nieuwe MAC (hardware) geblokkeerd is?

Zomaar wat ideetjes ...
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Josty

  • Gast
ADSL van XS4ALL in Ubuntu (6.06 LTS)
« Reactie #20 Gepost op: 2006/08/02, 14:38:05 »
Ik wilde het toch eens testen en heb me desktop van boven naar beneden versleept. Daar heb ik een ANDERE netwerk kabel tussen de modem en mijn desktop geplaats. Desktop vervolgens aangezet en op laten starten, direct had ik een internet verbinding via de DHCP. Echter als de kabel gebruik die van beneden naar boven ga en ik die vervolgens in mijn laptop plug, dan krijg ik ook een lan netwerk erbij en werken ze dus alle twee. Nu nog even uitzoeken wat de reden is dat de kabel van beneden naar boven en mijn desktop niet (meer) samen gaan en dan snel mijn wireless aan de praat krijgen.

Alvast bedankt voor alle hulp van jullie.