Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wel verbinding, niet op het net.  (gelezen 2035 keer)

nealz

  • Gast
Wel verbinding, niet op het net.
« Gepost op: 2008/03/28, 16:59:05 »
Ik maak gebruik van een belkin wifi router...
Met windows kan ik probleemloos internetten...
Maar nou wil ik graag met mijn laptop met linux erop, ook kunnen internetten...dit werkt hellaas niet.


Ik kan Via ubuntu wel connecten...
Alleen niet op het net komen....Ook kan ik niet mijn router benaderen in linux...
alleen in de Wicd manager geeft hi jwel aan dat ik ben geconnect.
wat kan dit zijn!? help me please!

Instellingen: Wifi belkin Router.
Security : WPA-PSK (no server)
Authentication : WPA-PSK
Encryption Technique : Tkip

Instellingen linux:
Wpa personal

Connaction settings : static ip address
ip address : 192.168.2.5
subnet mask 255.255.255.0
gateway: 192.168.2.1

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #1 Gepost op: 2008/03/28, 22:05:44 »
Aan nealz
Gebruik je Ubuntu 7.10? Wat voor kaartje zit er in je laptop?
vr.groet, peter

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #2 Gepost op: 2008/03/30, 13:46:23 »
Nog een paar dingen, wat krijg je bij:

netstat -rn
cat /etc/resolv.conf
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

nealz

  • Gast
Wel verbinding, niet op het net.
« Reactie #3 Gepost op: 2008/04/01, 17:42:59 »
Aan  Petervdw :
Het kaartje werkt wel, ik heb in mijn oude huis gewoon internet gehad met internet.
en het rare is, hij ziet mijn router wel...Alleen kan niet internetten, + ik kan niet op de routerkomen..
dus waarschijnelijk geen DNS probleem. Want kan ook niet op het interne netwerk.


Tukcedo:

Search belkin
192.168.2.1

jwtschaaf

  • Gast
Wel verbinding, niet op het net.
« Reactie #4 Gepost op: 2008/04/02, 10:51:19 »
ik heb hetzelfde probleem denk ik... Ik heb Gutsy Gibbon op mijn Desktop met WUSB54G(4), hij ziet mijn (Windows)netwerk wel (draadloos netwerk met modemrouter van Versatel, mijn XP laptop heeft wel internet), maar ondanks dat ik gebruikersnaam en wachtwoord invul, komt hij niet op het netwerk. Nu weet ik niet of het ligt aan:

1. Linux vs. Windows XP: ze kunnen niet met elkaar praten, maar daar heb ik het volgende aan gedaan: ik heb met Samba mijn gebruikersnaam en wachtwoord ingesteld... helpt niet
2. De USB adapter van Linksys (WUSB54G, versie 4): hij ziet het netwerk wel, dus volgens mij werkt het
3. Misschien verkeerde encryptiemethodes? WEP of WPA... bij Windows vind ik dit niet al te duidelijk hoe ik dat kan wijzigen...

Ik heb het gevoel dat ik wel de klok heb horen luiden, maar waar de klepel hangt... ik weet het niet!

Mijn dank alvast, Jan-Willem S. uit Den Haag

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #5 Gepost op: 2008/04/02, 12:03:13 »
Aan jwtschaaf
Kijk eens op de volgende pagina van de onvolprezen googlepages van Pjotr:

http://computertip.googlepages.com/geennetwerkverbinding

Verder werkt die WUSB54G versie4? met de RT2500 driver en die zit al in Ubuntu 7.10.
Dus met enig reboot- en spanningsloos maken van computer en modem/router en wat geduld zou het voor elkaar moeten komen. Wel regelmatig updaten.
Als 't niet werkt, vraag verder aub.
Vr.groet, peter

Verder wil je via je modem/router een netwerkje opzetten tussen desktop en laptop?
Daar wil ik je ook wel bij helpen, maar eerst allebei internet.

Ik zag dat de link niet werkte, nog een keer: dan zo maar en zelf even kijken:
http://computertip.googlepages.com/geennetwerkverbinding

Fout hersteld, even kijken of 't nu werkt.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #6 Gepost op: 2008/04/02, 12:24:34 »
Aan nealz
Je geeft wel info over je router, maar niet over de andere kant, het wireless kaartje in je laptop. Ingebouwd, doe dan eens lspci in de terminal en post de uitkomst. Pcmcia, merk en type. Of een USB adapter, merk en type. En verder: Na gebruik van Windows moet je het IP-nummer vrijgeven met: ipconfig /release, en dan pas overgaan op Ubuntu.
Vr.groet, peter

Waarom gebruik je statische IP-nummers?

jwtschaaf

  • Gast
Wel verbinding, niet op het net.
« Reactie #7 Gepost op: 2008/04/02, 15:58:39 »
Aan Peter

Dank je voor je hulp.

Het probleem is niet dat het IP nummer niet wordt vrijgegeven of iets dergelijks, want op mijn desktop staat alleen maar Ubuntu, geen dual.

Ik heb nu zo'n beetje alles geprobeerd voor mijn gevoel: met samba gebruikersnaam en wachtwoord maken, Manual configuration, Static IP ingeven, Rutilt geprobeerd te installeren, wel of niet Roaming gebruiken, allerlei verschillende opties met WEP encryptie etc geprobeerd, ook de modemrouter helemaal uitgedaan voor 2 minuten... het helpt helemaal niets...
Ik krijg wel een symbooltje dat hij een netwerksignaal oppikt, maar als ik iwconfig doe, dan zegt ie steevast: Acces-point: not associated... Ik heb ook met Ifup en Ifdown geprobeerd, geen resultaat... ik heb ook gecheckt of het een RT2500 chipset betreft en dat is zo, en dat klopt ook met de driver in Ubuntu...
Ik weet nu echt niet meer wat ik kan doen, heb al talloze fora afgestruind op informatie, maar niets heeft geholpen...

Hopelijk kan je hier nog wat mee, het is behoorlijk chaotisch, ik weet het...

Groet, Jan-Willem

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #8 Gepost op: 2008/04/02, 16:19:28 »
Aan jwtschaaf
Twee draadjes door elkaar, op het laatst raak ik zelf in de war. Kun je niet zelf een nieuw topic starten met de naam van de adapter in de titel? Dan probeer ik hier eerst  nealz te helpen.
Vr.groet, peter

Staat er heel onaardig, maar dat is niet de bedoeling. Naast af en toe een een blik op dit forum doe ik ook nog iets anders tegelijk erbij om een extra zakcentje te verdienen. En vooral als 2 problemen veel op elkaar lijken is de versuffing nabij.  :D

jwtschaaf

  • Gast
Wel verbinding, niet op het net.
« Reactie #9 Gepost op: 2008/04/02, 16:35:41 »
heb een nieuw draadje gemaakt hoor ! Groet, JW

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #10 Gepost op: 2008/04/03, 21:54:22 »
Peter, ik was ook al met Nealz bezig en het lijkt mij dat de routering of de name resolution niet werkt want hij schijnt een fysieke verbinding te hebben (lijkt een adres te krijgen met DHCP). Ik heb 'm om wat output gevraagd via email maar nog niks gezien.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #11 Gepost op: 2008/04/03, 22:20:11 »
Aan tukcedo
Nee, kijk er regelmatig naar, maar geen nieuwe post. Als ik zo het verloop van het draadje zie, kun jij hem beter helpen als je wilt. Ik heb helemaal geen Linux achtergrond, en behalve goed zoeken, geduld en enige ervaring met aansluiten van ADSL heb ik weinig te bieden. Ik hoop dat hij nog wat post en dat het je lukt. Succes.
Vr.groet, peter

nealz

  • Gast
Wel verbinding, niet op het net.
« Reactie #12 Gepost op: 2008/04/05, 12:21:06 »
Dingen die ik meer heb bekeken...
netstat -rn
>
> Destination           gateway         genmask                    
> flags      mss      interface
> 192.168.2.0          0.0.0.0            255.255.255.0         u        
>    00      wlan0
> 169.254.0.0          0.0.0.0             255.255.0.0            u      
>       00      eth0  
> 169.254.0.0           0.0.0.0            255.255.0.0         u        
>    00         wlan0
> 0.0.0.0                  192.168.2.1        0.0.0.0                
> UG       00      wlan0
> 0.0.0.0                    0.0.0.0               0.0.0.0            u  
>             00      eth0
>


etc/resolv.conf  stond ook al goed.
ik kom er niet uit....
Ik hoop dat tucedo mij via de mai lverder kan helpen...
Zodra ik het weet post ik het hier!

bedankt voor de hulp!

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Wel verbinding, niet op het net.
« Reactie #13 Gepost op: 2008/04/06, 01:04:38 »
Nealz, slecht nieuws vrees ik. Je zegt in je mail dat je de default router, 192.168.2.1, NIET kunt pingen. In dat geval heb je dus geen werkende verbinding. Is dit een adres dat je statisch hebt ingevoerd? Moet haast wel, want via DHCP verkregen adressen komen al over de wifi device.

Gebruik je wpa_supplicant trouwens voor je WPA encryptie? Dat zou mooi zijn want die kun je in debug mode laten draaien en dat zie je meestal wel wat er aan de hand is.

Ik draai zelf een scriptje voor mijn wifi verbinding wat er grosso modo zo uitziet:

/sbin/ifconfig eth0 down
/sbin/iwconfig ath0 essid "xxxxx"
/sbin/iwconfig ath0 channel 11
/usr/sbin/wpa_supplicant -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf -B
/sbin/dhclient ath0

EDIT: die -c regel hoort achter de voorgaande regel!

Probeer deze commando's (bij jou staan ze misschien ergens anders en je zal ze met sudo moeten laten voorafgaan) 1-voor-1 en kijk hoe ver je komt. Als je wpa_supplicant ZONDER de -B optie draait krijg je de output in je terminal. Hieruit moet blijken dat de AP gevonden wordt en dat er onderhandeling over de sessie key plaatsvindt.

Mijn /etc/wpa_supplicant.conf is zoiets als:

ap_scan=1

network={
        ssid="xxxxx"
        scan_ssid=1
        #psk="bladiebladiebladiebla"
        psk=hoophexkaraktertjes.............
}

We moeten dus eerst die verbinding maken. Succes weer!
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl