Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0  (gelezen 4791 keer)

Skoebidoe

  • Gast
Graag had ik een draadloze internetverbinding opgezet. Heb een handleiding van ndiswrapper doorlopen maar kom vast te zitten.
In de Terminal krijg ik het volgende :

alain@alain-desktop:~$ ndiswrapper -l
Installed ndis drivers:
gplus           driver present, hardware present
alain@alain-desktop:~$
Als ik dan via Systeem >>> Netwerk open, krijg ik enkel mijn eth0 en nog een modemverbinding te zien die niet geconfigureerd is.
Wlan0 staat er niet tussen.
Weet iemand raad? :(

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #1 Gepost op: 2006/07/30, 23:36:48 »
geeft het commando "iwconfig" je verbinding weer?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #2 Gepost op: 2006/07/30, 23:44:20 »
Citaat van: profoX
geeft het commando "iwconfig" je verbinding weer?
nee, jammer genoeg niet :

alain@alain-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

alain@alain-desktop:~$

Offline Gandyman

  • Lid
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #3 Gepost op: 2006/07/31, 00:00:11 »
Ik heb hier een pc met een nukke.
Wanneer ik hem opstart heeft hij afentoe ?? geen verbinding en de netwerkkaart doet nix.
Wanneer ik bij eth0 op Deactiveren klik en dan Activeren doet hij het wel.
 
Probeer dat ook eens >??

BTW als hij dit heeft geeft het commando "iwconfig" bij mij ook geen output.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #4 Gepost op: 2006/07/31, 00:04:56 »
Citaat van: Gandyman
Ik heb hier een pc met een nukke.
Wanneer ik hem opstart heeft hij afentoe ?? geen verbinding en de netwerkkaart doet nix.
Wanneer ik bij eth0 op Deactiveren klik en dan Activeren doet hij het wel.
 
Probeer dat ook eens >??

BTW als hij dit heeft geeft het commando "iwconfig" bij mij ook geen output.

SCCS

:D
ik zie mijn Wlan0 gewoonweg niet staan... jouw tip heeft jammer genoeg niet geholpen. Toch bedankt voor de moeite !

Offline Gandyman

  • Lid
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #5 Gepost op: 2006/07/31, 02:31:02 »
hmmmmz mooi ruk dan ??

ff wachten op Profox, hij is geloof ik specialist hierin.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #6 Gepost op: 2006/07/31, 02:53:04 »
specialist z
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Kelderkeuken

  • Lid
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #7 Gepost op: 2006/07/31, 03:48:07 »
Citaat van: profoX
Vandaag 02:53:04
Leuk om te zien dat ik niet de enige nachtbraker ben :) Toevallig ook een deadline morgen? Hehe.

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #8 Gepost op: 2006/07/31, 12:14:59 »
Citaat van: profoX
specialist z

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #9 Gepost op: 2006/07/31, 15:05:46 »
Citaat van: Kelderkeuken
Citaat van: profoX
Vandaag 02:53:04
Leuk om te zien dat ik niet de enige nachtbraker ben :) Toevallig ook een deadline morgen? Hehe.
Nee, was veel te warm om vroeg te gaan slapen met die warmte :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #10 Gepost op: 2006/07/31, 15:07:10 »
Citaat van: Alain1
Ik weet wel dat het in de lspci herkend wordt als een Texas Instruments ACX111. Ben even gaan kijken bij de How To van ACX111 maar eerlijk gezegd gaat dit mijn newbiepetje een beetje te boven. Ik snap het niet helemaal en heb schrik om het te verknoeien. :O
Er is in ieder geval een probleem met het laden van de driver... verkeerde firmware/windows driver gebruikt ofzo? anyway, ik heb wel een andere oplossing, want ik heb nog een oude laptop met een acx111 pcmcia kaartje :) als je ff de zoekfunctie gebruikt van het forum en zoekt op "acx111" en "profoX" vind je vast wel instructies

edit:
1. gebruik geen ndiswrapper meer: sudo rmmod ndiswrapper
2. laad de module "acx": sudo modprobe acx
3. Post #9 dit topic: http://forum.ubuntu-nl.org/topic/2218
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #11 Gepost op: 2006/07/31, 23:31:36 »
Citaat van: profoX
Citaat van: Alain1
Ik weet wel dat het in de lspci herkend wordt als een Texas Instruments ACX111. Ben even gaan kijken bij de How To van ACX111 maar eerlijk gezegd gaat dit mijn newbiepetje een beetje te boven. Ik snap het niet helemaal en heb schrik om het te verknoeien. :O
Er is in ieder geval een probleem met het laden van de driver... verkeerde firmware/windows driver gebruikt ofzo? anyway, ik heb wel een andere oplossing, want ik heb nog een oude laptop met een acx111 pcmcia kaartje :) als je ff de zoekfunctie gebruikt van het forum en zoekt op "acx111" en "profoX" vind je vast wel instructies

edit:
1. gebruik geen ndiswrapper meer: sudo rmmod ndiswrapper
2. laad de module "acx": sudo modprobe acx
3. Post #9 dit topic: http://forum.ubuntu-nl.org/topic/2218
De eerste 2 commando's uitgevoerd en dan krijg ik het volgende :
alain@alain-desktop:~$ sudo rmmod ndiswrapper
Password:
ERROR: Module ndiswrapper does not exist in /proc/modules
alain@alain-desktop:~$ sudo modprobe acx
FATAL: Error inserting acx (/lib/modules/2.6.15-26-386/kernel/drivers/net/wireless/acx/acx.ko): Invalid module format
alain@alain-desktop:~$

Ik ga nu naar de URL waar naar verwezen wordt... ben daar eerder ook al eens gaan neuzen...

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #12 Gepost op: 2006/07/31, 23:35:35 »
Oei, wat is er gebeurd met uw acx driver :P
anyway, we hebben hier al eens een post over gehad ;)
http://forum.ubuntu-nl.org/topic/2274 - ga naar #6
volg die instructies eens
(gewoon kopie
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #13 Gepost op: 2006/07/31, 23:40:11 »
Citaat van: profoX
Oei, wat is er gebeurd met uw acx driver :P
anyway, we hebben hier al eens een post over gehad ;)
http://forum.ubuntu-nl.org/topic/2274 - ga naar #6
volg die instructies eens
(gewoon kopie

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #14 Gepost op: 2006/08/01, 02:02:11 »
da's niet erg..je krijgt toch gedit te zien he? ga gewoon verder ... als je gedit niet te zien krijgt, doe dan:

xhost +

en dan nog een keer:
gksudo gedit /etc/modprobe.d/options

en ga dan verder

als het nu nog niet lukt, start dan een nieuwe terminal en probeer het nog eens opnieuw die gksudo gedit...
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #15 Gepost op: 2006/08/01, 12:48:16 »
Citaat van: profoX
da's niet erg..je krijgt toch gedit te zien he? ga gewoon verder ... als je gedit niet te zien krijgt, doe dan:

xhost +

en dan nog een keer:
gksudo gedit /etc/modprobe.d/options

en ga dan verder

als het nu nog niet lukt, start dan een nieuwe terminal en probeer het nog eens opnieuw die gksudo gedit...
Ik heb de lijnen kunnen toevoegen maar als ik de module opnieuw tracht te laden, krijg ik de melding dat ze niet bestaat :

alain@alain-desktop:~$ sudo rmmod acx && sudo modprobe acx
ERROR: Module acx does not exist in /proc/modules

Heb ik iets over het hoofd gezien?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #16 Gepost op: 2006/08/01, 13:54:44 »
Je hebt wellicht een andere kernel dan 386 deze keer, probeer dit eens:

sudo cp /lib/modules/2.6.15-26-386/kernel/drivers/net/wireless/acx/acx.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless/acx/acx.ko

en dan nog eens opnieuw de module proberen te laden
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #17 Gepost op: 2006/08/01, 18:30:50 »
hij zegt dat het over hetzelfde bestand gaat :
alain@alain-desktop:~$ sudo cp /lib/modules/2.6.15-26-386/kernel/drivers/net/wir eless/acx/acx.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless/acx/acx.ko cp: `/lib/modules/2.6.15-26-386/kernel/drivers/net/wireless/acx/acx.ko' en `/lib /modules/2.6.15-26-386/kernel/drivers/net/wireless/acx/acx.ko' zijn hetzelfde be stand
alain@alain-desktop:~$
:(
de module herladen geeft nog steeds dezelfde foutmelding

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #18 Gepost op: 2006/08/01, 18:32:44 »
Oh, nee, da's normaal die error.. Ik ben te snel geweest.
hij zegt bij rmmod dat de module niet geladen is, da's geen probleem :)
werkt na de "modprobe acx" alles wel?

nee: post de output van "dmesg|tail -n 20" en van "iwconfig" :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #19 Gepost op: 2006/08/01, 18:45:19 »
dit is de output van beide commando's :
alain@alain-desktop:~$ dmesg|tail -n 20
[17179598.548000] sd 0:0:0:0: Attached scsi removable disk sda
[17179598.564000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[17179602.684000] ACPI: Power Button (FF) [PWRF]
[17179602.684000] ACPI: Power Button (CM) [PWRB]
[17179602.872000] ibm_acpi: ec object not found
[17179602.924000] pcc_acpi: loading...
[17179607.712000] eth0: no IPv6 routers present
[17179610.236000] ppdev: user-space parallel port driver
[17179610.508000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[17179610.508000] apm: overridden by ACPI.
[17179614.784000] Bluetooth: Core ver 2.8
[17179614.784000] NET: Registered protocol family 31
[17179614.784000] Bluetooth: HCI device and connection manager initialized
[17179614.784000] Bluetooth: HCI socket layer initialized
[17179614.860000] Bluetooth: L2CAP ver 2.8
[17179614.860000] Bluetooth: L2CAP socket layer initialized
[17179614.916000] Bluetooth: RFCOMM socket layer initialized
[17179614.916000] Bluetooth: RFCOMM TTY layer initialized
[17179614.916000] Bluetooth: RFCOMM ver 1.7
[17179633.972000] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
alain@alain-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.
Ik zie hier niet onmiddellijk iets in staan van draadloos netwerk... het is ook allemaal een beetje chinees voor mij

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #20 Gepost op: 2006/08/03, 22:46:59 »
weet iemand hoe het hier verder moet?
Ik zou dolgelukkig zijn mocht ik dat draadloos netwerk aan de praat krijgen?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #21 Gepost op: 2006/08/03, 23:21:54 »
ff wachten op Profox of Dennis :)

heb geduld alles kom goe

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Azalin

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #22 Gepost op: 2006/08/04, 14:53:33 »
Tja, de manier waarop profox het beschrijft in http://forum.ubuntu-nl.org/topic/2274 zou toch de oplossing moeten zijn... de standaard firmware die er gebruikt wordt werkt inderdaad niet voor die ACX111 ... als je de firmware zou vervangen, en modprobe acx doet dan zou hij het gewoon moeten doen. Eventueel kan je hier de firmware ook downloaden: http://acx100.sourceforge.net/wiki/Firmware

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #23 Gepost op: 2006/08/04, 15:33:23 »
Citaat van: Alain1
weet iemand hoe het hier verder moet?
Ik zou dolgelukkig zijn mocht ik dat draadloos netwerk aan de praat krijgen?
heb jij eerst "sudo modprobe acx" gedaan en daarna pas "dmesg|tail -n 20" ?
ik vind het wel raar dat hij die acx module niet zien, hij staat toch op de juiste plaats volgens mij...

anyway, ik heb zo'n laptop met zo'n chipset, en die werkt prima met de acx driver na de fix die ik je gaf.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Skoebidoe

  • Gast
ndiswrapper geïnstalleerd en driver geïnstalleerd maar geen Wlan0
« Reactie #24 Gepost op: 2006/08/04, 18:28:09 »
Beste,

Heb het idd onder sudo gedaan... Ik zie echter geen wlan0 staan.
Ben nog eens naar de website van ACX gesurfd (http://acx100.sourceforge.net/wiki/Firmware) en heb de firmware gedownload. Dat is een bin bestand. Verder op de site staat er waar het zou moeten geplaatst worden.
Het zou in de map firmware moeten geplaatst worden. Ben naar die map gegaan en zie het volgende staan :
alain@alain-desktop:~$ cd /lib/firmware
alain@alain-desktop:/lib/firmware$ ls
2.6.15-23-386  2.6.15-26-386
alain@alain-desktop:/lib/firmware$

Als ik het goed voorheb, staat die firmware er gewoon niet in?
Moet ik dat bin-bestand eerst uitpakken (en hoe moet ik dat doen?) en daarna modprobe nogmaals proberen?

Als ik echter ndiswrapper -l doe, krijg ik te zien dat de driver aanwezig is en dat de  hardware aanwezig is. Ik begin me af te vragen of de firmware gewoon niet in de verkeerde map geplaatst is?
Al