Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ubuntu start niet meer op  (gelezen 1580 keer)

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Gepost op: 2008/03/27, 18:55:17 »
Hay,
Zoals vermeld in het off topic draadje ben ik aan het experimenteren met andere linux distros.
Even resumeren :
oude pc (intel 733 mhz - 512 mb ram) met 20 gb hdd. win 2K partitite verkleind naar 8Gb - gutsy en mandriva op de overblijvende ruimte ( 2 part + swap) Dat werkte goed.
Had nog een schijf liggen van 40 GB - oude hdd van 20 gb losgekoppeld en die 40 GB hdd op prim. master.
Dan terug gutsy - mandriva en pardus . Werkte zeer vlot. Ik dacht , ik sluit die 20 GB op de slave, heb ik not plaats om event. andere distros te proberen, maar wat bleek : ubuntu en mandriva starten niet meer op. Pardus werkte wel zodat ik de bestanden fstab en menu.lst kon veranderen (uuid verwijderen) Op die 20 Gb stond ook nog een ubuntu en mandriva op, Dus heb ik via gparted ook die partities verwijderd. Maar niks hoor. Ubuntu blijft hangen bij het opstarten. Die 2de hdd (op slave) terug afgekoppeld en alles werkt terug naar behoren.
Weet iemand wat er hier scheelt
(sorry mischien klint dit verhaal wat verwarrend maar vragen staat vrij hoor ) ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #1 Gepost op: 2008/03/28, 13:56:35 »
oei, niemand een idee.
ondertussen heb ik die 2DE hdd op prim.slave volledig terug geformateerd naar ntfs en Win2K opgezet. De entry in menu.lst heb ik behouden en Win start zonder probleem op maar ubuntu en Mandriva niet
hda1 : ubuntu
hda3 : Pardus
hda5 : swap
hda6 : mandriva

hdb1 : Win2K

Als ik de 2de hdd loskoppel, geen probleem.
Ik krijg zelfs de livecd niet gestart, ook niet in safe mode.
Heb wel volgende gezien : "sbin/modprobe : abnormal exit" en Mandriva gaat goed tot detecting new hardware, dan gaat ie in de fout
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #2 Gepost op: 2008/03/28, 15:03:52 »
Ben ik weer :
Hier even de uitdraai van /etcfstab en /boot/grub/menu.lst
De UUID's heb ik al verwijderd (volgens pjotr's instructies) maar geen effect.
Ik vind ook de fstab niet kloppen : hda6 wordt bv. niet vermeld :
Disk /dev/hda: 40.0 GB, 40027029504 bytes
255 heads, 63 sectors/track, 4866 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf03dc95b

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1216     9767488+  83  Linux
/dev/hda2            1217        2603    11141077+   5  Extended
/dev/hda3            2604        3878    10241437+  83  Linux
/dev/hda5            1217        1338      979933+  82  Linux swap / Solaris
/dev/hda6            1339        2603    10161081   83  Linux
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
 /dev/hda1
 /               ext3    defaults,errors=remount-ro 0       1
 /dev/hda5
 none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
#timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=a11e2c68-b41e-454c-9f77-7b21d2686398 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/hda1 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

title Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 7.10, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

title mandriva eerste kernel
kernel (hd0,5)/boot/vmlinuz BOOT_IMAGE=linux root=/dev/hda6  resume=/dev/hda5
initrd (hd0,5)/boot/initrd.img

title mandriva (safe mode)
kernel (hd0,5)/boot/vmlinuz BOOT_IMAGE=failsafe root=/dev/hda6 failsafe
initrd (hd0,5)/boot/initrd.img

title mandriva desktop586 2.6.22.18-1
kernel (hd0,5)/boot/vmlinuz-2.6.22.18-desktop586-1mdv BOOT_IMAGE=desktop586_2.6.22.18-1 root=/dev/hda6 resume=/dev/hda5
initrd (hd0,5)/boot/initrd-2.6.22.18-desktop586-1mdv.img

title Pardus 2007.3 Lynx lynx
root (hd0,2)
kernel (hd0,2)/boot/kernel-2.6.18.8-86 root=/dev/hda3 video=vesafb:off mudur=language:nl quiet resume=/dev/hda5
initrd (hd0,2)/boot/initramfs-2.6.18.8-86

title              Windows 2000
root               (hd1,0)
savedefault
makeactive
map                (hd0) (hd1)
map                (hd1) (hd0)
chainloader        +1
Niemand geen idee ?
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ubuntu start niet meer op
« Reactie #3 Gepost op: 2008/03/28, 16:54:08 »
Dat heb ik ook gehad, door het bijplaatsen van een IDE harddisk. Ik heb met Gparted Live gekeken hoe de schijven en partities in elkaar staken. Het bleek dat mijn SATA harddisk met Gutsy erop veranderd was van schijf 0 naar 1 dus de partitie met Gutsy was (hd0,5) en is nu (hd1,5).Ook moest ik de boot volgorde aanpassen in de BIOS. Laatst zou ik voor iemand wat gegevens van een IDE schijf halen, aangesloten en jahoor een Grub 22Error, ik kon niet zo snel achterhalen hoe de schijf volgorde stond, ik ga het een dezer dagen weer eens proberen,zal ongetwijfeld te maken hebben hoe linux/Ubuntu met de schijf volgorde omgaat. Ben er nog niet helemaal achter, maar het zal wel lukken. :) Met het programma pysdm, staat in Synaptic een starter moet je zelf aanmaken of in de terminal ingeven, kan je je schijven grafisch aankoppellen.
Als het goed is komen ze dan te voorschijn in je fstab.
Ik hoop dat je wat aan de info hebt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #4 Gepost op: 2008/03/29, 07:31:23 »
Ik heb zoals je zei hdb terug aangekoppeld en gparted vanaf de cd gestart. Mijn linux partities op hda bleken nog dezelfde te zijn. Wat ik wel vond in hdb (waar een nieuwe installatie van Win2k opstaat) was nog een bootflag die ik heb verwijderd. Ook eigenaardig was dat daar nog een ongebrukt gedeelte van 6.5 mb opstaat. Raar, want bij de install van win heb ik de gehele schijf geformateerd. Ook bleek die schijf een msdos label tehebben. Volgens de overigs schitterende handleiding van pjotr kan dit problemen veroorzaken. Maar ik wil hier geen dos label maken maar verwijderen. Blijjkbaar was dit niet gebeurd met het formateren.
Als ik de livvecd van ubuntu wil opstarten krijg ik een hele rits regels maar dan blijjft ie ook hangen. Ergens viel me wel de volgende vermelding op : "error /dev/hdb ; i/o output" en "error: /dev/hdb : unrecognised label" of ook "/sbin/modprobe/ abnormal exit"
Er loopt dus blijkbaar iets goed fout met hdb, want als ik die ontkoppel en alleen werk met hda (hda1 : ubuntu; hda3 : pardus; hda4 : puppy; hda5 :swap; hda6 : mandriva) werkt alles perfekt. Volgens mij moet ik van die msdos label af maar hoe ??
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #5 Gepost op: 2008/03/29, 13:06:56 »
oei ik begin te vrezen dat hier niemand een flauw idee heeft.
Nu ik ben veruit aan het einde van m'n latijn hier. Heb ondertussen ook kabels vervangen en knoppix 5.51 opgestart. Deze vermeld raar genoeg geen enkel probleem. En Win2K die op hdb staat start ook normaal op. Het is enkel ubuntu en mandriva die 't vertikken :lol:
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ubuntu start niet meer op
« Reactie #6 Gepost op: 2008/03/29, 22:24:34 »
Ik denk dat je je boot flag alleen kan veranderen als je de harde schijf formateert of heb je dat ook al geprobeerd?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #7 Gepost op: 2008/03/30, 13:14:59 »
Nee, niks werkt. Zolang die 2de hd is aangekoppeld werkt alleen pardus. Ook zag ik dikwijls (bv. bij opstarten van de livecd van gparted) een I/O error. Blijkbaar is er een hardware probleem met die 20 gb schijf. Heb ze afgekoppeld en ben opnieuw aan het installeren met die 40 gb schijf.
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ubuntu start niet meer op
« Reactie #8 Gepost op: 2008/04/01, 14:14:51 »
Kan je vanuit Pardus de disk niet benaderen?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #9 Gepost op: 2008/04/01, 17:13:37 »
idd, dat was juist het rare, pardus startte normaal op, ubuntu en mandriva niet. Ubuntu startte zelfs de kernel niet op terwijl Mandriva in de fout ging bij "detecting new hardware" Ik heb dan die 20 gb hdd op de master v/d ide kabel gezet, jumpers alletwee op CS maar niks hielp. Ten einde raad de 40 gb op master en die 20 gb in de doos !
Alles opnieuw geïnstalleerd en nu heb ik 't volgende :
hda1 : Win2K
hda2 : extended met
hda5 : ubuntu gutsy
hda6 : swap
hda7 ; pardus
hda8 : nog vrij (6.6 gb
Alles geupdate en werkend.
Klein detail : heb hier een HP scanjet G3010 (werkt op Win) In ubuntu : noppes; in pardus werkt ie gewoon :)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ubuntu start niet meer op
« Reactie #10 Gepost op: 2008/04/02, 16:34:54 »
Ik heb zelf ook een HP printer deze werd direct herkend door Ubuntu.
Volgens mij zijn er op het forum best wel mensen te vinden die voor jouw probleem een antwoord hebben.
In ieder geval; succes met je verdere stappen.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
ubuntu start niet meer op
« Reactie #11 Gepost op: 2008/04/02, 19:12:36 »
Die hp is een scanner. Misschien met 8.04. Die test pc draait nu zonder fouten. Het mysterie met die 2de hdd zal ik wel eens een andere keer aanpakken. Als het natuurlijk een hardware fout is , valt er weinig aan te doen ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
ubuntu start niet meer op
« Reactie #12 Gepost op: 2008/04/02, 22:39:28 »
Volgens mij moet ik een brilletje kopen, dit is al de derde keer dat ik de tekst niet goed lees. Wat ik vreemd vind is dat Pardus wel je scanner herkent en Ubuntu niet.
Inderdaad even wachten wat 8.04 ons brengt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.