Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [sound onboard] problemen met geluid opnemen(recording)  (gelezen 7245 keer)

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Gepost op: 2008/03/26, 15:23:48 »
Ik heb sindskort dus een nieuwe pc met sound onboard. Het geluid werkt wel, alleen het opnemen van geluid wil niet werken. Ik heb allerlij dingen geprobeerd om maar iets op te kunnen opnemen, maar het wil maar niet werken. Bijna alle schuifjes in de alsamixer staan gewoon omhoog, maar die van Head, IEC958 en Input Source mag ik niet naar boven schuiven. Ik heb zowel Capture als Digital vanuit gnome-sound-recorder geprobeerd, ik heb Audacity geprobeerd met alle opties in Audio in/uit, maar hij wil maar niks opnemen.

In windows had ik eerst ook al problemen met het geluid. Ik kon toen al helemaal geen geluid krijgen met de bijgeleverde drivers, maar heb dit weten op te lossen door de nieuwste drivers van het internet te installeren. Ik moest ook in de bios m'n sound onboard op AC97 i.p.v. HD-Audio zetten om m'n koptelefoon aan de voorkant van de pc te kunnen gebruiken. Het opnemen van geluid werkt in windows wel.



Ik heb een M2N-VM DVI moederboord.
Iemand een idee waar het aan kan liggen...?

Ik heb zelf het idee dat ik nog tegen meer dingen op ga lopen, aangezien het geluid in Second Life ook gigantisch haperd. Misschien dat ik dus een externe geluidskaart wil aanschaffen, maar heb hiervoor wel advies nodig. Dus welke geluidskaart is geschikt voor Linux? Creative?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #1 Gepost op: 2008/03/26, 15:44:50 »
Heb je al gekeken bij de tab switches? Dat tabje heb ik ook en daar kan ik de microfoon inschakelen en eventuel een boost van 20db. En moet je bij het plaatje rechts boven niet de speakertjes uitzetten, als je een meer sporen systeem hebt bijv. 7.1 dan gebruikt een geluids kaart meerdere aansluitingen van je geluidskaart. Aan je metertjes te zien zou ik die iets lager zetten op 88%, dit wordt op het forum geadviseerd. Als je een nieuwe kaart wilt kopen zou ik even dit stukje lezen http://www.ubuntu-nl.org/documentatie/hardware/geluidskaart/ en deze http://www.alsa-project.org/main/index.php/  Aan de linker kant de link SoundCards en nog veel meer info.
Ik hoop dat je zo voldoende info hebt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #2 Gepost op: 2008/03/26, 16:06:21 »
Aan Math.
Systeem>voorkeuren>geluid. Op de regel geluidsopname met de pijltjes (naar boven)
aanklikken: Alsa - Advanced Linux Sound Architecture. Bij Apparaat: HDA Intel (Alsa mixer) Opname bron op de line In (blauwe bus, minijack) of de microfoon (rode bus) en dan moet het toch lukken, als je tenminste het bijbehorende schuifje onder opname actief van de Alsamixer opschuift tot ca. 30 %.
Als het niet werkt, stel vragen.
Vr.groet, peter

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #3 Gepost op: 2008/03/26, 22:16:46 »
Allereerst bedankt voor de reacties. Ik heb maar eens ubuntu-desktop geïnstalleerd om de stappen van Petervdw te volgen. Alles stond al zo op die manier ingesteld, maar zodra ik op TEST achter soundcapture klik krijg ik dit te zien:

Failed to construct test pipeline for 'gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat'

Ik heb nu dus in ieder geval een melding. Weet alleen niet wat het betekend. Iemand een idee?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #4 Gepost op: 2008/03/26, 22:39:37 »
Aan Math.
Niet het flauwste idee. Ik kan alleen via de gui met Ubuntu omgaan. Als ik in dat paneel geluidsvoorkeuren op testen op die regel druk, dan krijg ik dezelfde melding. Voor de hand ligt natuurlijk dat een bron waar geen signaal vandaan komt, niet getest kan worden, maar het is een wilde gok. Bij de andere regels lukt een sonore fluittoon. Leuk voor de buren als per ongeluk de regelaars voor 2 x 150 Watt een beetje ver open staan. Laatst nog een geluidsvraag gezien, waar een andere mixer gebruikt moest worden. I.p.v. de gewone Intel HDA Alsa mixer naar de Gnome Alsa mixer. Gewoon via Installeren/ verwijderen. Ze staan direct onder elkaar.
Misschien te proberen. Misschien speelt jouw muziek wel via de inbelmodem-geluidskaart. Niet om aan te horen. En dan kun je ook niet opnemen.
Vr.groet, peter

Probeer eerst die mixer te installeren, zie je twee tabs, dan is de eerste USB. Dan kunnen we verder. De gui voor deze mixer staat onder Toep.>Audio en video.

Sorry, ik zie nu dat jij ook die melding via de gui krijgt

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #5 Gepost op: 2008/03/26, 23:15:57 »
Al eens gezocht op die foutmelding? Ik heb er ook last van en meerdere gebruikers hier op het forum ook.
Google zal ook wel een hoop meldingen vinden denk ik ;)

Ik krijg nu nog steeds die foutmelding, maar kan nu in ieder geval wel mijn microfoon gebruiken voor skype/ekiga.
Als ik morgen tijd heb zal ik eens beschrijven hoe ik het heb ingesteld.
Een echte oplossing heb ik ook nog niet gevonden.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #6 Gepost op: 2008/03/26, 23:26:43 »
Math.,had je al geprobeerd wat ik eerder heb geschreven?
Die fout is als bug gemeld zie : https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/199953


Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #7 Gepost op: 2008/03/29, 17:08:48 »
@Gijsbert

Wat je laatst omschreven hebt kan ik helaas niet vinden:

Lijk zeer beperkt te zijn met deze onboard soundcard.

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #8 Gepost op: 2008/03/29, 17:17:49 »
Citaat van: Johanvd
Al eens gezocht op die foutmelding? Ik heb er ook last van en meerdere gebruikers hier op het forum ook.
Google zal ook wel een hoop meldingen vinden denk ik ;)

Ik krijg nu nog steeds die foutmelding, maar kan nu in ieder geval wel mijn microfoon gebruiken voor skype/ekiga.
Als ik morgen tijd heb zal ik eens beschrijven hoe ik het heb ingesteld.
Een echte oplossing heb ik ook nog niet gevonden.
Ik heb zojuist uitgeprobeerd wat er op deze blog werd geschreven, maar ook dat helpt niet... :(

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #9 Gepost op: 2008/03/29, 17:56:37 »
Aan Math.
Er zijn een paar berichten door elkaar gaan lopen, ik wacht maar even af.
Vr.groet, peter

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #10 Gepost op: 2008/03/31, 00:02:02 »
Aan Math.
Heb je die andere mixer nu geïnstalleerd, de Gnome alsa mixer? Waarschijnlijk zie je daar 2 tabs, USB en nog één.
Probleem is nu dat de tweede kaart de verkeerde driver gebruikt.
Gaan we verhelpen:
In terminal:
gksudo gedit /etc/modprobe.d/alsa-base
Onderaan toevoegen:
options snd-hda-intel probe_mask=8 model=3stack index=0

SAVE de file en REBOOT de computer.

Deze wijsheden niet van mezelf, maar van een linux/ubuntu expert die er hetzelfde probleem mee oploste. Met dank bij deze.

Vr.groet, peter

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #11 Gepost op: 2008/03/31, 12:53:53 »
Citaat van: Petervdw
Aan Math.
Heb je die andere mixer nu geïnstalleerd, de Gnome alsa mixer? Waarschijnlijk zie je daar 2 tabs, USB en nog één.
Probleem is nu dat de tweede kaart de verkeerde driver gebruikt.
Gaan we verhelpen:
In terminal:
gksudo gedit /etc/modprobe.d/alsa-base
Onderaan toevoegen:
options snd-hda-intel probe_mask=8 model=3stack index=0

SAVE de file en REBOOT de computer.

Deze wijsheden niet van mezelf, maar van een linux/ubuntu expert die er hetzelfde probleem mee oploste. Met dank bij deze.

Vr.groet, peter
Bedankt voor de tip, zodra ik thuis kom ga ik dit meteen is proberen. Als ik het dan nog niet in oorde krijg schaf ik of een nieuw moederboord, of een extra geluidskaart aan. Want ook in windows krijg ik de kriebels van deze sound onboard...

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #12 Gepost op: 2008/03/31, 13:00:20 »
Aan Math.
Ja, vervelend. Het beste probeer je dan toch een los geluidskaartje, denk ik.
Trouwens, als je bovenstaande hebt geprobeerd, en het mocht niet werken, het hangt tenslotte gewoon van de chips op je onboard geluidskaart af, dan heb ik nog één optie. Tot vanavond.
Vr.groet, peter

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #13 Gepost op: 2008/04/02, 10:04:09 »
Ik heb er gisterenavond nog even mee lopen stoeien, maar krijg het echt niet voor elkaar... tis echt een ramp dat moederboord... Kga denk toch is kijken voor een extra geluidskaart. Werkt creative goed in Linux?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #14 Gepost op: 2008/04/02, 10:33:07 »
Begreep dat een Audigy en Audigy2 prima onder Linux hoord te werken. Een CREATIVE Soundblaster Audigy Se Bulk zou dus prima moeten werken?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #15 Gepost op: 2008/04/02, 12:45:10 »
Aan Math.
Gister nog een helder betoog van Razenko gelezen (Dank). Lees dat eerst nog even, voor je een losse kaart gaat kopen. Probeer omruil af te spreken met je leverancier voor als ie niet werkt.

http://forum.ubuntu-nl.org/topic/23249
Vr.groet, peter

Bij oudere versies van ubuntu werkten de audigi's allemaal goed. Zie:

https://wiki.ubuntu.com/HardwareSupportComponentsSoundCards

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #16 Gepost op: 2008/04/02, 15:28:39 »
Math, vervelend dat je je onboard geluidskaart niet voor elkaar krijgt. Zoals ik eerder had beschreven is het als een bug gemeld, misschien dat het in Hardy goed komt.
Ik heb zelf mijn onboard geluids kaart uitgezet, aangezien de speaker uitgang niet goed is, iets met de contra plug op het moederbord, en alleen mono geluid heb.
Ik heb mijn oude Creative Live Value uit der kast gehaald en deze functioneert probleemloos. Volgens mij doen de Creative geluidskaarten het wel goed. Ik zou alleen niet de meest nieuwe aanschaffen i.v.m. de drivers.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #17 Gepost op: 2008/04/03, 10:20:22 »
Citaat van: Gijsbert
Math, vervelend dat je je onboard geluidskaart niet voor elkaar krijgt. Zoals ik eerder had beschreven is het als een bug gemeld, misschien dat het in Hardy goed komt.
Nou, er is inderdaad duidelijk wat mis met het geluid in Ubuntu...
Kheb gisteren toch maar een Audigy2 aangeschaft, omdat ik erg zat geworden was. Niet alleen in Ubuntu, maar ook in windows werd ik er kriegel van. Anyway, de nieuwe kaart werkte meteen en goed, had ook meer opties en schuifjes in m'n mixer gekregen, dus leek allemaal prima te werken. Maar inderdaad... ik kon weer geen geluid opnemen. Ik heb allerlij mogelijke opties geprobeerd en kreeg toen een foutmelding en had vervolgens helemaal geen geluid meer. Ook niet na een reboot...

Kheb toen maar eens vanaf de laatste alpha versie van Xubuntu geboot en had toen wel weer geluid. Er is dus ergens iets helemaal fout gegaan.

Maar ook in Ubuntu 8.04 lijkt deze bug nog niet verholpen te zijn, ook daarin kon ik geen geluid opnemen.

Niet al te min, ik ben toch blij met deze nieuwe kaart. Ik heb bijv. geen happeringen en stotteringen meer in het geluid bij bepaalde games, ik krijg weer geluid vanuit m'n tv-kaart en het geluid is gewoon erg zuiver. :)

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #18 Gepost op: 2008/04/03, 16:57:01 »
Misschien al gezien http://ubuntuforums.org/showthread.php?t=205449 anders kan je er misschien wat mee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

marghie

  • Gast
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #19 Gepost op: 2008/04/07, 01:32:26 »
Petervdw schreef:
Probleem is nu dat de tweede kaart de verkeerde driver gebruikt.
Gaan we verhelpen:
In terminal:
gksudo gedit /etc/modprobe.d/alsa-base
Onderaan toevoegen:
options snd-hda-intel probe_mask=8 model=3stack index=0

SAVE de file en REBOOT de computer.
------------------------------------------------------------------------

Ook ik heb al geruime tijd en 2 versies Ubuntu lang geen geluid bij Skype.
Daarom bovenstaande  advies opgevolgd met als resultaat dat de kleuren van mijn monitor veranderden na de reboot.
Skype connectie veranderde niet.

Veranderingen in de Gnome-Alsa-mixer gaf de volgende foutmelding:
An error occurred while loading or saving configuration information for GNOME ALSA Mixer. Some of your configuration settings may not work properly.
Bad key or directory name: "/apps/gnome-alsamixer/display_mixers/": Key/directory may not end with a slash (/)
Bad key or directory name: "/apps/gnome-alsamixer/display_names/": Key/directory may not end with a slash (/)

Wat is de oplossing hiervoor?

De Alsa-base verandering heb ik weer teniet gedaan.

Dank voor jullie inzet!

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #20 Gepost op: 2008/04/07, 23:39:07 »
Aan marghie
Ja, af en toe zijn er hele rare effecten. De regel had het juiste effect op een Tecra A8 laptap. Maar bij een ander werkte het weer niet. Uit de verte is het ook heel lastig om direct de juiste remedie te geven. Razenko (de naam weet ik nog) gaf een heel goede beschrijving van wat er nu eigenlijk gebeurt, en hoe hij het verhielp. Feitelijk dezelfde oplossing in dezelfde richting. Ik zoek het even voor je op.
Om de goede informatie te krijgen kun je in de terminal vast invoeren:
cat /proc/asound/modules     en de uitkomst naar hier slepen.
Hieruit moet de volgorde van de geluidskaarten (als er al 2 te zien zijn) te lezen zijn.
Vr.groet, peter

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #21 Gepost op: 2008/04/07, 23:43:37 »
Aan marghie
Ja, af en toe zijn er hele rare effecten. De regel had het juiste effect op een Tecra A8 laptap. Maar bij een ander werkte het weer niet. Uit de verte is het ook heel lastig om direct de juiste remedie te geven. Razenko (de naam weet ik nog) gaf een heel goede beschrijving van wat er nu eigenlijk gebeurt, en hoe hij het verhielp. Feitelijk dezelfde oplossing in dezelfde richting. Ik zoek het even voor je op.
Om de goede informatie te krijgen kun je in de terminal vast invoeren:
cat /proc/asound/modules     en de uitkomst naar hier slepen. (spatie tussen cat en /)
Hieruit moet de volgorde van de geluidskaarten (als er al 2 te zien zijn) te lezen zijn.
Vr.groet, peter

Het is te lezen op:
http://forum.ubuntu-nl.org/message/219180#p219180
(met dank aan razenko en Pjotr  :)  )

marghie

  • Gast
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #22 Gepost op: 2008/04/17, 01:30:48 »
Aan Petervdw
Dank Peter, ik heb de akties opgeschreven!
Momenteel kan ik U7.1 plotsklaps slechts opstarten met de prompt in een zwart scherm. APT- get is niet bereikbaar, gedit evenmin, laat staan dat ik nu iets kan veranderen.. U 7.04 werkt nog wel, maar daar iets veranderen heeft geen zin.
Dit probleem heb ik al eens eerder gehad dus ik zoek het advies van toen even op.

marghie

  • Gast
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #23 Gepost op: 2008/04/21, 23:02:20 »
Peter,
Hier volgt het antwoord op:
 cat /proc/asound/modules  
 0 snd_via82xx
 1 snd_mpu401

-----------------------
gksu gedit /etc/modprobe.d/alsa-base
geeft het volgende,   pfffoeh, output:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
-----------------------------
Welke volgorde moet ik waar veranderen? Er zijn wel erg veel "snd" te zien...

Marghie

Offline Petervdw

  • Lid
  • Steunpunt: Nee
[sound onboard] problemen met geluid opnemen(recording)
« Reactie #24 Gepost op: 2008/04/21, 23:24:32 »
Aan marghie
In het Bios iets uitzetten heeft hier niet zoveel zin.
Beter om de file alsa-base aan te passen.
In de terminal:
gksudo gedit  /etc/modprobe.d/alsa-base              [enter]
Dan kun je de file editten.
Onderaan er gewoon bijtypen:
options snd_mpu401 index=0         [enter]
options snd_via82xx index=1         [enter]

SAVE de file en start de computer opnieuw op.
De 2 geluidskaarten worden dan door Ubuntu in de juiste volgorde gelezen.

Dit is geen wijsheid van mij, maar van anderen. Razenko heeft het in de eerder vermelde link beschreven, waarvoor dank.
Vr.groet, peter

Misschien moet je geen "underscore" streepje gebruiken, maar een gewoon verbindingsstreepje. Even proberen. Succes!