Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met externe monitor  (gelezen 9513 keer)

r_heliman

  • Gast
problemen met externe monitor
« Gepost op: 2008/03/25, 16:14:49 »
Hoi,

Ik ben bezig met het aansluiten van een externe monitor zodat ik op twee schermen tegenlijklijk kan werken. Maar nu doet UBUNTU het helemaal niet meer.

Mijn laptop : IBM T42 1400x1050 met een radion 9600 (hij heeft momenteel maar een 800X600 weer)

En de andere TFT monitor is een 1024 bij 1280 En tja het werkt allemaal gewoon niet.

- Wat moet ik doen om mijn laptop monitor weer normaal te krijgen? Via "screans and Graphiks" doet het niet.
- hoe kan ik een tweede monitor gewoon aalsuiten via mijn VGA output van de laptop?

Bedankt
Roel

Offline tabasco

  • Lid
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #1 Gepost op: 2008/03/25, 16:34:19 »
Ik heb laatst de tool nvidia-settings gebruikt om mijn beamer aan te sluiten, dit werkte perfect.
De tool nvidia-settings zit volgens mij gewoon in de repo's.

Je kunt hier voor de verschillende monitoren resoluties instellen e.d.

Op een laptop zit er ook vaak een Fn toets waarmee je de video uitvoer kunt bepalen:
- laptop scherm
- extern scherm (vga connector)
- beide weergeven

r_heliman

  • Gast
problemen met externe monitor
« Reactie #2 Gepost op: 2008/03/25, 16:43:58 »
Hoi,

ik wil deze monitor dan extern eraan hangen
http://support.packardbell.com/dk/item/index.php?i=spec_virtuoso190&pi=platform_monitor_virtuoso

Om als tweede monitor ernaast te bruiken..!!

Alvast bedankt voor alle tips
Roel

Offline tabasco

  • Lid
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #3 Gepost op: 2008/03/25, 16:58:37 »
mooi plaatje hoor :) ik lees daar dat hij alleen in resolutie van 1280 x 1024 (75 of 60hz) werkt. Heb je nvidia-settings al gebruikt?

EDIT: Er zijn veel nvidia gerelateerde topics op dit forum, probeer eens te zoeken naar een vergelijkende probleem omschrijving. Sommige instructies moeten daar nauwkeurig gevolgd worden om een niet werkende X te voorkomen. Als je niets vind geef hier dan iets precieser aan wat nu de status is en wat je al wel en niet hebt gedaan om het werkend te krijgen.

r_heliman

  • Gast
problemen met externe monitor
« Reactie #4 Gepost op: 2008/03/25, 17:07:43 »
Hoi,

als ik zoek op nvidea vindt die: Restricted Drivers Manager

En die is al geiïnstalleerd..
Maar het werkt nog niet :(

De FN toets werkt denk ik ook niet ... ik moet FN+F& drukken maar hij doet niks???

Groeten
Roel

Offline tabasco

  • Lid
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #5 Gepost op: 2008/03/25, 17:13:03 »
EDIT:
STOP DE PERSEN!

Ik lees nu pas goed dat je met Radeon werkt en niet Nvidia, mijn excuses voor dit misverstand!
Vergeet al het bovenstaande!

r_heliman

  • Gast
problemen met externe monitor
« Reactie #6 Gepost op: 2008/03/25, 17:31:20 »
juist,,,

Maar dan is mijn probleem nog steeds niet opgelost!!

Hoe / wat moet ik doen?

Groeten
Roel

Offline tabasco

  • Lid
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #7 Gepost op: 2008/03/25, 17:42:44 »
Als je zoekt op dit forum naar 'Radeon 9600' kom je enkele posts tegen betreffende instellingen en drivers voor jouw kaart.
Als je googled op 'Ubuntu Radeon 9600 dual' dan krijg je zelfs exact uitleg voor jouw probleem.

Ik kan je helaas niet verder helpen met Ati, hopelijk zijn er nog wel andere Ati wonders (grapje) op dit forum.
succes

r_heliman

  • Gast
problemen met externe monitor
« Reactie #8 Gepost op: 2008/03/25, 20:33:51 »
ja,,

er staat veel over geschreven, maar ik zie geen oplossing.. Dat zou wel balen zijn :(

HELP ;-)

Groeten
Roel

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #9 Gepost op: 2008/03/25, 22:33:53 »
Voor een 2e scherm aan mijn laptop gebruik ik xrandr. De grafische tool van ubuntu doet iets niet goed. Xrandr is standaard aanwezig. Tik in een terminal:
$ xrandr --auto
$ xrandr --output VGA-0 --mode 1280x1024 --rate 75 --left-of LVDS

Uiteraard is een andere mode ook mogelijk en left-of kan ook right-of zijn.

Deze opdrachten heb ik in een uitvoerbaar tekstbestand geplaatst die ik middels een icoon opstart als ik het externe scherm heb aangesloten.

Het was wel nodig een groter virtueel scherm (de 2 beeldschermen naast elkaar) in de /etc/X11/xorg.conf op te nemen in de section "Screen" kan dit met de regel:
Virtual 2560 1024

Mijn laptop heeft een ati videokaart. Dit werkt in Ubuntu 7.10 en nu ook in 8.04 beta.
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

r_heliman

  • Gast
problemen met externe monitor
« Reactie #10 Gepost op: 2008/03/25, 22:58:09 »
hoi,

Het "werkt" maar momenteel echt helemaal verleerd :(

- Resolutie Externo monitor links is goed.. Maar de muis is niet zichtbaar, maar een blokje..
- op de laptop heb ik een resolutie van 600x480 en tja, dat is gewoon echt te weinig...

Wat gaat er nu mis? Het werkt nu al bijna, maar nog net niet helemaal..... HELP please

Groeten
Roel

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #11 Gepost op: 2008/03/25, 23:19:59 »
De meest zekere manier is om handmatig je xorg.conf file aan te passen. Doe in een terminal eerst
Citaat
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
om een backup te maken.  
... knip ...
Ach, als je nog online bent als dit bericht vertrekt, dan post je hier gewoon de inhoud van xorg.conf even.  Doe in een terminal
Citaat
gedit /etc/X11/xorg.conf
Effe knippen en hier plakken tussen [ code ] en [ /code ] (zonder de spaties) Dan zal ik proberen er iets mee te doen...

Je kan ook altijd deze bijdrage lezen.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #12 Gepost op: 2008/03/25, 23:29:26 »
ok SUPER

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
Boardname "ati"
Busid "PCI:1:0:0"
Driver "fglrx"
Screen 0
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1400x1050"
Horizsync 31.5-65.5
Vertrefresh 56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1400 1050
Modes "1400x1050@60" "1280x1024@60" "1280x960@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
  screen 1 "screen1" leftof "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
Load "dbe"
Load "v4l"
EndSection
Section "Extensions"
Option "Composite" "0"
EndSection
Section "device" #  
Identifier "device1"
Boardname "ati"
Busid "PCI:1:0:0"
Driver "fglrx"
Screen 1
EndSection
Section "screen" #  
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "1280x1024@60" "1280x960@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection
Section "monitor" #  
Identifier "monitor1"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x1024"
Horizsync 31.5-64.0
Vertrefresh 56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Gamma 1.0
EndSection
Section "ServerFlags"
Option "Xinerama" "true"
EndSection
Mijn laptop is een 1400x1050 IBM T42 (beeld geen idee)
en de externe monitor op LINKS: Packerd Bell VT900 (1268 x 1024)

ALVAST 1000x dank
Roel

PS ik heb me net een externe monitor gekocht omdat ik zoveel verslagen voor school moet typen in Latex, dus dan zou het met een externe tweede monitor makkenlijk gaan. Nu alleen dat ding nog aan de praat krijgen.

PSS als die file word aangepast, ist het dan een probleem als ik de monitor NIET heb aangesloten?

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #13 Gepost op: 2008/03/26, 00:02:27 »
Let wel: dit is een poging, ben ook geen specialist..
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"    "/dev/psaux"
    Option        "Protocol"    "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Screen    0
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Vendorname    "Generic LCD Display"
    Modelname    "LCD Panel 1400x1050"
  Option "DPMS"
    Horizsync    31.5-65.5
    Vertrefresh    56.0 - 65.0
#    Gamma    1.0
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Monitor        "Generic Monitor"
    Defaultdepth    24
    SubSection "Display"
        Depth    24
#      Virtual    1400    1050
        Modes        "1400x1050"
    EndSubSection
EndSection



Section "Module"
    Load        "glx"
    Load        "dbe"
    Load        "v4l"
EndSection

Section "Extensions"
    Option        "Composite"    "0"
EndSection

Section "device" #  
    Identifier    "device1"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Screen    1
EndSection

Section "monitor" #  
    Identifier    "monitor1"
    Vendorname    "Packard Bell"
    Modelname    "Virtuoso"
    Horizsync    31.5-64.0
    Vertrefresh    56.0 - 65.0
    Option "DPMS"
#   modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
#   Gamma    1.0
EndSection

Section "screen" #  
    Identifier    "screen1"
    Device        "device1"
    Defaultdepth    24
    Monitor        "monitor1"
    SubSection "Display"
        Depth    24
        Modes        "1280x1024"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen 0 "Default Screen"
  screen 1 "screen1" leftof "Default Screen"
  Option "Xinerama" "True"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
   
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection

Section "ServerFlags"
    Option        "Xinerama"    "true"
EndSection
Hopelijk lukt het...

Eerst in de terminal gksu gedit /etc/X11/xorg.confPaswoordje invullen, enter.  De file die verschijnt leeg maken.  Hier kopiëren en daar plakken, opslaan, sluiten.  Terminal sluiten. en dan CTRL+ALT+Backspace om de xserver opnieuw op te starten.  Als het helemaal mis loopt, terug rebooten en desnoods in recovery-mode gaan, door op ESC te drukken. Dan je oude xorg.conf terugzetten door in de commandlijn te doen: mv /etc/X11/xorg.conf.old /etc/X11/xorg.confDit dus wel allen als je geen grafische omgeving meer had.

Succes !
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #14 Gepost op: 2008/03/26, 01:58:01 »
GEWELDIG,,,,,,

Het werkt,, je bent een held (bijna)

Heb jij een idee, waarom die de muis niet weergeeft in de externe monitor? Daar zie ik een 4-kant blok?? Dan werkt het echt perfect.

BEDANKT
Roel

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #15 Gepost op: 2008/03/26, 04:24:25 »
Zonder dank, 't is graag gedaan :)

Ik heb er destijds een paar weken aan bezig geweest en toen echt heel veel draadjes en howto's doorgelezen.  Ik heb nu dus wel zo ongeveer door hoe het in elkaar steekt.  Overigens was ik toen ook zwaar op het verkeerde pad geraakt met "Screens and graphics" dat vrij nieuw is en toch nog niet altijd doet wat het behoort te doen. (goede raad: gebruik het nooit meer, zeker tot er een serieus vernieuwde versie van komt)  Ook die xrandr werkt nog niet met alle kaarten, zeker ATI liet (laat ?) nog te wensen over.

Voor je muis heb ik zo geen oplossing, heb van dat probleem nog nooit gehoord :)

Edit: het is een niet zo vaak voorkomende bug, al lang geleden gesignaleerd, maar nooit serieus door iemand aangepakt, en dus nog niet opgelost. :
Zie op de Bugzilla van ATIsinds 21 september 2006 en laatst nog geconfirmeerd eind januari dit jaar...
Op Launchpad, het officiële platform voor het melden van bugs, wordt verwezen naar die Bugzilla, maar staat er verder ook niks.  Misschien kun jij daar eens posten dat het bij jou met die en die specificaties ook voorkomt ?
Ondertussen is er wel een workaround, maar die vertraagt wel (een beetje ?) je systeem, en ik weet echt niet of het nu nog werkt.  In je xorg.conf voeg je volgende lijn toe:
Citaat
Option        "SWCursor" "1"
in het deel van Section "device" over "device 1". Zo dus:
Citaat
Section "device" #  
    Identifier    "device1"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Option        "SWCursor" "1"
    Screen    1
EndSection
SWCursor staat hier voor Softwarecursor.  Werkt het dan nog niet, gewoon terug weghalen... In elk geval: melden op launchpad, en misschien ook bij die Bugzilla van ATI.

Doe zo verder !  :lol:
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #16 Gepost op: 2008/03/26, 07:13:20 »
Hoi,

Helaas,,, mijn xorg.conf ziet er nu zo uit (voor de controle)

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"    "/dev/psaux"
    Option        "Protocol"    "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Screen    0
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Vendorname    "Generic LCD Display"
    Modelname    "LCD Panel 1400x1050"
  Option "DPMS"
    Horizsync    31.5-65.5
    Vertrefresh    56.0 - 65.0
#    Gamma    1.0
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Monitor        "Generic Monitor"
    Defaultdepth    24
    SubSection "Display"
        Depth    24
#      Virtual    1400    1050
        Modes        "1400x1050"
    EndSubSection
EndSection



Section "Module"
    Load        "glx"
    Load        "dbe"
    Load        "v4l"
EndSection

Section "Extensions"
    Option        "Composite"    "0"
EndSection

Section "device" #  
    Identifier    "device1"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Option        "SWCursor" "1"
    Screen    1
EndSection

Section "monitor" #  
    Identifier    "monitor1"
    Vendorname    "Packard Bell"
    Modelname    "Virtuoso"
    Horizsync    31.5-64.0
    Vertrefresh    56.0 - 65.0
    Option "DPMS"
#   modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
#   Gamma    1.0
EndSection

Section "screen" #  
    Identifier    "screen1"
    Device        "device1"
    Defaultdepth    24
    Monitor        "monitor1"
    SubSection "Display"
        Depth    24
        Modes        "1280x1024"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen 0 "Default Screen"
  screen 1 "screen1" leftof "Default Screen"
  Option "Xinerama" "True"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
   
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection

Section "ServerFlags"
    Option        "Xinerama"    "true"
EndSection
Maar het werkt helaas niet, dus er is nog geen oplossing voor.. moet dan met een BLOKJE als muis leven :(....
Tja er zal wel een oplossing komen.

Groeten
Roel

r_heliman

  • Gast
problemen met externe monitor
« Reactie #17 Gepost op: 2008/03/26, 07:30:00 »
Hoi,

Hier:  http://ubuntuforums.org/showthread.php?t=314162  zeggen ze het opgelost te hebben. Maar ik heb niet echt een idee wat ze nou precies gedaan hebben zodat ik het na kan doen??

Kun jij mij misschien helpen wat ze gedaan hebben?
BEDANKT
Roel

PS en hiert http://ubuntuforums.org/showthread.php?t=273934

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #18 Gepost op: 2008/03/26, 09:46:49 »
Ben dat nu allemaal wat aan het doorlezen.  Probleem is dat het "verouderde" draadjes zijn: ondertussen is er veel veranderd qua drivers van ATI.
Post in elk geval eens de inhoud van /etc/modules.  Doe
Citaat
gedit /etc/modules
en dan knippen en plakken.
Doe ook eens het commando
Citaat
fglrxinfo
Het zou kunnen dat we eens helemaal opnieuw beginnen.  Nieuwe drivers installeren en zo.  Komt erop aan goede keuzes te maken...
Gooi alvast die oude backup weg en maak een nieuwe.  Doe achtereenvolgens
Citaat
sudo rmv /etc/X11/xorg.conf.old
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.blokje
Zo houden we zicht op welke file wat al voor elkaar kreeg.  Helaas moet ik nu eerst even een tijdje ergens heen.  Bij m'n terugkeer zien we wel weer.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #19 Gepost op: 2008/03/26, 10:16:04 »
Hoi,

mijn: modules:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
mijn fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
De backup is denk ik relatief overbodig (alles staat al hier in het forum), maar ik doe het toch maar even ;-)

Alvast bedankt
Roel

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #20 Gepost op: 2008/03/26, 11:42:02 »
Allereerst:
In je xorg.conf (op de ondertussen gekende manier) zet je nog even deze drie regels bij in de sectie "device" , net na driver "fglrx".  Je doet dat in beide secties ! Option "MergedFB" "False"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Vervolgens ga je naar Systeem-->Beheer-->Beperkt ondersteunde Stuurprogramma's en vinkt daar alles aan. Probeer het dan nog eens, desnoods na een reboot.

Lukt dat nog niet, dan gaan we een nieuwe driver installeren...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #21 Gepost op: 2008/03/26, 11:53:57 »
hoi,

Ik zit nu op de Uni, dus tja wat lastig te testen,, zal rond 3 uur naar huis gaan om het daar te testen.

Bij "restricted Drivers" staat alles aan
ATU accelerated graphical driver
Atheros HArdware ACces Layer (HAL)

UIT staat:
Software modem driver

die regels zal ik straks dan even toevoegen en testen.

Bedankt
Roel

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"    "/dev/psaux"
    Option        "Protocol"    "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Option        "MergedFB"    "False"
    Option        "VideoOverlay"    "on"
    Option        "OpenGLOverlay"    "off"
    Screen    0
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Vendorname    "Generic LCD Display"
    Modelname    "LCD Panel 1400x1050"
  Option "DPMS"
    Horizsync    31.5-65.5
    Vertrefresh    56.0 - 65.0
#    Gamma    1.0
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
    Monitor        "Generic Monitor"
    Defaultdepth    24
    SubSection "Display"
        Depth    24
#      Virtual    1400    1050
        Modes        "1400x1050"
    EndSubSection
EndSection



Section "Module"
    Load        "glx"
    Load        "dbe"
    Load        "v4l"
EndSection

Section "Extensions"
    Option        "Composite"    "0"
EndSection

Section "device" #  
    Identifier    "device1"
    Boardname    "ati"
    Busid        "PCI:1:0:0"
    Driver        "fglrx"
    Option        "MergedFB"    "False"
    Option        "VideoOverlay"    "on"
    Option        "OpenGLOverlay"    "off"
    Screen    1
EndSection

Section "monitor" #  
    Identifier    "monitor1"
    Vendorname    "Packard Bell"
    Modelname    "Virtuoso"
    Horizsync    31.5-64.0
    Vertrefresh    56.0 - 65.0
    Option "DPMS"
#   modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
#   Gamma    1.0
EndSection

Section "screen" #  
    Identifier    "screen1"
    Device        "device1"
    Defaultdepth    24
    Monitor        "monitor1"
    SubSection "Display"
        Depth    24
        Modes        "1280x1024"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen 0 "Default Screen"
  screen 1 "screen1" leftof "Default Screen"
  Option "Xinerama" "True"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
   
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection

Section "ServerFlags"
    Option        "Xinerama"    "true"
EndSection
ZO ZIET DIE ER NU UIT!! testen kan ik straks pas

r_heliman

  • Gast
problemen met externe monitor
« Reactie #22 Gepost op: 2008/03/26, 15:08:47 »
Hoi,

heb het net geprobeerd met de file die ik hierboven heb weergegeven. Helaas, het werkt nog niet :-(

Dus drivers vervangen?

Groeten
Roel

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
problemen met externe monitor
« Reactie #23 Gepost op: 2008/03/26, 16:02:44 »
Nog één poging: in de sectie modules, voeg daar nog aan toe:
Citaat
load  "dri"
Lukt het dan nog niet (na herstarten van de grafische omgeving (ALT+CTRL+Backspace) dan kun je eerst eens deze handleiding bestuderen...

Dus het tweede, manueel gedeelte.  Houd er rekening mee dat je eerst je oude drivers verwijdert, dus als het misloopt, moet je opstarten in recovery-mode, en met nano /etc/X11/xorg.confin je xorg.conf de driver-regel vervangen door driver "vesa", opslaan met control+O, stoppen met editen met control+X, dan typ je exit en kom je in een grafische omgeving die er niet uitziet, maar dan kan je tenminste weer op het net om "hulp" te roepen.
Zeer belangrijk is dat je het tweede kadertje doet: dat commando met "buildpkg" erin: zo krijg je de goede verise voor ubuntu.
Nogmaals: eerst goed doorlezen: best even afdrukken of overschrijven....
Verder vooral het hoofd koel houden. Let wel: het zou kunnen dat het ook met die driver nog niet lukt... Maar dan ben ik wel aan het eind van mijn ideeën :(
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

r_heliman

  • Gast
problemen met externe monitor
« Reactie #24 Gepost op: 2008/03/26, 16:11:32 »
Hoi,

de eerste poging werkt helaas niet :-(....

En de tweede moet ik echt eens rustig de tijd voor nemen wat ik daar allemaal precies moet gaan doen. Is mij allemaal vrij onduidelijk. Dus dat doe ik liever als ik meer tijd heb / rust.. ;-)

Toch alvast bedankt, ik denk dat misschien wachten op versie 8.04 zin heeft. misschien dat het daar wel "direct" werkt :-)

Maar ik ben al al blij dat ik nu twee beeldschermen heb, werkt echt super relaxed.

Groeten
Roel