Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid werkt niet op laptop.  (gelezen 4171 keer)

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Gepost op: 2008/03/23, 22:32:37 »
Ik van alles geprobeerd zowel op de NL als de UK sites, maar kan op geen enkel manier geluid krijgen op mijn laptop. Niet via de speakers en niet via de koptelefoon.

Ik heb een IBM Lenovo 3000 N200 Laptop , met Ubuntu 7.10.
Als ik twee geluidskaarten heb, weet ik niet hoe ik een uit kan zetten. Ik de BIOS zijn geen opties beschikbaar.

Ik heb als voorbeeld enkele gegevens toegevoegd (ben nieuw met Linux).

cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22
***********************************************************

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

*********************************************************
Ik heb zelf Alsa gui mix geinstalleerd, maar helaas.....

Alsa gui mix geinstalleerd,
Card HDA Intel
Chip Realtek ALC861-VD
*********************************************************
Ik heb zelf deze link geprobeerd, maar kan niets compileren.

http://ubuntuforums.org/showthread.php?p=2396093

**********************************************************
Ik heb de nieuwste driver binnen gehaald:
cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.15rc3.

*************************************************************
Maar alle resultaten hebben tot nu toe geresulteerd dat ik nu voor de 5e keer Ubunto moet installeren.

Wie o Wie kan mij helpen?

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #1 Gepost op: 2008/03/23, 22:51:51 »
Aan JanCamp
Als er iets niet goed gaat, hoef je niet direct Ubuntu opnieuw te installeren, toch?
Even terzake, als er nu een muzieknummer *.wav in de map muziek staat, en een speler, bijv. Totem geinstalleerd. en je dubbelklikt op dat nummer, dan gaat er toch iets spelen. Dan is het aanvinken en uitschuiven van de Alsa mixer. Desnoods onder bewerken>voorkeuren even alles aanvinken. en proberen.
Als niet duidelijk of niet werkt, stel meer vragen.
Vr.groet, peter

Trouwens, in die Alsa mixer kun je onder bestand ook nog kiezen voor Alsa of iets van Realtek. Net even gekozen voor Realtek, maar dat werkt niet bij mij. Maar ja, Alsa werkte wel, dus weer terug, et voila.

En bij mijn laptap zit er een regelwieltje aan de zijkant, staat ook wel eens "dicht".

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #2 Gepost op: 2008/03/23, 23:41:13 »
Bedankt Peter,
Maar helaas ook deze optie werkt niet. Misschien stom, maar ik ga even windows installeren om te kijken of het geluid het doet. Dan weet ik zeker dat de laptop niet stuk is. Dan snel weer terug naar Ubuntu.

Heb je een andere oplossing?

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #3 Gepost op: 2008/03/23, 23:45:59 »
Aan JanCamp
Eerlijk gezegd niet. "Even" Windows installeren is wel omslachtig, maar een probaat middel denk ik. Ik hoor graag of je een oplossing vindt.
Onderwijl zoek ik ook nog even verder.
Vr.groet, peter

Ja, bij mij heb ik Gstreamer geinstalleerd. Een wave-codec. Misschien? :)

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #4 Gepost op: 2008/03/23, 23:49:46 »
Thanks, ik weet even geen raad meer. Ben al twee dagen bezig. Als het geluid in windows het doet, ligt het zeker aan Ubuntu. Hoop dat dit in de release van april wel opgelost wordt.

Ik hoor graag van je als je een oplossing gevonden hebt.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #5 Gepost op: 2008/03/23, 23:55:38 »
Aan JanCamp
Nog maar even een postje ertegenaan. Dan valt het op.
Alle software beginnend met Gstreamer uit alle beschikbare progs via install./verwijderen kun je installeren.
Misschien?
Vr.groet, peter

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #6 Gepost op: 2008/03/23, 23:58:53 »
Had ik al gedaan. Na een schone installatie, heb ik alle vereiste acties uitgevoerd die noodzakelijk zijn (medibestanden, etc), maar heeft ook geen positief resultaat opgeleverd.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #7 Gepost op: 2008/03/24, 00:01:12 »
Aan JanCamp
Dan zoek ik morgen verder.  Ben wel benieuwd wat er nu hapert.
Vr.groet, peter

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #8 Gepost op: 2008/03/24, 00:16:57 »
Bedankt Peter,

Intussen is Vista geinstalleerd en alles werkt zoals het moet. Maw: Met Vista heb ik geluid. Dus het ligt aan Ubuntu. Ik heb net de live cd van Ubuntu weer ingedaan. Ik heb morgenochtend een verse ingestalleerd Ubuntu. Ik hoop dat jij of iemand anders een oplossing voor mij heeft.
gr,
Jan

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #9 Gepost op: 2008/03/24, 00:18:58 »
Aan JanCamp
Wat ik ook nog vond, (heb ik al eens eerder gezien) maar vergeten.
Systeem>Voorkeuren>Geluid. Bij geluidsopname moet staan Alsa (advanced linux sound Architecture) met de pijltjes kun je een testgeluid instellen en op testen erachter klikken. Regelen met PCM-schuifje. Verder staat alles op autodetectie. Je kunt er in ieder geval aardig mee rommelen. Ik herinner me dat ik er in het begin met Ubuntu ook aardig mee heb zitten tobben. Wel op een desktop, en die speelde op Vista en /of XP ook geweldig.
Vr.groet, peter

Door op testen te klikken krijg je bij elk weergave-item een testpiepje.

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #10 Gepost op: 2008/03/24, 10:25:30 »
Morgen Peter,
Ook dat heb ik weer geprobeerd. Ik bij geluid alle opties geprobeerd en binnen Alsa  zitten schuiven met de balkjes. Maar ook weer zonder positief resulaat. Het wordt nu wel zeer vervelend.

gr,
Jan

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #11 Gepost op: 2008/03/24, 11:01:10 »
Probeer eens of de bèta van 8.04 wel werkt? Tijdens de installatie even aan de netwerkdraad hangen (dus niet draadloos) en eerst alle updates binnenhalen.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #12 Gepost op: 2008/03/24, 11:01:44 »
Aan JanCamp
Goedemorgen,
Vanmorgen ook mijn laptop (U7.10) aangezet, maar waar ik al bang voor was, dat ding werkt altijd al voor ik erop verdacht ben. Ook zo met draadloos, sommige gevallen dwars door encryptie heen. Zo speelde ook het geluid. Het is een oudje, Toshiba M10, maar ik houd hem nog maar even.
Ik kan me voorstellen dat je het vervelend begint te vinden. Ik vind het vervelend dat ik je er niet mee kan helpen. Vandaag probeer ik nog een paar dingen. Als ik iets vind, hoor je het direct.
Vr.groet, peter

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #13 Gepost op: 2008/03/24, 13:08:10 »
Aan Jan Camp
Eén van de onvolprezen sites van Pjotr gevonden. Ik zou toch meer moeten lezen.
Misschien heb je hem ook wel gezien, maar bij deze:

http://computertip.googlepages.com/geluidskaartinubuntu

Misschien staat hier iets in.
vr.groet, peter

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #14 Gepost op: 2008/03/24, 14:55:17 »
Heren,
ik heb het advies van Pjotr123 uitgevoerd, nu zit Ubuntu 8.04 op mijn laptop. ik heb de acties uitgevoerd, die je direct na een installatie moet uitvoeren. Ik heb Alsamixergui geinstalleerd, maar ook hier geen voortgang in. Ook de link geprobeerd. Er moeten wel twee geluidkaarten in zitten, maar kan via de BIOS niets uitschakelen. Help.................

Offline lizardman

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #15 Gepost op: 2008/03/24, 21:11:49 »
Die tweede geluidskaart is denk ik het modem, kun je die ook niet uitschakelen in de bios?
Citaat
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Zomaar een gedachte.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #16 Gepost op: 2008/03/24, 21:15:17 »
Citaat van: lizardman
Die tweede geluidskaart is denk ik het modem, kun je die ook niet uitschakelen in de bios?
Citaat
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Zomaar een gedachte.
Een heel goede gedachte, volgens mij! Ik meen me te herinneren, dat in bepaalde omstandigheden het ingebouwde telefoonmodem wordt aangezien als geluidskaart (omdat het een eigen geluidschip heeft, voor de bekende inbelgeluiden). Het uitschakelen van het telefoonmodem in het BIOS, zou weleens de oplossing kunnen zijn.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #17 Gepost op: 2008/03/24, 23:03:32 »
Aan JanCamp, Pjotr, en lizardman
Die tweede kaart is inderdaad het modem. Soms wordt daar ook geluid over verstuurd, en dus is dat voor Ubuntu ook een geluidskaart. Deze wijsheid heb ik niet van mezelf, maar van iemand, die hetzelfde probleem met geluid tegenkwam en het heeft opgelost. Yes! Dus laat duidelijk zijn: niet mijn verdienste. Ik hoop dat ik erin slaag om het uit te leggen. Gedurende de uitleg zijn er diverse mails naar mijn adres verzonden, en daar moet ik even de weg in terug vinden. Dus even geduld, ik probeer het zelf even te doorwroeten. Je hoort het nog vandaag of anders morgen.
Vr.groet, peter

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #18 Gepost op: 2008/03/24, 23:45:11 »
Aan JanCamp
Het is per chip op de geluidskaart verschillend. Voor de ALC861VD:
Als alles goed werkt, hangt gewoon van de chip af: Houden zo, Alsamixergui prima.
Als 't niet werkt: Alsamixergui deïnstalleren en de Gnome alsa mixer installeren. Kan gewoon via Installeren/verwijderen. Ze staan bij elkaar. De mixer staat als snelkoppeling bij Toepass. Audio en Video. Kun je ook als snelkopp. in het paneel zetten. Als je hem aanklikt, zie je bovenin 2 tabs, 1xUSB(die van het modem) en 1xALC861VD(van de mixer die je nodig hebt.)
Dan in terminal:
$ gksudo gedit /etc/modprobe.d/alsa-base
Onderaan toevoegen:
options snd-hda-intel probe_mask=8 model=3stack index=0
Daarna SAVE en daarna een REBOOT.
En dan zou het goed moeten werken.
Eventueel kan er nog een verandering nodig zijn, maar als het zo goed werkt .....
Vr.groet, peter

Jan, vanmorgen zag ik dat ik iets vergeten was in de options regel. (index=0) Ik heb het er even gewoon achter gezet.
Nu ik er een nachtje over geslapen heb, begrijp ik wat er gebeurt. Met die nieuwe mixer wordt die modem geluidskaart (USB, eerste tab)zichtbaar en als eerste aangestuurd. Door de tweede tab aan te klikken krijg je zicht op een volledige muziekmixer. Die moet als eerste opstarten. Dus moet die onder de eerste tab komen en die USB tab liefst op plaats tig. Dat gebeurt met die terminal regels. Succes!

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #19 Gepost op: 2008/03/25, 07:50:15 »
Bedankt voor de reacties. Ik zal het vanavond al sik thuis ben, proberen. Ik heb alleen het vermoeden dat ik in mijn bios niets kan uitzetten. Daar was ik ook al terecht gekomen en het verbaasde mij hoe weinig opties ik had in de BIOS. Maar voor nu kan ik niet wachten dat ik thuis ben om de laatste suggesties uit te testen. Tot vanavond.

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #20 Gepost op: 2008/03/25, 20:48:45 »
Ook geen van de bovenstaande opties werken.
Ik eerst alleen in de BIOS de modem uitgezet en dan de Ubuntu opgestart. Geluid deed het niet. Volume gecheckt, was oke.
Alsamixer geinstl. deed het ook niet. Weggehaald en GNOME Alsamixer geinstal. Weer geen geluid.

Regel toegevoegd in alsa base en opnieuw gestart. (alleen 1 tab zichtbaar, omdat modem uitgeschakeld is in de BIOS). Geen resultaat.
Opnieuw opgestart met modem aan in de BIOS....

in de BIOS modem weer uit gedaan en in Alsa base bestand INDEX=0 weggehaald.
rood (mute) knop zichtbaar bij volume. Geen geluid. Fout melding dat Gstreamer plugin niet geinstalleerd is of hardware niet gvonden kan worden. Check uitgevoerd of plugin geinstalleerd is. Was geinstalleerd. Restart gedaan en modem (waarom?) aangezet. Blijft bij de foutmelding.

Ik heb de regel maar in Alsa basa weggehaald en de modem maar uitgeschakeld. Regel in Alsa basa gaf alleen maar foutmeldingen.
Geen enkele poging heeft geholpen.
Ik heb wel de ALC861VD...

Ik zie door de bomen het bos niet meer.....

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #21 Gepost op: 2008/03/25, 22:46:01 »
Aan Jan Camp
Sorry, had gedacht wat vroeger terug te zijn. Computers ......
Jan, dat valt me tegen. Mijn kennis had een Tecra 8A die niet speelde, en die op deze manier wel aan de praat kwam. Met een 1888 chip, en gaan!
Maar ik weet nog iets. Moet ik effe de andere ubuntu opstarten.
In die Alsa file (zoals boven) vijfde regel van onderaf staat: xxxx-usb-audio index=-2, maak daar eens een 0 (nul) van. Dan saven en rebooten.
Heb je misschien in Systeem>Voorkeuren>geluid zo met die instellingen zitten rommelen dat er iets misgaat. Mijn raadgever is een echte pikeur, kan me niet voorstellen dat hij het misheeft. Ik kan me voorstellen dat je er een beetje down bij raakt, maar als het werkt, dan zeg je vast: Was dat alles!
Vr.groet, peter

JanCamp

  • Gast
Geluid werkt niet op laptop.
« Reactie #22 Gepost op: 2008/03/25, 23:22:49 »
Ook deze optie werkt niet. bij elke poging probeer ik ook via het menu en keuze geluid om te kijken of daar iets tussen zit. Maar ook deze keer niets. Ik voeg het tekst bestand van alsa hierbij met de wijziging van 2 naar 0. Ik heb een IBM Lenovo 3000 N200.

=====
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-0
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
=================

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #23 Gepost op: 2008/03/25, 23:37:39 »
Aan JanCamp
-0? Erboven staat snd-xxxxxx-modem index=-2 ====>=0 maken. Ik zeg het eerlijk,
het is raadwerk. ik weet het ook niet verder. Pas volgende week maandag krijg ik weer college. Jammer dat het niet lukt.
Vr.groet, peter

Ik vond ook nog: onderaan toevoegen: options snd-hda-intel model=lenovo

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geluid werkt niet op laptop.
« Reactie #24 Gepost op: 2008/03/26, 11:27:25 »
Aan JanCamp
Goedemorgen,
Vanmorgen op de laptop de Gnome Alsa mixer geinstalleerd. En een muzieknummer. In principe hou ik de laptop zo schoon mogelijk alleen Ubuntu 7.10. In die laptop zit een Analog Devices 1981B chip. Als altijd werkte alles direct perfect. En hij ziet ook automatisch het inbelmodem niet. Dus maar één Tab. Even zitten spelen met die mixer. Onderaan in die mixer staat een lijst, waarvan alleen External Amplifier is aangevinkt. Als ik die wegklik, heb ik ook geen muziek meer. Kan het zijn, dat dat vinkje bij jou is weggevlogen?
Buiten dat wil ik ook een inbelverbiding met mijn laptap instellen, om te proberen die Modem Tab in die Alsa mixer zichtbaar te krijgen.
Vr.groet, peter