Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Foutmelding bij installatie MySQL  (gelezen 7866 keer)

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Gepost op: 2008/03/16, 12:01:30 »
Ubuntu versie 7.10
Ik ben bezig Apache/MySQL/PHP te installeren. Apache draait inmiddels, maar...

Achtereenvolgens heb ik uitgevoerd
$ sudo apt-get install mysql-server
$ sudo apt-get install libapache2-mod-auth-mysql
$ sudo apt-get install php5-mysql
$sudo apt-get install phpmyadmin
$ cd /usr
$ sudo ./bin/mysql_install_db --user=mysql

Bij het installieproces van MySQL geef ik dan de volgende opdracht:
pim@microstar:~$ sudo mysql -u root
Er verschijnt de mededeling:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

Wat is dat en hoe los ik het op?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #1 Gepost op: 2008/03/16, 13:23:26 »
Uit m'n hoofd weet ik het niet precies, maar volgens mij moet je eerst een mysqladmin commando uitvoeren om het root wachtwoord in te stellen. Google maar es op mysqladmin, new installation e.d.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #2 Gepost op: 2008/03/16, 13:55:43 »
Als ik phpMyAdmin start in de adresregel krijg ik het volgende:

Welkom op phpMyAdmin 2.10.3deb1ubuntu0.2

Fout
Het configuratie bestand heeft nu een geheime wachtwoord zin nodig (blowfish_secret).

Wat moet ik daarmee?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #3 Gepost op: 2008/03/16, 16:46:23 »
Aanvulling: in de cinfig.inc.php staat het volgende:

/**
 * Debian local configuration file
 *
 * This file overrides the settings made by phpMyAdmin interactive setup
 * utility.
 *
 * For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz
 *
 * NOTE: do not add security sensitive data to this file (like passwords)
 * unless you really know what you're doing. If you do, any user that can
 * run PHP or CGI on your webserver will be able to read them. If you still
 * want to do this, make sure to properly secure the access to this file
 * (also on the filesystem level).
 */

/**
 * Server(s) configuration
 */
$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;

/* Authentication type */
//$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
//$cfg['Servers'][$i]['host'] = 'localhost';
//$cfg['Servers'][$i]['connect_type'] = 'tcp';
//$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
//$cfg['Servers'][$i]['extension'] = 'mysql';
/* Optional: User for advanced features */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';
/* Optional: Advanced phpMyAdmin features */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
 * End of servers configuration
 */

/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';


Is dit juist?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline rja

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #4 Gepost op: 2008/03/16, 21:42:36 »
Ik heb volgens mij de zelfde configuratie file voor phpmyadmin.

Heb je root password gezet ?

Kun je via een terminal inloggen op mysql :
mysql -u root -p

Anders moet je root password opnieuw zetten.

Zie :

http://ubuntu-tutorials.com/2008/01/08/how-to-reset-the-mysql-password-ubuntu-710/

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #5 Gepost op: 2008/03/16, 22:34:18 »
Ja, ik heb het root password gezet. Inloggen via mysql -u root -p gaat prima.
Als ik phpmyadmin start in de adresbalk krijg ik toch nog steeds de mededeling:

Welkom op phpMyAdmin 2.10.3deb1ubuntu0.2
Fout
Het configuratie bestand heeft nu een geheime wachtwoord zin nodig (blowfish_secret).

Zit het probleem toch ergens anders?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #6 Gepost op: 2008/03/16, 23:06:45 »
Even een kleine How To om MySQL te installeren ??

#################
sudo apt-get install mysql-server mysql-client libmysqlclient12-dev

nu word alles geinstalleerd wat je nodig hebt.
EN JA je mag dit nogmaals doen, daar heeft Linux geen moeite mee.

Wat je nu als eerste moet doen is:
mysqladmin -u root password jouwrootsqlwachtwoord

Nu word er een WW gezet voor MySQL

Als je nu in terminal typt:
netstat -tap

Zou je zoiets moeten zien als
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     2449/mysqldWat zoveel betekent dat je MySQL kan bereiken op 127.0.0.1 op poort 3306

Wanneer je dit niet ziet moet je in /etc/mysql/my.cnf  even een # weghalen bij skip-networking.
Dus dit :
# skip-networking
word dit
skip-networking

Als je wilt dan MySQL luisterd naar alle beschikbare IP adressen verander dan in /etc/mysql/my.cnf  de regel bind-address = 127.0.0.1:

Dus dit
#bind-address            = 127.0.0.1
word dit
bind-address            = 127.0.0.1

NOTE, en zie hier waarom ik al eerder aangaf dat die 127.0.0.1 in ere gehouden moet worden, want is dit op jouw systeem nu een ander IP adres zul je het ook hier moeten veranderen, en hier zal je aldoor tegenaan blijven lopen, want de community die deze software schreef gaat uit van afgesproken regels.

Indien je de /etc/mysql/my.cnf heb bewerkt zul je MySQL moeten herstarten:
sudo /etc/init.d/mysql restart

Indien je MySQL luisterd naar alle interfaces moet je voor iedere site (bijv. server1.example.com ) een wachtwoord zetten anders kan iedereen de databasen in.
dus dit:
sudo mysqladmin -h server1.example.com -u root password jouwrootsqlwachtwoord

Uiteraard kan je voor alles hetzelfde wachtwoord gebruiken.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline rja

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #7 Gepost op: 2008/03/16, 23:15:23 »
Geen idee, waarom dat bij jouw anders is.

Zet je dat password toch ?

Toevoegen in die file

$cfg['blowfish_secret'] = 'jouw wachtwoord';

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #8 Gepost op: 2008/03/16, 23:38:29 »
Bedankt voor de aanwijzingen.
Als ik het commando geef dat je aangeeft krijg ik:
pim@microstar:~$ sudo apt-get install mysql-server mysql-client libmysqlclient12-dev
[sudo] password for pim:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
 dat doe ik dan:
pim@microstar:~$ sudo dpkg --configure -a
Instellen van ubuntu-docs (7.10.5) ...


Bij netstat -tap krijg ik dit:

pim@microstar:~$ netstat -tap
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name  
tcp        0      0 *:nfs                   *:*                     LISTEN     -                  
tcp        0      0 localhost:mysql         *:*                     LISTEN     -                  
tcp        0      0 *:netbios-ssn           *:*                     LISTEN     -                  
tcp        0      0 *:50094                 *:*                     LISTEN     -                  
tcp        0      0 *:sunrpc                *:*                     LISTEN     -                  
tcp        0      0 *:www                   *:*                     LISTEN     -                  
tcp        0      0 localhost:ipp           *:*                     LISTEN     -                  
tcp        0      0 localhost:postgresql    *:*                     LISTEN     -                  
tcp        0      0 *:smtp                  *:*                     LISTEN     -                  
tcp        0      0 *:microsoft-ds          *:*                     LISTEN     -                  
tcp        0      0 *:36605                 *:*                     LISTEN     -                  
tcp        0      0 *:39615                 *:*                     LISTEN     -                  
tcp        0      0 microstar:33729         62.69.184.140:www       ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:37632         62.69.179.205:www       ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:48496         q-138.n-81.18.240.q:www ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:33728         62.69.184.140:www       ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:37629         62.69.179.205:www       ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:53086         mu-in-f91.google.co:www ESTABLISHED7647/firefox-bin    
tcp        0      0 microstar:60125         62.69.179.213:www       ESTABLISHED7647/firefox-bin    
pim@microstar:~$

In de my.cnf staat het volgende:

# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port      = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice      = 0

[mysqld]
#
# * Basic Settings
#
user      = mysql
pid-file   = /var/run/mysqld/mysqld.pid
socket      = /var/run/mysqld/mysqld.sock
port      = 3306
basedir      = /usr
datadir      = /var/lib/mysql
tmpdir      = /tmp
language   = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address      = 127.0.0.1
#
# * Fine Tuning
#
key_buffer      = 16M
max_allowed_packet   = 16M
thread_stack      = 128K
thread_cache_size   = 8
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log      = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries   = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id      = 1
log_bin         = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days   = 10
max_binlog_size         = 100M
#binlog_do_db      = include_database_name
#binlog_ignore_db   = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet   = 16M

[mysql]
#no-auto-rehash   # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/


Hoe ga ik verder?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #9 Gepost op: 2008/03/16, 23:52:42 »
Wat gebeurde er na dit:
Citaat
pim@microstar:~$ sudo dpkg --configure -a
Instellen van ubuntu-docs (7.10.5) ...
Want blijkbaar heb je een installatie afgebroken iets wat je eigenlijk nooit moet doen...

meestal doe ik er nogmaals achteraan:
sudo apt-get update
sudo apt-get upgrate

en dan moeten er geen foutmeldingen meer zijn.

eventueel als er gee outputs waren nadat je die opdracht --configure had gedaan zou je nogmaals die installatie moeten doen om te kijken of echt alles geinstalleerd is.

eerst
sudo /etc/init.d/mysql stop

dan
sudo apt-get install mysql-server mysql-client libmysqlclient12-dev

kijken of er geen foutmeldingen komen en alles geinstalleerd is.

Nu
sudo /etc/init.d/mysql restart

en dan weer
netstat -tap

Want in je my.cnf staat duidelijk dat je poort 3306 gebruikt maar die zie ik niet in je vorige netstat staan ???
Citaat
tcp        0      0 localhost:mysql         *:*                     LISTEN     -
Heb je verder alle wachtwoorden gezet ??
zoals rja en ik aangaven ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #10 Gepost op: 2008/03/17, 00:02:56 »
Ik heb alle aanwijzingen gevolgd en krijg het volgende:

pim@microstar:~$ sudo /etc/init.d/mysql stop
 * Stopping MySQL database server mysqld                                 [ OK ]
pim@microstar:~$ sudo apt-get install mysql-server mysql-client libmysqlclient12-dev
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
mysql-server is reeds de nieuwste versie.
mysql-client is reeds de nieuwste versie.
Pakket libmysqlclient12-dev is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket libmysqlclient12-dev heeft geen installeerbare kandidaat
pim@microstar:~$ sudo /etc/init.d/mysql restart
 * Stopping MySQL database server mysqld                                 [ OK ]
 * Starting MySQL database server mysqld                                 [ OK ]
 * Checking for corrupt, not cleanly closed and upgrade needing tables.
pim@microstar:~$ netstat -tap
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name  
tcp        0      0 *:nfs                   *:*                     LISTEN     -                  
tcp        0      0 localhost:mysql         *:*                     LISTEN     -                  
tcp        0      0 *:netbios-ssn           *:*                     LISTEN     -                  
tcp        0      0 *:50094                 *:*                     LISTEN     -                  
tcp        0      0 *:sunrpc                *:*                     LISTEN     -                  
tcp        0      0 *:www                   *:*                     LISTEN     -                  
tcp        0      0 localhost:ipp           *:*                     LISTEN     -                  
tcp        0      0 localhost:postgresql    *:*                     LISTEN     -                  
tcp        0      0 *:smtp                  *:*                     LISTEN     -                  
tcp        0      0 *:microsoft-ds          *:*                     LISTEN     -                  
tcp        0      0 *:36605                 *:*                     LISTEN     -                  
tcp        0      0 *:39615                 *:*                     LISTEN     -

Voor mij als leek zegt me dit niet veel, maar wellicht voor jou gesneden koek?
Voor zover ik weet heb ik overal de wachtwoorden gezet.
Wat moet ik nu doen?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #11 Gepost op: 2008/03/17, 00:19:22 »
Hierover:
Citaat
Pakket libmysqlclient12-dev is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket libmysqlclient12-dev heeft geen installeerbare kandidaat
hoef je je geen zorgen te maken :D

Ik ga uit van een Debian server installatie en blijkbaar heeft Ubuntu die niet zomaar voor handen.
Echter ik gaf ze erbij omdat ik altijd uitga van beter mee verlegen als OM verlegen.
je weet maar nooit.

In theorie zou je nog naar dit libmysqlclient12-dev  pakket kunnen zoeken in Synaptic.

Ik zeg dit niet omdat het veel zin heeft of omdat je dit perse nodig hebt hoor ??
ik probeer je alleen maar Linux ritme aan te leren en Linux te laten denken.

eg je nooit zomaar uit het veld laten slaan door een output van de Terminal en ff iets anders proberen.
In Linux leiden namelijk heel veel wegen naar Rome en zal je nog heel vaak meemaken dat verschillende dingen doen tot hetzelfde effect leiden.

Goed de output van netstat blijft hetzelfde, zie nog steeds die poort niet verscheinen ???
hmmz
ik ga er nu ff niet vanuit dat MySQL nu niet naar behoren werkt....

Kijk even of phpMyAdmin goed werkt ??
Test ff het 1 en ander ?
en of je uberhaupt er wel op kan komen ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #12 Gepost op: 2008/03/17, 00:26:47 »
libmysqlclient12-dev gezocht in Synaptic en in het linker venster gevonden. Maar rechts staat niets... Leeg?

Als ik nu in de adresbalk het adres http://127.0.0.1/phpmyadmin/
ingeef krijg ik nog steeds dezelfde foutmelding:

Welkom op phpMyAdmin 2.10.3deb1ubuntu0.2
Language Info
Fout
Het configuratie bestand heeft nu een geheime wachtwoord zin nodig (blowfish_secret).

Wat nu?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #13 Gepost op: 2008/03/17, 03:25:07 »
ok
Zoek eens naar de file  config.inc.php in /usr/local/php5/phpMyAdmin-X.X.X-pl2/
dat laatste is een voorbeeld want ik heb geen idee waar jij hem hebt staan ??

Open de config.inc.php met gedit.

Zoek nu naar het stukje tekst:
/**
 * The 'cookie' auth_type uses blowfish algorithm to encrypt the password. If
 * at least one server configuration uses 'cookie' auth_type, enter here a
 * passphrase that will be used by blowfish. The maximum length seems to be 46
 * characters.
 */
$cfg[''] = '';
en verander die laatste regel in

$cfg['blowfish_secret'] = 'jouwrootwachtwoord';

Nu je hier toch vrolijk aan het rommelen bent kunnen we misschien beter de veiligheid aanpakken...
Je kan kiezen tussen 3 dingen: 'config', 'http', and 'cookie'
De 'config' is standaard maar vereist dat je wachtwoord in de file blijft wat niet fijn is.

De 'http' prompt het wachtwoord in tekst wat ook niet erg goed is.

De 'cookie' en deze gebruikt de passphrase met de [blowfish_secret] parameter, waardoor PHPMyAdmin het wachtwoord versleuteld in een cookie wanneer je inlogt.

Scroll ff door die file en zoek deze regel:
$cfg['Servers'][$i]['auth_type']     = 'config';

en verander dit naar
$cfg['Servers'][$i]['auth_type']     = 'cookie';

Sla nu die file op.

Nu zou alles moeten werken als het goed is ???

Nog even wat veiligheid tips voor Apache.
Want je zit vrolijk een server te maken met van alles en nog wat erop maar dit neemt wel risico's met zich mee zodra je pc aanstaat, en voor je het weet met zo'n maagdelijk systeem heb je een hacker erin zitten....

Met dit trucje kan je ervoor zorgen dat mensen van buitenaf niet op je pc kunnen komen, uuh niet middels apache dan !

Je kan hiervoor de hoofd cfg gebruiken maar je kan ook een aparte cfg ervoor maken.
Op die manier houd je eigen en apache dingen gescheiden wat vaak makkelijker is.

Gooi deze file in de /etc/apache2/conf.d/ directorie.
open gedit en kopieer dit erin
# Tighten access to the file system.

        # Forbid default access to file system locations
        Order Deny,Allow
        Deny from all
        # prevent use of .htaccess files in all directories
        # apart from those specifically enabled.
        AllowOverride None


# Limit available info about this server.
ServerSignature Off
ServerTokens production
Sla de file op met de naam local_configs.conf  ( vermits die nog niet bestaat- bewerk anders die of bekijk hem ff) in de /etc/apache2/conf.d/ directorie.

Nu ff Apache herstarten en dan zou je alleen maar van je eigen pc erop moeten kunnen komen.
Lees anders dit ff door security tips

maagoe stapje voor stapje en ik draaf weer door dus wacht ff voor input van jouw.... :P
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #14 Gepost op: 2008/03/17, 07:59:56 »
In mijn phpmyadmin map staat de file config.inc.php. Hierin staat niks over blowfish. Letterlijk staat er:

/**
 * Debian local configuration file
 *
 * This file overrides the settings made by phpMyAdmin interactive setup
 * utility.
 *
 * For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz
 *
 * NOTE: do not add security sensitive data to this file (like passwords)
 * unless you really know what you're doing. If you do, any user that can
 * run PHP or CGI on your webserver will be able to read them. If you still
 * want to do this, make sure to properly secure the access to this file
 * (also on the filesystem level).
 */

/**
 * Server(s) configuration
 */
$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;

/* Authentication type */
//$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
//$cfg['Servers'][$i]['host'] = 'localhost';
//$cfg['Servers'][$i]['connect_type'] = 'tcp';
//$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
//$cfg['Servers'][$i]['extension'] = 'mysql';
/* Optional: User for advanced features */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';
/* Optional: Advanced phpMyAdmin features */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
 * End of servers configuration
 */

/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

Als ik verder zoek kom ik nog een bestant config.inc.php tegen in de map home. Hierin staat:


$cfg['blowfish_secret'] = 'hier staat mijn correcte wachtwoord';

$i=0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['socket'] = '/var/run/mysql/mysql.sock';

?>


Voor mijn gevoel kom ik steeds dichterbij, maar vooraleer ik het overzicht verlies wil ik eerst deze stap afronden.  Daarna komt de veiligheid aan de beurt.
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #15 Gepost op: 2008/03/17, 12:10:50 »
Aha ( config.inc.php tegen in de map home )
En die gebruikt hij niet en dus werkt het niet naar behoren.

Dit is nu de erfenis om een desktop en server door elkaar te gebruiken.

Voortaan kan je het beste dit soort zaken als root installeren.
Dus wanneer je in de desktop omgeving aan het werk bent en je gaat dit soort dingen installeren doe je eerst in terminal:
sudo -s

Nu je root wachtwood ingeven en dan pas verder werken.

Voor nu lijkt het me het simpelst indien je gewoon alles van die config.inc.php die in de map home staat te kopieren naar die file die in de phpmyadmin map staat .

Dus dit gedeelte

$cfg['blowfish_secret'] = 'hier staat mijn correcte wachtwoord';

$i=0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['socket'] = '/var/run/mysql/mysql.sock';

dan moet de boel een beetje beter werken...
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #16 Gepost op: 2008/03/17, 12:56:06 »
Weer iets geleerd, maar ik ben er nog niet. Als ik het volgende doe:

pim@microstar:~$ sudo -s
root@microstar:~# sudo gedit etc/phpmyadmin/config.inc.php

dan krijg ik een leeg document te zien. Als ik in de map phpmyadmin datzelfde bestand open met een tekstverwerker krijg ik een heel verhaal. Zie Vandaag 07:59:56

De eindstreep lijkt in zicht...
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #17 Gepost op: 2008/03/17, 13:34:59 »
sudo -s , zorgt niet voor die foutmelding.

Dit "sudo gedit etc/phpmyadmin/" zorgt voor die foutmelding.

Nog precieser dit: etc/phpmyadmin/

Dit noemen we het pad of in het engels path  oftewel < pad naar>

Indien je in Linux een opdracht geeft met bijv. gedit om een file te bewerken en die file bestaat niet , gaat Linux ervanuit dat je die file wilt maken, dus dat het een nieuwe file is.

Daarom zie je niets, want het pad naar is niet goed.
In jouw geval staat de config.inc.php dus niet daar waar jij hem naartoe verwijst.

Houd er ook rekening mee dat alles in Linux karakter gevoelig is.
Dus hij maakt een groot onderscheid tussen hoofd- en kleine letters of cijfers of  ? / _ - |  enz enz.

Misschien dat het pad dus wel goed is maar dat in werkelijkheid dit er moet staan: etc/PHPMyadmin/
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #18 Gepost op: 2008/03/17, 14:17:15 »
Vandaar dat de config file er meerdere keren instond. De reservekopieen heb ik inmiddels verwijderd.
Het lukt me alleen niet de file vanuit de home locatie te verplaatsen naar de phpmyadmin map. Met welk programma doe je dat? Is er zoiets als Verkenner in Ubuntu?
Bij het wijzigen van de 'goede' config file in een tekstverwerker kan ik het niet opslaan, dit wordt geweigerd. Nu heb ik de teksten gekopieerd in de Oo-tekstverwerker en met SUDO teruggezet in de configfile in home. Die is nu in orde. Alleen: hoe krijg ik hem in de juiste map?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Hendrikdegraaf

  • Gast
Foutmelding bij installatie MySQL
« Reactie #19 Gepost op: 2008/03/17, 15:08:33 »
Ik heb begrepen dat je ook een grafische interface gebruikt (zo niet vergeet dan dit advies):

sudo nautilus

(dan open je de bestandsbladeraar als root)

Als je geen GUI hebt kan het als volgt:
-s
cp /[plaats_van_je_config] /[doelmap]

Misschien moet je dan eerst dat (lege) bestand dat er al staat wissen.
Let wel: er staat uiteraard een spatie tussen de twee verschillende locaties.

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #20 Gepost op: 2008/03/17, 15:25:34 »
Met nautilus is het me gelukt de config in de goede map te krijgen. Maar helaas is mijn probleem nog hetzelfde:

pim@microstar:~$ sudo mysql -u root
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
pim@microstar:~$

Nog steeds die foutmelding

En als ik http://127.0.0.1/phpmyadmin/ ingeef krijg ik ook nog dezelfde foutmelding:

Welkom op phpMyAdmin 2.10.3deb1ubuntu0.2
Language Info
Fout
Het configuratie bestand heeft nu een geheime wachtwoord zin nodig (blowfish_secret).

Dat blowfish_secret heb ik toch aangepast...
Wat nu?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #21 Gepost op: 2008/03/17, 15:40:57 »
In principe ben ik niet blij met dit:
Citaat
Vandaar dat de config file er meerdere keren instond. De reservekopieen heb ik inmiddels verwijderd.
Je moet voorlopig ff nix verwijderen, totdat alles perfect werkt.
Pas dan kan je dit soort dingetjes doen om te fine tunen of als het in de weg zit.

Het "waarom" is omdat je middels een desktop omgeving dit soort dingen installeerd en het dus onvoorspelbaar is ( voor ons) waar wat met welke rechten staat.

Dus nog ff nix verwijderen en slechts alleen aanpassen.
Wanneer het straks werkt kan  je stap voor verwijderen totdat iets niet meer werkt en dan de file terug zetten...

Waarom het nu nog niet goed werkt snap ik niet helemaal, misschien staat die of een config.inc.php nog ergens anders ???

wat ik wel weet is dat normaal gesproken in deze situatie je apache word aangepast zodat er een virtual host aan het werk is voor PHPMydmin.

Misschien dat jij dit nog niet gedaan hebt en dat het daarom niet lekker werkt.

Een kleine How To kan ik vanavond wel; posten hiervoor....
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #22 Gepost op: 2008/03/17, 15:54:20 »
Heel graag die How To

Ik heb nog eens gekeken in de config file. De regel met het blowfish_secret staat bovenaan. Kan daarin een fout schuilen? Of maakt de volgorde niet uit?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline rja

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #23 Gepost op: 2008/03/17, 16:11:51 »
Citaat van: WGM50
Heel graag die How To

Ik heb nog eens gekeken in de config file. De regel met het blowfish_secret staat bovenaan. Kan daarin een fout schuilen? Of maakt de volgorde niet uit?
Wat staat er nu in de config.inc.php. ?

Je hebt de orginele config.inc.php overschreven ?

Offline WGM50

  • Lid
  • Steunpunt: Nee
Foutmelding bij installatie MySQL
« Reactie #24 Gepost op: 2008/03/17, 16:14:48 »
Hier is de volledige tekst (wachtwoord gewijzigd uiteraard)


/**

 * Debian local configuration file

 *

 * This file overrides the settings made by phpMyAdmin interactive setup

 * utility.

 *

 * For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz

 *

 * NOTE: do not add security sensitive data to this file (like passwords)

 * unless you really know what you're doing. If you do, any user that can

 * run PHP or CGI on your webserver will be able to read them. If you still

 * want to do this, make sure to properly secure the access to this file

 * (also on the filesystem level).

 */



/**

 * Server(s) configuration

 */

$i = 0;

// The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].

// You can disable a server config entry by setting host to ''.

$i++;



//$cfg['blowfish_secret'] = 'MijnWachtwoord';



//$cfg['Servers'][$i]['socket'] = '/var/run/mysql/mysql.sock';
/* Authentication type */

//$cfg['Servers'][$i]['auth_type'] = 'cookie';

/* Server parameters */

//$cfg['Servers'][$i]['host'] = 'localhost';

//$cfg['Servers'][$i]['connect_type'] = 'tcp';

//$cfg['Servers'][$i]['compress'] = false;

/* Select mysqli if your server has it */

//$cfg['Servers'][$i]['extension'] = 'mysql';

/* Optional: User for advanced features */

// $cfg['Servers'][$i]['controluser'] = 'pma';

// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* Optional: Advanced phpMyAdmin features */

// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

// $cfg['Servers'][$i]['relation'] = 'pma_relation';

// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';

// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';

// $cfg['Servers'][$i]['history'] = 'pma_history';

// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';



/*

 * End of servers configuration

 */



/*

 * Directories for saving/loading files from server

 */

$cfg['UploadDir'] = '';

$cfg['SaveDir'] = '';

Zitten er fouten in?
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox